GTX1060

Message boards : Number crunching : GTX1060
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3 · Next

AuthorMessage
juan BFP Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 16 Mar 07
Posts: 9786
Credit: 572,710,851
RAC: 3,799
Panama
Message 1898203 - Posted: 30 Oct 2017, 1:31:29 UTC
Last modified: 30 Oct 2017, 1:37:20 UTC

Make some tests.

DL a TV series program directly to the SSD to avoid a possible problem with the HDD latency to use for test. The source is in 720P HDTV resolution only.

Stop the AV software

Check and not see any strange process running on the hosts. With 1 CPU + 1 GPU WU been crunched and the movie running the total CPU usage is is about 12% only and still more than 70 % of RAM avaiable and all most 0% of disk & network usage .

With Process Lasso i rise the priority of the MPC (media player) program to real time and down the priority of the Boinc and the crunching programs to less than normal. The problem remains.

Running then the DPC LatencyChecker with this configuration and the programs said the host could handle streamin g video without drop-out. Absolute latency is in the range or less than 600 micro segs (530-570).

The command line used during the test was: -sbs 128 -period_iterations_num 250 -no_defaults_scaling -use_sleep

I rely start to believe i´m chasing an impossible configuration. Maybe the code does not allow that.

BTW I made similar test on the 1070 and the 1080Ti hosts with similar results. Less in their case (more powerful GPU´s). You could see the lags, very fast but still there. Switching back the hosts to E@H where the problem not appears. All are X99 MB with 6800 or 6850 CPU´s

If somebody has any other ideia i will be happy to test.

Thanks for all the tips.
ID: 1898203 · Report as offensive
Profile Keith Myers Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 29 Apr 01
Posts: 13159
Credit: 1,160,866,277
RAC: 1,873
United States
Message 1898218 - Posted: 30 Oct 2017, 4:58:05 UTC

The default for BOINC science apps is Below Normal. You must have raised them from defaults with ProcessLasso. I would use ProcessLasso to drop the science apps to Idle and test again.
Seti@Home classic workunits:20,676 CPU time:74,226 hours

A proud member of the OFA (Old Farts Association)
ID: 1898218 · Report as offensive
juan BFP Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 16 Mar 07
Posts: 9786
Credit: 572,710,851
RAC: 3,799
Panama
Message 1898267 - Posted: 30 Oct 2017, 15:04:53 UTC - in response to Message 1898218.  
Last modified: 30 Oct 2017, 15:12:01 UTC

I´m prety sure that was what i do, low all the priorities for all Boinc related programs, special the MB & GPU exe´s. Yes some was allready at below normal priority.

I try below normal, no idle, so i will try again when at home.

My question now is: Why no body has the same problem? Sure it´s a lot of guy´s here who see movies & crunching too.

I see similar behavier in the 1070 & 1080Ti hosts. Could be related to the X99 chipset i use? All my MB are from diferent companies.

In this host (the one i´m writing the msg) the lag is even worst, but that could be easely explanied due the 4 x 1070 (6850 CPU running 8 GPU + 4 CPU WU @ time) it has and the -hp switch used in the configuration. It´s a cruncher only host most of the time.
ID: 1898267 · Report as offensive
Profile Keith Myers Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 29 Apr 01
Posts: 13159
Credit: 1,160,866,277
RAC: 1,873
United States
Message 1898280 - Posted: 30 Oct 2017, 16:20:59 UTC - in response to Message 1898267.  
Last modified: 30 Oct 2017, 16:22:10 UTC

I´m prety sure that was what i do, low all the priorities for all Boinc related programs, special the MB & GPU exe´s. Yes some was allready at below normal priority.

I try below normal, no idle, so i will try again when at home.

Do you mean you have no IDLE setting available in Priority >> Current or Always in Process Lasso. I have IDLE in all my running processes available?

My question now is: Why no body has the same problem? Sure it´s a lot of guy´s here who see movies & crunching too.

I see similar behavier in the 1070 & 1080Ti hosts. Could be related to the X99 chipset i use? All my MB are from diferent companies.

In this host (the one i´m writing the msg) the lag is even worst, but that could be easely explanied due the 4 x 1070 (6850 CPU running 8 GPU + 4 CPU WU @ time) it has and the -hp switch used in the configuration. It´s a cruncher only host most of the time.

The way that PCIe slots are configured changes from one manufacturer to the next even if based on the same chipset. It could be motherboard related and seems likely since no one else with similar configurations has a problem playing movies and crunching at the same time. I would drop the -hp setting. It always was the worst parameter to affect system lag over all other tunings.
Seti@Home classic workunits:20,676 CPU time:74,226 hours

A proud member of the OFA (Old Farts Association)
ID: 1898280 · Report as offensive
juan BFP Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 16 Mar 07
Posts: 9786
Credit: 572,710,851
RAC: 3,799
Panama
Message 1898368 - Posted: 31 Oct 2017, 0:55:34 UTC - in response to Message 1898280.  

Done all i could imagine.

Set the Crunchers & Boinc programs priority to idle, I/O & Memory to the lowest possible value.

Rise the Media Player program prioity to Real Tami, I/O and memory to the fastest avaiable value.

Even try to rise the command line options to: -sbs 64 -period_iterations_num 1000 -tt 1500 -no_defaults_scaling

And the lag is still, in very few moments but still present.

I realy start to see as some part of the crunching code does uses too many of the GPU resources to keep both program running fine.

I'm forced to abandon crunching Seti on the GPU and back it to crunch Einstein. Leave the CPU running here,

Thanks all for the help.
ID: 1898368 · Report as offensive
Profile Keith Myers Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 29 Apr 01
Posts: 13159
Credit: 1,160,866,277
RAC: 1,873
United States
Message 1898370 - Posted: 31 Oct 2017, 1:24:58 UTC - in response to Message 1898368.  

Sorry I couldn't be of more help. Funny, it's the Einstein GPU tasks that are the Achilles Heel on my Windows7 systems. They cannot be interrupted while crunching without dropping my gpus out by forcing a graphics driver reset. Most annoying. I try to just let them run through even though I might need to do some rescheduling at the time but if try to reschedule with them running, it will guarantee a driver dropout which forces you to exit BOINC anyway since you can't apply overclocks with BOINC running. I can get away with stopping BOINC with a reschedule on the Win 10 system though. Much more stable or accommodating to interrupting a Einstein task crunch.
Seti@Home classic workunits:20,676 CPU time:74,226 hours

A proud member of the OFA (Old Farts Association)
ID: 1898370 · Report as offensive
juan BFP Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 16 Mar 07
Posts: 9786
Credit: 572,710,851
RAC: 3,799
Panama
Message 1898378 - Posted: 31 Oct 2017, 1:46:18 UTC
Last modified: 31 Oct 2017, 1:56:12 UTC

Thanks Keith for your help.

Unfortunately we where unable to fix the problem this time, maybe in the future could appears a new idea. Who Knows?

Switch back to E@H and the lag dissapears like magic.

My 3 GPU´s (1060/1070 & 1080Ti) will stay remain crunching E@H and anxious for a solution to do their part here, as you know Seti is my beloved project.

Will try to reach Mike or Raistmer, maybe they could have any new idea.
ID: 1898378 · Report as offensive
Profile Brent Norman Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester

Send message
Joined: 1 Dec 99
Posts: 2786
Credit: 685,657,289
RAC: 835
Canada
Message 1898383 - Posted: 31 Oct 2017, 2:24:06 UTC - in response to Message 1898368.  

I'm forced to abandon crunching Seti on the GPU and back it to crunch Einstein. Leave the CPU running here,
A last resort maybe to try running CUDA apps, it will be a lot slower, but may keep it running SETI.
ID: 1898383 · Report as offensive
Profile Keith Myers Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 29 Apr 01
Posts: 13159
Credit: 1,160,866,277
RAC: 1,873
United States
Message 1898384 - Posted: 31 Oct 2017, 2:38:32 UTC - in response to Message 1898383.  

True, the old CUDA50 app has almost no need of a cpu core support. If SETI is your true first love, then a sacrifice is appropriate.
Seti@Home classic workunits:20,676 CPU time:74,226 hours

A proud member of the OFA (Old Farts Association)
ID: 1898384 · Report as offensive
juan BFP Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 16 Mar 07
Posts: 9786
Credit: 572,710,851
RAC: 3,799
Panama
Message 1898386 - Posted: 31 Oct 2017, 2:47:56 UTC - in response to Message 1898384.  
Last modified: 31 Oct 2017, 3:34:39 UTC

True, the old CUDA50 app has almost no need of a cpu core support. If SETI is your true first love, then a sacrifice is appropriate.


That could be a good idea. SoG on Cuda... OMG... IIRC was a pain. Will work on that. Thanks again.

<Edit> Done back to CUDA50 let´s see what i get.
No screen lag until now.
ID: 1898386 · Report as offensive
juan BFP Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 16 Mar 07
Posts: 9786
Credit: 572,710,851
RAC: 3,799
Panama
Message 1898517 - Posted: 1 Nov 2017, 14:20:21 UTC
Last modified: 1 Nov 2017, 14:21:35 UTC

To be a little productive, to run the old builds need to run 2 or 3 WU at a time but when i do that the BLC WU produces a little of lag.

Will think what i will do. The crunching performance is heavely penalized when compared against the Sog builds. Maybe is time to forget to try to use this GPU´s in S@H
ID: 1898517 · Report as offensive
Stephen "Heretic" Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 20 Sep 12
Posts: 5557
Credit: 192,787,363
RAC: 628
Australia
Message 1898598 - Posted: 1 Nov 2017, 22:38:29 UTC - in response to Message 1898013.  
Last modified: 1 Nov 2017, 23:05:50 UTC


Any other idea?


. . It's all been covered. But ...

. . I wouldn't think dropping -sbs below 512 would be of any help on a 3GB or 6GB card. But as has been said, the -hp setting should be removed, it is a real lag producer. Iterations should be fine at anything over 30 but -tt does not need to be more than about 120 or 150 at that value of iterations, too high can cause lag as well. And -use_sleep should reduce any log jam on system calls between CPU and GPU. As Keith says, it is surprising that there is no problem when running E@H. Well good luck.

Stephen
ID: 1898598 · Report as offensive
Profile Keith Myers Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 29 Apr 01
Posts: 13159
Credit: 1,160,866,277
RAC: 1,873
United States
Message 1898602 - Posted: 1 Nov 2017, 23:16:29 UTC - in response to Message 1898598.  

Yes, that is a real mystery to me too. Einstein GPU tasks have always rewarded GPU cards in the highest PCIe transfer rate slots and really show an impact by running in a X4 slot for example. Those tasks are a lot more demanding in bus transfers. Which should show the movie lag/dropout problem even more than SETI. A mystery for sure. I would really like to hear what the explanation is for no impact on movie playback with Einstein project.
Seti@Home classic workunits:20,676 CPU time:74,226 hours

A proud member of the OFA (Old Farts Association)
ID: 1898602 · Report as offensive
juan BFP Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 16 Mar 07
Posts: 9786
Credit: 572,710,851
RAC: 3,799
Panama
Message 1898612 - Posted: 2 Nov 2017, 1:50:41 UTC

My only clue is something on the code itself. The Seti SoG code was highly optimized, maybe too much. LOL

The Seti CUDA code works fine with the movies, but it highly penalizes when crunching blc WU, The Sog was made in Open CL, maybe that´s the answer, something inside the OpenCL itself. Who knows. Raistmer?

I PM Mike asking him if he has any other clue. No answer yet.

For now i will leave this GPU´s crunching E@H until a new idea apears.

<edit> Will test if the lag apears on the GPUGrid too, but i belive no, the GPUGrid code was writed in CUDA 8.0. Back with the answer tomorrow.
ID: 1898612 · Report as offensive
Profile Keith Myers Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 29 Apr 01
Posts: 13159
Credit: 1,160,866,277
RAC: 1,873
United States
Message 1898614 - Posted: 2 Nov 2017, 2:53:34 UTC - in response to Message 1898612.  

But that makes no sense to me either. Einstein is an OpenCL GPU app also. I do SETI, MilkyWay and Einstein OpenCL GPU apps on my systems. By far, the MilkyWay OpenCL app impacts the systems the greatest. I also run ProcessLasso and it is always having to put restraints on MW tasks. If fact, MW is just about the ONLY app that regularly has to be restrained by PL to maintain system responsiveness. I've never seen PL restrain any SETI or Einstein app.
Seti@Home classic workunits:20,676 CPU time:74,226 hours

A proud member of the OFA (Old Farts Association)
ID: 1898614 · Report as offensive
juan BFP Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 16 Mar 07
Posts: 9786
Credit: 572,710,851
RAC: 3,799
Panama
Message 1898615 - Posted: 2 Nov 2017, 3:04:52 UTC
Last modified: 2 Nov 2017, 3:09:43 UTC

Ok since i can´t go to sleep without make the tests.

Dpne In GPUGrid at least on the long runs there is NO LAG.

The Lag only appears on the SoG builds.

My clue is something in the code itself, some optimization who take control of the GPU maybe for microseconds but that´s is enought to produce the lag.

BTW It´s a GTX1060 3GB from Gygabyte running on a PCIe x16 Slot at GPU clock 1557 an d memory 2002 Mhz (stock). Check by GPU-Z

GIGABYTE GTX 1060 WindForce 2X OC
GV-N1060WF2OC-3GD

Now it´s with the dev´s.......
ID: 1898615 · Report as offensive
juan BFP Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 16 Mar 07
Posts: 9786
Credit: 572,710,851
RAC: 3,799
Panama
Message 1898622 - Posted: 2 Nov 2017, 4:26:04 UTC
Last modified: 2 Nov 2017, 4:28:12 UTC

Optimization is fine, and i like that on my cruncher only host.

But for a daily usehost I not care if i could use only 70% or even less of the GPU power if i could made a configuration who allow to see a movie without lags, nothing extraordinary, just a simple movie, not gaming or other GPU intensive program. Simply like that.

That´s the point. There must be a way to configurate the build to allow common users run without screen lags.

Chris S As you clearely explain, with your command line you must stop the boinc if you try to do anything on the host. That´s clearely not what most of the users wants .

Thanks alll for you help and patience
ID: 1898622 · Report as offensive
Profile Keith Myers Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 29 Apr 01
Posts: 13159
Credit: 1,160,866,277
RAC: 1,873
United States
Message 1898626 - Posted: 2 Nov 2017, 5:11:58 UTC

Please educate me. I don't watch movies on my daily driver which also crunches full-time. But I DO watch a lot of YT videos full-screen from my favorite tech tubers. I have no issues with lag or dropouts watching the YT videos. So what is the difference in video downloaded real-time from YT versus watching a movie? I don't think you ever stated whether you are watching the movie from a data stream or via recorded media.
Seti@Home classic workunits:20,676 CPU time:74,226 hours

A proud member of the OFA (Old Farts Association)
ID: 1898626 · Report as offensive
Profile Zalster Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 27 May 99
Posts: 5516
Credit: 528,817,460
RAC: 242
United States
Message 1898628 - Posted: 2 Nov 2017, 5:24:58 UTC - in response to Message 1898626.  

Juan, is this a mixed machine? I mean, 1060, 1070, 1080???
ID: 1898628 · Report as offensive
juan BFP Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 16 Mar 07
Posts: 9786
Credit: 572,710,851
RAC: 3,799
Panama
Message 1898633 - Posted: 2 Nov 2017, 6:26:57 UTC - in response to Message 1898628.  
Last modified: 2 Nov 2017, 6:41:57 UTC

NO all are single GPU hosts. The one i made the test it´s a single 1060 GPU on a X99 MB with a 6800 CPU..

I have another 2 hosts one with a 1070 and one with the 1080Ti..

The multi GPU host (3x1070+980Ti) its a complete diferent host.

About the movies, they are allready fully DL files to an SSD so the internet/HDD lag is out of the question.

Most of them are in low resolution (from torrent sites for example) mostly are simple TV Series or documentaries. Some even DL from streaming services like Netflix but never watched directly. My internet connection is very slow , so watch directly is not an option.

They run smothly when the GPU work is stoped even with few CPU WU running. The lag apears when the GPU work is started, even with no CPU work running. But only when runs GPU SOG work. When AP GPU work is done there are no Lag or the lag is to fast to notice.
ID: 1898633 · Report as offensive
Previous · 1 · 2 · 3 · Next

Message boards : Number crunching : GTX1060


 
©2022 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.