AMD 6950 GPU load starts and stops

Questions and Answers : GPU applications : AMD 6950 GPU load starts and stops
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile ITEHQ
Avatar

Send message
Joined: 10 Jun 16
Posts: 38
Credit: 1,810,243
RAC: 0
United States
Message 1798243 - Posted: 23 Jun 2016, 23:37:06 UTC

having a strange issue with SETI@home the latest version of BOINC.

I installed AMD 15.7.1 for my Sapphire HD6950,
Install the AMD SDK
GPUz shows OpenCL support
Event log shows I have OpenCL support in BOINC,

GPU usage will start and stop go for 5-30 seconds then stop, over and over again, all my other machines stay steady GPU usage. I see no throttling,

I have reformated, as well. Any ideas what could cause this? I tried running multiple WUs, default settings etc....
Monitoring the Universe for signs of intelligent life, as we have not found any on Earth yet (^_^)
ID: 1798243 · Report as offensive
Profile ITEHQ
Avatar

Send message
Joined: 10 Jun 16
Posts: 38
Credit: 1,810,243
RAC: 0
United States
Message 1798489 - Posted: 24 Jun 2016, 20:31:02 UTC

thinking maybe I should try and uninstall video drivers and install the

AMD 14.4 drivers for HD6950 and AMD SDK 2.9 which seems to have full support for HD6950,OpenCL.

15.7.1 and SDK3 causes GPU to start and stop, it also does this with no SDK installed.

I will let you know when I get this working. One problem is if the drivers are too old and it is my GFs PC battlefield 4 will crash if not using the latest drivers haha priorities!

IF I can get it working that would be great, I am going to be purchasing some new RX480s soon will also report those numbers.
Monitoring the Universe for signs of intelligent life, as we have not found any on Earth yet (^_^)
ID: 1798489 · Report as offensive
Profile Jord
Volunteer tester
Avatar

Send message
Joined: 9 Jun 99
Posts: 15183
Credit: 4,362,181
RAC: 3
Netherlands
Message 1798749 - Posted: 26 Jun 2016, 0:39:09 UTC - in response to Message 1798243.  
Last modified: 26 Jun 2016, 0:40:02 UTC

Install the AMD SDK

Why do you install the SDK? Are you an application developer, making your own GPU applications? If you aren't you don't need the SDK, you only need the AMD drivers, as they contain the necessary components for doing OpenCL calculations.

15.7.1 and SDK3 causes GPU to start and stop, it also does this with no SDK installed.

What do you mean with start and stop? Like it's being throttled?
Or do you drivers crash?
ID: 1798749 · Report as offensive
Profile ITEHQ
Avatar

Send message
Joined: 10 Jun 16
Posts: 38
Credit: 1,810,243
RAC: 0
United States
Message 1798956 - Posted: 27 Jun 2016, 5:04:36 UTC

When using the AMD 15.7.1 Drivers from the AMD website when monitoring GPUz.

BOINC will start and says it sees and is using the GPU, I can see load start goes up to 90% then it would stop and go to 0% load, then about 30 seconds later it would start again.... over and over again.

I read in other forums that installing the SDK helps to ensure the proper dll files are put in place for boinc and the graphics card to communicate correctly...

Installing AMD SDK 3 the latest version did not work. rebooting etc.. clean driver instllations etc...

FINALLY got it to work...

Install AMD 14.4 WHQL drivers, but that did not make it use any GPU load... hmmm.... Then I installed AMD SDK 2.9, NO REBOOt, launched BOINC started using GPU load steady with no issues.


I was reading and the HD6950 OpenCL is only compatible with AMD 14.4 and SDK 2.9
Monitoring the Universe for signs of intelligent life, as we have not found any on Earth yet (^_^)
ID: 1798956 · Report as offensive
Profile BilBg
Volunteer tester
Avatar

Send message
Joined: 27 May 07
Posts: 3720
Credit: 9,385,827
RAC: 0
Bulgaria
Message 1798992 - Posted: 27 Jun 2016, 15:10:18 UTC - in response to Message 1798956.  
Last modified: 27 Jun 2016, 15:23:25 UTC

clean driver instllations etc...

To be really "clean" did you used "Display Driver Uninstaller (DDU)"?:
http://www.wagnardmobile.com/
http://www.guru3d.com/files_details/display_driver_uninstaller_download.html


Install AMD 14.4 WHQL drivers, but that did not make it use any GPU load...

If "AMD 14.4 WHQL drivers" are the last working for HD 6950 - it is possible that ATI AMD dropped (did not include) the OpenCL part in the package.

Check if what you Downloaded have the OpenCL part:
- Open the Setup .exe by 7-Zip and look what files are inside
- Look in C:\ATI\Support\{driver version name}\Packages\Apps\OpenCL\

E.g. I can see OpenCL.msi in:
11-12_xp32_dd_ccc_ocl.exe\$_OUTDIR\Packages\Apps\OpenCL\
D:\ATI\Support\11-12_xp32_dd_ccc_ocl\Packages\Apps\OpenCL\
 


- ALF - "Find out what you don't do well ..... then don't do it!" :)
 
ID: 1798992 · Report as offensive
Profile ITEHQ
Avatar

Send message
Joined: 10 Jun 16
Posts: 38
Credit: 1,810,243
RAC: 0
United States
Message 1799075 - Posted: 27 Jun 2016, 22:04:16 UTC

This was actually a clean build from scratch, it would not work until I installed the AMD SDK 2.9 14.4 whql drivers.

I rebooted and everything but boinc would not have any gpu load until the SDK 2.9 was installed for my 6950.

Some people had to install it then uninstall it to get it working. interesting.

be nice if boinc could load the dlls that it requires.
Monitoring the Universe for signs of intelligent life, as we have not found any on Earth yet (^_^)
ID: 1799075 · Report as offensive
Profile ITEHQ
Avatar

Send message
Joined: 10 Jun 16
Posts: 38
Credit: 1,810,243
RAC: 0
United States
Message 1799077 - Posted: 27 Jun 2016, 22:04:32 UTC - in response to Message 1799075.  

yes I also used DDU.
Monitoring the Universe for signs of intelligent life, as we have not found any on Earth yet (^_^)
ID: 1799077 · Report as offensive
Profile ITEHQ
Avatar

Send message
Joined: 10 Jun 16
Posts: 38
Credit: 1,810,243
RAC: 0
United States
Message 1799078 - Posted: 27 Jun 2016, 22:11:39 UTC - in response to Message 1798992.  
Last modified: 27 Jun 2016, 22:12:10 UTC

Also I should state, that BOINC did see the gpu in the program 1cpu + 1 AMD GPU but it would not put any load on it. gpuz showed 0% load when the tasks were running.

installing the SDK2.9 with no reboot and relaunching boinc gpu load went to 80%-99%

all is well now.
Monitoring the Universe for signs of intelligent life, as we have not found any on Earth yet (^_^)
ID: 1799078 · Report as offensive

Questions and Answers : GPU applications : AMD 6950 GPU load starts and stops


 
©2022 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.