Linux Remote Admin

Questions and Answers : Unix/Linux : Linux Remote Admin

To post messages, you must log in.

AuthorMessage
Profile Pad

Send message
Joined: 21 Jun 00
Posts: 2
Credit: 746,592
RAC: 0
Ireland
Message 916568 - Posted: 10 Jul 2009, 18:00:54 UTC

Hi all,
I've got several linux boxes running the command line version of boinc/seti. I usually ssh into them, cd to the machine's dedicated dir and do any admin using the boinc_cmd tool. All that's fine but I'd like to do this without having to ssh. So I tried the line:

./boinc_cmd --host <host name or IP address> --passwd <strong key> --get_state

but I get the following error.
connect: Connection refused
can't connect to <host name>

Do I have to open ports or some such? Is there an alternative that I haven't thought of?

Thanks in advance,
Padraig

PS: Sorry if this was covered already, but can't find it.

ID: 916568 · Report as offensive
Profile Gundolf Jahn

Send message
Joined: 19 Sep 00
Posts: 3184
Credit: 386,704
RAC: 39
Germany
Message 916576 - Posted: 10 Jul 2009, 18:49:13 UTC - in response to Message 916568.

I'm not quite sure, but perhaps the remote controlling mechanism with gui_rpc_auth.cfg and remote_hosts.cfg is used here too. See Controlling BOINC remotely in the BOINC wiki.

Gruß,
Gundolf


Computer sind nicht alles im Leben. (Kleiner Scherz)

SETI@home classic workunits 3,758
SETI@home classic CPU time 66,520 hours

ID: 916576 · Report as offensive
Profile Kai
Volunteer tester
Avatar

Send message
Joined: 30 Jun 09
Posts: 619
Credit: 15,732
RAC: 0
United Kingdom
Message 916580 - Posted: 10 Jul 2009, 19:36:03 UTC
Last modified: 10 Jul 2009, 19:42:25 UTC

On the Client machines have you set --allow_remote_gui_rpc?
Or are you using .cfg files to control the lists of hosts that can connect remotely?

Let us know, we'll try our best to help you further!!!


"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former." - Albert Einstein
Vextor Homepage | Vextor Blog

ID: 916580 · Report as offensive
Profile Pad

Send message
Joined: 21 Jun 00
Posts: 2
Credit: 746,592
RAC: 0
Ireland
Message 917563 - Posted: 14 Jul 2009, 9:19:32 UTC - in response to Message 916580.

It's easy when you know how! Thanks guys, that web page is what I was looking for. Problem solved. Added the remote_host.cfg, restarted and presto.

ID: 917563 · Report as offensive

Questions and Answers : Unix/Linux : Linux Remote Admin


 
©2016 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.