Posts by computerguy09

1) Message boards : Number crunching : Formatting a Dell hardrive. (Message 932115)
Posted 9 Sep 2009 by Profile computerguy09
Hmm USB 5.25 eh.... Would love to archive my C64 stuff onto PC somehow. Yes I've got an emulator but it's my own stuff on the disks I would like to live for eternity.

I had to toss all my C64/PET hardware and software last year when I got flooded out. This included the early TPUG (Toronto users group) news letters and the dozens of different magazine titles I'd subscribed to (many from first issue), that I had collected starting in the late 70's. It was a really painfully experience getting rid of my introduction to home computing.

I still have the first 2 years of Byte magazine sitting in storage. And they are stacked high on shelves, well above any water line...
2) Message boards : SETI@home Staff Blog : If fire insurance were like health insurance. (Message 921932)
Posted 28 Jul 2009 by Profile computerguy09

Healthcare is a right, not a damned privilege.

There are many well financed lobby efforts aimed at protecting the profits of corporate healthcare.

The way we treat the weakest amongst us is a reflection of our society.

We are a society of people, who live on the earth together. None of us are perfect, but too often, we stop thinking beyond ourselves too much.

I agree that how we treat others around us is a reflection of our society.

I disagree that we should hand over the duty of taking care of "the weakest" to government. In the end, it's the responsibility of us all to take care of others.

And I'm tired of blaming "the evil corporate entities" as the problem. They are part of the problem. But it's also a problem of believing that folks that take responsibility for themselves, build a business or trade, and then are taxed at a high rate BECAUSE THEY ARE SUCCESSFUL should pay for anyone who "can't afford healthcare". I'm willing to pay my share, but that share shouldn't be any more than anyone else, including the "middle class". So put a 1% (or whatever percentage fits here) tax on everyone's income (including Congress!) to pay for a better way in healthcare.

Note: I'm not in the healthcare industry, but have been dealing with it for over 40 years. I don't make over $200,000 or whatever number is considered "rich" these days.

I'm tired of the politicians trying to spend the $ I send to the government...
3) Message boards : Number crunching : Why only 3 CPU's with Core 2 Quad CPU? (Message 915815)
Posted 8 Jul 2009 by Profile computerguy09
Hal had it right. When the project sent out the GPU based WU, it estimated that it would use about 10% of a CPU to help run that WU. For the "normal" CPU based workunits, probably coming from a project like SETI, they each will use 100% of a CPU or core. So when you see 5 WU's running, you should be running 4 CPU based WUs, and 1 GPU/CUDA based WU.

Based on that slight overhead in the CUDA WU, I typically do run my Q6600 @ 80% multiprocessor utilization. This allows my box to run 3 CPU-based WU and 1 GPU based WU, and leaves some time for the real user of the box (me!) to do things on the screen as well.

To fully cover every possibility, be aware that some BOINC projects, like AQUA@home, now have a multi-threaded application, which can use multiple CPUs for one WU. So those will show up as (3 CPU's, 0 CUDA), and so you'll see only 2 or 3 WU running on a quad processor machine.

4) Message boards : Number crunching : Why only 3 CPU's with Core 2 Quad CPU? (Message 915790)
Posted 8 Jul 2009 by Profile computerguy09
Thank you Hal.

Any ideas on the (0.11 CPUs, 1 CUDA) thing?


You have a video/graphic card in your PC that is capable of running CUDA tasks, which run on the GPU in your video card, not on your CPU. So it's taking up part of one CPU (.11 or about 10%) and all of the GPU to run a work unit (WU).

This is normal for a CUDA WU from the GPUGRID project.

As mentioned earlier, be sure your CPU and Multiprocessor preferences are set to 100%, and you should be running 4 CPU based (normal) WU and 1 CUDA WU on your C2Q.

5) Message boards : Technical News : More Groaning (Jun 10 2009) (Message 911033)
Posted 25 Jun 2009 by Profile computerguy09
I do recall one PDP system we had that suddenly started to re-boot itself when no-one was around. After much headscratching, this was tracked down to the latest batch of fan-fold paper on the line-printer being wood-free and building up an excessive static charge; eventually it would throw a spark to the nearest earthed metal and...


And then there was the janitor who kept unplugging the modem so he could use the outlet for the floor buffer...

I was around when one vax unplugged itself by melting the line cord.

I have seen the results of a program that would move the disk heads on one of the washing machine sized disk packs at the resonant frequency of the cabinet. Walked across the floor to the limit of the line cord.

Sounds like an RP06. Ah, those were the days...
6) Message boards : Number crunching : I don't get any CUDA Apps :-/ (Message 856278)
Posted 22 Jan 2009 by Profile computerguy09
01/21/09 19:33:21|SETI@home Beta Test|Message from server: Can't use CUDA app for SETI@home Enhanced: Your CUDA device has the wrong software version

This appears to be the message you get when your CUDA card only has CUDA 1.0 capability. If all is well, David is fixing the server to take out the mistaken assumption that CUDA 1.0 cards cannot run Seti CUDA, so this message should go away in the near future.

(And all CUDA 1.0 cards will be free, free! ;-))

I believe it depends on which CUDA version you compile the app with. Current version of CUDA is 2.0 (I think). For those v2.0 apps, there's backward compatibility to CUDA 1.1, but not to 1.0.

At least that's the way it's been explained in the GPUGRID forums. It also may be that the old v1.0 cards can still crunch, but since they take so long to complete, it may not be reasonable to run them.

If, on the other hand, there's no technical reason not to run the old V1.0 cards, and SETI's deadlines are long enough, then more power to remove the server side restriction.
7) Message boards : Number crunching : I don't get any CUDA Apps :-/ (Message 855805)
Posted 20 Jan 2009 by Profile computerguy09
Thank you for the feedback!

Well, I made sure that "GPU Usage" is checked. It was checked already at the time when I installed BOINC 6.4.5; so about 2 weeks ago.

I thought the CUDA app is already "common practice", thats why I was starting this thread. There is at least the official word on this website, that CUDA apps are ready to use.
But if there are still settings to do like "set your processor number manually to one more than you really have", and I have to install things, the official instruction is not talking about, then I leave my hands from that ;-)

You know, this is still a valuable daily used machine for me and I dont want any sudden crashes or so :)

So good luck with integrating CUDA !


8800 GTS 320/640 is the "old" G80 GPU, which typically won't run with CUDA v2 apps. It certainly isn't supported on GPUgrid, and probably isn't on SETI.

While CUDA drivers will load on this card, any recently built CUDA app most likely will run very slowly or not at all...
8) Message boards : Number crunching : zero credit (Message 855802)
Posted 20 Jan 2009 by Profile computerguy09
you appear to be using an out of date 4.36 optimised app needs to be updated then.

For some reason AP gives a 0 credit until two WUs agree

I expected that the pages would show "pending" not zero.

That's what most would expect, but it seems that you get zero until the WU validates, and then get credit.
9) Message boards : Number crunching : What will my experience be with CUDA? (Message 855799)
Posted 20 Jan 2009 by Profile computerguy09

I am running a Dell XPS M1530, I have downloaded the latest BIOS driver for said system. BIOS revision A12.

My Graphics Card is a Nvidia GeForce 8600M GT 256MB. I am running the apparent "current" Driver of 179.28.

My Science application is 6.03, with AK V8 SSE3 AP+MB, it has run very successfully since installation.

I have my preferences set to Use 3 multiprocessors (2CPU+1CUDA)

BOINC recognizes a Coprocessor, so does the SETI@home page for my laptop. No crunching (that I know of) is being run by CUDA.

Let's start with the basics... and go from there.

Is this a Laptop/Notebook? IF so, then you risk overheating. Notebooks weren't designed to run GPU at full tilt for 100% of time.

In the message log, what is the full line that shows CUDA device detection. Hopefully it doesn't say "emulation" anywhere. Just trying to verify that your graphics card is supported.

If you've setup BOINC to use the AK version, then you've got an app_info.xml in your SETI directory. You'll need to change/customize it to allow CUDA apps to be downloaded/run. That's not a trivial task, and is most likely the reason you're not running any CUDA WUs.
10) Message boards : Technical News : Smoking Room (Dec 30 2008) (Message 847296)
Posted 31 Dec 2008 by Profile computerguy09
Matt and crew,

Thanks as always for your dedication and hard work...
11) Message boards : Technical News : Tom (Dec 23 2008) (Message 847294)
Posted 31 Dec 2008 by Profile computerguy09
Hi Guys

I'm at work atm, so will try this after I get home.

I think I was a little tired yesterday, and SOME of the threads are am\\making more sense today.

After what happened with the cut and paste cc_config.xml last night, I must say I'm a little wary of doing it again, but "Nothing ventured, nothing gained".

Here's some free advice. If the projects set the % of CPU required for the GPU application to the right value, BOINC *should* manage the number of WU's of the correct type for you. By this, I mean that you shouldn't have to set NCPU's in the config file to anything higher than the actual number of CPUs/cores. I have seen 5 WU's running on my quad with a single GPU card. However, for some projects (GPUGRID, for example), the amount of CPU required to keep the GPU app fed takes 60% of a core, and so trying to run a CPU WU with a GPU WU isn't worth it. This only occurs on Windows - the Linux apps take only about 10-20% of a core to keep the GPUGRID app fed.

So, my advice is to stay away from the config XML file, and run more than one project so that you can easily keep all GPU and CPU cores running.
12) Message boards : Number crunching : BOINC not pulling 6.05 (Message 842014)
Posted 19 Dec 2008 by Profile computerguy09
If you have an app_info.xml file, it won't pull the CUDA client.

Also, I'm not sure that the "custom" BOINC client 6.5.x supports, or knows about CUDA. (At least one poster here showed 6.5.x in their logs)

BOINC client 6.3.x to 6.4.5 knows about CUDA, and will use the CUDA DLL to detect if there is a supported GPU present.

SO the first thing to try on a new setup is to install BOINC 6.4.5 client, then attach to SETI. That should pull the standard SET CUDA client.

Now, if you want to try to switch to BOINC 6.5, OK. If it works, great, but no guarantees.

That would be my approach.

Also note: Not all 8600/8800 video cards are supported by the SETI CUDA client. Got to the nVidia website and see if your card and GPU support at least CUDA v1.1 (NOT 1.0). And the latest nVidia drivers with CUDA 2.0 support are required as well.
13) Message boards : Number crunching : Does anyone run CPU + GPU SETI on main? (Message 842010)
Posted 19 Dec 2008 by Profile computerguy09
i think if you install boinc 6.2 and 6.4 in two folders then run them both ...

Can't be done.

1. BOINC checks if another client is already running and if it is, the 2nd started will give a message about that and not run at all.

2. There's only one registry entry for BOINC, so if you install 6.4 first, then try to install 6.2 in another directory, this install overwrites the registry settings of 6.4, including where the Data directory is ... if you then start 6.4, it will run with all the preferences of 6.2, in the directory of 6.2

Possible way to run 2 BOINC installations on the same host is to use
VM for CPU-bound BOINC apps and host OS for CUDA.
I did such installation with Win/Linux BOINCs running together on single host.
But there will be VM overhead.... not sure it's worth to try.
But for host that does SETI and only SETI MB and has CUDA capable GPU it can be good solution.

I was going to suggest just the same thing. I'm currently running 2 VM's on my quad-core Q6600. The box runs Vista 32-bit, but the 2 VM's are running 64-bit Linux. While I'm running the same project (Primegrid challenge right now) on all 3 "boxes", I could just as easily run the GPU SETI client on the "host" box, and be running AP units in the VM's. Host client is set to only run 1 processor, and the other 3 are split between the VM's. Works fine here.

Note: the ability to run 64-bit VM's with VMware under a 32-bit OS is dependent on your CPU and BIOS. VMware has a utility on their website that allows you to check this... VMware player is free.

14) Message boards : Technical News : Kitchen Light (Dec 18 2008) (Message 842004)
Posted 19 Dec 2008 by Profile computerguy09
Thanks for all your hard work. Thanks also for the acknowledgment that Beta uploads are hosed. I did some GPU work on Beta and it's been sitting on those uploads for forever (or at least since Tuesday!)

I had already rebooted the box (thank you, MS, for still requiring reboots after some "updates"), and since it's running 2 VM's with lots of PrimeGrid work, has no problem uploading to other projects...
15) Message boards : Number crunching : Multiprocessor question (Message 840306)
Posted 15 Dec 2008 by Profile computerguy09
As per the SETI preferences page,
"On multiprocessors, use at most 3 processors
(Enforced by version 5.10 and earlier)
On multiprocessors, use at most 75% of the processors
(Enforced by version 6.1+)"

So if you have the latest version of SETI, set number isn't enforced, % of processor use is.

As for Vista and SP1, I didn't install Vista until SP1 came out. BUT I know that isn't the issue because I have been running SETI on Vista SP1 since it came out.

SETI has been running great, Quad core processor is awesome and minus Astropulse, I still love SETI.

Thank you for the information, I'll keep it set at 75% of processor speed.

Just so it's clear, there are two different settings:

A: Use % of # of processors
B: Use % of CPU time

For Multicore/multiprocessor machines, if you see a slowdown, it's recommended to set A to less than 100%. That frees up a core to allow other things to run.

If you set B to less than 100%, you are telling BOINC to pause frequently on EVERY core to get an average CPU utilization of say, 75%. So, you'll run as many WU's as you have cores, but at less than full speed.

As an example, I was seeing heat/shutdown problems with my laptop, which has a dual-core AMD processor. It works much better, and with less stress on the fan/CPU to set A to 50%, so it only runs one WU at a time, on one of the cores. I did try to just set B to 80%. It did run 2 WU's but it didn't seem to run as well.
16) Message boards : Number crunching : Upgraded CPU ! (Message 813241)
Posted 29 Sep 2008 by Profile computerguy09
re: 6.2.18/19.

I'm running v 6.2.18/19 on several Windows hosts - Vista, Win2K3 and XP without any problems. They are all running 32-bit versions, not 64-bit. Been running for several weeks, with lots of different projects, including SETI.

Haven't tried v6.x on any of my Linux hosts.

17) Message boards : Number crunching : Qad core will not reboot (Message 813051)
Posted 29 Sep 2008 by Profile computerguy09
Easiest method to test, grab a DMM, turn on PC and remove the mobo powersupply.. check your PSU PIN out schematic and confirm the required voltage output, since its all TTL.. set the DMM to the appropiate scale of measurement.

Hopefully its your PSU.. although Im a little concerned with the size, 450W... seems kinda low, id like to know your hardware specs (GPU, mobo.. etc)


A quick note on this technique. The PS won't put out the listed voltages unless the "PS_ON" pin connector is grounded. This is usually used by the power switch circuitry to control your power to the CPU etc...

A good way to check if all the required signals are correct is to monitor the PS_OK pin connector. This signal is raised when the PS says all the voltages are correct.

So you can't just disconnect the cable from the motherboard, turn on the PS, and expect to get voltage on each pin.
18) Message boards : Number crunching : WOW...GPUGRID! (Message 811881)
Posted 25 Sep 2008 by Profile computerguy09
I downloaded and it is up and running but I have only 4 WU crunching right now and it did see my CUDA card how do I get it to crunch 4 cpu core and 1 gpu core at the same time?

Will I have to reset project this is what is found.

"9/25/2008 12:29:08 AM||CUDA devices found
9/25/2008 12:29:08 AM||Coprocessor: Device Emulation (CPU) (1)"

But I am crunching 4 WU on my CPU my GPU is not crunching.

If you get this message "Device Emulation", this usually means you don't have the right driver loaded, or that your card isn't supported by the latest CUDA driver. PS3GRID (and Nvidia) recently moved to using CUDA version 2, and some older cards (including some of the 8800 series!) only support CUDA v1 and aren't supported to run PS3/GPUGRID.

I'd check the forums at PS3GRID. They have a sticky post that highlights which cards don't/might/will work.
19) Message boards : Number crunching : 6.2.18 Issues. (Message 811875)
Posted 25 Sep 2008 by Profile computerguy09
I see that BOINC 6.2.19 is out.
Question: worth the bother of upgrading? I only crunch here, Einstein, MW and PrimeGrid. I'm Windows Vista Home Premium (SP1) in AMD 2.4 ghz dual core.
So, should I?

[edit] I've not had any problems with .18 so far :)[/edit]

I'm perfectly content with 5.10.45 but I hear projects like Pirates are forcing use of newer Boinc versions

I also crunch at PrimeGrid (and other BOINC projects) some of which have had 6.XX/XX problems so I was just looking for a broad view as to if I should update in regards to the overall BOINC world.
I have asked at PrimeGrid but not yet at Einstein or MW. I haven't had any issues at any of my projects with .18, but was just wondering.

I've tried BOINC 6.2.18/16/14 on 3 PC's now, 2 C2Q, one running VISTA(32) and one on XP64, also on a Pentium Dual-Core (P4D;Smithfield), runs XP32 Home.
On all 3 host's noticed the same kind off error's (GetSharedMem), also random reBOOT's, without any traceble cause yet.
Also problems with graphic card's. And some kind off interaction with 32BIT EINSTEIN, wich also produces error's. I've tested the 32BIT handling (SiSoftSandra) and found nothing, all test and benchmarks went smooth and OK.
Only thing left, going back to 5.10.45, on wich I never seen such strange error's.(And still use Crunch3r's 6.1.0 on one host.)
If my healt wasn't in such a bad condition*, I would have tried to figure out, or debug version 6.2.xx.
Do need surgery and am now on heavy (nico-morfin)painkillers :(

Not sure what's wrong with your setups, but I've been running 6.2.18 on 3 or 4 rigs (WinXP and Vista) for awhile without any problems. I've slowly been converting my 5.10.45 rigs to the 6.2.18/19 version.

I will leave at least one at 5.10.45 (it's an old P3) that runs LHC and a few other projects because of LHC's problems right now with 6.x.

I did try to run my quad 6600 on 6.3.10 for a little while, for GPUGRID, but due to problems with BOINCview and the graphics drivers, I moved back to 6.2.18.

20) Message boards : Number crunching : Task ID Rollover 999999999 - 1000000000 (Message 811731)
Posted 25 Sep 2008 by Profile computerguy09
Only 900 pending? When I checked this morning before going to work it was up around 1100.

That's not 900 credits pending, that's 900 work units in cache. A big difference.

I try to keep about 1 day's worth of WU in cache, which isn't much, but then again...I run several different projects.

Next 20

©2024 University of California
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.