strange problem with amdgpu install

Questions and Answers : Unix/Linux : strange problem with amdgpu install
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile Joseph Stateson Project Donor
Volunteer tester
Avatar

Send message
Joined: 27 May 99
Posts: 289
Credit: 70,759,933
RAC: 3
United States
Message 2032227 - Posted: 13 Feb 2020, 14:37:20 UTC
Last modified: 13 Feb 2020, 14:39:04 UTC

Spent hours trying to get a "mining only" RX570 to crunch. Finally gave up. Guess what happened after I pulled the "mining only card"?" None of the other cards worked on boinc!
Tried default=1 in grub.

Ran /usr/bin/amdgpu-pro-uninstall
then to be sure did apt purge amdpro*

Then did (with and w/o the --compute)
sudo ./amdgpu-install --compute
on amd driver 19.50 (the lastest)


saw several error messages, dkms was mentioned along with the error:
void found where constant char expected

grep in /var/log showed error messages such as "amdgpu accelerated=0" which was duplicated in the
/var/bin/boinc/stderr... log file

Shut it down and the next morning did all the above except the following change
sudo ./amdgpu-install --OpenCL=legacy,pal --no-dkms


that worked, did not see the "void found where constant char expected" and boinc is crunching away

I am afraid to reboot. I do have default=1 in grub because I thought that might fix the problem but it seem the --no-dkms was what fixed the problem
ID: 2032227 · Report as offensive

Questions and Answers : Unix/Linux : strange problem with amdgpu install


 
©2021 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.