Problems with NVIDIA Fermi / SETI@HOME / Win10 Update to V1803 ? See here

Message boards : Number crunching : Problems with NVIDIA Fermi / SETI@HOME / Win10 Update to V1803 ? See here
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile Seneca Special Project $75 donor
Volunteer tester
Avatar

Send message
Joined: 17 Oct 02
Posts: 51
Credit: 10,114,348
RAC: 272
Germany
Message 1937079 - Posted: 25 May 2018, 12:55:19 UTC
Last modified: 25 May 2018, 12:56:36 UTC

Hi friends,

just for your convenience if you run into the truoble I experienced:

After updating my Win10 pro desktop machine, containing a NVIDIA GForce GTX570 (based on the Fermi architecture), I faced severe problems, probably due to a NVIDIA driver in the update (388.x).


  • Initial symptom was SETI@HOME not recognizing the GPU, therefore not crunching anything with it.
  • Subsequently I had problems with the driver (any version) refusing to update/reinstall.
  • After solving that mess, the GPU was detected, but ran with the handbrake fastened at about 10% speed ... a regular SETI@HOME workunit ran more than 3 hours instead of the usual about 10 minutes (or about 1 hour on a single i7-2600k core).



Final remediation was


  • Run DDU (get the newest release, but at least V17.0.7.5) in Windows Safe Mode
  • Reboot
  • Run
    sfc /scannow
    DISM /Online /Cleanup-Image /RestoreHealth
    as administrator
  • install NVIDIA driver 375.70 (anything more recent I've tried failed ....)
  • probably reinstall BOINC (not sure if needed)



(You might read about my odyssee here and here. Applause for Links above to Greybear @ NVIDIA forums)

Greetings

SENECA


Per Aspera Ad ETI ..
0=0
ID: 1937079 · Report as offensive
rob smith Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer moderator
Volunteer tester

Send message
Joined: 7 Mar 03
Posts: 20913
Credit: 416,307,556
RAC: 380
United Kingdom
Message 1937093 - Posted: 25 May 2018, 14:27:29 UTC

A known issue is that Microsoft supplies drivers that do not have the parts required for calculation as they assume that everyone wants to play games and not do "real work" on their computers. BOINC looks for these, and if they are missing then it won't detect the GPU correctly, or if it does then then the GPU won't do the calculations correctly.
Solution
Turn off Windows drivers update
Download the drivers the the nVidia website - you may have to hunt for the drivers for your 570 as it is now several generations old and support is getting thinner on the round.
Install the drivers, doing a Clean installation, this option is generally hidden under the "advanced" button, but has been known to move on the odd occasion. I find that rebooting after the installation just to make sure everything is working well.
Finally - make sure that you are still running BOINC in "user" mode rather than as a service - it may be that the update has upset some setting or other (it shouldn't, but I don't trust MS not to....).
Bob Smith
Member of Seti PIPPS (Pluto is a Planet Protest Society)
Somewhere in the (un)known Universe?
ID: 1937093 · Report as offensive
Richard Haselgrove Project Donor
Volunteer tester

Send message
Joined: 4 Jul 99
Posts: 14488
Credit: 200,643,578
RAC: 874
United Kingdom
Message 1937100 - Posted: 25 May 2018, 15:07:20 UTC - in response to Message 1937093.  

I tested that situation not long after the 'Fall Creator's Update' (if that's the exact name, I forget, but the one about 7 or 8 months ago) - with a complete bare silicon fresh install of W10. It took about two days to download all the updates, but once they'd all arrived, the NVidia card in the machine had a Microsoft driver that was adequate for running CUDA tasks.

When I took the NVidia card out again, the intel_gpu downloaded a driver with OpenCL support. Put the NVidia card back in, and that inherits OpenCL support as well. Full house. So the Microsoft position is getting slowly better over time. Full report at message 1914455

There have been reports that NVidia itself put out a dodgy driver recently, so it's possible that 1803 came at just the wrong moment and inherited that one. That might explain why the OP's experience is different from mine. Installing a known good driver direct from nvidia.com is always good and safe advice, but it's a bit of a hassle - it may not always be necessary.
ID: 1937100 · Report as offensive
Kevin Olley

Send message
Joined: 3 Aug 99
Posts: 906
Credit: 261,085,289
RAC: 572
United Kingdom
Message 1937103 - Posted: 25 May 2018, 15:15:30 UTC - in response to Message 1937100.  

Nvidia 397.31 is the one to steer clear of.

Nvidia 397.64 has not given me any problems.

Nvidia 397.93 has just been released, have not tried.
Kevin


ID: 1937103 · Report as offensive
Grant (SSSF)
Volunteer tester

Send message
Joined: 19 Aug 99
Posts: 13352
Credit: 208,696,464
RAC: 304
Australia
Message 1937141 - Posted: 25 May 2018, 22:20:54 UTC

NVidia 372.54 is still working for me.
Grant
Darwin NT
ID: 1937141 · Report as offensive
Kevin Olley

Send message
Joined: 3 Aug 99
Posts: 906
Credit: 261,085,289
RAC: 572
United Kingdom
Message 1937148 - Posted: 25 May 2018, 22:41:24 UTC - in response to Message 1937141.  

I am still new to W10, was running Vista before that, which for me run stable all the time.

Only upgraded after I brought a pair of 1050 ti's, they would not run through lack of driver support in Vista.

Had an earlier driver bumped in w10 so do try to keep them fairly up to date.
Kevin


ID: 1937148 · Report as offensive

Message boards : Number crunching : Problems with NVIDIA Fermi / SETI@HOME / Win10 Update to V1803 ? See here


 
©2022 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.