Questions and Answers :
Unix/Linux :
Boinc on FreeNAS [FreeBSD] for setiathome
Message board moderation
Author | Message |
---|---|
Stefano Send message Joined: 26 May 01 Posts: 5 Credit: 14,062,108 RAC: 0 |
Here is the process I have done to get the furthest I can.. $ is the rapresentation of the shell in a terminal, the command is what I have to write to replicate the situation # is the error rapresentation @ is the specific account string 1) Create FreeBSD 9.3 Jail in FreeNAS using default values 2) $ portsnap fetch extract 3) $ pkg update 4) $ cd /usr/ports/net/boinc-client 5) $ ee Makefile 6) $ Change line (adding LINUX) "OPTIONS_DEFAULT= CLIENT MANAGER X11 LINUX USER" 7) $ pkg upgrade 8) $ make BATCH=yes install clean #1 Error, linux_base-c6-6.6_6 linuxulator is not (kld)loaded 9) $ cd /usr/local/bin 10) $ boinc & #2 No start 11) Now you need to add your project and hope it runs using the boinccmd CLI... pray about... 12) $ pkg-static install -f pkg 13) $ pkg2ng 14) $ pkg-static upgrade -f 15) $ cd /usr/ports/net/boinc-client 16) $ pkg install linux_base-c6 17) $ make BATCH=yes install clean 18) $ cd /usr/local/bin 19) $ boinc & #WORK! #OK #1 & #2 Error solved 20) $ cd /usr/ports/astro/boinc-setiathome-enhanced 21) $ make install clean Pico & Nano to edit file /etc/make.conf and other in future, because I hate VIM. If you use VIM ignore steps until 30 and use VIM instead of pico or nano 22) $ portsnap fetch update 23) $ portsnap fetch extract update 24) $ cd /usr/ports/editors/nano 25) $ make install clean 26) $ ln -s /usr/local/bin/nano /usr/bin/nano 27) $ ln -s /usr/local/bin/nano /usr/bin/pico 28) $ pico #WORK!! 28a) ctrl x 29) $ cd ~/ 30) $ nano .cshrc # change default SETENV editor to nano instead of ee or vi 31) $ nano /etc/make.conf 31a) BOINC_HOME=/var/db/boinc enter 31b) BOINC_USER=boinc enter 31c) BOINC_GROUP=nobody enter 31d) ctrl x enter 31e) y enter enter 32) $ nano /etc/rc.conf 32a) boinc_enable="YES" enter 32b) boinc_client_enable="YES" enter 32c) jail_sysvipc_allow="YES" enter 32d) boinc_client_flags="-allow_remote_gui_rpc" enter 32e) boinc_flags="-allow_remote_gui_rpc -redirectio" enter 32f) ctrl x 32g) y enter enter 33) $ cd /var/db/boinc/ && /usr/local/etc/rc.d/boinc* start #3 --> 'idprio: RTP_SET: Operation not permitted' 34) $ /usr/local/etc/rc.d/boinc* onestart #3 same error, demonstrate that is independent from configurations? I don't know but I'm praying... Continuing with the setting of my account manually 35) $ pico /var/db/boinc/account_setiathome.berkeley.edu.xml paste into the new file the 4 line down <account> <master_url>http://setiathome.berkeley.edu/</master_url> <authenticator>@Your_Auth_Code_ID</authenticator> </account> ctrl x y enter 36) $ boinc_client -attach_project http://setiathome.berkeley.edu @Your_Auth_Code_ID is needed some "infrastructure parts" 37) $ cd projects/setiathome.berkeley.edu 38) $ ln -s /usr/local/lib/boinc/setiathome 39) $ ln -s /var/db/boinc/projects/setiathome.berkeley.edu/app_info.xml 40) $ cat /etc/master.passwd Only a dubt about the home directory of boinc... but is correct 41) $ cd /usr/ports/astro/boinc-setiathome-v7/ 42) $ make install 43) $ cd /var/db/boinc 44) $ boinccmd --project_attach setiathome.berkeley.edu @Your_Auth_Code_ID #4 --> 'can't connect to local host' 45) $ boinc -attach_project setiathome.berkeley.edu @Your_Auth_Code_ID # WORK!!! 45a) ctrl C to kill the app 46) $ /var/db/boinc/gui_rpc_auth.cfg set something you can remember as a password instead of the alphanumeric string you found inside 47) $ chmod -R 755 /var/db/boinc/* 48) $ chown -R boinc /var/db/boinc/* 49) $ boinc_client -allow_remote_gui_rpc -attach_project http://setiathome.berkeley.edu @Your_Auth_Code_ID with this command here the app start, I can connect from a remote machine and see that all was downloaded from setiathome project server. The status of the works downloaded is in "Waiting for shared memory"... 50) /usr/local/etc/rc.d/boinc* start # 'idprio: RTP_SET: Operation not permitted' I've never prayed in my life except today SOME HELP!? |
Stefano Send message Joined: 26 May 01 Posts: 5 Credit: 14,062,108 RAC: 0 |
in file: /usr/local/etc/rc.d/boinc-client idprio 31 su - ${boinc_client_user} -c \ "\"${command}\" ${boinc_client_flags} ${command_args}" || return 1 this command is the cause of error 'idprio: RTP_SET: Operation not permitted' |
Stefano Send message Joined: 26 May 01 Posts: 5 Credit: 14,062,108 RAC: 0 |
$ sysctl security.bsd.unprivileged_idprio=1 -> sysctl: security.bsd.unprivileged_idprio=1: Operation not permitted ;( |
©2024 University of California
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.