Posts by Chirag Patel


log in
1) Questions and Answers : GPU applications : Is there a cuda_kepler yet? cuda_fermi Computation Error on GTX 660 Ti (Message 1280067)
Posted 745 days ago by Profile Chirag Patel
It is a known issue with the newer drivers and the stock app.

Currently the only solution is to install the optimized apps as they do not have that problem.

http://lunatics.kwsn.net/index.php?module=Downloads;sa=dlview;id=330

You will have to keep an eye on the forums here as we will be releasing an updated installer once multibeam v7 is released.

Is it only with Kepler GPUs though? The GTX 560 Ti worked fine even with 3xx series drivers.
2) Questions and Answers : GPU applications : Is there a cuda_kepler yet? cuda_fermi Computation Error on GTX 660 Ti (Message 1279995)
Posted 745 days ago by Profile Chirag Patel
So I recently upgraded from a GeForce GTX 560 Ti to a GTX 660 Ti, and ever since, all SETI@Home GPU tasks have failed with a computation error. I let it sit since August 24 with the 'No new tasks' option so I could finish the leftover CPDN tasks, and uninstalled BOINC, deleted the ProgramData\Boinc folder (I thought it was perhaps assuming I still had a 560 Ti), reinstalled, and today, the first cuda_fermi task failed, again.

Other GPU applications, like those from GPUGRID and Milkyway@Home work perfectly on the new GPU, even when I hadn't reset everything by uninstalling and deleting program data.

Any suggestions?

P.S. See this task, for example.
3) Questions and Answers : GPU applications : Safe to use laptop GPU? (GeForce GTX 260M) (Message 945325)
Posted 1779 days ago by Profile Chirag Patel
I'm a bit late to respond, but I bought the same computer (ASUS G51VX) three weeks ago and I've been running SETI@Home with no problems (except with SETI Beta's 6.09 CUDA application, but that's beta).

ASUS downclocks the GPU to 500/1250/900 MHz (core/shaders/memory) from NVIDIA's reference clocks of 550/1375/950 MHz, and this takes care of the temperature issue, mostly.

For example, at ASUS clocks with the SETI@Home CUDA 6.08 application running, my GPU temperatures average ~81C with a maximum of 86C.

At NVIDIA clocks, the temperature goes to 83C average, 87C maximum.

Compared to playing a game (Borderlands - fantastic game, by the way), the temperature goes up to 91C during Borderlands at 550/1375/900 MHz.

So somewhat surprisingly, SETI@Home CUDA uses less GPU processing power than most games (in fact, Crysis makes GPU temperature go to 93C).
4) Message boards : Number crunching : Q about nvidia crash & recovery. (Message 942828)
Posted 1790 days ago by Profile Chirag Patel
It's happened to me before, the GPU clocks go from 550/1375/900 MHz (core/shaders/memory) to 383/767/301 MHz and stay there, which is why WUs take considerably longer. Unfortunately, the only solution I know of is to restart. The drivers do this when the card gets too hot and/or you overclock too far.

You can use GPU-Z to check whether the clocks go down (under the Sensors tab).
5) Message boards : Number crunching : (x.xx CPUs, 1 CUDA) (Message 941984)
Posted 1793 days ago by Profile Chirag Patel
Later Beta 190.38 Notebook drivers are available in the 2nd post in this thread:

CUDA Toolkit and SDK 2.3 released

Claggy

Cool, thanks. I downloaded and installed the 190.38 beta drivers yesterday, and got the CUDA V2.3 DLLs from Lunatics, and now my long WUs finish in ~25 minutes, instead of ~45 minutes.

I am a bit concerned though, how can just a CUDA version upgrade cause such a massive increase in efficiency? I hope the Lunatics team are not taking any shortcuts in SETI@Home's algorithms just to get the highest RAC.

But - if it's a mobile GPU in a laptop/notebook - you must look to the GPU temps.

Like I said, because of boinc.exe and System activity/peaks, CPU and GPU tasks are disturbed.

If you work on your laptop, also if you have a big WU cache, this will disturb the GPU calculation. (if the CPU isn't idle)

Yes, I have to watch the temperatures sometimes. I've set the system to shut down if the GPU temp goes above 88C. The max is around 85C with the GPU at stock speeds (550/1375/950), and with the driver and CUDA DLL upgrade, the average temp is now 82C.

Also, there is absolutely no extra disk or CPU activity when I leave the laptop alone, except the occasional indexing. I don't have antivirus software installed (yes, I know the risks), and Windows 7 is very good about keeping CPU activity minimal.
6) Message boards : Number crunching : (x.xx CPUs, 1 CUDA) (Message 941558)
Posted 1795 days ago by Profile Chirag Patel
Chirag Patel,
I could be wrong... but you might get performance if you were to update your geforce drivers. I see you have 186.x

186.82 are the latest mobile drivers available officially from nVidia. I've tried LaptopVideo2Go's custom ones based on the 191.xx desktop drivers, but I've trouble with Powermizer in the past if I used those drivers (the 260M wouldn't clock down from max clocks even when the card was idle).

And call me Chirag. ;)
7) Message boards : Number crunching : (x.xx CPUs, 1 CUDA) (Message 941543)
Posted 1796 days ago by Profile Chirag Patel
AMD Phenom II X4 940 BE @ 4 x 3.0 GHz with 4x OCed GTX260-216.


It depend which kind of CPU and GPU/s you have.
Maybe, if you have >= 2x GTX2xx GPU series in your PC case, one/two (or more) free CPU-Core/s.

Wow, I only have one mobile GTX 260M (basically a shrunk desktop 9800 GT) with a P7350 CPU. That's only 112 shaders, compared to your 864! I will see what happens when I switch off one CPU core, or both.
8) Message boards : Number crunching : (x.xx CPUs, 1 CUDA) (Message 941460)
Posted 1796 days ago by Profile Chirag Patel
All right, thanks for the information everyone.

I'll play around with the one-CPU setting to see if my GPU WUs take less time. I have a Core 2 Duo P7350 (OC'd to 2.5 GHz), not the best CPU, so maybe the extra GPU usage will make up for the lack of a CPU core. And yes, CPU usage for the CUDA application jumps between 0% and 10% most of the time.
9) Message boards : Number crunching : (x.xx CPUs, 1 CUDA) (Message 941351)
Posted 1796 days ago by Profile Chirag Patel
if you look on your preferences on the BOINC manager you see the "run GPU when computer is being used" if its unclicked and you are using your PC then no it won't be running.

Yeah, I've clicked that option, so I know it's running even when I'm using my PC (also the CUDA task says 'Running' in the manager, not 'Waiting to run'). But it still hardly has any impact on the computer.
10) Message boards : Number crunching : (x.xx CPUs, 1 CUDA) (Message 941296)
Posted 1797 days ago by Profile Chirag Patel
So, I've noticed this line in my CUDA tasks, that says "Running (0.04 CPUs, 1 CUDA)". I assume this means that 4% of one CPU is being used to supply work to the GPU. Is that enough?

I have a feeling that the GPU isn't doing as much work as it could. For example, when I watch a movie and I forget to switch off BOINC, it still runs for a minute or so before the occasional stuttering. Also, Windows 7's Aero feature (say minimising windows) is unaffected most of the time even when BOINC is running. Does this mean my GPU is idle all that time?
11) Message boards : Number crunching : ATI - 6.10.13 - GFLOPS - How accurate? (Message 941284)
Posted 1797 days ago by Profile Chirag Patel
Doesn't 6.10.13 report nvidia's "marketing" FLOPS as well? The numbers in both cases (ATI and nVidia) are the peak single-precision float performance.
12) Message boards : Number crunching : Post your BOINC Startup 'CUDA' Info (Message 941259)
Posted 1797 days ago by Profile Chirag Patel
Representing all the notebook crunchers out there, here's the GTX 260M 1024MB GDDR3 card (actually a desktop 9800GT in disguise):


NVIDIA GPU 0: GeForce GTX 260M (driver version 18682, compute capability 1.1, 1024MB, est. 60GFLOPS)


The GFLOPS remains at 60, regardless of whether it's 550/1375/950 or 600/1500/900 (core/shader/memory) MHz. Right now I'm at 600/1500/900.
But CUDA-Z tells me 62481 Miops/s at stock and 66941 Miops/s at OC'd speeds, so shouldn't it be est. 62GFLOPS or 67GFLOPS?

Edit: Also, third post in three years... I should come here more often (the website that hosted my sig no longer exists..).
13) Message boards : Number crunching : Broadband Speed Test - speedtest.net (Message 827971)
Posted 2142 days ago by Profile Chirag Patel
Here's mine. Something is definitely amiss:

Those numbers are for the closest server, which is probably hosted by the ISP.

For a server slightly further away,

Hosted by someone else I presume.

Here's an especially disappointing one:


14) Message boards : Number crunching : SETI on XBox360? Petition Microsoft! (Message 670947)
Posted 2514 days ago by Profile Chirag Patel
True. My Xbox 360 hung after playing 16 hours of Oblivion straight. But if they find the perfect cutoff FLOPS (not using the processors to 100%), it is probably going to work. And very well. Better than my damned 1.6 GHz Pentium M at least.
And optimisation for it would be easy. Everyone with an Xbox 360 has exactly the same hardware to run SETI@Home.
15) Message boards : Number crunching : BOINC 5.4.9 (Message 303110)
Posted 3053 days ago by Profile Chirag Patel
I don't know if this question is appropriate for this thread, but I just downloaded BOINC 5.4.9 for Windows and reinstalled Trux's calibrating client. Now BOINC doesn't start. So, Trux's client doesn't work with the newest BOINC, eh?
Regards,
16) Questions and Answers : Unix/Linux : Can't find it (Message 283978)
Posted 3077 days ago by Profile Chirag Patel
The WU runntimes should IMHO be OK for this CPU.
Hm, it looks like you have installed and running correctly. With a "find / -name setiathome-4\\*" or "find / -name projects" you should find now the working directory.


I solved the problem by removing the Synaptic install of BOINC and then reinstalling BOINC manually into /usr/BOINC, and installed the optimised application and calibrating client.
But now, though the application works, the client doesn't calibrate my GFlops and CPU time like it does in Windows. How do I know if I'm still using the standard BOINC client or the calibrating one?
Thanks again,
17) Questions and Answers : Unix/Linux : Can't find it (Message 283503)
Posted 3078 days ago by Profile Chirag Patel
I did not know, where debian will install it. But you can do a find : "find / -name boinc_client" or "find / -name run_client" to find, where the package has installed the binaries.

That didn't work. This is what I get:

root@Tails:/home/moi# cd /
root@Tails:/# find / -name boinc_client
/usr/bin/boinc_client
find: WARNING: Hard link count is wrong for /proc: this may be a bug in your filesystem driver. Automatically turning on find's -noleaf option. Earlier results may have failed to include directories that should have been searched.
find: /proc/8342/task: No such file or directory
find: /proc/8342/fd: No such file or directory
find: /proc/8508/task: No such file or directory
find: /proc/8508/fd: No such file or directory
find: /proc/9193/task: No such file or directory
find: /proc/9193/fd: No such file or directory
root@Tails:/#

Now what? Should I reinstall BOINC? Using the terminal this time?
P.S. Why are my work units taking so long? My Linux host
18) Questions and Answers : Unix/Linux : Can't find it (Message 283210)
Posted 3078 days ago by Profile Chirag Patel
Umm, I've only been using Ubuntu for a week, or Linux for that matter, and I can't find the directory to which BOINC was installed.
I used Synaptic to get BOINC by adding these lines to /etc/apt/sources.list :
# BOINC packages for Ubuntu 5.10 "Breezy Badger"
deb http://pkg-boinc.alioth.debian.org/ubuntu breezy universe
deb-src http://pkg-boinc.alioth.debian.org/ubuntu breezy universe
And then I clicked reload, so boinc-client, boinc-dev and boinc-manager appeared in the 'New in repository' list, and I installed each one of them.
Now I've been trying to use this calibrated client and optimised application, but I can't find the BOINC directory, or the BOINC/projects/setiathome.berkeley.edu directory.
Sorry for being so dumb.
Thanks
19) Message boards : Number crunching : SETI/BOINC Milestonesâ„¢ VI -- Closed (Message 263733)
Posted 3108 days ago by Profile Chirag Patel
YEAH. Finally crossed 100000 credits, though 1 (out of 2) host died some time back.
20) Message boards : Number crunching : **** Closed SETI/BOINC Milestonesâ„¢ V Closed **** (Message 249005)
Posted 3137 days ago by Profile Chirag Patel
YEAH. Finally crossed an RAC of 1000 with two, lets say not-so-ultrafast, hosts. But something tells me the RAC is going to go below 1000 soon, because it took a week to go from 950 to 1000.
I'm also getting close to a rank of 10000 in SETI@Home.


Next 20

Copyright © 2014 University of California