Linux Problem - BOINC Won't Run Under Mate Desktop

Questions and Answers : Unix/Linux : Linux Problem - BOINC Won't Run Under Mate Desktop

To post messages, you must log in.

AuthorMessage
Terror Australis
Volunteer tester

Send message
Joined: 14 Feb 04
Posts: 1790
Credit: 225,259,130
RAC: 10,081
Australia
Message 1466334 - Posted: 19 Jan 2014, 18:46:56 UTC

Hi All
I recently installed 64 bit PCLinuxOS with the Mate desktop. I downloaded BOINC for 64 bit Linux from the boinc.berkeley website and installed it.

When I tried to run BOINC, it crashed with a "cannot find libgtk-x11-2.0.so.0" error.

I searched and found a file of the same name name in the /lib64 folder and symlinked to the /lib folder.

Now run_manager gives the error"wrong ELF class: ELFCLASS64"

I presumed that this meant that the BOINC Linux app for 64bit is actually a 32 bit app and the Manager was crashing because it could not find the appropriate 32 bit library.

I found the correct 32b lib but when I went to install it I ran into "dependency hell" and it refused to install because there were too many other programs that needed the 64b version.

The same BOINC download worked flawlessly first time using the same distro, but with the 64b KDE desktop.

I've posted the this problem on the PClinuxOS forums but have not received any viable answer. Does anyone here have an idea for a fix ?

T.A.

ID: 1466334 · Report as offensive
Push it back to the states where it belongs!
Avatar

Send message
Joined: 3 Apr 99
Posts: 2517
Credit: 104,984,489
RAC: 206
United States
Message 1466413 - Posted: 19 Jan 2014, 22:02:53 UTC
Last modified: 21 Mar 2014, 23:34:24 UTC

--

ID: 1466413 · Report as offensive
Profile ignorance is no excuse
Avatar

Send message
Joined: 4 Oct 00
Posts: 9529
Credit: 44,433,321
RAC: 0
Korea, North
Message 1472435 - Posted: 3 Feb 2014, 20:11:48 UTC

try downloading boinc from a linux repository. It might not be the latest version but it should have all the files intact and run as intended


In a rich man's house there is no place to spit but his face.
Diogenes Of Sinope

End terrorism by building a school

ID: 1472435 · Report as offensive

Questions and Answers : Unix/Linux : Linux Problem - BOINC Won't Run Under Mate Desktop


 
©2016 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.