Open beta for OpenCL AstroPulse for Intel GPUs started


log in

Advanced search

Message boards : Number crunching : Open beta for OpenCL AstroPulse for Intel GPUs started

Previous · 1 · 2 · 3 · 4 · 5 . . . 6 · Next
Author Message
hbomber
Volunteer tester
Send message
Joined: 2 May 01
Posts: 437
Credit: 50,852,854
RAC: 2
Bulgaria
Message 1342962 - Posted: 4 Mar 2013, 15:55:34 UTC

I'll join the test tonight also, got i3-3225 today.
____________

Profile Raistmer
Volunteer developer
Volunteer tester
Avatar
Send message
Joined: 16 Jun 01
Posts: 3419
Credit: 46,534,174
RAC: 9,773
Russia
Message 1343066 - Posted: 4 Mar 2013, 20:57:17 UTC - in response to Message 1342962.
Last modified: 4 Mar 2013, 20:58:17 UTC

I'll join the test tonight also, got i3-3225 today.

Good news!

Regarding work fetch - not so easy as I thought.
I recive _only_AP now.. so CPU sits idle. Reported issue on BOINC alpha mail list.
Think the reason in gpu_intel support. It supported in client but not in server code. So server thinks it sends CPU work while client accepts it as GPU Intel work... and ask more for CPU and so on and so forth. Had to switch venue to one that will not ask AP work at all to fill CPU queue with some MB tasks.
____________

ClaggyProject donor
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 4097
Credit: 33,049,529
RAC: 8,039
United Kingdom
Message 1343095 - Posted: 4 Mar 2013, 21:55:36 UTC - in response to Message 1343066.
Last modified: 4 Mar 2013, 21:57:40 UTC

I'll join the test tonight also, got i3-3225 today.

Good news!

Regarding work fetch - not so easy as I thought.
I recive _only_AP now.. so CPU sits idle. Reported issue on BOINC alpha mail list.
Think the reason in gpu_intel support. It supported in client but not in server code. So server thinks it sends CPU work while client accepts it as GPU Intel work... and ask more for CPU and so on and so forth. Had to switch venue to one that will not ask AP work at all to fill CPU queue with some MB tasks.

I had the same problem at Collatz, David changed in Boinc 7.0.34 what device name the client reported to the scheduler from CUDA to NVIDIA (when running anonymous platform),
projects with older Boinc server software wouldn't sent GPU work unless CPU work was also requested, then it suddenly became GPU work:

No work available for the applications you have selected

Claggy

zombie67 [MM]
Volunteer tester
Avatar
Send message
Joined: 22 Apr 04
Posts: 753
Credit: 16,591,806
RAC: 6,437
United States
Message 1345377 - Posted: 11 Mar 2013, 16:43:22 UTC - in response to Message 1342816.

this one gets work OK:


BOINC says there is an error with this app_info.xml. But I can't find it. I tried it with both .52 and .54.

1 3/11/2013 9:40:12 AM Starting BOINC client version 7.0.52 for windows_x86_64
2 3/11/2013 9:40:12 AM log flags: file_xfer, sched_ops, task, sched_op_debug
3 3/11/2013 9:40:12 AM Libraries: libcurl/7.25.0 OpenSSL/1.0.1 zlib/1.2.6
4 3/11/2013 9:40:12 AM Data directory: C:\ProgramData\BOINC
5 3/11/2013 9:40:12 AM Running under account zombie67
6 3/11/2013 9:40:12 AM Processor: 8 GenuineIntel Intel(R) Core(TM) i7-3770S CPU @ 3.10GHz [Family 6 Model 58 Stepping 9]
7 3/11/2013 9:40:12 AM Processor: 256.00 KB cache
8 3/11/2013 9:40:12 AM Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss htt tm pni ssse3 cx16 sse4_1 sse4_2 popcnt aes syscall nx lm vmx smx tm2 pbe
9 3/11/2013 9:40:12 AM OS: Microsoft Windows 8: Professional x64 Edition, (06.02.9200.00)
10 3/11/2013 9:40:12 AM Memory: 15.90 GB physical, 18.15 GB virtual
11 3/11/2013 9:40:12 AM Disk: 465.42 GB total, 309.34 GB free
12 3/11/2013 9:40:12 AM Local time is UTC -7 hours
13 3/11/2013 9:40:12 AM VirtualBox version: 4.2.6
14 3/11/2013 9:40:12 AM OpenCL: Intel GPU 0: Intel(R) HD Graphics 4000 (driver version 9.17.10.2932, device version OpenCL 1.1, 1624MB, 1624MB available, 45 GFLOPS peak)
15 SETI@home 3/11/2013 9:40:12 AM Found app_info.xml; using anonymous platform
16 SETI@home 3/11/2013 9:40:12 AM Syntax error in app_info.xml

____________
Dublin, CA

Profile WilliamProject donor
Volunteer tester
Avatar
Send message
Joined: 14 Feb 13
Posts: 1594
Credit: 9,468,608
RAC: 575
Message 1345405 - Posted: 11 Mar 2013, 17:20:41 UTC - in response to Message 1345377.
Last modified: 11 Mar 2013, 17:22:06 UTC

this one gets work OK:


BOINC says there is an error with this app_info.xml. But I can't find it. I tried it with both .52 and .54.

1 3/11/2013 9:40:12 AM Starting BOINC client version 7.0.52 for windows_x86_64
2 3/11/2013 9:40:12 AM log flags: file_xfer, sched_ops, task, sched_op_debug
3 3/11/2013 9:40:12 AM Libraries: libcurl/7.25.0 OpenSSL/1.0.1 zlib/1.2.6
4 3/11/2013 9:40:12 AM Data directory: C:\ProgramData\BOINC
5 3/11/2013 9:40:12 AM Running under account zombie67
6 3/11/2013 9:40:12 AM Processor: 8 GenuineIntel Intel(R) Core(TM) i7-3770S CPU @ 3.10GHz [Family 6 Model 58 Stepping 9]
7 3/11/2013 9:40:12 AM Processor: 256.00 KB cache
8 3/11/2013 9:40:12 AM Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss htt tm pni ssse3 cx16 sse4_1 sse4_2 popcnt aes syscall nx lm vmx smx tm2 pbe
9 3/11/2013 9:40:12 AM OS: Microsoft Windows 8: Professional x64 Edition, (06.02.9200.00)
10 3/11/2013 9:40:12 AM Memory: 15.90 GB physical, 18.15 GB virtual
11 3/11/2013 9:40:12 AM Disk: 465.42 GB total, 309.34 GB free
12 3/11/2013 9:40:12 AM Local time is UTC -7 hours
13 3/11/2013 9:40:12 AM VirtualBox version: 4.2.6
14 3/11/2013 9:40:12 AM OpenCL: Intel GPU 0: Intel(R) HD Graphics 4000 (driver version 9.17.10.2932, device version OpenCL 1.1, 1624MB, 1624MB available, 45 GFLOPS peak)
15 SETI@home 3/11/2013 9:40:12 AM Found app_info.xml; using anonymous platform
16 SETI@home 3/11/2013 9:40:12 AM Syntax error in app_info.xml


You did surround the 'works ok' example with
<app_info> </app_info>
tags?
No offence meant, just checking.
____________
A person who won't read has no advantage over one who can't read. (Mark Twain)

zombie67 [MM]
Volunteer tester
Avatar
Send message
Joined: 22 Apr 04
Posts: 753
Credit: 16,591,806
RAC: 6,437
United States
Message 1345413 - Posted: 11 Mar 2013, 17:33:35 UTC - in response to Message 1345405.
Last modified: 11 Mar 2013, 17:49:12 UTC

You did surround the 'works ok' example with
<app_info> </app_info>
tags?
No offence meant, just checking.


*smacks forehead*

Duh, that's it. Thanks!

Edit: Now, if I could only get some tasks. I have everything selected in my project preferences. All devices and all applications. Also, "If no work for selected applications is available, accept work from other applications?" is yes.

361 SETI@home 3/11/2013 10:46:33 AM [sched_op] Starting scheduler request
362 SETI@home 3/11/2013 10:46:33 AM Sending scheduler request: Requested by user.
363 SETI@home 3/11/2013 10:46:33 AM Requesting new tasks for intel_gpu
364 SETI@home 3/11/2013 10:46:33 AM [sched_op] CPU work request: 0.00 seconds; 0.00 devices
365 SETI@home 3/11/2013 10:46:33 AM [sched_op] intel_gpu work request: 108000.00 seconds; 1.00 devices
366 SETI@home 3/11/2013 10:46:40 AM Scheduler request completed: got 0 new tasks
367 SETI@home 3/11/2013 10:46:40 AM [sched_op] Server version 701
368 SETI@home 3/11/2013 10:46:40 AM No tasks sent
369 SETI@home 3/11/2013 10:46:40 AM No tasks are available for SETI@home Enhanced
370 SETI@home 3/11/2013 10:46:40 AM No tasks are available for Astropulse v505
371 SETI@home 3/11/2013 10:46:40 AM No tasks are available for SETI@home v7
372 SETI@home 3/11/2013 10:46:40 AM No tasks are available for AstroPulse v6
373 SETI@home 3/11/2013 10:46:40 AM Project has no tasks available
____________
Dublin, CA

Holmis
Volunteer tester
Send message
Joined: 1 Jun 99
Posts: 30
Credit: 880,763
RAC: 0
Sweden
Message 1345557 - Posted: 11 Mar 2013, 21:28:23 UTC - in response to Message 1345413.

361 SETI@home 3/11/2013 10:46:33 AM [sched_op] Starting scheduler request
362 SETI@home 3/11/2013 10:46:33 AM Sending scheduler request: Requested by user.
363 SETI@home 3/11/2013 10:46:33 AM Requesting new tasks for intel_gpu
364 SETI@home 3/11/2013 10:46:33 AM [sched_op] CPU work request: 0.00 seconds; 0.00 devices
365 SETI@home 3/11/2013 10:46:33 AM [sched_op] intel_gpu work request: 108000.00 seconds; 1.00 devices
366 SETI@home 3/11/2013 10:46:40 AM Scheduler request completed: got 0 new tasks
367 SETI@home 3/11/2013 10:46:40 AM [sched_op] Server version 701
368 SETI@home 3/11/2013 10:46:40 AM No tasks sent
369 SETI@home 3/11/2013 10:46:40 AM No tasks are available for SETI@home Enhanced
370 SETI@home 3/11/2013 10:46:40 AM No tasks are available for Astropulse v505
371 SETI@home 3/11/2013 10:46:40 AM No tasks are available for SETI@home v7
372 SETI@home 3/11/2013 10:46:40 AM No tasks are available for AstroPulse v6
373 SETI@home 3/11/2013 10:46:40 AM Project has no tasks available


That's exactly the same as I got. Haven't tried for a few day now as I'm waiting on a response over on the Intel board on why all OpenCL apps ran on the Intel HD Graphics stall when I turn my TV/monitor off.

The only way I was able to get any work was by adding another AP-app to the app_info and then manually reschedule the tasks to the Intel GPU.

I think that Claggy's comment about the server backend not being able to handle Intel GPUs yet is correct.
____________

Profile Wiggo
Avatar
Send message
Joined: 24 Jan 00
Posts: 6949
Credit: 94,583,403
RAC: 75,118
Australia
Message 1345568 - Posted: 11 Mar 2013, 21:40:56 UTC - in response to Message 1345557.
Last modified: 11 Mar 2013, 21:41:30 UTC

361 SETI@home 3/11/2013 10:46:33 AM [sched_op] Starting scheduler request
362 SETI@home 3/11/2013 10:46:33 AM Sending scheduler request: Requested by user.
363 SETI@home 3/11/2013 10:46:33 AM Requesting new tasks for intel_gpu
364 SETI@home 3/11/2013 10:46:33 AM [sched_op] CPU work request: 0.00 seconds; 0.00 devices
365 SETI@home 3/11/2013 10:46:33 AM [sched_op] intel_gpu work request: 108000.00 seconds; 1.00 devices
366 SETI@home 3/11/2013 10:46:40 AM Scheduler request completed: got 0 new tasks
367 SETI@home 3/11/2013 10:46:40 AM [sched_op] Server version 701
368 SETI@home 3/11/2013 10:46:40 AM No tasks sent
369 SETI@home 3/11/2013 10:46:40 AM No tasks are available for SETI@home Enhanced
370 SETI@home 3/11/2013 10:46:40 AM No tasks are available for Astropulse v505
371 SETI@home 3/11/2013 10:46:40 AM No tasks are available for SETI@home v7
372 SETI@home 3/11/2013 10:46:40 AM No tasks are available for AstroPulse v6
373 SETI@home 3/11/2013 10:46:40 AM Project has no tasks available


That's exactly the same as I got. Haven't tried for a few day now as I'm waiting on a response over on the Intel board on why all OpenCL apps ran on the Intel HD Graphics stall when I turn my TV/monitor off.

The only way I was able to get any work was by adding another AP-app to the app_info and then manually reschedule the tasks to the Intel GPU.

I think that Claggy's comment about the server backend not being able to handle Intel GPUs yet is correct.

For starters AP's have not been produced for a several days now and until new files are loaded there won't be any other than resends (see server page for those details).

Also rescheduling tasks from CPU to GPU (and visa versa) is not a very good idea at all as has been discussed many times before.

Cheers.
____________

Holmis
Volunteer tester
Send message
Joined: 1 Jun 99
Posts: 30
Credit: 880,763
RAC: 0
Sweden
Message 1345830 - Posted: 12 Mar 2013, 14:30:23 UTC - in response to Message 1345568.

Also rescheduling tasks from CPU to GPU (and visa versa) is not a very good idea at all as has been discussed many times before.

Cheers.


Yeah I've read about that and I only did it to test a suggestion from the Intel Developers forum. Won't be doing it again if not absolutely necessary.
____________

Profile trader
Volunteer tester
Send message
Joined: 25 Jun 00
Posts: 126
Credit: 4,968,173
RAC: 0
United States
Message 1346453 - Posted: 14 Mar 2013, 8:15:32 UTC - in response to Message 1332850.

[quote]Binaries are available here:
http://lunatics.kwsn.net/12-gpu-crunching/open-beta-for-intel-opencl-ap-application.0.html

To check if your intel processor supports OpenCL for GPU check this list:
http://software.intel.com/en-us/articles/opencl-release-notes/#2

[quote]

looked for thintel sdk on the intel site with the link provided else where in this thread. couldnt find where exactly to download. also just for my own curiousity is there a reason you use the 7zip format for your dl's and not regular zip format? i really hate having to install software on my system that isnt needed.
____________
I RTFM and it was WYSIWYG then i found out it was a PEBKAC error

hbomber
Volunteer tester
Send message
Joined: 2 May 01
Posts: 437
Credit: 50,852,854
RAC: 2
Bulgaria
Message 1346464 - Posted: 14 Mar 2013, 8:53:57 UTC
Last modified: 14 Mar 2013, 8:59:16 UTC

I ran several APs I had here, while there weren't new units split. I hit several problems. First - when you close most programs, I'm certain on Firefox, IE9, GPU-Z, Paint, crunching stops and needs BOINC restart or snooze/unsnooze. All cores were free during all my tests, so problem isn't there. This is game breaker unfortunately. Second - I'm using BOINC 6.10.58, heavily modified by me version, but just cosmetics, and problem is that it runs ALL AP tasks at once. I had to suspend them(more on this later) and allow them running one by one manually. And finally, suspend doesn't work at all - tasks remains running, so it needs additional BOINC restart(at least it marks it suspended in client_state.xml). I understand my BOINC/Manager version is very outdated, but warning about this behavior is needed - I'm not sure is this app supposed to run on such old BOINC version at any future moment.

I'm gonna run Intel OpenCL app now on live data and as I'm not into BOINC bugs or misfeatures itself, which version will be best to use?

As for performance. Those WUs I ran, were zero blanked tasks, crunched before with 4.6 GHz 2500K. Times were little above 15K seconds. On Intel GPU, HD4000, they took 9200-9300 second per WU, which is good enough, even very good. It differs big time from what I saw so far, as times, listed from users here, and it is unexplainable for me. Perhaps my relatively fast memory helps alot, but I doubt it is that much. Memory is running 1866 8-8-8-24 1T.
Overclocking is not giving a big deal - from 1050 MHz to 1350 MHz gave like 17% crunch time decrease, but almost doubled power consumption(well, its not a problem, it still barely reaches 14W).
As for start parameters. Just leave it with default parameters, my tests say. There are slight decreases with some other combinations of parameters, but not more than 1.7% by my measures.

I'm excited about this app, it could bring more RAC from weak CPU as my i3-3225, almost can double it, but only when first problem, with sudden stops, if fixed somehow. Ah, forgot to mention - turning monitor on/off by power policy or intentionally with program able to do it, doesn't affect crunching. It was fixed for me with latest(current) drivers.

I'll run tests for a week or so only. It has Windows 2003 installation, where it serves its purposes. When this app is mature, I'll definitely switch to other OS, where Intel OpenCL can run.
____________

hbomber
Volunteer tester
Send message
Joined: 2 May 01
Posts: 437
Credit: 50,852,854
RAC: 2
Bulgaria
Message 1346642 - Posted: 14 Mar 2013, 19:16:02 UTC

Well, whats wrong again?!?! Whole day not a single task assigned to the host.

3/14/2013 9:10:51 PM | SETI@home | update requested by user
3/14/2013 9:10:55 PM | SETI@home | [sched_op] Starting scheduler request
3/14/2013 9:10:55 PM | SETI@home | Sending scheduler request: Requested by user.
3/14/2013 9:10:55 PM | SETI@home | Requesting new tasks for intel_gpu
3/14/2013 9:10:55 PM | SETI@home | [sched_op] CPU work request: 0.00 seconds; 0.00 devices
3/14/2013 9:10:55 PM | SETI@home | [sched_op] intel_gpu work request: 864000.00 seconds; 1.00 devices
3/14/2013 9:11:02 PM | SETI@home | Scheduler request completed: got 0 new tasks
3/14/2013 9:11:02 PM | SETI@home | [sched_op] Server version 701
3/14/2013 9:11:02 PM | SETI@home | No tasks sent
3/14/2013 9:11:02 PM | SETI@home | No tasks are available for SETI@home Enhanced
3/14/2013 9:11:02 PM | SETI@home | No tasks are available for Astropulse v505
3/14/2013 9:11:02 PM | SETI@home | No tasks are available for AstroPulse v6
3/14/2013 9:11:02 PM | SETI@home | Project has no tasks available
3/14/2013 9:11:02 PM | SETI@home | Project requested delay of 303 seconds
3/14/2013 9:11:02 PM | SETI@home | [sched_op] Deferring communication for 5 min 3 sec
3/14/2013 9:11:02 PM | SETI@home | [sched_op] Reason: requested by project


____________

Profile Raistmer
Volunteer developer
Volunteer tester
Avatar
Send message
Joined: 16 Jun 01
Posts: 3419
Credit: 46,534,174
RAC: 9,773
Russia
Message 1346647 - Posted: 14 Mar 2013, 19:34:41 UTC - in response to Message 1346464.
Last modified: 14 Mar 2013, 19:35:22 UTC

1) Regarding BOINC version.
You use BOINC w/o OpenCL support. So it can't properly handle GPU apps.
It looks into their CPU share perhaps and launches many tasks at once cause CPU share is low.
For such old configs ALL my GPU apps have so called "GPUlock" feature. Now, with BOINC 7 introduction, it disabled by default but still presents. Read ReadMe file and try corresponding switches listed there.
Or BOINC 7.0.52 and up that understand what Intel GPU is.

2)Regarding app stops on firefox and so on closing. Definitely not app-level issue. So please take time to report your config and findings on Intel forum (look links above for corresponding thread there). This was reported issue already but Intel's support still has no clue how to fix this.
Does your host has another GPU ?

3) I found that crunching time strongly depends (as with other OpenCL flavors) from CPU load. But for my own host leaving cores free is waste of resourses (I have HD2500 not HD4000) so i crunch with full cores busy + GPU AP.
____________

zombie67 [MM]
Volunteer tester
Avatar
Send message
Joined: 22 Apr 04
Posts: 753
Credit: 16,591,806
RAC: 6,437
United States
Message 1346705 - Posted: 14 Mar 2013, 22:09:24 UTC

Has anyone been able to get any tasks? I know the AP queue is empty, but I haven't even been able to get resends over the past three days. So I am not sure if the would issue them to me, if they were available.
____________
Dublin, CA

Profile MikeProject donor
Volunteer tester
Avatar
Send message
Joined: 17 Feb 01
Posts: 24084
Credit: 33,088,757
RAC: 23,946
Germany
Message 1346706 - Posted: 14 Mar 2013, 22:11:41 UTC

I got 4 at least.

____________

Profile trader
Volunteer tester
Send message
Joined: 25 Jun 00
Posts: 126
Credit: 4,968,173
RAC: 0
United States
Message 1348005 - Posted: 18 Mar 2013, 6:59:56 UTC - in response to Message 1332850.

[quote]Binaries are available here:
http://lunatics.kwsn.net/12-gpu-crunching/open-beta-for-intel-opencl-ap-application.0.html

quote]


could someone convert this file to zip format for me. pm me if you are willing
____________
I RTFM and it was WYSIWYG then i found out it was a PEBKAC error

Profile arkaynProject donor
Volunteer tester
Avatar
Send message
Joined: 14 May 99
Posts: 3643
Credit: 48,596,091
RAC: 5,562
United States
Message 1348008 - Posted: 18 Mar 2013, 7:23:13 UTC - in response to Message 1348005.

[quote]Binaries are available here:
http://lunatics.kwsn.net/12-gpu-crunching/open-beta-for-intel-opencl-ap-application.0.html

quote]


could someone convert this file to zip format for me. pm me if you are willing


Why, 7-zip is a very good application.
http://www.7-zip.org/
____________

Profile trader
Volunteer tester
Send message
Joined: 25 Jun 00
Posts: 126
Credit: 4,968,173
RAC: 0
United States
Message 1348013 - Posted: 18 Mar 2013, 7:44:01 UTC - in response to Message 1348008.

[quote]Binaries are available here:
http://lunatics.kwsn.net/12-gpu-crunching/open-beta-for-intel-opencl-ap-application.0.html

quote]


could someone convert this file to zip format for me. pm me if you are willing


Why, 7-zip is a very good application.
http://www.7-zip.org/



because windows has a built in zip extractor. and i do not like adding software that i do not need.
____________
I RTFM and it was WYSIWYG then i found out it was a PEBKAC error

Profile Raistmer
Volunteer developer
Volunteer tester
Avatar
Send message
Joined: 16 Jun 01
Posts: 3419
Credit: 46,534,174
RAC: 9,773
Russia
Message 1348019 - Posted: 18 Mar 2013, 8:46:06 UTC - in response to Message 1348013.
Last modified: 18 Mar 2013, 8:49:03 UTC


because windows has a built in zip extractor. and i do not like adding software that i do not need.

LoL, how you define "needed software" then if you can't use app because you don't have archiver to extract binaries? Some "search toolbar" installed together with "free" app and never used - that's unneeded software. But archiver required for extraction - is very needed software. I would say even "must have" one.
And what included in Windows doesn't really matter. Prev Windows did not have even zip, but peoples used zip, rar, arj, uc2 and so on even w/o M$ help. Archivers are system software that should present on host.
____________

Profile trader
Volunteer tester
Send message
Joined: 25 Jun 00
Posts: 126
Credit: 4,968,173
RAC: 0
United States
Message 1348021 - Posted: 18 Mar 2013, 9:10:24 UTC - in response to Message 1348019.


because windows has a built in zip extractor. and i do not like adding software that i do not need.

LoL, how you define "needed software" then if you can't use app because you don't have archiver to extract binaries? Some "search toolbar" installed together with "free" app and never used - that's unneeded software. But archiver required for extraction - is very needed software. I would say even "must have" one.
And what included in Windows doesn't really matter. Prev Windows did not have even zip, but peoples used zip, rar, arj, uc2 and so on even w/o M$ help. Archivers are system software that should present on host.



i do not install search toolbars or any toolbar for that matter. and i owned a current copy of zip (pre windows days) and winzip up until windows incoperated a zip extractor at which time i stopped installing winzip. even whan i buy hardware 95% of the stuff that comes with it is not installed.
____________
I RTFM and it was WYSIWYG then i found out it was a PEBKAC error

Previous · 1 · 2 · 3 · 4 · 5 . . . 6 · Next

Message boards : Number crunching : Open beta for OpenCL AstroPulse for Intel GPUs started

Copyright © 2014 University of California