Underclaiming credits with 4.* clients and 4.27 app's


log in

Advanced search

Message boards : Number crunching : Underclaiming credits with 4.* clients and 4.27 app's

Author Message
Profile Logan
Volunteer tester
Avatar
Send message
Joined: 26 Jan 07
Posts: 743
Credit: 917,654
RAC: 136
Spain
Message 628986 - Posted: 29 Aug 2007, 17:57:39 UTC
Last modified: 29 Aug 2007, 17:58:57 UTC

Hi...!

I was looking my claimed and granted credits and i find this:

595334455 2538296 20 Aug 2007 14:31:17 UTC 23 Aug 2007 12:23:21 UTC Over Success Done 20,638.95 33.85 33.85
595334456 3048167 21 Aug 2007 0:35:34 UTC 29 Aug 2007 10:17:14 UTC Over Success Done 10,111.17 74.28 33.85

The first is from my 'quorum mate' and the second it's mine... (WU 149762826)

His stderr show that:

<core_client_version>4.45</core_client_version>
<stderr_txt>
Unrecognized XML in parse_init_data_file: core_version
Skipping: 445
Skipping: /core_version
Unrecognized XML in parse_init_data_file: core_version
Skipping: 445
Skipping: /core_version
Unrecognized XML in parse_init_data_file: core_version
Skipping: 445
Skipping: /core_version
setiathome_enhanced 5.27 DevC++/MinGW

Work Unit Info:
...............
WU true angle range is : 0.386084
Optimal function choices:
-----------------------------------------------------
name
-----------------------------------------------------
v_BaseLineSmooth (no other)
v_vGetPowerSpectrumUnrolled 0.00037 0.00000
v_ChirpData 0.02218 0.00000
v_vTranspose4x16ntw 0.01225 0.00000
AK SSE folding 0.00153 0.00000
Unrecognized XML in parse_init_data_file: core_version
Skipping: 445
Skipping: /core_version
Unrecognized XML in parse_init_data_file: core_version
Skipping: 445
Skipping: /core_version
Restarted at 50.65 percent.
No heartbeat from core client for 31 sec - exiting
Unrecognized XML in parse_init_data_file: core_version
Skipping: 445
Skipping: /core_version
Unrecognized XML in parse_init_data_file: core_version
Skipping: 445
Skipping: /core_version
Restarted at 50.65 percent.
Unrecognized XML in parse_init_data_file: core_version
Skipping: 445
Skipping: /core_version
Unrecognized XML in parse_init_data_file: core_version
Skipping: 445
Skipping: /core_version
Unrecognized XML in parse_init_data_file: core_version
Skipping: 445
Skipping: /core_version
Restarted at 86.18 percent.
No heartbeat from core client for 31 sec - exiting
Unrecognized XML in parse_init_data_file: core_version
Skipping: 445
Skipping: /core_version
Unrecognized XML in parse_init_data_file: core_version
Skipping: 445
Skipping: /core_version
Restarted at 86.18 percent.

Flopcounter: 22521139935562.645000

Spike count: 3
Pulse count: 1
Triplet count: 0
Gaussian count: 0

</stderr_txt>

That is becouse he have the 4.45 core client version...?

The app version is the latest... 5.27 says the stderr...

Anybody knows what is happening...?


Thank for all.

Best regards from Spain.



____________
Logan.

BOINC FAQ Service (Ahora, también disponible en Español/Now available in Spanish)

Profile Jim-R.
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 7 Feb 06
Posts: 1475
Credit: 46,565
RAC: 0
United States
Message 628990 - Posted: 29 Aug 2007, 18:02:39 UTC - in response to Message 628986.
Last modified: 29 Aug 2007, 18:05:47 UTC

Hi...!


That is becouse he have the 4.45 core client version...?

The app version is the latest... 5.27 says the stderr...

Anybody knows what is happening...?


Thank for all.

Best regards from Spain.



Yes, this is because your "wingman" is running the 4.45 version of BOINC. Any version earlier than 5.2.6 uses the "benchmarks vs time" method of calculating credits, and usually underclaims badly. (Not always, but "most" of the time.)
BOINC versions 5.2.6 and up use FPOPS or Floating Point OPerations to calculate the claimed credits.
The project allows these older versions because the newer versions have problems communicating through certain types of proxy servers, and newer versions aren't available for a few operating systems, so until these issues are fixed we will still see these older versions around.
____________
Jim

Join GQFCrunchers
Problems?
Check the Boinc Wiki
Or NEW Enhanced FAQ

Astro
Volunteer tester
Avatar
Send message
Joined: 16 Apr 02
Posts: 8026
Credit: 600,015
RAC: 0
Message 628993 - Posted: 29 Aug 2007, 18:03:51 UTC

Hi, or is that Hola?

Anyway. The things you're refering to are different. The 4.45 core client is BOINC. The 5.27 is the new MB Seti application that runs under Boinc.

Any Core client (boinc) version below 5.2.7 doesn't use the current counting method to determine "claimed credit". There doesn't appear to be a high percentage of those boinc clients left, but they do exist. Anyway, they "generally" claim less than the newer Boinc versions using "flops counting" do.

There's been much chat about asking the project to stop issuing work to those old Core Clients, but nothing has happened as of yet. There are a couple good reasons why the project hasn't done so. One is that the newer CC's don't support ntlm proxies very well, so Seti would lose out on the larger corporate machines running from behind those proxies. There are a few others I won't mention.

Anyway, every should be getting "paired" up with these users at about the same rate, so in the end, it's fair (I guess).

does this help?

tony

Profile Logan
Volunteer tester
Avatar
Send message
Joined: 26 Jan 07
Posts: 743
Credit: 917,654
RAC: 136
Spain
Message 629001 - Posted: 29 Aug 2007, 18:16:49 UTC
Last modified: 29 Aug 2007, 18:54:04 UTC

Thanks Jim...

I suspected that...

I sent a PM to my wingman, asking him to update to 5.10.13 client.

Best Regards


Hola Astro.

Yes, I know... app crunchs and client manages... Anyway, thaks for the detailed explanations...


Saludos
____________
Logan.

BOINC FAQ Service (Ahora, también disponible en Español/Now available in Spanish)

Profile The Chosen
Avatar
Send message
Joined: 24 Jul 00
Posts: 54
Credit: 4,508,244
RAC: 3
Germany
Message 629450 - Posted: 30 Aug 2007, 6:03:16 UTC

yes there is until today the proxy problem

all my pc's behind my proxy must run 4.45 version

with all the newer versions i have problems to connect to the seti server

if one day the 4.45 version is no more allowed i have a problem

im only sad about this...until today the developers not fix this problem in the newer versions...why i dont know...

greetings
ralf

Richard HaselgroveProject donor
Volunteer tester
Send message
Joined: 4 Jul 99
Posts: 8434
Credit: 47,898,483
RAC: 57,057
United Kingdom
Message 629473 - Posted: 30 Aug 2007, 8:12:45 UTC

Interesting post from Thyme Lawn in CPDN today:

Boinc doesn't cope with proxy servers very well.

Not quite true. I'm only aware of BOINC having a problem with proxy servers using NTLM authentication, but a CPDN user who was affected by that problem has confirmed to me that it was fixed for him in 5.10.13.

The best way I know of diagnosing what's causing the problem is to install the freeware network protocol analyser Wireshark and use it to trace the HTTP packets between BOINC and the proxy server.

I'll see if I can get further information from him.

Profile Logan
Volunteer tester
Avatar
Send message
Joined: 26 Jan 07
Posts: 743
Credit: 917,654
RAC: 136
Spain
Message 629640 - Posted: 30 Aug 2007, 16:28:06 UTC

I find another user with 4.45:

595623106 1844958 21 Aug 2007 13:21:25 UTC 22 Aug 2007 2:41:34 UTC Over Success Done 26,318.67 44.90 44.90
595623107 3048167 21 Aug 2007 0:56:33 UTC 30 Aug 2007 5:13:51 UTC Over Success Done 9,759.98 74.20 44.90

I hope he reads my PM and update to 5.10.13...



____________
Logan.

BOINC FAQ Service (Ahora, también disponible en Español/Now available in Spanish)

Profile Logan
Volunteer tester
Avatar
Send message
Joined: 26 Jan 07
Posts: 743
Credit: 917,654
RAC: 136
Spain
Message 629795 - Posted: 30 Aug 2007, 21:07:53 UTC
Last modified: 30 Aug 2007, 21:09:52 UTC

This post is for edit the tittle of the tread.
____________
Logan.

BOINC FAQ Service (Ahora, también disponible en Español/Now available in Spanish)

Profile Pooh Bear 27
Volunteer tester
Avatar
Send message
Joined: 14 Jul 03
Posts: 3221
Credit: 2,080,926
RAC: 900
United States
Message 629837 - Posted: 30 Aug 2007, 22:55:48 UTC

Reading on other project forums, it seems the NTML Proxy issue was fixed in the current 5.10.13 version. People who could not use CPDN because they could only use 5, are now coming back because the Proxy issue is gone.

People who read this, I'd like someone on the old that has/had this issue please at least try one update to 5.10.13 and see if it is gone. If it works, this would make tons of people happy.

____________

Message boards : Number crunching : Underclaiming credits with 4.* clients and 4.27 app's

Copyright © 2014 University of California