Proxy requiring login and password


log in

Advanced search

Questions and Answers : Unix/Linux : Proxy requiring login and password

Author Message
Profile [BAT]Krikke
Volunteer tester
Send message
Joined: 2 Jun 00
Posts: 11
Credit: 276,487
RAC: 0
Belgium
Message 1798 - Posted: 25 Jun 2004, 9:46:19 UTC

Will support be added to be able to connect through
a proxy that requires authentication ?
"reality is an illusion created by a lack of alcohol"

albertw
Send message
Joined: 13 Apr 99
Posts: 8
Credit: 3,155,815
RAC: 0
Ireland
Message 1907 - Posted: 25 Jun 2004, 14:16:59 UTC

This appears to be provided through the http_user_name and http_user_passwd tags in client_state.xml though I have not tested it.

Achim
Send message
Joined: 11 Jun 99
Posts: 5
Credit: 549,423
RAC: 19
Luxembourg
Message 9688 - Posted: 19 Jul 2004, 10:43:56 UTC

HI,

I tested it(Version 3.20), but had no success.

setting the HTTP_USER_NAME and HTTP_USER_PASSWD did not update the corresponding lines in client_state.xml
So I added it manually:
xxx
xxx

But still I get this:
2004-07-19 12:28:00 [---] HTTP_OP_SET::poll(): Proxy Authentication Failed
2004-07-19 12:28:00 [---] HTTP_OP_SET::poll(): Proxy Authentication Failed

And the proxy itself (I'm using squid), reports the try, but does not see the user.

So I checked on the net, and found nothing.

Seems either we need somthing like for authetification, or we have a bug.

Achim
Send message
Joined: 11 Jun 99
Posts: 5
Credit: 549,423
RAC: 19
Luxembourg
Message 9692 - Posted: 19 Jul 2004, 10:57:12 UTC - in response to Message 9688.

> HI,
>
> I tested it(Version 3.20), but had no success.
>
> setting the HTTP_USER_NAME and HTTP_USER_PASSWD did not update the
> corresponding lines in client_state.xml
> So I added it manually:
> xxx
> xxx
>
> But still I get this:
> 2004-07-19 12:28:00 [---] HTTP_OP_SET::poll(): Proxy Authentication Failed
> 2004-07-19 12:28:00 [---] HTTP_OP_SET::poll(): Proxy Authentication Failed
>
> And the proxy itself (I'm using squid), reports the try, but does not see the
> user.
>
> So I checked on the net, and found nothing.
>
> Seems either we need somthing like for authetification, or we have a bug.
>
>
>
Oops:
now I searched the boinc code as well and found the use_proxy_auth tag.
it looks like this:



....
xxxx
xxxx


Now I don't get the Auth message any more, so I assume it works.

Questions and Answers : Unix/Linux : Proxy requiring login and password

Copyright © 2014 University of California