GPU detection failed: process exited with status 0x1: Incorrect function. (0x1) :(

Questions and Answers : Windows : GPU detection failed: process exited with status 0x1: Incorrect function. (0x1) :(
Message board moderation

To post messages, you must log in.

AuthorMessage
Idahoryan

Send message
Joined: 4 Jun 19
Posts: 2
Credit: 150,339
RAC: 0
Message 1996931 - Posted: 5 Jun 2019, 17:25:58 UTC

Hello fellow searchers!
II a hoping some throw me a bone here on an error I am seeing regarding failed GPU detection.

The machine is running Windows 10 with an Intel Core I9 9980XE 18 core processor with a GTX 1080TI and AMD Firepro W7100
I downloaded video drivers straight from the manufacturer websites The GTX is running driver version 26.21.14.3086 (driver date 5.22.2019), the Firepro is running driver 26.20.11002.1001 (driver date 4.15.2019) The application is not running as a service. I have another machine running with Dual Xeon 2687's and a GTX980TI and that one seems to work great.

Here is the event log.

Thank you in advance for any help!
6/5/2019 9:07:45 AM | | cc_config.xml not found - using defaults
6/5/2019 9:07:45 AM | | Starting BOINC client version 7.14.2 for windows_x86_64
6/5/2019 9:07:45 AM | | log flags: file_xfer, sched_ops, task
6/5/2019 9:07:45 AM | | Libraries: libcurl/7.47.1 OpenSSL/1.0.2g zlib/1.2.8
6/5/2019 9:07:45 AM | | Data directory: I:\
6/5/2019 9:07:45 AM | | Running under account Ryan
6/5/2019 9:07:45 AM | | GPU detection failed: process exited with status 0x1: Incorrect function. (0x1)
6/5/2019 9:07:45 AM | | No usable GPUs found
6/5/2019 9:07:45 AM | | Host name: Walle
6/5/2019 9:07:45 AM | | Processor: 36 GenuineIntel Intel(R) Core(TM) i9-9980XE CPU @ 3.00GHz [Family 6 Model 85 Stepping 4]
6/5/2019 9:07:45 AM | | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss htt tm pni ssse3 fma cx16 sse4_1 sse4_2 movebe popcnt aes f16c rdrandsyscall nx lm avx avx2 tm2 pbe fsgsbase bmi1 hle smep bmi2
6/5/2019 9:07:45 AM | | OS: Microsoft Windows 10: x64 Edition, (10.00.18362.00)
6/5/2019 9:07:45 AM | | Memory: 127.68 GB physical, 146.68 GB virtual
6/5/2019 9:07:45 AM | | Disk: 931.51 GB total, 912.45 GB free
6/5/2019 9:07:45 AM | | Local time is UTC -7 hours
6/5/2019 9:07:45 AM | | No WSL found.
6/5/2019 9:07:45 AM | SETI@home | URL http://setiathome.berkeley.edu/; Computer ID 8728172; resource share 100
6/5/2019 9:07:45 AM | SETI@home | General prefs: from SETI@home (last modified 04-Jun-2019 08:30:37)
6/5/2019 9:07:45 AM | SETI@home | Host location: none
6/5/2019 9:07:45 AM | SETI@home | General prefs: using your defaults
6/5/2019 9:07:45 AM | | Reading preferences override file
6/5/2019 9:07:45 AM | | Preferences:
6/5/2019 9:07:45 AM | | max memory usage when active: 117673.66 MB
6/5/2019 9:07:45 AM | | max memory usage when idle: 117673.66 MB
6/5/2019 9:07:45 AM | | max disk usage: 912.51 GB
6/5/2019 9:07:45 AM | | max CPUs used: 18
6/5/2019 9:07:45 AM | | (to change preferences, visit a project web site or select Preferences in the Manager)
6/5/2019 9:07:45 AM | | Setting up project and slot directories
6/5/2019 9:07:45 AM | | Checking active tasks
6/5/2019 9:07:45 AM | | Setting up GUI RPC socket
6/5/2019 9:07:45 AM | | Checking presence of 168 project files
6/5/2019 9:15:24 AM | SETI@home | project resumed by user.


Cheers!
Ryan
ID: 1996931 · Report as offensive
Profile Jord
Volunteer tester
Avatar

Send message
Joined: 9 Jun 99
Posts: 14893
Credit: 4,152,587
RAC: 1,253
Netherlands
Message 1996945 - Posted: 5 Jun 2019, 19:23:47 UTC - in response to Message 1996931.  

Process exited with code 1 means as much as your system is missing a driver or part of a driver to function correctly, or one of the GPUs has a memory problem. Also, trying to get two different brand GPUs to run is hell on earth as their drivers will overwrite parts of each other, in this case the OpenCL driver. Which may again give you the aforementioned error.

Start off with downloading and installing Display Driver Uninstaller.
First disable Windows 10 automatic driver updates.
Then run DDU. Uninstall the AMD driver, the Nvidia driver and for good measure the Intel GPU driver.

Don't install the Intel GPU driver.
Now, some swear that you have to install the Nvidia GPU driver first, so do that and reboot at the end (even when not prompted).
Next install the AMD GPU driver and at the end reboot (also even when not prompted)

When you now start BOINC, does it still give the error? If it does, you may have to repeat the removal steps and install the ADM driver first (reboot, then the Nvidia driver (reboot).

One extra thing you can enable which may give a little more detail on what BOINC feels is missing, is to enable the coproc_debug flag.
In BOINC Manager press CTRL+SHIFT+F and in the window that opens, check coproc_debug. Save the changes.
Then exit BOINC & restart it. Check the messages again to see if there's any more info.
ID: 1996945 · Report as offensive
Idahoryan

Send message
Joined: 4 Jun 19
Posts: 2
Credit: 150,339
RAC: 0
Message 1996964 - Posted: 5 Jun 2019, 22:58:31 UTC - in response to Message 1996945.  

Thanks, Ageless.
She is churning and burning now! ( In a good way that is. Not the "I dropped a screw in the power supply" sort of way. LOL... )

Cheers,
Ryan
ID: 1996964 · Report as offensive

Questions and Answers : Windows : GPU detection failed: process exited with status 0x1: Incorrect function. (0x1) :(


 
©2019 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.