No graphics on Mac 8.04 version

Questions and Answers : Macintosh : No graphics on Mac 8.04 version
Message board moderation

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
Profile James Adrian Project Donor
Avatar

Send message
Joined: 15 Oct 05
Posts: 8
Credit: 3,909,401
RAC: 1,324
United States
Message 1953059 - Posted: 31 Aug 2018, 16:21:46 UTC

I'm running mac os 10.13.6, boinc 7.12.0. I've notice with the latest app 8.04, I can no longer display graphics, when I click on the "show graphics" button nothing happens. The app appears to be working fine. Has anyone else seen this behavior?
ID: 1953059 · Report as offensive     Reply Quote
Bob Merrill

Send message
Joined: 7 Jun 99
Posts: 119
Credit: 7,021,634
RAC: 1,137
United States
Message 1953236 - Posted: 1 Sep 2018, 16:21:42 UTC - in response to Message 1953059.  

You are right.. It works for Einstein @ home but not for Seti. WTF?
ID: 1953236 · Report as offensive     Reply Quote
Profile James Adrian Project Donor
Avatar

Send message
Joined: 15 Oct 05
Posts: 8
Credit: 3,909,401
RAC: 1,324
United States
Message 1953239 - Posted: 1 Sep 2018, 16:56:48 UTC - in response to Message 1953236.  

Thanks for confirming! Probably a bug. I don't use the graphics that often but I do like to look at them every once in a while. Hopefully fixed soon.
ID: 1953239 · Report as offensive     Reply Quote
Profile Tink N Moo

Send message
Joined: 11 Sep 18
Posts: 4
Credit: 26,538
RAC: 713
Message 1955142 - Posted: 13 Sep 2018, 9:31:14 UTC

Yes, same issue here, (running on OS 10.11.6) Shame as I rejoined to show my class SETi as part of their science STEM project!
Any update or work around?
ID: 1955142 · Report as offensive     Reply Quote
Profile Zalster Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 27 May 99
Posts: 4732
Credit: 301,658,435
RAC: 304,793
United States
Message 1955579 - Posted: 15 Sep 2018, 21:47:12 UTC - in response to Message 1955142.  
Last modified: 15 Sep 2018, 21:58:34 UTC

Not sure. Been so long since I ran the project on my mac but I believe the screen saver was disabled as it was slowing down or causing issue with work units on the graphics cards.

For the CPU work units, I believe the graphics might still work.

edit...

Nevermind, I looked. Everyone here is running CPU work units. So, no. The graphics portion is not working on the CPU apps. Currently only TBar is developing applications for MAC but he's busy compiling the cuda apps for the GPUs. Since each new version of OS from apple seems to break the previous cuda, he's having a very hard time with it. Which leaves no time for the CPU apps as they work, just not with the graphics.
ID: 1955579 · Report as offensive     Reply Quote
Profile Tink N Moo

Send message
Joined: 11 Sep 18
Posts: 4
Credit: 26,538
RAC: 713
Message 1956010 - Posted: 18 Sep 2018, 8:32:05 UTC - in response to Message 1955579.  

Thanks for the update!
Still very happy to keep supporting SETi, will use a screen shot of graphics instead!
ID: 1956010 · Report as offensive     Reply Quote
Ralf Maruhn

Send message
Joined: 22 Sep 16
Posts: 1
Credit: 9,639
RAC: 5
Germany
Message 1956015 - Posted: 18 Sep 2018, 9:55:11 UTC

Hi, all … same problem with me. Just after updating to 7.12.0 graphics failed. Uncool - downgrading to previous version may help ?
Greets - Ralf -
ID: 1956015 · Report as offensive     Reply Quote
Profile Tink N Moo

Send message
Joined: 11 Sep 18
Posts: 4
Credit: 26,538
RAC: 713
Message 1956097 - Posted: 18 Sep 2018, 15:22:00 UTC - in response to Message 1956015.  

what version were you on when it was working?
ID: 1956097 · Report as offensive     Reply Quote
Profile Ageless
Volunteer tester
Avatar

Send message
Joined: 9 Jun 99
Posts: 14566
Credit: 3,720,410
RAC: 928
Netherlands
Message 1956122 - Posted: 18 Sep 2018, 20:34:03 UTC - in response to Message 1956097.  
Last modified: 18 Sep 2018, 20:34:48 UTC

It's not the BOINC version that broke it, it's the new Seti application that did. As https://setiathome.berkeley.edu/apps.php shows, v8.04 was just released on the 29th of August. Any work you had before with older applications would still have had the graphics/screen saver. Any newer will not.

But that's always been the problem here at Seti, since they gave the community the chance to build the science applications. There's just one volunteer developer who decides for all that the graphics are no longer needed, and thus they're removed. Same thing happened with the Windows (GPU) apps. You apparently have no say in this, another user decides for you.

I don't agree with that and have written a complaint about it to the admin of this project.
Jord

Ancient Astronaut Theorists can tell you that I do not help with tech questions via private message. Please use the forums for that.
ID: 1956122 · Report as offensive     Reply Quote
Profile Tink N Moo

Send message
Joined: 11 Sep 18
Posts: 4
Credit: 26,538
RAC: 713
Message 1956279 - Posted: 19 Sep 2018, 8:32:00 UTC - in response to Message 1956122.  
Last modified: 19 Sep 2018, 8:54:47 UTC

yep, I just found this out the hard way! -installed 6.12.10 no graphic!

keep us posted if you have any luck!

+ happy to help if you think it will help... should I send a complaint a well? And who to?
ID: 1956279 · Report as offensive     Reply Quote
Eric Korpela Project Donor
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 3 Apr 99
Posts: 1307
Credit: 27,494,435
RAC: 48,757
United States
Message 1956357 - Posted: 19 Sep 2018, 19:19:15 UTC - in response to Message 1956279.  

Charlie Fenton found the problem. The executable bits weren't set on the setigraphics_8.04 binary. If you go into the BOINC directory and change them manually it should work. Or you can reset the project and it should download new executables.
@SETIEric

ID: 1956357 · Report as offensive     Reply Quote
Profile Ageless
Volunteer tester
Avatar

Send message
Joined: 9 Jun 99
Posts: 14566
Credit: 3,720,410
RAC: 928
Netherlands
Message 1956381 - Posted: 19 Sep 2018, 21:46:05 UTC - in response to Message 1956357.  
Last modified: 19 Sep 2018, 21:46:41 UTC

Thanks Eric. And excuses for being wrong in my previous post.
ID: 1956381 · Report as offensive     Reply Quote
Jan Louis Sally

Send message
Joined: 7 Aug 15
Posts: 1
Credit: 2,356,831
RAC: 2,544
United States
Message 1956396 - Posted: 19 Sep 2018, 22:30:57 UTC - in response to Message 1953059.  

I'm running Mac 8.04 and graphics display NOT working.
ID: 1956396 · Report as offensive     Reply Quote
CarlDD
Avatar

Send message
Joined: 14 May 18
Posts: 3
Credit: 134,591
RAC: 325
Serbia
Message 1956469 - Posted: 20 Sep 2018, 13:43:19 UTC

My show graphics has stopped working as well.

I'm running SETI@Home on an iMac, macOS High Sierra version 10.13.6, the SETI@Home version is v8 8.04

I've tried reseting the project as suggested but that didn't bring back the graphics.

I'll keep supporting SETI@Home but the graphics would be nice to have back.

Best Regards
Carl
ID: 1956469 · Report as offensive     Reply Quote
Profile Zalster Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 27 May 99
Posts: 4732
Credit: 301,658,435
RAC: 304,793
United States
Message 1956506 - Posted: 20 Sep 2018, 16:29:22 UTC - in response to Message 1956469.  

I would caution all users on laptops and desktop, might want to restrict the number of threads running. Macs tend to overheat as they have poor airflow.

I also tried to reset the project and use terminal to reset the properties without any luck so not sure what the issue is.
ID: 1956506 · Report as offensive     Reply Quote
CarlDD
Avatar

Send message
Joined: 14 May 18
Posts: 3
Credit: 134,591
RAC: 325
Serbia
Message 1956524 - Posted: 20 Sep 2018, 19:08:45 UTC - in response to Message 1956506.  

Hi Zalster

Thanks for the tip, how do I set the max number of threads ?

Best Regards
Carl
ID: 1956524 · Report as offensive     Reply Quote
Profile Zalster Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 27 May 99
Posts: 4732
Credit: 301,658,435
RAC: 304,793
United States
Message 1956544 - Posted: 20 Sep 2018, 22:02:43 UTC - in response to Message 1956524.  
Last modified: 20 Sep 2018, 22:05:36 UTC

The easiest way is to use the preferences in BOINC manager. There is 2 ways of showing BOINC. The simplified view and the advance view. Click on View and change it to advance (you can always go back and change it to simple later if you want). Then click on About Boinc Manager and a pull down show appear. Click preferences. A new window should appear. Click computing.

At the top is Usage limits

Use at most XXX % of the CPUs

Depending on your CPU Chip, this value will vary. Example If you have a 4 cores/8 threads, set this to either 50% (4 work units) or 25%(2 work units). Keep in mind, if you are running any work on a GPU, the gpu will always have priority over a cpu work unit.

So in the example above. If you limit it to 50% of a 8 thread, 4 work units will run.
That could be 1 nvidia gpu, 1 intel gpu and 2 CPU work units. (My MacPro has both an intel Iris graphic and a nvidia graphic) You can tell seti not to use either the Intel or nvidia graphics from your member page in the middle section marked Seti@home preferences. Just unselect the one you don't want. I unselected Intel as it's not that great at running and really you shouldn't use the built in graphic on your chip anyway.

So for my case since I deselected the intel, I actually have 1 Nvidia work unit and 3 CPU work tasks.

Same goes for 25%. 1 GPU and 1 CPU work tasks. If I run out of GPU tasks, then a second CPU work tasks starts up.

Change the value to what you want, then click save. Then go to Options pull down and click on Read local prefs file. Boinc manager should see the changes and restrict how many threads are used.


Hope I have not confused you with this. By the way, don't use this method when someone tells you to "save a core" for your graphics card. This is not how to do that. That is a totally different topic and has to be done in a totally different way.


Happy Crunching....

Zalster
ID: 1956544 · Report as offensive     Reply Quote
Bill Richter

Send message
Joined: 31 May 03
Posts: 1
Credit: 851,051
RAC: 1,018
United States
Message 1956545 - Posted: 20 Sep 2018, 22:04:49 UTC
Last modified: 20 Sep 2018, 22:08:06 UTC

So, I tried resetting the project and checked all the preferences, still no graphics. What is the exact path to setigraphics_8.04?

I'm on an iMac 27 mid-2011, i7 3.4GHz, 32GB, and the Radeon 6970M w/2GB memory, 10.11.6, and the setting for no GPU or use GPU makes no difference.
ID: 1956545 · Report as offensive     Reply Quote
Profile Zalster Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 27 May 99
Posts: 4732
Credit: 301,658,435
RAC: 304,793
United States
Message 1956549 - Posted: 20 Sep 2018, 22:10:56 UTC - in response to Message 1956545.  

The path to the location of the setigraphic_8.04 is

Macintosh HD > Library > Application Support > Boinc Data > projects > setiathome.berkeley.edu


To set the properties for setigraphics requires a terminal at that level and

sudo chmod +x NameOfFile

But is you are not familiar with terminal commands, I would not recommend trying this.


Zalster
ID: 1956549 · Report as offensive     Reply Quote
Profile James Adrian Project Donor
Avatar

Send message
Joined: 15 Oct 05
Posts: 8
Credit: 3,909,401
RAC: 1,324
United States
Message 1956593 - Posted: 21 Sep 2018, 2:28:44 UTC - in response to Message 1956549.  

Thanks Zalster, that fixed the problem for me.
ID: 1956593 · Report as offensive     Reply Quote
1 · 2 · Next

Questions and Answers : Macintosh : No graphics on Mac 8.04 version


 
©2018 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.