Trouble trying to get multiple WU per GPU on a multi GPU system

Questions and Answers : GPU applications : Trouble trying to get multiple WU per GPU on a multi GPU system
Message board moderation

To post messages, you must log in.

AuthorMessage
Jaydan

Send message
Joined: 7 Feb 17
Posts: 5
Credit: 3,371,250
RAC: 333
Australia
Message 1847487 - Posted: 9 Feb 2017, 10:50:26 UTC

Hey guys,

I've tried this method [http://setiathome.berkeley.edu/forum_thread.php?id=76856&postid=1648389#1648389] to get multiple WU's going on my gpus, however boinc still only shows 1 WU per gpu even after putting the app_config.xml in the right place.

I've got an EVGA 1070 FTW, Sapphire HD7950 OC and the Intel on board graphics of my i5 4670 going at it.

Any help would be appreciated, thanks!
ID: 1847487 · Report as offensive
Profile Tom Miller
Volunteer tester
Avatar

Send message
Joined: 28 Nov 02
Posts: 768
Credit: 18,733,442
RAC: 13,816
United States
Message 1847543 - Posted: 9 Feb 2017, 15:49:39 UTC - in response to Message 1847487.  

Hey guys,

I've tried this method [http://setiathome.berkeley.edu/forum_thread.php?id=76856&postid=1648389#1648389] to get multiple WU's going on my gpus, however boinc still only shows 1 WU per gpu even after putting the app_config.xml in the right place.

I've got an EVGA 1070 FTW, Sapphire HD7950 OC and the Intel on board graphics of my i5 4670 going at it.

Any help would be appreciated, thanks!


I know this will sound simplistic but have you also added the "use all gpu's" to the cc_config.xml file?

<cc_config>
<options>
<use_all_gpus>1</use_all_gpus>
</options>
</cc_config>


And have you stopped Bonic completely and restarted it? When I first installed a 2nd GPU I didn't have cc_config.xml in there. Then I created the file and told Bonic to re-read the config files. Still only one gpu. Only when I stopped and restarted Bonic did it recognize my new GPU.

Hopefully, someone else will weigh in.

Tom
"You are entitled to your own opinion but not to your own facts." Senator and Professor Patrick Moynihan
---
https://GalensonConsulting.WordPress.com
ID: 1847543 · Report as offensive
Jaydan

Send message
Joined: 7 Feb 17
Posts: 5
Credit: 3,371,250
RAC: 333
Australia
Message 1847556 - Posted: 9 Feb 2017, 17:08:06 UTC - in response to Message 1847543.  

Hmm that's interesting, I also don't have the cc_config file.

I guess I should make one then
ID: 1847556 · Report as offensive
Jaydan

Send message
Joined: 7 Feb 17
Posts: 5
Credit: 3,371,250
RAC: 333
Australia
Message 1847558 - Posted: 9 Feb 2017, 17:20:04 UTC - in response to Message 1847556.  
Last modified: 9 Feb 2017, 17:29:37 UTC

Okay, added the CC_Config.xml file
Rebooted the manager after getting it to check config, and also check config again after reboot.

Still only showing 1WU per GPU. This is what I have for the app_config.xml

<app_config>
<app>
<name>astropulse_v7</name>
<gpu_versions>
<gpu_usage>.33</gpu_usage>
<cpu_usage>.67</cpu_usage>
</gpu_versions>
</app>
<app>
<name>setiathome_v8</name>
<gpu_versions>
<gpu_usage>.33</gpu_usage>
<cpu_usage>.075</cpu_usage>
</gpu_versions>
</app>
</app_config>

Also just to clarify, all GPU's are working on it, just a single task each rather than 2-3 which is what I'm after.
ID: 1847558 · Report as offensive
Profile Ageless
Volunteer tester
Avatar

Send message
Joined: 9 Jun 99
Posts: 14245
Credit: 3,546,978
RAC: 1,805
Netherlands
Message 1847560 - Posted: 9 Feb 2017, 17:32:29 UTC - in response to Message 1847558.  

Where did you put the cc_config.xml file? It needs to be in the BOINC data directory, default at C:\Programdata\BOINC\
Make sure the file is called cc_config.xml, not that it got an extra extension.
Hope you made it with Notepad, as making it with any other text editor will add invisible characters that BOINC won't like.

A very easy way to get a fully populated cc_config.xml file in the right place is to open BOINC Manager->Advanced view->Options->Event Log options...->uncheck task->OK.
Do enable task again after this, BOINC Manager->Advanced view->Options->Event Log options...->check task->OK.

You have to restart both the BOINC Manager (GUI) and the client, as GPU detection decisions are only done at BOINC (client) startup.

The app_config.xml file also needs to be written in Notepad and not any other text editor, as those add invisible characters BOINC doesn't like.
It is stored in C:\Programdata\BOINC\projects\setiathome.berkeley.edu\

When writing or editing XML files in Notepad, save them as follows, i.e. app_config.xml:
File->Save as..->Filename app_config.xml ->save as type: All files (*.*) ->Encoding ANSI
Jord

Ancient Astronaut Theorists suggest that in many ways, you can be considered an alien conspiracy!
ID: 1847560 · Report as offensive
Profile Tom Miller
Volunteer tester
Avatar

Send message
Joined: 28 Nov 02
Posts: 768
Credit: 18,733,442
RAC: 13,816
United States
Message 1847566 - Posted: 9 Feb 2017, 17:40:57 UTC - in response to Message 1847558.  
Last modified: 9 Feb 2017, 17:42:47 UTC

Okay, added the CC_Config.xml file
Rebooted the manager after getting it to check config, and also check config again after reboot.

Still only showing 1WU per GPU. This is what I have for the app_config.xml

<app_config>
<app>
<name>astropulse_v7</name>
<gpu_versions>
<gpu_usage>.33</gpu_usage>
<cpu_usage>.67</cpu_usage>
</gpu_versions>
</app>
<app>
<name>setiathome_v8</name>
<gpu_versions>
<gpu_usage>.33</gpu_usage>
<cpu_usage>.075</cpu_usage>
</gpu_versions>
</app>
</app_config>

Also just to clarify, all GPU's are working on it, just a single task each rather than 2-3 which is what I'm after.



Might try upping the CPU to say: <cpu_usage>0.33</cpu_usage>

Don't forget all the restart stuff as well as confirming that your parameter files are located in the right subdirectories.
"You are entitled to your own opinion but not to your own facts." Senator and Professor Patrick Moynihan
---
https://GalensonConsulting.WordPress.com
ID: 1847566 · Report as offensive
rob smithProject Donor
Volunteer tester

Send message
Joined: 7 Mar 03
Posts: 15234
Credit: 253,158,658
RAC: 324,105
United Kingdom
Message 1847572 - Posted: 9 Feb 2017, 18:01:11 UTC

...and with the current crop of work 0.33 GPU is probably "too enthusiastic" - even on a GTX1080 - start at 0.5 and see what the system does.

Using the Intel GPU with two external GPU is probably going to be counter productive, especially if yo try to run multiple tasks on it.
Bob Smith
Member of Seti PIPPS (Pluto is a Planet Protest Society)
Somewhere in the (un)known Universe?
ID: 1847572 · Report as offensive
Jaydan

Send message
Joined: 7 Feb 17
Posts: 5
Credit: 3,371,250
RAC: 333
Australia
Message 1847588 - Posted: 9 Feb 2017, 19:25:11 UTC - in response to Message 1847572.  

I think I may have just found the root of my problems. It's saving as app_config.xml.txt
I've saved it as an all other files under ansi as well, however when I go to save it again it asks if you want to replace app_config.xml.txt

How do I get it to stop adding the extra file extension?
I'm kinda new to this, so sorry for any facepalm moments!

Also thank-you all for the solid and helpful replies so far!
ID: 1847588 · Report as offensive
Jaydan

Send message
Joined: 7 Feb 17
Posts: 5
Credit: 3,371,250
RAC: 333
Australia
Message 1847590 - Posted: 9 Feb 2017, 19:33:57 UTC

Scratch that! I've had success and managed to get the XML file to save without the extra extension. Boinc is now running 2 WU across all the GPUS
ID: 1847590 · Report as offensive
Profile Ageless
Volunteer tester
Avatar

Send message
Joined: 9 Jun 99
Posts: 14245
Credit: 3,546,978
RAC: 1,805
Netherlands
Message 1847603 - Posted: 9 Feb 2017, 20:33:51 UTC - in response to Message 1847588.  
Last modified: 9 Feb 2017, 20:34:12 UTC

I know you fixed it already, this is just for the next person with the same problem:
app_config.xml.txt
Right-click on the file name, from the drop-down menu choose Rename. Scroll to the end of the line, use backspace four times to remove the dot tee ex tee (.txt), and finish with Enter.
Jord

Ancient Astronaut Theorists suggest that in many ways, you can be considered an alien conspiracy!
ID: 1847603 · Report as offensive

Questions and Answers : GPU applications : Trouble trying to get multiple WU per GPU on a multi GPU system


 
©2017 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.