Running on Fedora ARM

Questions and Answers : Unix/Linux : Running on Fedora ARM
Message board moderation

To post messages, you must log in.

AuthorMessage
David Sterkehus

Send message
Joined: 10 Dec 06
Posts: 6
Credit: 10,246,286
RAC: 9
Korea, South
Message 1846946 - Posted: 6 Feb 2017, 2:49:38 UTC
Last modified: 6 Feb 2017, 2:50:48 UTC

Hi.

I have 3 RPI 2's and an i.MX6 Sabre QP laying around. So I felt like to exploit them into crunching rather than to leave rotting in the storage rack. I burnt Fedora 24 ARM minimal image on all of them and installed boinc client by dnf command(dnf install boinc-client).
Boinc started as usual and I was able to set up the project without any problem. But then, as soon as the client tried to fetch wu's, this line happened:
Fri 03 Feb 2017 17:34:38 KST | SETI@home | Message from server: This project doesn't support computers of type armv7hl-pc-linux-gnu

I knew SETI supports ARM because I ran it on my Android device for a while. After some research, I found this thread. Here's the cc_config.xml I made for my tiny machines:
<cc_config>
	<options>
		<alt_platform>arm-unknown-linux-gnueabihf</alt_platform>
	</options>
</cc_config>

With this config, the ARM machines are able to fetch wu's from the server. They're running them for 3 days now. Problem is, they're painfully slow than I'd remembered. They take more than 1 day to finish single wu. Is this normal? I have an Android device(LG G Pro) and it didn't take that long if I recall correctly.
This page shows there are several more ARM arch's than just one. Are my machines slow because they don't use the adequate app? If it is the case, what alt_platform value should I use?
ID: 1846946 · Report as offensive

Questions and Answers : Unix/Linux : Running on Fedora ARM


 
©2017 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.