SETI@home v8.22/23 Windows GPU applications support thread

Message boards : Number crunching : SETI@home v8.22/23 Windows GPU applications support thread
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3

AuthorMessage
marmot
Avatar

Send message
Joined: 15 May 99
Posts: 144
Credit: 1,220,664
RAC: 0
United States
Message 1840798 - Posted: 8 Jan 2017, 8:51:16 UTC - in response to Message 1840349.  
Last modified: 8 Jan 2017, 9:23:06 UTC

Interesting about that computer TBar linked with 5072 in progress tasks

SETI@home v8 8.22 windows_intelx86 (opencl_ati_nocal)
Number of tasks completed 2131
Max tasks per day 232
Number of tasks today 412
Consecutive valid tasks 199
Average processing rate 466.07 GFLOPS
Average turnaround time 0.51 days

SETI@home v8 8.23 windows_intelx86 (opencl_ati5_SoG_nocal)
Number of tasks completed 0
Max tasks per day 33
Number of tasks today 314
Consecutive valid tasks 0
Average turnaround time 0.00 days


It looks like it's been acting up since Nov 18.


Thankyou for uncovering this information.
This laptop got some WU's yesterday that were to be 8.23 but there is no setiathome_8.23_windows_intelx86__opencl_ati_xxx.exe in the project folder to process them.


The thing I don't understand is if no work is being done why is the server reporting 4GFLOPS of work?

The problem is No One has returned any work for the Two 8.23 Apps. The Server isn't sending it to Anyone.
Look at the Post from the Fourth, it also says 4 GF.
Windows/x86 8.23 (opencl_ati5_SoG_cat132) 28 Dec 2016, 23:34:07 UTC 4 GigaFLOPS
Windows/x86 8.23 (opencl_ati5_SoG_nocal) 28 Dec 2016, 23:34:07 UTC 4 GigaFLOPS

ID: 1840798 · Report as offensive
marmot
Avatar

Send message
Joined: 15 May 99
Posts: 144
Credit: 1,220,664
RAC: 0
United States
Message 1840800 - Posted: 8 Jan 2017, 9:13:47 UTC - in response to Message 1840294.  
Last modified: 8 Jan 2017, 10:02:18 UTC

So the server isn't sending an 8.23 application but it's sending 8.23 work units.

WUs are WUs there are no CPU or GPU WUs until they are allocated to a system.

Same with the version on the WU- it picks up whatever application it is allocated to.


^ Hence the easiest way to express this is to use the application version as a descriptive adjective in front of the WU and call it an 8.23 WU = a work unit designated to be used by the 8.23 application. The underlying data is just data that can be processed by whatever application that is desired.

Yes, I don't understand exactly the mechanism that the data packet is being assigned to CPU/GPU and version application once it's getting to the client but my usage was easily understood and this did turn out to be a server side issue.


EDIT: Oh, the revert to an older script probably going to be the heart of the problem.
plan_class_spec.xml was reverted
ID: 1840800 · Report as offensive
Profile Graham Thomas

Send message
Joined: 19 May 99
Posts: 32
Credit: 3,880,875
RAC: 4
United Kingdom
Message 1841377 - Posted: 11 Jan 2017, 9:25:38 UTC - in response to Message 1840800.  
Last modified: 11 Jan 2017, 9:26:40 UTC

It's been days since the bulk of the discussion about the missing 8.23 app for ATI GPUs, but I'm still getting several messages each day like this:

11/01/2017 05:17:59 | SETI@home | [error] No app version found for app setiathome_v8 platform windows_intelx86 ver 823 class opencl_ati5_SoG_cat132; discarding 05mr09aa.28271.2526.10.37.36_2

Has the cause of the problem been found, and has anything been done about it?

It's not urgent for me - I've got lots of other work units to process - but it may not be good for the project as a whole to have this mismatch.
Graham Thomas
ID: 1841377 · Report as offensive
Profile Raistmer
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 16 Jun 01
Posts: 6324
Credit: 106,370,077
RAC: 121
Russia
Message 1841393 - Posted: 11 Jan 2017, 12:01:24 UTC - in response to Message 1841377.  
Last modified: 11 Jan 2017, 12:01:43 UTC

It's up to Eric now. No response from him still.
SETI apps news
We're not gonna fight them. We're gonna transcend them.
ID: 1841393 · Report as offensive
Eric Korpela Project Donor
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 3 Apr 99
Posts: 1381
Credit: 54,506,847
RAC: 60
United States
Message 1841464 - Posted: 11 Jan 2017, 17:49:19 UTC

I've checked the database entries for the 8.23 versions and everything checks out. My guess at this point is that we've reached some limit on number of app versions that's present in the BOINC code. Looking into it now.
@SETIEric@qoto.org (Mastodon)

ID: 1841464 · Report as offensive
Eric Korpela Project Donor
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 3 Apr 99
Posts: 1381
Credit: 54,506,847
RAC: 60
United States
Message 1841467 - Posted: 11 Jan 2017, 18:04:28 UTC - in response to Message 1841464.  

I've cleaned up some unused app_versions from the database. Did that fix the problem?
@SETIEric@qoto.org (Mastodon)

ID: 1841467 · Report as offensive
Profile Raistmer
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 16 Jun 01
Posts: 6324
Credit: 106,370,077
RAC: 121
Russia
Message 1841475 - Posted: 11 Jan 2017, 18:44:40 UTC - in response to Message 1841467.  

I'm afraid not:

1/11/2017 9:42:50 PM | SETI@home | Sending scheduler request: Requested by user.
1/11/2017 9:42:50 PM | SETI@home | Requesting new tasks for AMD/ATI GPU
1/11/2017 9:42:54 PM | SETI@home | Scheduler request completed: got 4 new tasks
1/11/2017 9:42:54 PM | SETI@home | [error] No app version found for app setiathome_v8 platform windows_intelx86 ver 823 class opencl_ati5_SoG_nocal; discarding 08ja09ag.21670.4571.9.36.102_1
1/11/2017 9:42:54 PM | SETI@home | [error] No app version found for app setiathome_v8 platform windows_intelx86 ver 823 class opencl_ati5_SoG_nocal; discarding 08ja09ag.21670.4571.9.36.108_1
1/11/2017 9:42:54 PM | SETI@home | [error] No app version found for app setiathome_v8 platform windows_intelx86 ver 823 class opencl_ati5_SoG_nocal; discarding 08ja09ag.21670.4571.9.36.114_1
1/11/2017 9:42:54 PM | SETI@home | [error] No app version found for app setiathome_v8 platform windows_intelx86 ver 823 class opencl_ati5_SoG_nocal; discarding 08ja09ag.21670.4571.9.36.120_1
1/11/2017 9:43:22 PM | SETI@home | update requested by user
1/11/2017 9:43:25 PM | SETI@home | Sending scheduler request: Requested by user.
1/11/2017 9:43:25 PM | SETI@home | Requesting new tasks for AMD/ATI GPU

SETI apps news
We're not gonna fight them. We're gonna transcend them.
ID: 1841475 · Report as offensive
Eric Korpela Project Donor
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 3 Apr 99
Posts: 1381
Credit: 54,506,847
RAC: 60
United States
Message 1841540 - Posted: 12 Jan 2017, 0:52:25 UTC

I've temporarily disabled those plan classes while I debug the problem.
@SETIEric@qoto.org (Mastodon)

ID: 1841540 · Report as offensive
Eric Korpela Project Donor
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 3 Apr 99
Posts: 1381
Credit: 54,506,847
RAC: 60
United States
Message 1841714 - Posted: 12 Jan 2017, 23:06:04 UTC - in response to Message 1841540.  

OK, trying an 8.24 release (of the 8.22 binary).
@SETIEric@qoto.org (Mastodon)

ID: 1841714 · Report as offensive
Profile Raistmer
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 16 Jun 01
Posts: 6324
Credit: 106,370,077
RAC: 121
Russia
Message 1841727 - Posted: 12 Jan 2017, 23:40:01 UTC - in response to Message 1841714.  
Last modified: 12 Jan 2017, 23:41:18 UTC

Can't check with own PC until tomorrow but app statistics look suspicious right now:

Windows/x86 8.24 (opencl_ati5_SoG_cat132) 28 Dec 2016, 23:34:07 UTC 342 GigaFLOPS
Windows/x86 8.24 (opencl_ati5_SoG_nocal) 28 Dec 2016, 23:34:07 UTC 342 GigaFLOPS

Same value has one of 8.22 plan classes.
Looks like 342 was initial value and it remains the same. That would mean no real results returned still.

Also, wrong date of release. Usually new app version has currrent date, 8.24 both have date of 8.22 release...
SETI apps news
We're not gonna fight them. We're gonna transcend them.
ID: 1841727 · Report as offensive
Grant (SSSF)
Volunteer tester

Send message
Joined: 19 Aug 99
Posts: 13396
Credit: 208,696,464
RAC: 304
Australia
Message 1842090 - Posted: 14 Jan 2017, 7:06:03 UTC
Last modified: 14 Jan 2017, 7:07:45 UTC

I notice Windows 8.22 (opencl_ati5_SoG_cat132) & 8.22 (opencl_ati5_SoG_nocal) both have release dates of 13th Jan this year, and 27 & 59GFLOPS respectively for the work done by them.
Issue solved?
Grant
Darwin NT
ID: 1842090 · Report as offensive
ext2097
Volunteer tester

Send message
Joined: 17 Aug 99
Posts: 6
Credit: 50,808,502
RAC: 29
Korea, South
Message 1842102 - Posted: 14 Jan 2017, 8:10:56 UTC

My R9 Nano host downloaded 8.22 (opencl_ati5_SoG_nocal) works, but I had to abort those workunits because they were repeating 'postponed' and 'waiting to run'.

ERROR: OpenCL kernel/call 'Quering NV device abilities' call failed (-30) in file ..\..\..\src\GPU_lock.cpp near line 417.
Waiting 30 sec before restart...
ID: 1842102 · Report as offensive
Grant (SSSF)
Volunteer tester

Send message
Joined: 19 Aug 99
Posts: 13396
Credit: 208,696,464
RAC: 304
Australia
Message 1842104 - Posted: 14 Jan 2017, 8:23:34 UTC - in response to Message 1842102.  

My R9 Nano host downloaded 8.22 (opencl_ati5_SoG_nocal) works, but I had to abort those workunits because they were repeating 'postponed' and 'waiting to run'.

ERROR: OpenCL kernel/call 'Quering NV device abilities' call failed (-30) in file ..\..\..\src\GPU_lock.cpp near line 417.
Waiting 30 sec before restart...


Something odd going on here,
Info: BOINC provided OpenCL device ID used
ERROR: OpenCL kernel/call 'Quering NV device abilities' call failed (-30) in file ..\..\..\src\GPU_lock.cpp near line 417.
Waiting 30 sec before restart...

Did that application run OK on Beta for you?
Grant
Darwin NT
ID: 1842104 · Report as offensive
Profile Graham Thomas

Send message
Joined: 19 May 99
Posts: 32
Credit: 3,880,875
RAC: 4
United Kingdom
Message 1842125 - Posted: 14 Jan 2017, 10:07:52 UTC

I suspect this doesn't add anything significant, but as confirmation I got this message about a few 8.24 units yesterday. For instance:

13/01/2017 18:31:40 | SETI@home | [error] No app version found for app setiathome_v8 platform windows_intelx86 ver 824 class opencl_ati5_SoG_cat132; discarding 26no15ad.9508.20549.11.38.220_0

Looking back, I had similar messages about 8.24 units at around 13.00 and 03.00 yesterday. (All times are UTC in case that's not clear.)
Graham Thomas
ID: 1842125 · Report as offensive
Profile Raistmer
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 16 Jun 01
Posts: 6324
Credit: 106,370,077
RAC: 121
Russia
Message 1842130 - Posted: 14 Jan 2017, 10:19:21 UTC - in response to Message 1842125.  
Last modified: 14 Jan 2017, 10:35:06 UTC

AFAIK R9 Nano is AMD, not NV GPU so app shouldn't ask NV device capabilities.

I need first dozen of lines of stderr. WEB result has only 64k of last lines, first are lost.

My own Kalindi-based netbook received setiathome_8.22_windows_intelx86__opencl_ati5_SoG.exe (8.22 opencl_ati5_SoG_nocal) app.

Seems it started processing OK:

Running on device number: 0
Priority of worker thread raised successfully
Priority of process adjusted successfully, below normal priority class used
OpenCL platform detected: Advanced Micro Devices, Inc.
BOINC assigns device 0
0 slot of 64 used for this instance
Info: BOINC provided OpenCL device ID used
Info: CPU affinity mask used: 1; system mask is 3

Build features: SETI8 Non-graphics OpenCL USE_OPENCL_HD5xxx OCL_ZERO_COPY SIGNALS_ON_GPU OCL_CHIRP3 FFTW AMD specific USE_SSE2 x86
CPUID: AMD A4-1250 APU with Radeon(TM) HD Graphics

Cache: L1=64K L2=1024K

CPU features: FPU TSC PAE CMPXCHG8B APIC SYSENTER MTRR CMOV/CCMP MMX FXSAVE/FXRSTOR SSE SSE2 HT SSE3 SSSE3 SSE4.1 SSE4.2 AVX SSE4A
Low-performance GPU detected, default period_iterations_num set to 500
OpenCL-kernels filename : MultiBeam_Kernels_r3584.cl
INFO: can't open binary kernel file: C:\BOINCdata/projects/setiathome.berkeley.edu\MultiBeam_Kernels_r3584.clHD5_Kalindi.bin_V7_SoG_13485VM, continue with recompile...
Info : Building Program (binary, clBuildProgram):main kernels: OK code 0
INFO: binary kernel file created
ar=0.447658 NumCfft=191295 NumGauss=1055534808 NumPulse=226412070870 NumTriplet=452820396964
Currently allocated 229 MB for GPU buffers
In v_BaseLineSmooth: NumDataPoints=1048576, BoxCarLength=8192, NumPointsInChunk=32768


So, right binary released under this plan class.

Issues with R9 Nano are host config dependend. First lines from stderr still needed for troubleshooting.
SETI apps news
We're not gonna fight them. We're gonna transcend them.
ID: 1842130 · Report as offensive
Profile Raistmer
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 16 Jun 01
Posts: 6324
Credit: 106,370,077
RAC: 121
Russia
Message 1842132 - Posted: 14 Jan 2017, 10:44:00 UTC

This thread happened to be more about deployment process support instead of support of app itself. So I'll ask of locking this thread and start refreshed one.
Deployment looks OK now.
SETI apps news
We're not gonna fight them. We're gonna transcend them.
ID: 1842132 · Report as offensive
Previous · 1 · 2 · 3

Message boards : Number crunching : SETI@home v8.22/23 Windows GPU applications support thread


 
©2022 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.