[WIN10] GPU missing

Questions and Answers : GPU applications : [WIN10] GPU missing
Message board moderation

To post messages, you must log in.

AuthorMessage
peluso

Send message
Joined: 10 May 04
Posts: 8
Credit: 84,092
RAC: 0
Netherlands
Message 1821265 - Posted: 2 Oct 2016, 8:55:45 UTC
Last modified: 2 Oct 2016, 8:57:16 UTC

Hello

Right at this moment my SETI client tells me im missing my GPU.

Ive read in other threads about drivers and such and fast user switching.
- im the only user logged in, not switching accounts
- running the latest NVIDIA driver
I have checked the NVIDIA driver cheatsheet but that only runs up to driver version 340.xx while im at 372.90

edit: I just noticed in the logs that the app needs opencl, but its missing.... It used to run before tho.


Im running Windows 10 in the fast update ring, so I get early preview versions. Though im guessing it will be something my latest NVIDIA driver (which I cant downgrade because of some bugs I experienced in previous version)

Here is my log (filtered a little):
10/2/2016 10:17:54 AM |  | Starting BOINC client version 7.6.22 for windows_x86_64
10/2/2016 10:17:54 AM |  | log flags: file_xfer, sched_ops, task
10/2/2016 10:17:54 AM |  | Libraries: libcurl/7.45.0 OpenSSL/1.0.2d zlib/1.2.8
10/2/2016 10:17:54 AM |  | Data directory: C:\ProgramData\BOINC
10/2/2016 10:17:54 AM |  | Running under account wimno
10/2/2016 10:17:55 AM |  | CUDA: NVIDIA GPU 0: GeForce GTX 750 Ti (driver version 372.90, CUDA version 8.0, compute capability 5.0, 2048MB, 1689MB available, 1388 GFLOPS peak)
10/2/2016 10:17:55 AM |  | App version needs OpenCL but GPU doesn't support it
10/2/2016 10:17:55 AM | SETI@home | Application uses missing NVIDIA GPU
10/2/2016 10:17:55 AM |  | App version needs OpenCL but GPU doesn't support it
10/2/2016 10:17:55 AM | SETI@home | Application uses missing NVIDIA GPU
10/2/2016 10:17:55 AM |  | App version needs OpenCL but GPU doesn't support it
10/2/2016 10:17:55 AM | SETI@home | Application uses missing NVIDIA GPU
10/2/2016 10:17:55 AM | SETI@home | Missing coprocessor for task blc5_2bit_guppi_57432_25545_HIP57328_OFF_0004.8437.0.17.26.224.vlar_0
10/2/2016 10:17:55 AM | SETI@home | Missing coprocessor for task 01mr09ag.5891.14796.8.35.252_3
10/2/2016 10:17:55 AM | SETI@home | Missing coprocessor for task blc5_2bit_guppi_57432_26529_HIP57328_0007.25106.416.18.27.55.vlar_0
10/2/2016 10:17:55 AM | SETI@home | Missing coprocessor for task 24ja16aa.23838.11519.15.42.13_1
10/2/2016 10:17:55 AM | SETI@home | Missing coprocessor for task 27ja16aa.23284.341625.6.33.105_1
10/2/2016 10:17:55 AM | SETI@home | Missing coprocessor for task blc5_2bit_guppi_57432_25545_HIP57328_OFF_0004.24610.831.17.26.253.vlar_2
10/2/2016 10:17:55 AM | SETI@home | Missing coprocessor for task blc5_2bit_guppi_57432_24865_PSR_J1136+1551_0002.27270.416.17.26.126.vlar_2
10/2/2016 10:17:55 AM | SETI@home | Missing coprocessor for task blc5_2bit_guppi_57432_26529_HIP57328_0007.32269.0.18.27.111.vlar_1
10/2/2016 10:17:55 AM | SETI@home | Missing coprocessor for task blc5_2bit_guppi_57432_26529_HIP57328_0007.32269.0.18.27.113.vlar_1
10/2/2016 10:17:55 AM | SETI@home | Missing coprocessor for task blc5_2bit_guppi_57432_26529_HIP57328_0007.32280.0.17.26.131.vlar_1
10/2/2016 10:17:55 AM | SETI@home | Missing coprocessor for task blc5_2bit_guppi_57432_26857_HIP57328_OFF_0008.15783.831.18.27.58.vlar_1
10/2/2016 10:17:55 AM | SETI@home | Missing coprocessor for task 08dc15aa.24472.11519.3.30.212_0
10/2/2016 10:17:55 AM | SETI@home | Missing coprocessor for task blc5_2bit_guppi_57432_25873_HIP57328_0005.31819.831.17.26.154.vlar_3
10/2/2016 10:17:55 AM |  | Host name: .....
10/2/2016 10:17:55 AM |  | Processor: 4 GenuineIntel Intel(R) Core(TM) i5-4460  CPU @ 3.20GHz [Family 6 Model 60 Stepping 3]
10/2/2016 10:17:55 AM |  | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss htt tm pni ssse3 fma cx16 sse4_1 sse4_2 movebe popcnt aes f16c rdrandsyscall nx lm avx avx2 vmx tm2 pbe fsgsbase bmi1 smep bmi2
10/2/2016 10:17:55 AM |  | OS: Microsoft Windows 10: Professional x64 Edition, (10.00.14936.00)
10/2/2016 10:17:55 AM |  | Memory: 15.94 GB physical, 18.82 GB virtual
10/2/2016 10:17:55 AM |  | Disk: 418.69 GB total, 150.54 GB free
10/2/2016 10:17:55 AM |  | Local time is UTC +2 hours
10/2/2016 10:17:55 AM |  | VirtualBox version: 5.0.3
10/2/2016 10:17:55 AM |  | Config: don't compute while WorldOfTanks.exe is running
10/2/2016 10:17:55 AM |  | Config: don't use GPUs while Kodi.exe is running
10/2/2016 10:17:55 AM |  | Config: don't use GPUs while WorldOfTanks.exe is running
10/2/2016 10:17:55 AM | SETI@home | URL http://setiathome.berkeley.edu/; Computer ID 7775739; resource share 100
10/2/2016 10:17:55 AM |  | General prefs: from http://milkyway.cs.rpi.edu/milkyway/ (last modified 05-Dec-2012 23:47:34)
10/2/2016 10:17:55 AM |  | Computer location: home
10/2/2016 10:17:55 AM |  | General prefs: no separate prefs for home; using your defaults
10/2/2016 10:17:55 AM |  | Reading preferences override file
10/2/2016 10:17:55 AM |  | Preferences:
10/2/2016 10:17:55 AM |  | max memory usage when active: 8161.31MB
10/2/2016 10:17:55 AM |  | max memory usage when idle: 14690.36MB
10/2/2016 10:17:55 AM |  | max disk usage: 5.00GB
10/2/2016 10:17:55 AM |  | don't compute while active
10/2/2016 10:17:55 AM |  | don't use GPU while active
10/2/2016 10:17:55 AM |  | suspend work if non-BOINC CPU load exceeds 25%
10/2/2016 10:17:55 AM |  | (to change preferences, visit a project web site or select Preferences in the Manager)
10/2/2016 10:17:55 AM |  | Suspending computation - computer is in use
10/2/2016 10:31:24 AM | SETI@home | Message from task: 0
10/2/2016 10:31:24 AM | SETI@home | Computation for task blc5_2bit_guppi_57432_26857_HIP57328_OFF_0008.24714.416.18.27.33.vlar_0 finished
ID: 1821265 · Report as offensive
Profile Bernie Vine
Volunteer moderator
Volunteer tester
Avatar

Send message
Joined: 26 May 99
Posts: 9947
Credit: 103,452,613
RAC: 328
United Kingdom
Message 1821269 - Posted: 2 Oct 2016, 9:35:52 UTC

You are probably using the graphics driver installed by a Windows update, Windows drivers do not have OpenCL support as Windows doesn't require it.

Go to the Nvidia website and download the latest driver from there.

Only ever use Nvidia drivers if you are processing Seit@Home work units.
ID: 1821269 · Report as offensive
peluso

Send message
Joined: 10 May 04
Posts: 8
Credit: 84,092
RAC: 0
Netherlands
Message 1821272 - Posted: 2 Oct 2016, 9:50:24 UTC - in response to Message 1821269.  

Actually in the third line it states I have the NVIDIA driver installed. Ill give reinstalling the driver a try tho..
ID: 1821272 · Report as offensive
peluso

Send message
Joined: 10 May 04
Posts: 8
Credit: 84,092
RAC: 0
Netherlands
Message 1821273 - Posted: 2 Oct 2016, 10:01:51 UTC - in response to Message 1821272.  

great, you are correct :)

Despite the that the client lists the NVIDIA driver it apparently doesnt use it.
Maybe its standard behaviour after a big Windows (preview) update or so...

Would be nice if it is possible in the client to see which driver the client is actually using instead of listing the installed driver...
ID: 1821273 · Report as offensive
OzzFan Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 9 Apr 02
Posts: 15688
Credit: 84,761,841
RAC: 28
United States
Message 1821407 - Posted: 3 Oct 2016, 1:22:11 UTC - in response to Message 1821273.  

The driver from Microsoft is also from NVIDIA. Microsoft doesn't write drivers for third party hardware. The drivers Microsoft provides are through it's WHQL program when a partner submits the driver for review. The problem stems from the fact that the drivers submitted to Microsoft are often, literally, just the graphics drivers and not all the supporting software such as the OpenCL components.

So the client was listing an NVIDIA driver and it was using it, it was just missing some components for GPU crunching.
ID: 1821407 · Report as offensive
Profile tullio
Volunteer tester

Send message
Joined: 9 Apr 04
Posts: 8628
Credit: 2,930,782
RAC: 1
Italy
Message 1821409 - Posted: 3 Oct 2016, 2:17:01 UTC

I have a Geforce GTX on my Windows 10 PC Home edition, updated to 1607. I get my drivers from Geforce Experience and now it is 372.90.SETI@home GPU tasks run well.
Tullio
ID: 1821409 · Report as offensive
Profile BilBg
Volunteer tester
Avatar

Send message
Joined: 27 May 07
Posts: 3720
Credit: 9,385,827
RAC: 0
Bulgaria
Message 1821426 - Posted: 3 Oct 2016, 4:18:22 UTC - in response to Message 1821273.  

I just posted some suggestions on this in adjacent thread:
http://setiathome.berkeley.edu/forum_thread.php?id=80289&postid=1821423#1821423

Were you able to Stop Windows 10 from Automatically installing drivers?
 


- ALF - "Find out what you don't do well ..... then don't do it!" :)
 
ID: 1821426 · Report as offensive
Profile Jord
Volunteer tester
Avatar

Send message
Joined: 9 Jun 99
Posts: 15183
Credit: 4,362,181
RAC: 3
Netherlands
Message 1821506 - Posted: 3 Oct 2016, 15:21:18 UTC - in response to Message 1821273.  
Last modified: 3 Oct 2016, 15:24:38 UTC

Despite the that the client lists the NVIDIA driver it apparently doesnt use it.

The client does not use the GPU, that's correct. The science applications of this project use the GPU, and this project has got both CUDA and OpenCL applications. It depends on which resource the tasks are appointed to whether it uses the CUDA or OpenCL app though. And whether or not you have set to use the NVIDA GPU in your project preferences, for the correct location (the same that the computer is in) and set Seti to run the correct applications (Astropulse v7 and Seti@Home v8).

Edit: By the way, your known system hasn't contacted this project since 27 Sep 2015, so if this is a different system we're talking about, good chance you're using a new account, and another one (with another name) than the one you presently post with.

Would be nice if it is possible in the client to see which driver the client is actually using instead of listing the installed driver...

BOINC only uses the driver that the user that is allowed to run BOINC installed. It does not use the driver that other users may have installed, or the RDP driver that Windows uses by default when no other driver is installed - other than in cases where you use remote desktop procedure of course.

Maybe its standard behaviour after a big Windows (preview) update or so...

Yes, it is, because when you install an upgrade of Windows, it will install all parts of itself anew, overwriting the old. It'll reset much of the privacy settings back to default on. It'll rewrite and remove parts of the system32 directory that it doesn't understand or that for Microsoft are in some sort of breach with the use of the Windows license. This includes the removal of OpenCL, OpenGL and CUDA drivers and libraries and in future probably all programs that aren't available through the Microsoft Windows store.

And you'll get onto this each time you install a new version of Windows.
Just reinstall the newest drivers for your hardware and all should be fine.
ID: 1821506 · Report as offensive
Profile tullio
Volunteer tester

Send message
Joined: 9 Apr 04
Posts: 8628
Credit: 2,930,782
RAC: 1
Italy
Message 1821512 - Posted: 3 Oct 2016, 15:51:45 UTC

My Geforce driver 372.90 on my Windows 10 Home edition survives all Windows 10 updates. The board is a Geforce GTX 750 OC.
Tullio
ID: 1821512 · Report as offensive
Profile BilBg
Volunteer tester
Avatar

Send message
Joined: 27 May 07
Posts: 3720
Credit: 9,385,827
RAC: 0
Bulgaria
Message 1821595 - Posted: 4 Oct 2016, 2:12:46 UTC - in response to Message 1821506.  

Edit: By the way, your known system hasn't contacted this project since 27 Sep 2015, so if this is a different system we're talking about, good chance you're using a new account, and another one (with another name) than the one you presently post with.

Yes,
From this line:
10/2/2016 10:17:55 AM | SETI@home | URL http://setiathome.berkeley.edu/; Computer ID 7775739; resource share 100

Computer 7775739
http://setiathome.berkeley.edu/show_host_detail.php?hostid=7775739

"Owner wpn"
http://setiathome.berkeley.edu/show_user.php?userid=222838
 


- ALF - "Find out what you don't do well ..... then don't do it!" :)
 
ID: 1821595 · Report as offensive

Questions and Answers : GPU applications : [WIN10] GPU missing


 
©2022 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.