Postponed: CL file build failure with BOINC 7.6.31 / Ubuntu 16.04 / AMD GPU

Questions and Answers : GPU applications : Postponed: CL file build failure with BOINC 7.6.31 / Ubuntu 16.04 / AMD GPU
Message board moderation

To post messages, you must log in.

AuthorMessage
macvelli

Send message
Joined: 31 May 00
Posts: 2
Credit: 40,797,455
RAC: 0
United States
Message 1816543 - Posted: 12 Sep 2016, 0:50:03 UTC

So I just upgraded from Ubuntu 15.10 to Ubuntu 16.04 and things have gone sideways with respect to GPU computing for BOINC.

First off, Ubuntu 16.04 got rid of the AMD Catalyst fglrx drivers so everything that used to work under Ubuntu 15.10 no longer works under Ubuntu 16.04.

I found a package called

mesa-opencl-icd

which seems to have worked to some degree as my AMD GPU is now recognized by BOINC again. However, all of my GPU tasks have a status of

Postponed: CL file build failure


Any thoughts on what is going on? Thanks!
ID: 1816543 · Report as offensive
Profile BilBg
Volunteer tester
Avatar

Send message
Joined: 27 May 07
Posts: 3720
Credit: 9,385,827
RAC: 0
Bulgaria
Message 1816638 - Posted: 12 Sep 2016, 13:02:56 UTC - in response to Message 1816543.  

Applications devs and people using Linux (and I'm not Linux user) usually don't check posts here, they read Number Crunching

Files like MultiBeam_Kernels_r3430.cl (which are text files in OpenCL language) have to be compiled to binary form.
That compilation is done by the ATI AMD OpenCL driver.
Obviously that "mesa-opencl-icd" (which I don't know what it is) can't do this, at least in a way as expected by the app.

I don't know what means "got rid of the AMD Catalyst fglrx drivers", can't you get drivers manually from ATI AMD site?

(I really can't help you more than this for Linux issues, post in Number Crunching)
 


- ALF - "Find out what you don't do well ..... then don't do it!" :)
 
ID: 1816638 · Report as offensive
Profile Jord
Volunteer tester
Avatar

Send message
Joined: 9 Jun 99
Posts: 15183
Credit: 4,362,181
RAC: 3
Netherlands
Message 1816642 - Posted: 12 Sep 2016, 13:56:31 UTC - in response to Message 1816638.  
Last modified: 12 Sep 2016, 13:58:26 UTC

"mesa-opencl-icd" (which I don't know what it is)

This is an open source OpenCL installable client driver (icd) of the Mesa 3D Graphics Library.

I don't know what means "got rid of the AMD Catalyst fglrx drivers", can't you get drivers manually from ATI AMD site?

No, he cannot. Ubuntu 16.04 dropped support for the proprietary graphics driver for AMD/ATI graphics cards.

I Don’t Understand: What’s Happening?

Let’s say you use the fglrx driver on Ubuntu 15.10, and that you plan to upgrade to Ubuntu 16.04 next month.
The Ubuntu 16.04 upgrade process will remove both the fglrx driver and the Xorg.conf that supports it from Ubuntu.

You cannot avoid this, stall it or put it off; you upgrade, you say bye-bye.
Depending on your exact graphics hardware, Ubuntu 16.04 will use the open-source AMDGPU or the open-source Radeon driver in place of flgrx.

At this point you might be thinking: “Fine, I’ll just reinstall the driver myself.”

Well, you can’t.

You can not re-install the fglrx/catalyst driver (or its display stack) from the Ubuntu 16.04 archives after the upgrade completes as the driver is, bluntly, no longer there.
Furthermore, you cannot download and install the fglrx/catalyst driver using binary packages from the AMD website as, even if you could get them to install, the driver does not support Xorg 1.18 that ships in Xenial.


AMD only has Ubuntu 16.04 drivers for the RX400 series. All others are deprecated.

The only quick solution I see is to return to a previous Linux, if need be via virtual machine. The Mesa ICD is not yet ready and isn't compatible with the Khronos OpenCL drivers.
ID: 1816642 · Report as offensive
macvelli

Send message
Joined: 31 May 00
Posts: 2
Credit: 40,797,455
RAC: 0
United States
Message 1816681 - Posted: 12 Sep 2016, 18:22:39 UTC - in response to Message 1816642.  

The Mesa ICD is not yet ready and isn't compatible with the Khronos OpenCL drivers.


This is what I was afraid of. Thanks for the insight!
ID: 1816681 · Report as offensive

Questions and Answers : GPU applications : Postponed: CL file build failure with BOINC 7.6.31 / Ubuntu 16.04 / AMD GPU


 
©2022 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.