Open Beta test: SoG for NVidia, Lunatics v0.45 - Beta6 (RC again)

Message boards : Number crunching : Open Beta test: SoG for NVidia, Lunatics v0.45 - Beta6 (RC again)
Message board moderation

To post messages, you must log in.

Previous · 1 . . . 25 · 26 · 27 · 28 · 29 · 30 · 31 . . . 32 · Next

AuthorMessage
Richard Haselgrove Project Donor
Volunteer tester

Send message
Joined: 4 Jul 99
Posts: 14542
Credit: 200,643,578
RAC: 874
United Kingdom
Message 1831726 - Posted: 21 Nov 2016, 12:38:38 UTC - in response to Message 1831724.  

I just installed Beta 6 and checked for the affinity issue noticed when troubleshooting my Penta-Nano system. Not sure if an attempt was made to fix it, but it looks like it is still an issue. One of the 5 running MB tasks has affinity set to all cores, while the other 4 are set to unique cores.

This isn't really an installation question, more a question about the application payload.

Please contact Raistmer about this sort of question, citing

OpenCL version by Raistmer, r3557
AMD HD5 version by Raistmer
ID: 1831726 · Report as offensive
Profile RueiKe Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 14 Feb 16
Posts: 492
Credit: 378,512,430
RAC: 785
Taiwan
Message 1831729 - Posted: 21 Nov 2016, 12:56:26 UTC - in response to Message 1831726.  

I just installed Beta 6 and checked for the affinity issue noticed when troubleshooting my Penta-Nano system. Not sure if an attempt was made to fix it, but it looks like it is still an issue. One of the 5 running MB tasks has affinity set to all cores, while the other 4 are set to unique cores.

This isn't really an installation question, more a question about the application payload.

Please contact Raistmer about this sort of question, citing

OpenCL version by Raistmer, r3557
AMD HD5 version by Raistmer


Thanks. I will PM him.
GitHub: Ricks-Lab
Instagram: ricks_labs
ID: 1831729 · Report as offensive
Profile HAL9000
Volunteer tester
Avatar

Send message
Joined: 11 Sep 99
Posts: 6533
Credit: 196,805,888
RAC: 57
United States
Message 1831731 - Posted: 21 Nov 2016, 13:55:26 UTC - in response to Message 1831729.  
Last modified: 21 Nov 2016, 13:56:22 UTC

I just installed Beta 6 and checked for the affinity issue noticed when troubleshooting my Penta-Nano system. Not sure if an attempt was made to fix it, but it looks like it is still an issue. One of the 5 running MB tasks has affinity set to all cores, while the other 4 are set to unique cores.

This isn't really an installation question, more a question about the application payload.

Please contact Raistmer about this sort of question, citing

OpenCL version by Raistmer, r3557
AMD HD5 version by Raistmer


Thanks. I will PM him.

Is it the same issue you were discussing in this thread?
SETI@home classic workunits: 93,865 CPU time: 863,447 hours
Join the BP6/VP6 User Group today!
ID: 1831731 · Report as offensive
Profile RueiKe Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 14 Feb 16
Posts: 492
Credit: 378,512,430
RAC: 785
Taiwan
Message 1831732 - Posted: 21 Nov 2016, 14:00:57 UTC - in response to Message 1831731.  

I just installed Beta 6 and checked for the affinity issue noticed when troubleshooting my Penta-Nano system. Not sure if an attempt was made to fix it, but it looks like it is still an issue. One of the 5 running MB tasks has affinity set to all cores, while the other 4 are set to unique cores.

This isn't really an installation question, more a question about the application payload.

Please contact Raistmer about this sort of question, citing

OpenCL version by Raistmer, r3557
AMD HD5 version by Raistmer


Thanks. I will PM him.

Is it the same issue you were discussing in this thread?


Yes, it is an issue but not the cause of the problem on my system.
GitHub: Ricks-Lab
Instagram: ricks_labs
ID: 1831732 · Report as offensive
Stephen "Heretic" Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 20 Sep 12
Posts: 5557
Credit: 192,787,363
RAC: 628
Australia
Message 1831735 - Posted: 21 Nov 2016, 14:53:49 UTC - in response to Message 1831729.  

I just installed Beta 6 and checked for the affinity issue noticed when troubleshooting my Penta-Nano system. Not sure if an attempt was made to fix it, but it looks like it is still an issue. One of the 5 running MB tasks has affinity set to all cores, while the other 4 are set to unique cores.

This isn't really an installation question, more a question about the application payload.

Please contact Raistmer about this sort of question, citing

OpenCL version by Raistmer, r3557
AMD HD5 version by Raistmer


Thanks. I will PM him.


. . Perhaps just write a message listing your problem in the V8.20 support thread. He checks in there regularly.

Stephen

.
ID: 1831735 · Report as offensive
Stephen "Heretic" Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 20 Sep 12
Posts: 5557
Credit: 192,787,363
RAC: 628
Australia
Message 1832265 - Posted: 24 Nov 2016, 21:40:15 UTC

. . @ Richard Hasselgrove

. . I was wondering, is it at all likely there will ever be support for SSE4.1 in Lunatics?

Stephen

.
ID: 1832265 · Report as offensive
Richard Haselgrove Project Donor
Volunteer tester

Send message
Joined: 4 Jul 99
Posts: 14542
Credit: 200,643,578
RAC: 874
United Kingdom
Message 1832270 - Posted: 24 Nov 2016, 22:01:10 UTC - in response to Message 1832265.  

. . @ Richard Hasselgrove

. . I was wondering, is it at all likely there will ever be support for SSE4.1 in Lunatics?

Stephen

.

That depends if a volunteer with the skills to drive GCC 4.7.1 with aggressive optimization settings puts themselves forward to replace Joe Segur.
ID: 1832270 · Report as offensive
Stephen "Heretic" Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 20 Sep 12
Posts: 5557
Credit: 192,787,363
RAC: 628
Australia
Message 1832276 - Posted: 24 Nov 2016, 23:00:53 UTC - in response to Message 1832270.  

. . @ Richard Hasselgrove

. . I was wondering, is it at all likely there will ever be support for SSE4.1 in Lunatics?

Stephen

.

That depends if a volunteer with the skills to drive GCC 4.7.1 with aggressive optimization settings puts themselves forward to replace Joe Segur.


. . Hi Richard,

. . 'nuff said!

Stephen

.
ID: 1832276 · Report as offensive
Profile BilBg
Volunteer tester
Avatar

Send message
Joined: 27 May 07
Posts: 3720
Credit: 9,385,827
RAC: 0
Bulgaria
Message 1832981 - Posted: 28 Nov 2016, 8:23:55 UTC - in response to Message 1829188.  

BOINC quirk:
Despite you put at the top (in MB8_win_x86_SSE2_OpenCL_ATi_HD5.aistub):

    <app_version>
        <app_name>setiathome_v8</app_name>
        <version_num>819</version_num>
        <api_version>7.5.0</api_version>
        <avg_ncpus>0.04</avg_ncpus>
        <max_ncpus>0.2</max_ncpus>
        <plan_class>opencl_ati5_sah</plan_class>

... the new downloaded tasks were labelled:
<version_num>820</version_num>
<plan_class>opencl_ati5_sah</plan_class>



(transition from Lunatics_Win32_v0.45_Beta4 to Beta6)

BOINC 6.10.58 decided to sort by version_num and choose the highest?
 


- ALF - "Find out what you don't do well ..... then don't do it!" :)
 
ID: 1832981 · Report as offensive
kittyman Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 9 Jul 00
Posts: 51468
Credit: 1,018,363,574
RAC: 1,004
United States
Message 1835016 - Posted: 9 Dec 2016, 18:11:09 UTC

Has work on the new installer totally stalled out?

Meow?
"Freedom is just Chaos, with better lighting." Alan Dean Foster

ID: 1835016 · Report as offensive
Richard Haselgrove Project Donor
Volunteer tester

Send message
Joined: 4 Jul 99
Posts: 14542
Credit: 200,643,578
RAC: 874
United Kingdom
Message 1835019 - Posted: 9 Dec 2016, 18:22:22 UTC - in response to Message 1835016.  

Has work on the new installer totally stalled out?

Meow?
Read the threads about memory leaks (possibly) with the ATi_HD5 apps. I can't stabilise an installer until Raistmer stabilises his apps.
ID: 1835019 · Report as offensive
kittyman Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 9 Jul 00
Posts: 51468
Credit: 1,018,363,574
RAC: 1,004
United States
Message 1835021 - Posted: 9 Dec 2016, 18:27:22 UTC - in response to Message 1835019.  

Has work on the new installer totally stalled out?

Meow?
Read the threads about memory leaks (possibly) with the ATi_HD5 apps. I can't stabilise an installer until Raistmer stabilises his apps.

Would it be unrealistic to ask for an interim installer with the nVidia apps?
That is all the kitties have online.
I am sure it would be an extra bother, but with the ATI stuff holding the good apps hostage, I have to ask.
"Freedom is just Chaos, with better lighting." Alan Dean Foster

ID: 1835021 · Report as offensive
Profile UniMatrixZ
Avatar

Send message
Joined: 2 Feb 01
Posts: 102
Credit: 30,826,065
RAC: 3
Sweden
Message 1835031 - Posted: 9 Dec 2016, 19:18:59 UTC
Last modified: 9 Dec 2016, 19:19:15 UTC

I run the r3571 build on my 7850 card (and also on my NV cards), I can't say it uses any more RAM then the r3557 build.
But I guess that it can be different from system to system.
Otherwise why not buy more RAM( ironic)

If you guys wanna try another build here is a link to r3578 ( I can't find the link to r3571 build)
https://cloud.mail.ru/public/AeMs/SYvE7Eiei

You just need to edit the app_info.xml to the r3578 build, and of course copy the new r3578 build files and .cl file to BOINC data directory.

Cheers!

"SETI is probably the most important quest of our time,
and it amazes me that governments and corporations
are not supporting it sufficiently."- Arthur C. Clarke 2006
ID: 1835031 · Report as offensive
Profile Raistmer
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 16 Jun 01
Posts: 6324
Credit: 106,370,077
RAC: 121
Russia
Message 1835035 - Posted: 9 Dec 2016, 19:57:12 UTC - in response to Message 1835019.  
Last modified: 9 Dec 2016, 19:58:06 UTC

Read the threads about memory leaks (possibly) with the ATi_HD5 apps. I can't stabilise an installer until Raistmer stabilises his apps.

Current ones still RC.
RAM usage differs hugely between different setups that looks much more like driver issue (some drivers backup at least part of GPU memory allocations with host memory).
Will see how latest one differs from those RC (still did not get report).
SETI apps news
We're not gonna fight them. We're gonna transcend them.
ID: 1835035 · Report as offensive
Profile Mike Special Project $75 donor
Volunteer tester
Avatar

Send message
Joined: 17 Feb 01
Posts: 33728
Credit: 79,922,639
RAC: 80
Germany
Message 1835056 - Posted: 9 Dec 2016, 21:36:20 UTC

I also see no extended RAM usage with new apps.
We only have one host so far i know.
Will test more during the weekend.


With each crime and every kindness we birth our future.
ID: 1835056 · Report as offensive
Profile Zalster Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 27 May 99
Posts: 5516
Credit: 528,817,460
RAC: 242
United States
Message 1835068 - Posted: 9 Dec 2016, 22:46:19 UTC - in response to Message 1835056.  

I ran a whole bunch under the current build back when it first came out. Been a while but all the results are there. No unusual RAM usage with the NVIDIA version
ID: 1835068 · Report as offensive
Richard Haselgrove Project Donor
Volunteer tester

Send message
Joined: 4 Jul 99
Posts: 14542
Credit: 200,643,578
RAC: 874
United Kingdom
Message 1835168 - Posted: 10 Dec 2016, 12:36:37 UTC - in response to Message 1835165.  

My rig running R3557 seems OK to me.

Nvidia GTX950, driver 375.70
You're right, r3557 was an improvement on what had gone before. But r3571 is better. The question now is whether r3578 is better than r3571 for either ATi, NVidia, both, or neither. And whether r3581 is better for ATi. And whether SoG for ATi is back in the picture, having been ruled out a few builds ago. And so the circle turns.
ID: 1835168 · Report as offensive
Profile RueiKe Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 14 Feb 16
Posts: 492
Credit: 378,512,430
RAC: 785
Taiwan
Message 1835175 - Posted: 10 Dec 2016, 13:23:59 UTC - in response to Message 1835035.  

Read the threads about memory leaks (possibly) with the ATi_HD5 apps. I can't stabilise an installer until Raistmer stabilises his apps.

Current ones still RC.
RAM usage differs hugely between different setups that looks much more like driver issue (some drivers backup at least part of GPU memory allocations with host memory).
Will see how latest one differs from those RC (still did not get report).


Let me know if there is anything you want me to test or beta release on my system.
GitHub: Ricks-Lab
Instagram: ricks_labs
ID: 1835175 · Report as offensive
Profile Keith Myers Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 29 Apr 01
Posts: 13159
Credit: 1,160,866,277
RAC: 1,873
United States
Message 1835255 - Posted: 10 Dec 2016, 18:52:09 UTC - in response to Message 1832981.  

I have two systems that are downloading and labeling work 8.20 also. I haven't figured out how. The other system is still downloading and labeling work as 8.19. All systems have identical app_info files. The app version sections at the beginning of the MB GPU section have both 8.19 and 8.20 version numbers listed for the same plan_class. I don't know how the servers decides to label identical GPU tasks 8.20 on two systems but 8.19 on the other. I used the latest Beta6 Lunatics installer on all systems and selected exactly the same choices for apps. No real problems with the labeling except for messy task ordering in BoincTasks.
Seti@Home classic workunits:20,676 CPU time:74,226 hours

A proud member of the OFA (Old Farts Association)
ID: 1835255 · Report as offensive
Stephen "Heretic" Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 20 Sep 12
Posts: 5557
Credit: 192,787,363
RAC: 628
Australia
Message 1835278 - Posted: 10 Dec 2016, 20:31:05 UTC - in response to Message 1835255.  

I have two systems that are downloading and labeling work 8.20 also. I haven't figured out how. The other system is still downloading and labeling work as 8.19. All systems have identical app_info files. The app version sections at the beginning of the MB GPU section have both 8.19 and 8.20 version numbers listed for the same plan_class. I don't know how the servers decides to label identical GPU tasks 8.20 on two systems but 8.19 on the other. I used the latest Beta6 Lunatics installer on all systems and selected exactly the same choices for apps. No real problems with the labeling except for messy task ordering in BoincTasks.


. . Have you had a peek in the Slot folders for the GPU tasks to check what revision of the app is actually running on all machines?

Stephen

.
ID: 1835278 · Report as offensive
Previous · 1 . . . 25 · 26 · 27 · 28 · 29 · 30 · 31 . . . 32 · Next

Message boards : Number crunching : Open Beta test: SoG for NVidia, Lunatics v0.45 - Beta6 (RC again)


 
©2023 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.