app_config.xml help please

Message boards : Number crunching : app_config.xml help please
Message board moderation

To post messages, you must log in.

AuthorMessage
Jim
Volunteer tester
Avatar

Send message
Joined: 24 Aug 99
Posts: 21
Credit: 1,511,693
RAC: 1
United Kingdom
Message 1772206 - Posted: 17 Mar 2016, 19:31:03 UTC

Hi
Can somebody tell me what I've done wrong?
I eventually changed my app_config file for v8
and now my GPu is only doing 2 wu's not 3
content of file below.


<app_config>

<app>
<name>setiathome_v7</name>
<gpu_versions>
<gpu_usage>0.33</gpu_usage>
<cpu_usage>0.4</cpu_usage>
</gpu_versions>
</app>

<app>
<name>setiathome_v8</name>
<gpu_versions>
<gpu_usage>0.33</gpu_usage>
<cpu_usage>0.4</cpu_usage>
</gpu_versions>
</app>

<app>
<name>astropulse_v7</name>
<gpu_versions>
<gpu_usage>0.5</gpu_usage>
<cpu_usage>0.4</cpu_usage>
</gpu_versions>
</app>

</app_config>
If at first you don't succeed,
Then skydiving is not for you.
ID: 1772206 · Report as offensive
OTS
Volunteer tester

Send message
Joined: 6 Jan 08
Posts: 363
Credit: 20,533,537
RAC: 0
United States
Message 1772214 - Posted: 17 Mar 2016, 20:13:36 UTC - in response to Message 1772206.  

Hi
Can somebody tell me what I've done wrong?
I eventually changed my app_config file for v8
and now my GPu is only doing 2 wu's not 3
content of file below.


<app_config>

<app>
<name>setiathome_v7</name>
<gpu_versions>
<gpu_usage>0.33</gpu_usage>
<cpu_usage>0.4</cpu_usage>
</gpu_versions>
</app>

<app>
<name>setiathome_v8</name>
<gpu_versions>
<gpu_usage>0.33</gpu_usage>
<cpu_usage>0.4</cpu_usage>
</gpu_versions>
</app>

<app>
<name>astropulse_v7</name>
<gpu_versions>
<gpu_usage>0.5</gpu_usage>
<cpu_usage>0.4</cpu_usage>
</gpu_versions>
</app>

</app_config>


I assume it is not doing three APs at a time. If that is the case I think under astropulse_v7 you want

<gpu_usage>0.33</gpu_usage>

The value should be the reciprocal of the number of units you wan to run.

At least give it a try. There may be more knowledgeable people who can help if it doesn't work.
ID: 1772214 · Report as offensive
Profile Brent Norman Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester

Send message
Joined: 1 Dec 99
Posts: 2786
Credit: 685,657,289
RAC: 835
Canada
Message 1772219 - Posted: 17 Mar 2016, 20:52:10 UTC
Last modified: 17 Mar 2016, 20:57:25 UTC

If my math is right, Try

0.26 for both SETI v7 and v8
0.38 for Astropulse

That should give you :
3 MB or
2 MB + 1 AP or
2 AP

EDIT: What you have now is, If an AP task is running, only 1 MB can run with it. Or 2 AP tasks.
ID: 1772219 · Report as offensive
Jim
Volunteer tester
Avatar

Send message
Joined: 24 Aug 99
Posts: 21
Credit: 1,511,693
RAC: 1
United Kingdom
Message 1772248 - Posted: 17 Mar 2016, 22:26:35 UTC

found the problem
<cpu_usage>0.4</cpu_usage>
should be 0.33 or less

thanks for the help
If at first you don't succeed,
Then skydiving is not for you.
ID: 1772248 · Report as offensive

Message boards : Number crunching : app_config.xml help please


 
©2022 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.