Android Version Checking

Message boards : News : Android Version Checking
Message board moderation

To post messages, you must log in.

1 · 2 · 3 · Next

AuthorMessage
Eric KorpelaProject Donor
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 3 Apr 99
Posts: 1249
Credit: 20,538,820
RAC: 10,075
United States
Message 1641350 - Posted: 13 Feb 2015, 18:12:36 UTC

The versions of SETI@home currently distributed can't run on Android 5+ (Lollypop). We're working on new versions.

We've limited distribution to earlier distributions. If you can't get work on Android 4, it may be necessary to update your BOINC app.
@SETIEric

ID: 1641350 · Report as offensive
Profile Manxscouse
Avatar

Send message
Joined: 23 Jul 00
Posts: 8
Credit: 7,326,992
RAC: 250
Message 1641388 - Posted: 13 Feb 2015, 19:22:08 UTC - in response to Message 1641350.  

Hi, I noticed that Intel Atom is not listed as a processor for Android. My Tablet has an Intel atom and Android 4.4 but I can not get work units for SETI. Any ideas? Thanks.
ID: 1641388 · Report as offensive
Profile HAL9000
Volunteer tester
Avatar

Send message
Joined: 11 Sep 99
Posts: 6467
Credit: 176,047,548
RAC: 56,351
United States
Message 1641406 - Posted: 13 Feb 2015, 19:56:33 UTC - in response to Message 1641388.  
Last modified: 13 Feb 2015, 19:56:50 UTC

Hi, I noticed that Intel Atom is not listed as a processor for Android. My Tablet has an Intel atom and Android 4.4 but I can not get work units for SETI. Any ideas? Thanks.

There are currently no Applications for Android x86 on main. However Beta does have one listed under Applications as Android (Intel/AMD x86 processor).
SETI@home classic workunits: 93,865 CPU time: 863,447 hours
Join the BP6/VP6 User Group today!
ID: 1641406 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4654
Credit: 47,183,054
RAC: 417
United Kingdom
Message 1641550 - Posted: 13 Feb 2015, 23:58:04 UTC - in response to Message 1641406.  
Last modified: 13 Feb 2015, 23:58:31 UTC

However Beta does have one listed under Applications as Android (Intel/AMD x86 processor).

But that one is broken, a rebuild with Android compatible libs/api required.

Claggy
ID: 1641550 · Report as offensive
Menace
Volunteer tester

Send message
Joined: 23 Nov 00
Posts: 20
Credit: 823,625
RAC: 980
United Kingdom
Message 1642540 - Posted: 15 Feb 2015, 20:43:47 UTC

Have tried to run current Andrioid 5 compatible version on Galaxy Note 2 running 4.3. It will not download any work. Cannot get hold of earlier version anywhere.
ID: 1642540 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4654
Credit: 47,183,054
RAC: 417
United Kingdom
Message 1642594 - Posted: 15 Feb 2015, 23:22:49 UTC - in response to Message 1642540.  

Have tried to run current Andrioid 5 compatible version on Galaxy Note 2 running 4.3. It will not download any work. Cannot get hold of earlier version anywhere.

Your Android host hasn't asked for work in two and a half hours, At Setiathome it can be you ask for work at one moment, and not get any work,
then five minutes later when you're allowed to ask again, you then get flooded with work, If Boinc, or you, don't allow it to ask for work, you won't get any.

Both my Android 4.4.4 and 4.4.2 hosts have picked up work today, If you haven't managed to pick up work in the next day, I'll email the Boinc devs, your host calling it's OS Android 4.3 and not Android 4.3.0 is suspicious.

Claggy
ID: 1642594 · Report as offensive
Wild6-NJ
Volunteer tester

Send message
Joined: 4 Aug 99
Posts: 29
Credit: 67,195,693
RAC: 51,725
United States
Message 1642683 - Posted: 16 Feb 2015, 2:21:38 UTC - in response to Message 1642594.  

My Samsung GS3 (ID: 7495128) running oem firmware also identifies itself as Android 4.3 and hasn't been able to get work since this change.
ID: 1642683 · Report as offensive
Menace
Volunteer tester

Send message
Joined: 23 Nov 00
Posts: 20
Credit: 823,625
RAC: 980
United Kingdom
Message 1642800 - Posted: 16 Feb 2015, 9:36:34 UTC

Thanks for the reply, Claggy. It's a rooted device. Will investigate that also. Running others, Einstein, Collatz, just fine.
ID: 1642800 · Report as offensive
Menace
Volunteer tester

Send message
Joined: 23 Nov 00
Posts: 20
Credit: 823,625
RAC: 980
United Kingdom
Message 1642806 - Posted: 16 Feb 2015, 9:52:53 UTC

Tried on an older Android tablet, running 4.1. Initialised and working right away. Weird...
ID: 1642806 · Report as offensive
Profile Rene
Volunteer tester

Send message
Joined: 30 Jan 01
Posts: 25
Credit: 688,894
RAC: 0
Netherlands
Message 1642971 - Posted: 16 Feb 2015, 19:24:45 UTC

So is it safe to run SETI on Android 5 (as in it won't unnecessarily ask for work) ?
ID: 1642971 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4654
Credit: 47,183,054
RAC: 417
United Kingdom
Message 1643010 - Posted: 16 Feb 2015, 20:53:57 UTC - in response to Message 1642971.  

So is it safe to run SETI on Android 5 (as in it won't unnecessarily ask for work) ?

You can't run the Seti_v7 on Android 5 because the apps aren't compatible yet.

Boinc 7.4.41 will still ask for work, The server just won't send it.

Claggy
ID: 1643010 · Report as offensive
Profile Rene
Volunteer tester

Send message
Joined: 30 Jan 01
Posts: 25
Credit: 688,894
RAC: 0
Netherlands
Message 1643025 - Posted: 16 Feb 2015, 21:25:06 UTC - in response to Message 1643010.  

OK, that's what I meant. I assume it will pick up a new app when it's ready, like Einstein did?
ID: 1643025 · Report as offensive
David S
Volunteer tester
Avatar

Send message
Joined: 4 Oct 99
Posts: 18206
Credit: 22,870,932
RAC: 2,972
United States
Message 1643348 - Posted: 17 Feb 2015, 16:06:13 UTC - in response to Message 1641350.  

If you can't get work on Android 4, it may be necessary to update your BOINC app.

I was hoping not to have to do that. I like the older GUI of the Boinc I currently have. But I will go ahead and do it when the Einsteins it's currently running finish.
David
Sitting on my butt while others boldly go,
Waiting for a message from a small furry creature from Alpha Centauri.

ID: 1643348 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4654
Credit: 47,183,054
RAC: 417
United Kingdom
Message 1643471 - Posted: 18 Feb 2015, 0:06:12 UTC - in response to Message 1642800.  

Thanks for the reply, Claggy. It's a rooted device. Will investigate that also. Running others, Einstein, Collatz, just fine.

I emailed the boinc_dev list, DA replied:

I changed the schedule code so that it parses either "4.3.0" or "4.3".
Eric, feel free to deploy this on S@h.
-- D

Hopefully they managed to apply the scheduler change during maintenance.

Claggy
ID: 1643471 · Report as offensive
Menace
Volunteer tester

Send message
Joined: 23 Nov 00
Posts: 20
Credit: 823,625
RAC: 980
United Kingdom
Message 1643670 - Posted: 18 Feb 2015, 9:57:25 UTC - in response to Message 1643471.  

Many thanks for that, will retry.
ID: 1643670 · Report as offensive
Kerry

Send message
Joined: 30 Oct 14
Posts: 4
Credit: 362,176
RAC: 0
United States
Message 1644184 - Posted: 19 Feb 2015, 18:49:44 UTC

I'm getting as much SETI work as I can handle.

Kerry from USA
ID: 1644184 · Report as offensive
Profile Geoff Pullinger
Avatar

Send message
Joined: 5 Sep 06
Posts: 10
Credit: 4,357,230
RAC: 774
United States
Message 1645297 - Posted: 22 Feb 2015, 14:28:33 UTC - in response to Message 1641350.  

I just installed BOINC on my Samsung S5 with Android 5 and it seems to be downloading tasks and running them.
ID: 1645297 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4654
Credit: 47,183,054
RAC: 417
United Kingdom
Message 1645326 - Posted: 22 Feb 2015, 16:18:02 UTC - in response to Message 1645297.  

I just installed BOINC on my Samsung S5 with Android 5 and it seems to be downloading tasks and running them.

Not on this Account you haven't, you don't have any Android hosts attached to Seti on this Account:

Computers belonging to Geoff Pullinger

And even if you had, Setiathome hasn't released an Android 5 compatible app yet.

Claggy
ID: 1645326 · Report as offensive
Menace
Volunteer tester

Send message
Joined: 23 Nov 00
Posts: 20
Credit: 823,625
RAC: 980
United Kingdom
Message 1645333 - Posted: 22 Feb 2015, 16:55:37 UTC

Definitely that parsing error - blew Android 4.4.2 onto the phone and away it went.
ID: 1645333 · Report as offensive
Profile geoffp

Send message
Joined: 14 Oct 00
Posts: 2
Credit: 892,171
RAC: 3,427
United States
Message 1645364 - Posted: 22 Feb 2015, 18:33:43 UTC - in response to Message 1645326.  

It says on the Google store that the Android 5 compatible app has been released, is that old?
ID: 1645364 · Report as offensive
1 · 2 · 3 · Next

Message boards : News : Android Version Checking


 
©2017 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.