SetiPerformance 1.8 + Added apps from Lunatics v0.41

Message boards : Number crunching : SetiPerformance 1.8 + Added apps from Lunatics v0.41
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile BilBg
Volunteer tester
Avatar

Send message
Joined: 27 May 07
Posts: 3720
Credit: 9,385,827
RAC: 0
Bulgaria
Message 1453245 - Posted: 12 Dec 2013, 16:45:29 UTC


I hope the authors of programs/applications do not mind that I did this 'tweaked' package.


To know what it's all about - read the original author's thread:
Optimize your GPU. Find the value the easy way:
http://setiathome.berkeley.edu/forum_thread.php?id=69136&sort_style=6&start=0

Original Seti Performance page:
http://efmer.com/forum/index.php?topic=974.0

***

The package bellow is SetiPerformance 1.8
+ Added by me 8 apps from Lunatics_Win32_v0.41_setup.exe
(+ 2 more my 'joke apps' )

Download:
SetiPerformance_32_64_1_8__BilBg-Add_Lunatics_v041.7z (28 MB):
http://www16.zippyshare.com/v/24698066/file.html

MD5
b6c026249b7e8f6219ffa53b83cb6447 *SetiPerformance_32_64_1_8__BilBg-Add_Lunatics_v041.7z


Due to lack of NVIDIA CUDA GPU I tested only the 3 ATI GPU OpenCL applications.
Please, gurus here - get and proofread/check/test the package.





http://prikachi.com/images/201/6844201l.png


Mirror2 (to use if the link at ZippyShare do not work):
http://mail.dir.bg/~bil/SetiPerformance_32_64_1_8__BilBg-Add_Lunatics_v041.7z

I don't mind (if authors agree) if you also put the file on other sites
but don't use sites that are overly annoying (waiting counters, ad-ware Download Managers or similar annoyances)


***

Some necessary and stupid notes:
The 'stupid' Antiviruses flag red:

Lunatics_Win32_v0.41_setup.exe (if you have Antivirus that show red here you may/will have problems running SETI@home in general)
https://www.virustotal.com/en/file/9264c7e03f57ec5c5295fbd34d892b5608af2924a10dde40afea5f8402b18ee5/analysis/

This package:
https://www.virustotal.com/en/file/2400553ca70720d47de5dbbdf34e9a1180b05f064b8d41b9d09b2d6858f8c19c/analysis/

... have more 'stupid-red' because contains (in 'SetiPerformance_Test' sub-directory) also some files from/generated-by AutoHotkey
(which are UPX compressed, my sources available in the .ahk files):
http://www.autohotkey.com/
https://www.mywot.com/en/scorecard/autohotkey.com


I use ESET-NOD32, if you trust Comodo, TrendMicro-HouseCall, ... do as you wish (ToUse-or-notToUse--that's-the-Question ;) )
I hope gurus will share their opinion also on that (False-positive) matter.


 


- ALF - "Find out what you don't do well ..... then don't do it!" :)
 
ID: 1453245 · Report as offensive
Profile BilBg
Volunteer tester
Avatar

Send message
Joined: 27 May 07
Posts: 3720
Credit: 9,385,827
RAC: 0
Bulgaria
Message 1454113 - Posted: 15 Dec 2013, 9:09:33 UTC


OK, shy people, no one want to admit 'guru' status ;)

There were some Downloads
So, please, everybody that did tests (or just looked at the files) - share your findings/opinions...

Does it work, especially on NVIDIA CUDA 23...50 (MultiBeam) and NVIDIA OpenCL (AstroPulse)?
Do you think that just one 'CUDA' directory for all the CUDA applications (111 MB) causes too much overhead at startup?
(for 4 tasks (count 0.25) this means copy/write of 444 MB to disk)

Do you think the WU I used (work_unit.sah == PG0444_v7.wu) is a good choice?
Is it good I moved some of the .wu files out of 'workunits' directory (to 'workunits_OFF' directory)?


 


- ALF - "Find out what you don't do well ..... then don't do it!" :)
 
ID: 1454113 · Report as offensive
Profile Mike Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 17 Feb 01
Posts: 31832
Credit: 74,680,140
RAC: 24,101
Germany
Message 1454123 - Posted: 15 Dec 2013, 9:53:33 UTC
Last modified: 15 Dec 2013, 10:22:22 UTC

I had a quick look.
Didn`t work.

Edit i had to recopy the apps to get it work.

message app couldn`t start.
With each crime and every kindness we birth our future.
ID: 1454123 · Report as offensive
Profile BilBg
Volunteer tester
Avatar

Send message
Joined: 27 May 07
Posts: 3720
Credit: 9,385,827
RAC: 0
Bulgaria
Message 1454125 - Posted: 15 Dec 2013, 10:21:12 UTC - in response to Message 1454123.  

Didn`t work.

What didn`t work?
CUDA app? (which)
Error message?


 


- ALF - "Find out what you don't do well ..... then don't do it!" :)
 
ID: 1454125 · Report as offensive
Profile Mike Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 17 Feb 01
Posts: 31832
Credit: 74,680,140
RAC: 24,101
Germany
Message 1454127 - Posted: 15 Dec 2013, 10:23:00 UTC - in response to Message 1454125.  

Didn`t work.

What didn`t work?
CUDA app? (which)
Error message?



OpenCL

I had to recopy the apps to get it work.

message app couldn`t start.
With each crime and every kindness we birth our future.
ID: 1454127 · Report as offensive
Profile BilBg
Volunteer tester
Avatar

Send message
Joined: 27 May 07
Posts: 3720
Credit: 9,385,827
RAC: 0
Bulgaria
Message 1454154 - Posted: 15 Dec 2013, 12:12:28 UTC - in response to Message 1454127.  


Do you mean manually "recopy the apps" (while SetiPerformance is started?) from
...\zip\OpenCL\
to
%APPDATA%\eFMer\SetiPerformance\slot0\

Do you have some 'strange' (German) letters in the directory paths?
(the first directory where the files are extracted is by your choice,
the problem is the second directory is always in %APPDATA% and no Option to change it
)

Some other reason you can think of that can prevent SetiPerformance to copy files?


app couldn`t start.

String "couldn" is not in SetiPerformance.exe (ASCII and Unicode search)
The only similar Message I can find in SetiPerformance.exe is:
"ERROR: Device: %d, Count: %d, program failed to start."


 


- ALF - "Find out what you don't do well ..... then don't do it!" :)
 
ID: 1454154 · Report as offensive
Profile Mike Crowdfunding Project Donor*Special Project $75 donorSpecial Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 17 Feb 01
Posts: 31832
Credit: 74,680,140
RAC: 24,101
Germany
Message 1454173 - Posted: 15 Dec 2013, 13:31:52 UTC - in response to Message 1454154.  


Do you mean manually "recopy the apps" (while SetiPerformance is started?) from
...\zip\OpenCL\
to
%APPDATA%\eFMer\SetiPerformance\slot0\

Do you have some 'strange' (German) letters in the directory paths?
(the first directory where the files are extracted is by your choice,
the problem is the second directory is always in %APPDATA% and no Option to change it
)

Some other reason you can think of that can prevent SetiPerformance to copy files?


app couldn`t start.

String "couldn" is not in SetiPerformance.exe (ASCII and Unicode search)
The only similar Message I can find in SetiPerformance.exe is:
"ERROR: Device: %d, Count: %d, program failed to start."



No, it seems apps weren`t found at all or write protected.
I had to manually copy the apps from my Lunatics folder into OpenCL folder.
Same with the CPU app.

Yes, message was program failed to start.
No strange german letters in direcory path.

I just copied all apps i need from my own sources into OpenCL and CPU folder.


With each crime and every kindness we birth our future.
ID: 1454173 · Report as offensive
Profile BilBg
Volunteer tester
Avatar

Send message
Joined: 27 May 07
Posts: 3720
Credit: 9,385,827
RAC: 0
Bulgaria
Message 1455555 - Posted: 19 Dec 2013, 19:51:04 UTC - in response to Message 1454173.  

No, it seems apps weren`t found at all or write protected.
I had to manually copy the apps from my Lunatics folder into OpenCL folder.
Same with the CPU app.

Very strange ...
Is this on this computer?:
http://setiathome.berkeley.edu/show_host_detail.php?hostid=5735690

So you uncompressed the .7z file (I use context/right-click menu - both WinRAR and 7-Zip work)
This creates the 'zip' directory (I did this in different partitions/folders and every time SetiPerformance works)
Then you go to the (uncompressed) ...\zip\OpenCL\ directory and see total of 15 files of which 4 .exe files (with non-zero length)

You start SetiPerformance64.exe (I can test only with SetiPerformance.exe, I don't know if SetiPerformance.exe will work OK on 'Windows 7 Ultimate x64')
You try some OpenCL ATI test and get "ERROR: Device: %d, Count: %d, program failed to start."

Then you copy the same 4 .exe files "from your own sources into OpenCL and CPU folder" overwriting the .exe files which are already there.
(did you compare 'your' and 'my' .exe files before the copy to see if they are identical?)

And after this copy/overwrite SetiPerformance64 works?


 


- ALF - "Find out what you don't do well ..... then don't do it!" :)
 
ID: 1455555 · Report as offensive
Profile BilBg
Volunteer tester
Avatar

Send message
Joined: 27 May 07
Posts: 3720
Credit: 9,385,827
RAC: 0
Bulgaria
Message 1455560 - Posted: 19 Dec 2013, 20:16:28 UTC


REMINDER to all users of SetiPerformance

As I already noted in the original thread:
http://setiathome.berkeley.edu/forum_thread.php?id=69136&postid=1300787#1300787

"the decisions for "The best average time found" are really weird
(I'm confident there is a bug in that code)

Better to do the decision by yourself ..."

So DON'T pay attention to 'The best average time found' - just look at 'average time on device' and compare by yourself
(the bug is still there, probably the last test is not taken into account)


Starting automatic test: (SetiPerformance Test4Test (Progress, Random times))
16 December 2013 - 19:50:06 Start, devices: 1, device count: 1 (1.00)
16 December 2013 - 19:50:06 Set: SetiPerformance Test4Test (Progress, Random times) , Exe: SetiPerformance_Test.exe , Parameters:
16 December 2013 - 19:50:48 Runtime: Device: 0, count: 0, 41 seconds
16 December 2013 - 19:50:48 Device: 0, Count: 0, finished.
--------------------------------------------------------------------------- Results:
Device: 0, device count: 1, average time / count: 41, average time on device: 41 Seconds (0 Minutes, 41 Seconds)
Next :---------------------------------------------------------------------------
16 December 2013 - 19:50:51 Start, devices: 1, device count: 2 (0.50)
16 December 2013 - 19:50:51 Set: SetiPerformance Test4Test (Progress, Random times) , Exe: SetiPerformance_Test.exe , Parameters:
16 December 2013 - 19:51:04 Runtime: Device: 0, count: 0, 12 seconds
16 December 2013 - 19:51:04 Device: 0, Count: 0, finished.
16 December 2013 - 19:51:06 Runtime: Device: 0, count: 1, 14 seconds
16 December 2013 - 19:51:06 Device: 0, Count: 1, finished.
--------------------------------------------------------------------------- Results:
Device: 0, device count: 2, average time / count: 13, average time on device: 6 Seconds (0 Minutes, 6 Seconds)
>> The best average time found: 41 Seconds (0 Minutes, 41 Seconds), with count: 1.00 (1)



Starting automatic test: (SetiPerformance Test4Test (Progress, Random times))
18 December 2013 - 06:27:16 Start, devices: 1, device count: 1 (1.00)
18 December 2013 - 06:27:16 Set: SetiPerformance Test4Test (Progress, Random times) , Exe: SetiPerformance_Test.exe , Parameters:
18 December 2013 - 06:27:58 Runtime: Device: 0, count: 0, 41 seconds
18 December 2013 - 06:27:58 Device: 0, Count: 0, finished.
--------------------------------------------------------------------------- Results:
Device: 0, device count: 1, average time / count: 41, average time on device: 41 Seconds (0 Minutes, 41 Seconds)
Next :---------------------------------------------------------------------------
18 December 2013 - 06:28:02 Start, devices: 1, device count: 2 (0.50)
18 December 2013 - 06:28:02 Set: SetiPerformance Test4Test (Progress, Random times) , Exe: SetiPerformance_Test.exe , Parameters:
18 December 2013 - 06:28:35 Runtime: Device: 0, count: 1, 32 seconds
18 December 2013 - 06:28:35 Device: 0, Count: 1, finished.
18 December 2013 - 06:28:39 Runtime: Device: 0, count: 0, 36 seconds
18 December 2013 - 06:28:39 Device: 0, Count: 0, finished.
--------------------------------------------------------------------------- Results:
Device: 0, device count: 2, average time / count: 34, average time on device: 17 Seconds (0 Minutes, 17 Seconds)
Next :---------------------------------------------------------------------------
18 December 2013 - 06:28:42 Start, devices: 1, device count: 3 (0.33)
18 December 2013 - 06:28:42 Set: SetiPerformance Test4Test (Progress, Random times) , Exe: SetiPerformance_Test.exe , Parameters:
18 December 2013 - 06:28:48 Runtime: Device: 0, count: 2, 5 seconds
18 December 2013 - 06:28:48 Device: 0, Count: 2, finished.
18 December 2013 - 06:28:52 Runtime: Device: 0, count: 1, 9 seconds
18 December 2013 - 06:28:52 Device: 0, Count: 1, finished.
18 December 2013 - 06:28:54 Runtime: Device: 0, count: 0, 11 seconds
18 December 2013 - 06:28:54 Device: 0, Count: 0, finished.
--------------------------------------------------------------------------- Results:
Device: 0, device count: 3, average time / count: 8, average time on device: 2 Seconds (0 Minutes, 2 Seconds)
>> The best average time found: 17 Seconds (0 Minutes, 17 Seconds), with count: 0.50 (2)


 


- ALF - "Find out what you don't do well ..... then don't do it!" :)
 
ID: 1455560 · Report as offensive

Message boards : Number crunching : SetiPerformance 1.8 + Added apps from Lunatics v0.41


 
©2019 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.