Updating for upcoming apps.....

Message boards : Number crunching : Updating for upcoming apps.....
Message board moderation

To post messages, you must log in.

Previous · 1 . . . 7 · 8 · 9 · 10 · 11 · Next

AuthorMessage
Claggy
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4654
Credit: 47,435,977
RAC: 549
United Kingdom
Message 1209629 - Posted: 24 Mar 2012, 13:21:43 UTC - in response to Message 1209627.  
Last modified: 24 Mar 2012, 13:24:23 UTC

Hmmm, now, not impressed. Had two of those AP v6.01s and they both ran for all of 2 seconds. What's the use of downloading 16MB worth of data that runs all together 4 seconds, less even when you count CPU time (0.39 + 0.41 seconds)? ;-)

Matt's Technical News post from Thursday:

Other progress: we finally launched the new splitters which are sensitive to VGC values and thus skip (most) noisy data blocks instead of splitting them into workunits that will return quickly and clog up our pipeline. Yay! However there were unexpected results last night: turns out it's actually slower to parse such a noisy data file and skip bad blocks than to just split everything, so splitters were getting stuck on these files and not generating work. Oops. We ran out of multi-beam work last night due to this, and I reverted back this morning just to the plumbing working again. I'm going to change the logic to be a little more aggressive and thus speed up skipping through noisy files, and implement that next week.

At least it won't bump your APR up to unbelievable high values now,

Claggy
ID: 1209629 · Report as offensive
Profile Jord
Volunteer tester
Avatar

Send message
Joined: 9 Jun 99
Posts: 14893
Credit: 4,152,794
RAC: 1,250
Netherlands
Message 1209638 - Posted: 24 Mar 2012, 13:31:42 UTC - in response to Message 1209629.  

At least it won't bump your APR up to unbelievable high values now,

No, they left me with no APR. What is the unbelievably high value, though?
ID: 1209638 · Report as offensive
Richard Haselgrove Project Donor
Volunteer tester

Send message
Joined: 4 Jul 99
Posts: 13250
Credit: 161,233,404
RAC: 232,398
United Kingdom
Message 1209645 - Posted: 24 Mar 2012, 13:49:19 UTC - in response to Message 1209638.  

At least it won't bump your APR up to unbelievable high values now,

No, they left me with no APR. What is the unbelievably high value, though?

I think we've seen it up into the TeraFlop range. 2 TFlop, IIRC.
ID: 1209645 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4654
Credit: 47,435,977
RAC: 549
United Kingdom
Message 1209647 - Posted: 24 Mar 2012, 13:59:20 UTC - in response to Message 1209638.  

At least it won't bump your APR up to unbelievable high values now,

No, they left me with no APR.

Yet, once you complete a full length AP v6 task that has less than 10% Blanking, and it validates, then you'll get an APR for that app,

Claggy
ID: 1209647 · Report as offensive
Josef W. Segur
Volunteer developer
Volunteer tester

Send message
Joined: 30 Oct 99
Posts: 4504
Credit: 1,414,761
RAC: 0
United States
Message 1209713 - Posted: 24 Mar 2012, 16:43:06 UTC - in response to Message 1209638.  

At least it won't bump your APR up to unbelievable high values now,

No, they left me with no APR. What is the unbelievably high value, though?

The rsc_fpops_est for AP is 1.821e15, so a runtime of 2 seconds would have driven APR toward 910500.0 or so, 910.5 TeraFLOPS or nearly 1 PetaFLOPS.

Note: I'm using FLOPS in the generally accepted meaning Floating Point Operations Per Second. It's a rate, not a count.
                                                                   Joe
ID: 1209713 · Report as offensive
Cosmic_Ocean
Avatar

Send message
Joined: 23 Dec 00
Posts: 3013
Credit: 12,492,022
RAC: 7,438
United States
Message 1209943 - Posted: 25 Mar 2012, 3:46:00 UTC

Just wanted to note that I don't know when/if that changeset for the credits thing went into effect, but the two tasks in my list that have validated since that was posted here have gained ~200 credits. The wingmates that were involved on those, it was their first or second completed task according to application details. Was looking at the 550 range before, now it is in the low-mid 700s.

Anyone else seeing something similar?
Linux laptop:
record uptime: 1511d 20h 19m (ended due to the power brick giving-up)
ID: 1209943 · Report as offensive
OTS
Volunteer tester

Send message
Joined: 6 Jan 08
Posts: 360
Credit: 20,533,537
RAC: 0
United States
Message 1210090 - Posted: 25 Mar 2012, 17:46:39 UTC - in response to Message 1206387.  

I have two questions for those in the know about the new V6 AP apps.

1. Will there be an AP_V6 stock version available shortly for 32-bit Linux to go along with the Windows version?.

2. I see there is a beta version of the 64-bit Linux AP_v6 version now (R546). Once it leaves beta status, will there be a version compiled for 32-bit Linux based of the same source code, or alternatively, will a tarball be made available for Linux users to compile their own?

About your 2. Q :
There will be optimized 32bit and 64bit APv6 versions for Linux available as soon as the validator/credit issues here are called off.
The source code (r546) will be also available at lunatics. But don't expect a tarball, 7z compresses better these days.


It appears the AP_V6 Windows optimized versions (r555 &r557) have been released. Are the Linux versions far behind?
ID: 1210090 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4654
Credit: 47,435,977
RAC: 549
United Kingdom
Message 1210094 - Posted: 25 Mar 2012, 18:06:16 UTC - in response to Message 1210090.  

I have two questions for those in the know about the new V6 AP apps.

1. Will there be an AP_V6 stock version available shortly for 32-bit Linux to go along with the Windows version?.

2. I see there is a beta version of the 64-bit Linux AP_v6 version now (R546). Once it leaves beta status, will there be a version compiled for 32-bit Linux based of the same source code, or alternatively, will a tarball be made available for Linux users to compile their own?

About your 2. Q :
There will be optimized 32bit and 64bit APv6 versions for Linux available as soon as the validator/credit issues here are called off.
The source code (r546) will be also available at lunatics. But don't expect a tarball, 7z compresses better these days.


It appears the AP_V6 Windows optimized versions (r555 &r557) have been released. Are the Linux versions far behind?

r555 and r557 haven't been released yet, they are still in Beta testing, once the nod from Eric has been received then they'll be released in the 0.40 Installers.

linux AP apps are in Alpha testing, hopefully one of the Linux Gurus will actually download & test them before release: (1060.15 KB - downloaded 0 times.)

Claggy
ID: 1210094 · Report as offensive
Profile Khangollo
Avatar

Send message
Joined: 1 Aug 00
Posts: 245
Credit: 36,410,524
RAC: 0
Slovenia
Message 1210101 - Posted: 25 Mar 2012, 18:25:46 UTC - in response to Message 1210094.  

linux AP apps are in Alpha testing, hopefully one of the Linux Gurus will actually download & test them before release: (1060.15 KB - downloaded 0 times.)


I would gladly run them, but the only available release I see is " Beta1-Linux 64bit AstroPulse, v6.01 (r546 BETA)" (19 downloads) with note s@h-beta only.
ID: 1210101 · Report as offensive
OTS
Volunteer tester

Send message
Joined: 6 Jan 08
Posts: 360
Credit: 20,533,537
RAC: 0
United States
Message 1210105 - Posted: 25 Mar 2012, 18:41:23 UTC - in response to Message 1210094.  

I have two questions for those in the know about the new V6 AP apps.

1. Will there be an AP_V6 stock version available shortly for 32-bit Linux to go along with the Windows version?.

2. I see there is a beta version of the 64-bit Linux AP_v6 version now (R546). Once it leaves beta status, will there be a version compiled for 32-bit Linux based of the same source code, or alternatively, will a tarball be made available for Linux users to compile their own?

About your 2. Q :
There will be optimized 32bit and 64bit APv6 versions for Linux available as soon as the validator/credit issues here are called off.
The source code (r546) will be also available at lunatics. But don't expect a tarball, 7z compresses better these days.


It appears the AP_V6 Windows optimized versions (r555 &r557) have been released. Are the Linux versions far behind?

r555 and r557 haven't been released yet, they are still in Beta testing, once the nod from Eric has been received then they'll be released in the 0.40 Installers.

linux AP apps are in Alpha testing, hopefully one of the Linux Gurus will actually download & test them before release: (1060.15 KB - downloaded 0 times.)

Claggy


OK. I thought that since the Linux version (http://lunatics.kwsn.net/index.php?module=Downloads;catd=34) was clearly marked "r446 beta" while the Windows versions (http://lunatics.kwsn.net/index.php?module=Downloads;catd=31) was not that it had been released. Good thing I covered myself by saying it "appears" to be released ;-).

ID: 1210105 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4654
Credit: 47,435,977
RAC: 549
United Kingdom
Message 1210107 - Posted: 25 Mar 2012, 18:48:45 UTC - in response to Message 1210101.  
Last modified: 25 Mar 2012, 18:52:15 UTC

linux AP apps are in Alpha testing, hopefully one of the Linux Gurus will actually download & test them before release: (1060.15 KB - downloaded 0 times.)


I would gladly run them, but the only available release I see is " Beta1-Linux 64bit AstroPulse, v6.01 (r546 BETA)" (19 downloads) with note s@h-beta only.

I'm looking at the 32bit version of r546 that's posted in my Astropulse v6 Dev thread, no doubt it'll be released for Beta testing shortly.

Claggy
ID: 1210107 · Report as offensive
Profile Philip Stehno
Avatar

Send message
Joined: 17 May 99
Posts: 7
Credit: 10,241,552
RAC: 0
United States
Message 1210302 - Posted: 26 Mar 2012, 14:25:53 UTC

Astropulse V6.01 application files will not download on my machine, I get instant HTTP errors while trying to connect. It's been going on for several days now. Any suggesting on how to fix?
ID: 1210302 · Report as offensive
LadyL
Volunteer tester
Avatar

Send message
Joined: 14 Sep 11
Posts: 1679
Credit: 5,230,097
RAC: 0
Message 1210304 - Posted: 26 Mar 2012, 14:44:44 UTC - in response to Message 1210302.  

Astropulse V6.01 application files will not download on my machine, I get instant HTTP errors while trying to connect. It's been going on for several days now. Any suggesting on how to fix?


What exactly are you trying to download? Or is BOINC trying to get AP 6.01 stock?
I'm not the Pope. I don't speak Ex Cathedra!
ID: 1210304 · Report as offensive
Profile Raistmer
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 16 Jun 01
Posts: 6115
Credit: 101,232,229
RAC: 52,284
Russia
Message 1210309 - Posted: 26 Mar 2012, 14:57:41 UTC - in response to Message 1208269.  
Last modified: 26 Mar 2012, 15:06:54 UTC



control part of the program (running on the host CPU) has to be different.

so it will make it fail ? :(

Cant wait the other is ready. because doing AP on CPU i always found it silly and doing a 8hrs-12hrs-18hrs task on a core.. i will never accept that. Sorry



Correct. Carry on using that until the dust settles on this rollout, and you are ready to choose which applications you wish to run. The updated application to run AP (the new version) on CPU is the only benefit you will find in the new installer.




1) ATi AP improved also so you could expect improved speed over prev release.
2) NV AP will not (in most cases) fail. It will work and accordingly already available reports it will work fast.
But there are 2 issues we want to be fixed before inclusion of NV AP to installer:
a) 100% CPU usage. Currently I'm working on possible workaround, hope it will be clear if such workaround possible or not in few days. But I still believe that proper solution is bugfix for nVidia (in their driver). This bug was reported few months ago already, was confirmed and "in process"... few months. So, give nice kick to NV debugger group if you can ;)

b) Silent failures (incorrect overflows) if GPU can't handle proposed parameters (i.e., proposed unroll value). I can't recall such behavior on ATi GPUs. There is error reported if something go wrong. But here user even will not know that there is something wrong until incorrectly overflowed tasks will start to fail validation. Fix is quite simple - to reduce unroll/fetch values and this helps in most cases... but we feel it's not suitable for installer target audience.
(cause there is no error reported to deal with) it's again a shot at NV's OpenCL driver group. Make clear OpenCL error reporting instead of doing buffer corruption...

Nevertheless, NV AP is quite suitable for advanced users who can check their task logs and don't fear to edit app_info manually. App will be released soon as separate binary.
ID: 1210309 · Report as offensive
Profile cliff
Avatar

Send message
Joined: 16 Dec 07
Posts: 625
Credit: 3,590,440
RAC: 0
United Kingdom
Message 1210350 - Posted: 26 Mar 2012, 16:45:23 UTC
Last modified: 26 Mar 2012, 16:46:11 UTC

Would you believe it, new apps out, installed fine on rig 1, went to install on rig 2, and boinc has gone bonkers and everything is running HP, and of course it bumped a bucket of running tasks into 'waiting to run':-/

Damm daft thing, there are tasks there that had a couple of mins to run to completion.

Anyway I'm gonna wait to upgrade rig 2 when boinc gotten over its spasm of HPing

Anyone else noticed a definate lag with S@H today?
Cheers,
Cliff,
Been there, Done that, Still no damm T shirt!
ID: 1210350 · Report as offensive
Profile Michel448a
Volunteer tester
Avatar

Send message
Joined: 27 Oct 00
Posts: 1331
Credit: 2,970,814
RAC: 0
Canada
Message 1210351 - Posted: 26 Mar 2012, 16:45:28 UTC
Last modified: 26 Mar 2012, 16:46:20 UTC

if you need help for testing, Raistmer.... :)
ID: 1210351 · Report as offensive
Profile perryjay
Volunteer tester
Avatar

Send message
Joined: 20 Aug 02
Posts: 3377
Credit: 20,676,751
RAC: 0
United States
Message 1210394 - Posted: 26 Mar 2012, 19:02:24 UTC - in response to Message 1210350.  

Cliff, did you remember to redo your flops? The new installer gives you a brand new app_info and it doesn't have the flops entry.


PROUD MEMBER OF Team Starfire World BOINC
ID: 1210394 · Report as offensive
Profile cliff
Avatar

Send message
Joined: 16 Dec 07
Posts: 625
Credit: 3,590,440
RAC: 0
United Kingdom
Message 1210403 - Posted: 26 Mar 2012, 19:28:58 UTC - in response to Message 1210394.  

Cliff, did you remember to redo your flops? The new installer gives you a brand new app_info and it doesn't have the flops entry.


I dont have a flops entry in app_info..
I've been running the default app_info apart from a very brief punt into trying out 2 tasks per gpu.. PSU couldnt hack the power drain, got rebootitis until I removed the offending entries..

When I have a good rig for crunching, which at present is some time away:-/ I'll start to tweak my app info on that rig.

So far I just have a new HAFX case on order, then as and when I can find the pennies, new mobo, new GPU[s] and 1000watt PSU..

Regards,
Cliff,
Been there, Done that, Still no damm T shirt!
ID: 1210403 · Report as offensive
OTS
Volunteer tester

Send message
Joined: 6 Jan 08
Posts: 360
Credit: 20,533,537
RAC: 0
United States
Message 1212839 - Posted: 1 Apr 2012, 16:04:32 UTC - in response to Message 1206075.  

Thank you Richard. Mine was set to 6 hours but there must be a bug as they come far more often than that.

15/03/2012 04:39:48 | SETI@home | Message from server: Your app_info.xml file doesn't have a usable version of AstroPulse v6.
15/03/2012 05:44:09 | SETI@home | Message from server: Your app_info.xml file doesn't have a usable version of AstroPulse v6.
15/03/2012 07:32:13 | SETI@home | Message from server: Your app_info.xml file doesn't have a usable version of AstroPulse v6.

If you didn't have an app_info and didn't have the AP V6 switch selected, you would get a message saying 'there is AP v6 work available, but your preferences are set to not accept it',
it's just the server's way of saying why you didn't get that task it could have sent you,

Claggy



What if you are getting the message:

“Message from server: Your app_info.xml file doesn't have a usable version of AstroPulse v6”

and you DO have an app_info.xml file, you DO have the app, you DO have the AP v6 switch selected, and you DO want V6 AP work units?

I am receiving MB work units and the occasional 5.05/5.06 work unit but so far no V6. What is the server saying in this case?


My app_info.xml looks like the following and I see nothing wrong with it, but perhaps I am overlooking something. It wouldn’t be the first time.



<app_info>

<app>
<name>astropulse_v6</name>
</app>
<file_info>
<name>ap_6.01r546_sse3_linux32</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v6</app_name>
<version_num>601</version_num>
<file_ref>
<file_name>ap_6.01r546_sse3_linux32</file_name>
<main_program/>
</file_ref>
</app_version>

<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>AK_V8_linux32_ssse3</name>
<executable/>
</file_info>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>6.10.58</version_num>
<file_ref>
<file_name>AK_V8_linux32_ssse3</file_name>
<main_program/>
</file_ref>
</app_version>

<app>
<name>astropulse_v505</name>
</app>
<file_info>
<name>ap_5.06r411b_sse_linux32</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v505</app_name>
<version_num>506</version_num>
<file_ref>
<file_name>ap_5.06r411b_sse_linux32</file_name>
<main_program/>
</file_ref>
</app_version>

</app_info>


Sorry about the indents being stripped away but I did put extra spaces between the sections which might help make it more readable.

ID: 1212839 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4654
Credit: 47,435,977
RAC: 549
United Kingdom
Message 1212851 - Posted: 1 Apr 2012, 16:27:49 UTC - in response to Message 1212839.  

Thank you Richard. Mine was set to 6 hours but there must be a bug as they come far more often than that.

15/03/2012 04:39:48 | SETI@home | Message from server: Your app_info.xml file doesn't have a usable version of AstroPulse v6.
15/03/2012 05:44:09 | SETI@home | Message from server: Your app_info.xml file doesn't have a usable version of AstroPulse v6.
15/03/2012 07:32:13 | SETI@home | Message from server: Your app_info.xml file doesn't have a usable version of AstroPulse v6.

If you didn't have an app_info and didn't have the AP V6 switch selected, you would get a message saying 'there is AP v6 work available, but your preferences are set to not accept it',
it's just the server's way of saying why you didn't get that task it could have sent you,

Claggy



What if you are getting the message:

“Message from server: Your app_info.xml file doesn't have a usable version of AstroPulse v6”

and you DO have an app_info.xml file, you DO have the app, you DO have the AP v6 switch selected, and you DO want V6 AP work units?

I am receiving MB work units and the occasional 5.05/5.06 work unit but so far no V6. What is the server saying in this case?


My app_info.xml looks like the following and I see nothing wrong with it, but perhaps I am overlooking something. It wouldn’t be the first time.



<app_info>

<app>
<name>astropulse_v6</name>
</app>
<file_info>
<name>ap_6.01r546_sse3_linux32</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v6</app_name>
<version_num>601</version_num>
<file_ref>
<file_name>ap_6.01r546_sse3_linux32</file_name>
<main_program/>
</file_ref>
</app_version>

<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>AK_V8_linux32_ssse3</name>
<executable/>
</file_info>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>6.10.58</version_num>
<file_ref>
<file_name>AK_V8_linux32_ssse3</file_name>
<main_program/>
</file_ref>
</app_version>

<app>
<name>astropulse_v505</name>
</app>
<file_info>
<name>ap_5.06r411b_sse_linux32</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v505</app_name>
<version_num>506</version_num>
<file_ref>
<file_name>ap_5.06r411b_sse_linux32</file_name>
<main_program/>
</file_ref>
</app_version>

</app_info>


Sorry about the indents being stripped away but I did put extra spaces between the sections which might help make it more readable.


I can't see anything wrong with the app_info to do with AP v6, the 6.10.58 version number for setiathome_enhanced is a bit odd,

The only thing i can think of is: you have restarted Boinc haven't you? if you edited the app_info, and didn't restart Boinc, you'd still be using the app_info settings from earlier.

Claggy
ID: 1212851 · Report as offensive
Previous · 1 . . . 7 · 8 · 9 · 10 · 11 · Next

Message boards : Number crunching : Updating for upcoming apps.....


 
©2019 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.