Running SETI@home on an nVidia Fermi GPU

Message boards : Number crunching : Running SETI@home on an nVidia Fermi GPU
Message board moderation

To post messages, you must log in.

Previous · 1 . . . 10 · 11 · 12 · 13 · 14 · 15 · Next

AuthorMessage
Josef W. Segur
Volunteer developer
Volunteer tester

Send message
Joined: 30 Oct 99
Posts: 4504
Credit: 1,414,761
RAC: 0
United States
Message 1023771 - Posted: 8 Aug 2010, 19:55:07 UTC - in response to Message 1023762.  

Hey guys,

I just put together a seti box with 2x GTX460s...the performance is pretty poor however. I understand Fermi support isn't real solid at present, but my results seem worse than what I'm seeing browsing around.

System Info
Intel i7 920
2x GTX460
Windows 7-64bit
BOINC 6.11.4
Lunatics UI 0.36 (MB only)

My Fermi's are currently spending ~30-45 minutes per workunit...each.
According to GPUz, they are running at speed with ~75% GPU load.

I've tried running multiple WUs on the GPUs, and that yeilds really awefull results. GPU usage drops to ~40%, and complete about 0.25% in 5 minutes.

Below is my app_info that I cobbled together from this thread.
Any assistance would be great...or maybe this is to be expected (VLARs?) ??

Thank you
...

Yes, you got a few reissues of old VLARs. Other than those, midrange ARs are showing 12 or 13 minutes, VHARs 3 or 4 minutes in your validated tasks.

That's only about 6.5 times faster than your CPU for midrange, I'd expect better. As usual for fermi cards there's "clockRate = 810000" shown in the stderr reports. Are you sure the clocks are being boosted when doing tasks?

A quick very approximate estimation for <flops> to put in your app_info.xml as the cards are now working would be 3.17e10 for the CPU app and 2.05e11 for the GPU app.
                                                                  Joe
ID: 1023771 · Report as offensive
Profile Codeman05

Send message
Joined: 16 Dec 01
Posts: 33
Credit: 15,457,430
RAC: 0
United States
Message 1023772 - Posted: 8 Aug 2010, 19:57:12 UTC - in response to Message 1023770.  

I have a batch that hasn't uploaded yet (network issues).
Looks like they are finishing up in the 22-25min range for the most part.
With some 12 mins as you noted
ID: 1023772 · Report as offensive
Profile Codeman05

Send message
Joined: 16 Dec 01
Posts: 33
Credit: 15,457,430
RAC: 0
United States
Message 1023773 - Posted: 8 Aug 2010, 19:58:34 UTC - in response to Message 1023771.  

Hi Josef,

Yes I've been logging with GPU-z and the clock speeds are staying at 100%.
However they usually however around 60-70% load...which I'm not sure if that is normal or not.

I will try putting in the flops values for the card and see what that does.

Appreciate the help
ID: 1023773 · Report as offensive
Josef W. Segur
Volunteer developer
Volunteer tester

Send message
Joined: 30 Oct 99
Posts: 4504
Credit: 1,414,761
RAC: 0
United States
Message 1023777 - Posted: 8 Aug 2010, 20:11:10 UTC - in response to Message 1023773.  

Hi Josef,

Yes I've been logging with GPU-z and the clock speeds are staying at 100%.
However they usually however around 60-70% load...which I'm not sure if that is normal or not.

I will try putting in the flops values for the card and see what that does.

Appreciate the help

You're welcome.

The flops won't affect runtime, but should help BOINC estimate and do work fetch better. It's just an attempt to cooperate with the way BOINC is designed rather than fight it.

The 60-70% load is similar to what others have reported for fermi cards running single instances. Maybe one of those VLARs was involved when you tried the multiple instance setup before, or maybe the 48 processors/shaders per multiprocessor of the 460 reacts differently from the 32 on GTX 470 and 480 cards.
                                                              Joe
ID: 1023777 · Report as offensive
Profile jason_gee
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 24 Nov 06
Posts: 7489
Credit: 91,093,184
RAC: 0
Australia
Message 1023786 - Posted: 8 Aug 2010, 20:41:08 UTC - in response to Message 1023773.  

Hey! You're a Squire!, when you get comfortable you might like to try the x32f build in Beta testing.

Jason
"Living by the wisdom of computer science doesn't sound so bad after all. And unlike most advice, it's backed up by proofs." -- Algorithms to live by: The computer science of human decisions.
ID: 1023786 · Report as offensive
Profile Codeman05

Send message
Joined: 16 Dec 01
Posts: 33
Credit: 15,457,430
RAC: 0
United States
Message 1023789 - Posted: 8 Aug 2010, 21:05:15 UTC - in response to Message 1023786.  

Hey thanks for the heads up Jason, not sure how I missed that lol
Wow...so far looks to be a sizable boost on my box...nice... :)

On the bright side, did also manage to get multiple WUs running on the 460s :D
Guessing I had some bad units before, because I cant figure out what I did for the life of me...

thanks again guys

Hey! You're a Squire!, when you get comfortable you might like to try the x32f build in Beta testing.

Jason

ID: 1023789 · Report as offensive
Fulvio Cavalli
Volunteer tester
Avatar

Send message
Joined: 21 May 99
Posts: 1736
Credit: 259,180,282
RAC: 0
Brazil
Message 1024079 - Posted: 10 Aug 2010, 1:36:53 UTC
Last modified: 10 Aug 2010, 1:40:38 UTC

Hey guys, can anyone tell me what im doing wrong? I just manage to make my system (and cache) survive a win xp32 -> win7 64 upgrade, and was confident to insert Fermi information on it, in preparation for my 2 GTX 460 that are on the way, even still with my GTX 295 installed (its supposed to be backward compatible?).
I reschedule all my WUs to cpu, and when i can get some 610 work now, its ending like this:

09/08/2010 22:31:38 Starting BOINC client version 6.10.58 for windows_x86_64
09/08/2010 22:31:38 log flags: file_xfer, sched_ops, task
09/08/2010 22:31:38 Libraries: libcurl/7.19.7 OpenSSL/0.9.8l zlib/1.2.3
09/08/2010 22:31:38 Data directory: C:\ProgramData\BOINC
09/08/2010 22:31:38 Running under account Casa
09/08/2010 22:31:38 Processor: 4 GenuineIntel Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz [Family 6 Model 26 Stepping 5]
09/08/2010 22:31:38 Processor: 256.00 KB cache
09/08/2010 22:31:38 Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss htt tm pni ssse3 cx16 sse4_1 sse4_2 syscall lm vmx tm2 popcnt pbe
09/08/2010 22:31:38 OS: Microsoft Windows 7: Ultimate x64 Edition, (06.01.7600.00)
09/08/2010 22:31:38 Memory: 2.99 GB physical, 5.98 GB virtual
09/08/2010 22:31:38 Disk: 232.88 GB total, 198.49 GB free
09/08/2010 22:31:38 Local time is UTC -3 hours
09/08/2010 22:31:38 NVIDIA GPU 0: GeForce GTX 295 (driver version 25896, CUDA version 3010, compute capability 1.3, 879MB, 725 GFLOPS peak)
09/08/2010 22:31:38 NVIDIA GPU 1: GeForce GTX 295 (driver version 25896, CUDA version 3010, compute capability 1.3, 880MB, 596 GFLOPS peak)
09/08/2010 22:31:38 SETI@home Found app_info.xml; using anonymous platform
09/08/2010 22:31:39 SETI@home URL http://setiathome.berkeley.edu/; Computer ID 5482370; resource share 100
09/08/2010 22:31:39 SETI@home General prefs: from SETI@home (last modified 20-Apr-2009 18:19:58)
09/08/2010 22:31:39 SETI@home Computer location: school
09/08/2010 22:31:39 General prefs: using separate prefs for school
09/08/2010 22:31:39 Reading preferences override file
09/08/2010 22:31:39 Preferences:
09/08/2010 22:31:39 max memory usage when active: 1531.06MB
09/08/2010 22:31:39 max memory usage when idle: 2755.91MB
09/08/2010 22:31:39 max disk usage: 10.00GB
09/08/2010 22:31:39 (to change preferences, visit the web site of an attached project, or select Preferences in the Manager)
09/08/2010 22:31:39 Not using a proxy
09/08/2010 22:31:39 SETI@home Restarting task 20my10aa.13252.24885.11.10.119_0 using setiathome_enhanced version 603
09/08/2010 22:31:39 SETI@home Restarting task 22dc09ab.23792.13737.15.10.20_4 using setiathome_enhanced version 603
09/08/2010 22:31:39 SETI@home Restarting task 21dc09aa.399.48652.6.10.121_4 using setiathome_enhanced version 603
09/08/2010 22:31:39 SETI@home Restarting task 08my10ae.6880.63310.16.10.4_1 using setiathome_enhanced version 603
09/08/2010 22:31:52 SETI@home update requested by user
09/08/2010 22:31:56 SETI@home Sending scheduler request: Requested by user.
09/08/2010 22:31:56 SETI@home Requesting new tasks for GPU
09/08/2010 22:32:25 SETI@home Scheduler request completed: got 21 new tasks
09/08/2010 22:32:25 SETI@home Message from server: No work can be sent for the applications you have selected
09/08/2010 22:32:25 SETI@home Message from server: No work is available for Astropulse v5
09/08/2010 22:32:25 SETI@home Message from server: Your preferences allow work from applications other than those selected
09/08/2010 22:32:25 SETI@home Message from server: Sending work from other applications
09/08/2010 22:32:27 SETI@home Started download of 20my10ad.19272.17654.3.10.93
09/08/2010 22:32:27 SETI@home Started download of 20my10ad.19272.17654.3.10.113
09/08/2010 22:32:34 SETI@home Finished download of 20my10ad.19272.17654.3.10.113
09/08/2010 22:32:34 SETI@home Started download of 21my10aa.15797.15200.11.10.97
09/08/2010 22:32:34 SETI@home Starting 20my10ad.19272.17654.3.10.113_0
09/08/2010 22:32:34 SETI@home [error] Process creation failed:
09/08/2010 22:32:34 SETI@home [error] Process creation failed:
09/08/2010 22:32:35 SETI@home [error] Process creation failed:
09/08/2010 22:32:35 SETI@home [error] Process creation failed:
09/08/2010 22:32:35 SETI@home [error] Process creation failed:
09/08/2010 22:32:36 SETI@home Computation for task 20my10ad.19272.17654.3.10.113_0 finished
09/08/2010 22:32:36 SETI@home Output file 20my10ad.19272.17654.3.10.113_0_0 for task 20my10ad.19272.17654.3.10.113_0 absent
09/08/2010 22:32:44 SETI@home Finished download of 20my10ad.19272.17654.3.10.93
09/08/2010 22:32:44 SETI@home Started download of 20my10ac.14201.270938.13.10.107
09/08/2010 22:32:44 SETI@home Starting 20my10ad.19272.17654.3.10.93_1
09/08/2010 22:32:44 SETI@home [error] Process creation failed:
09/08/2010 22:32:44 SETI@home [error] Process creation failed:
09/08/2010 22:32:45 SETI@home [error] Process creation failed:
09/08/2010 22:32:45 SETI@home [error] Process creation failed:
09/08/2010 22:32:46 SETI@home [error] Process creation failed:
09/08/2010 22:32:47 SETI@home Computation for task 20my10ad.19272.17654.3.10.93_1 finished
09/08/2010 22:32:47 SETI@home Output file 20my10ad.19272.17654.3.10.93_1_0 for task 20my10ad.19272.17654.3.10.93_1 absent
09/08/2010 22:32:48 SETI@home Finished download of 21my10aa.15797.15200.11.10.97
09/08/2010 22:32:48 SETI@home Started download of 21my10aa.15797.15200.11.10.122
09/08/2010 22:32:48 SETI@home Starting 21my10aa.15797.15200.11.10.97_0
09/08/2010 22:32:48 SETI@home [error] Process creation failed:
09/08/2010 22:32:48 SETI@home [error] Process creation failed:
09/08/2010 22:32:49 SETI@home [error] Process creation failed:
09/08/2010 22:32:50 SETI@home [error] Process creation failed:
09/08/2010 22:32:51 SETI@home [error] Process creation failed:
09/08/2010 22:32:52 SETI@home Computation for task 21my10aa.15797.15200.11.10.97_0 finished
09/08/2010 22:32:52 SETI@home Output file 21my10aa.15797.15200.11.10.97_0_0 for task 21my10aa.15797.15200.11.10.97_0 absent
09/08/2010 22:32:56 Suspending network activity - user request

What im doing wrong?
ID: 1024079 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4654
Credit: 47,537,079
RAC: 4
United Kingdom
Message 1024106 - Posted: 10 Aug 2010, 5:09:39 UTC - in response to Message 1024079.  

Try doing a Boinc repair installation, to reset your folder permissions,

Claggy
ID: 1024106 · Report as offensive
Fulvio Cavalli
Volunteer tester
Avatar

Send message
Joined: 21 May 99
Posts: 1736
Credit: 259,180,282
RAC: 0
Brazil
Message 1024777 - Posted: 14 Aug 2010, 1:45:24 UTC
Last modified: 14 Aug 2010, 1:45:55 UTC

Hi Claggy. I did a repair installation but it didn´t work. This time im running the 460 sli. Still getting the "Process creation failed" message. Any other ideas?
ID: 1024777 · Report as offensive
Profile S@NL - Vipertje - D. van Es
Avatar

Send message
Joined: 19 Oct 02
Posts: 39
Credit: 32,174,152
RAC: 0
Netherlands
Message 1024922 - Posted: 14 Aug 2010, 7:37:16 UTC

I find this very funny. Everybody says, yes better performance and faster blablabla.

The thing is, I did try it out for a week a few weeks ago and it is NOT faster or better performance. It's just BS.

The thing is, yes do 3 wu's crunching at same time on fermi, BUT it also needs 3 times more from the cpu!

Normaly it uses for 1 wu between 10%-20%, now becource of 3 wu's it takes 30%-60% of the CPU. It slows the CPU down. And I thing that is not what you want to see!
I do what I can and I can what I do! :P
ID: 1024922 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4654
Credit: 47,537,079
RAC: 4
United Kingdom
Message 1024923 - Posted: 14 Aug 2010, 7:49:47 UTC - in response to Message 1024777.  

Hi Claggy. I did a repair installation but it didn´t work. This time im running the 460 sli. Still getting the "Process creation failed" message. Any other ideas?


Post your app_info.xml

Claggy
ID: 1024923 · Report as offensive
TheFreshPrince a.k.a. BlueTooth76
Avatar

Send message
Joined: 4 Jun 99
Posts: 210
Credit: 10,315,944
RAC: 0
Netherlands
Message 1024948 - Posted: 14 Aug 2010, 10:12:45 UTC - in response to Message 1024922.  
Last modified: 14 Aug 2010, 10:13:45 UTC

I find this very funny. Everybody says, yes better performance and faster blablabla.

The thing is, I did try it out for a week a few weeks ago and it is NOT faster or better performance. It's just BS.

The thing is, yes do 3 wu's crunching at same time on fermi, BUT it also needs 3 times more from the cpu!

Normaly it uses for 1 wu between 10%-20%, now becource of 3 wu's it takes 30%-60% of the CPU. It slows the CPU down. And I thing that is not what you want to see!


I don't share the same experience...
When I look at the taskmanager, the GPU tasks are only using 1-2% of the CPU.

The GPU is much faster than the CPU so it doesn't really matter if it uses up a little bit of CPU time...

All my CPU cores (6 of them) process a normal WU in about 1 hour 58 minutes, except for the one that is reserved fot the GPU... It takes about 10 minutes longer...
But in exchange for that, I get 2.5 more WU's done in an hour by the GPU because it processes 3 at a time...
Rig name: "x6Crunchy"
OS: Win 7 x64
MB: Asus M4N98TD EVO
CPU: AMD X6 1055T 2.8(1,2v)
GPU: 2x Asus GTX560ti
Member of: Dutch Power Cows
ID: 1024948 · Report as offensive
Fulvio Cavalli
Volunteer tester
Avatar

Send message
Joined: 21 May 99
Posts: 1736
Credit: 259,180,282
RAC: 0
Brazil
Message 1024967 - Posted: 14 Aug 2010, 11:48:04 UTC - in response to Message 1024923.  

Hi Claggy. I did a repair installation but it didn´t work. This time im running the 460 sli. Still getting the "Process creation failed" message. Any other ideas?


Post your app_info.xml

Claggy


Yep, I was about to do that. Probably I have a problem i can´t see here. Oh, the files are in he proper folder. Here it goes:

<app_info>
<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>AK_v8b_win_x64_SSSE3x.exe</name>
<executable/>
</file_info>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>603</version_num>
<platform>windows_intelx86</platform>
<file_ref>
<file_name>AK_v8b_win_x64_SSSE3x.exe</file_name>
<main_program/>
</file_ref>
</app_version>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>603</version_num>
<platform>windows_x86_64</platform>
<file_ref>
<file_name>AK_v8b_win_x64_SSSE3x.exe</file_name>
<main_program/>
</file_ref>
</app_version>
<app>
<name>astropulse_v505</name>
</app>
<file_info>
<name>ap_5.05r339_SSE.exe</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v505</app_name>
<version_num>505</version_num>
<platform>windows_intelx86</platform>
<file_ref>
<file_name>ap_5.05r339_SSE.exe</file_name>
<main_program/>
</file_ref>
</app_version>
<app_version>
<app_name>astropulse_v505</app_name>
<version_num>505</version_num>
<platform>windows_x86_64</platform>
<file_ref>
<file_name>ap_5.05r339_SSE.exe</file_name>
<main_program/>
</file_ref>
</app_version>
<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>setiathome_6.10_windows_intelx86__cuda_fermi.exe</name>
<executable/>
</file_info>
<file_info>
<name>cudart32_30_14.dll</name>
<executable/>
</file_info>
<file_info>
<name>cufft32_30_14.dll</name>
<executable/>
</file_info>
<file_info>
<name>libfftw3f-3-1-1a_upx.dll</name>
<executable/>
</file_info>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>610</version_num>
<platform>windows_intelx86</platform>
<plan_class>cuda</plan_class>
<avg_ncpus>0.040000</avg_ncpus>
<max_ncpus>0.040000</max_ncpus>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>setiathome_6.10_windows_intelx86__cuda_fermi.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart32_30_14.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft32_30_14.dll</file_name>
</file_ref>
<file_ref>
<file_name>libfftw3f-3-1-1a_upx.dll</file_name>
</file_ref>
</app_version>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>610</version_num>
<platform>windows_intelx86</platform>
<plan_class>cuda23</plan_class>
<avg_ncpus>0.040000</avg_ncpus>
<max_ncpus>0.040000</max_ncpus>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>setiathome_6.10_windows_intelx86__cuda_fermi.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart32_30_14.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft32_30_14.dll</file_name>
</file_ref>
<file_ref>
<file_name>libfftw3f-3-1-1a_upx.dll</file_name>
</file_ref>
</app_version>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>610</version_num>
<platform>windows_x86_64</platform>
<plan_class>cuda</plan_class>
<avg_ncpus>0.040000</avg_ncpus>
<max_ncpus>0.040000</max_ncpus>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>setiathome_6.10_windows_intelx86__cuda_fermi.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart32_30_14.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft32_30_14.dll</file_name>
</file_ref>
<file_ref>
<file_name>libfftw3f-3-1-1a_upx.dll</file_name>
</file_ref>
</app_version>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>610</version_num>
<platform>windows_x86_64</platform>
<plan_class>cuda23</plan_class>
<avg_ncpus>0.040000</avg_ncpus>
<max_ncpus>0.040000</max_ncpus>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>setiathome_6.10_windows_intelx86__cuda_fermi.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart32_30_14.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft32_30_14.dll</file_name>
</file_ref>
<file_ref>
<file_name>libfftw3f-3-1-1a_upx.dll</file_name>
</file_ref>
</app_version>
</app_info>

ID: 1024967 · Report as offensive
Fulvio Cavalli
Volunteer tester
Avatar

Send message
Joined: 21 May 99
Posts: 1736
Credit: 259,180,282
RAC: 0
Brazil
Message 1024982 - Posted: 14 Aug 2010, 12:52:58 UTC

Oooops, my bad.. it seems that I have a corrupted downloaded file. More in a few minutes...
ID: 1024982 · Report as offensive
Fulvio Cavalli
Volunteer tester
Avatar

Send message
Joined: 21 May 99
Posts: 1736
Credit: 259,180,282
RAC: 0
Brazil
Message 1024998 - Posted: 14 Aug 2010, 13:46:14 UTC

Yeah, it´s working now.... i had a corrupted executable. Ty guys, ty Claggy.
ID: 1024998 · Report as offensive
Richard Haselgrove Project Donor
Volunteer tester

Send message
Joined: 4 Jul 99
Posts: 14660
Credit: 200,643,578
RAC: 874
United Kingdom
Message 1025005 - Posted: 14 Aug 2010, 14:08:27 UTC - in response to Message 1024998.  

Yeah, it´s working now.... i had a corrupted executable. Ty guys, ty Claggy.

Always something to watch out for with manual downloads (no signature or MD5 checksum), especially when the download pipe is maxxed out - that's why I always try to remember to put file sizes alongside my download links.

Well done for sorting it out by yourself - I had a look at the app_info earlier, but there didn't seem to be anything wrong there (and clearly wasn't).
ID: 1025005 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4654
Credit: 47,537,079
RAC: 4
United Kingdom
Message 1025019 - Posted: 14 Aug 2010, 15:07:13 UTC - in response to Message 1024998.  
Last modified: 14 Aug 2010, 15:13:30 UTC

Yeah, it´s working now.... i had a corrupted executable. Ty guys, ty Claggy.

That was going to be my next suggestion, but i've out for the afternoon, so hadn't even got to look at the app_info until now,
Glad it's working now,

You might want to swap the Astropulse_v505 r339 app for the latest r409 app, there were compatibility fixes with r409, can't remember if there were any speedups,

Claggy
ID: 1025019 · Report as offensive
Fulvio Cavalli
Volunteer tester
Avatar

Send message
Joined: 21 May 99
Posts: 1736
Credit: 259,180,282
RAC: 0
Brazil
Message 1025402 - Posted: 15 Aug 2010, 22:37:51 UTC

Well, thank you guys, its always very nice to know that you will find strong support here on this foruns no matter what your problem is.
ID: 1025402 · Report as offensive
Profile [AF>EDLS] Polynesia
Volunteer tester
Avatar

Send message
Joined: 1 Apr 09
Posts: 54
Credit: 5,361,172
RAC: 0
France
Message 1025614 - Posted: 16 Aug 2010, 17:13:30 UTC
Last modified: 16 Aug 2010, 17:25:17 UTC

Hello everyone,

You tell me, you have to read ...

But with no English programming boinc, I wanted to know that I can file app_info created for my system:

i7 860, GTX 470, 7 64 bit win

For optimized precisely ...

I already installed 0.36 lunatics ...

below the existing file to change ....

<app_info>
<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>AK_v8b_win_x64_SSE41.exe</name>
<executable/>
</file_info>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>603</version_num>
<platform>windows_intelx86</platform>
<file_ref>
<file_name>AK_v8b_win_x64_SSE41.exe</file_name>
<main_program/>
</file_ref>
</app_version>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>603</version_num>
<platform>windows_x86_64</platform>
<file_ref>
<file_name>AK_v8b_win_x64_SSE41.exe</file_name>
<main_program/>
</file_ref>
</app_version>
<app>
<name>astropulse_v505</name>
</app>
<file_info>
<name>ap_5.05r409_SSE.exe</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v505</app_name>
<version_num>505</version_num>
<platform>windows_intelx86</platform>
<file_ref>
<file_name>ap_5.05r409_SSE.exe</file_name>
<main_program/>
</file_ref>
</app_version>
<app_version>
<app_name>astropulse_v505</app_name>
<version_num>505</version_num>
<platform>windows_x86_64</platform>
<file_ref>
<file_name>ap_5.05r409_SSE.exe</file_name>
<main_program/>
</file_ref>
</app_version>
<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>MB_6.08_CUDA_V12_VLARKill_FPLim2048.exe</name>
<executable/>
</file_info>
<file_info>
<name>cudart.dll</name>
<executable/>
</file_info>
<file_info>
<name>cufft.dll</name>
<executable/>
</file_info>
<file_info>
<name>libfftw3f-3-1-1a_upx.dll</name>
<executable/>
</file_info>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>608</version_num>
<platform>windows_intelx86</platform>
<plan_class>cuda</plan_class>
<avg_ncpus>0.040000</avg_ncpus>
<max_ncpus>0.040000</max_ncpus>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>MB_6.08_CUDA_V12_VLARKill_FPLim2048.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft.dll</file_name>
</file_ref>
<file_ref>
<file_name>libfftw3f-3-1-1a_upx.dll</file_name>
</file_ref>
</app_version>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>608</version_num>
<platform>windows_intelx86</platform>
<plan_class>cuda23</plan_class>
<avg_ncpus>0.040000</avg_ncpus>
<max_ncpus>0.040000</max_ncpus>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>MB_6.08_CUDA_V12_VLARKill_FPLim2048.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft.dll</file_name>
</file_ref>
<file_ref>
<file_name>libfftw3f-3-1-1a_upx.dll</file_name>
</file_ref>
</app_version>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>608</version_num>
<platform>windows_x86_64</platform>
<plan_class>cuda</plan_class>
<avg_ncpus>0.040000</avg_ncpus>
<max_ncpus>0.040000</max_ncpus>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>MB_6.08_CUDA_V12_VLARKill_FPLim2048.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft.dll</file_name>
</file_ref>
<file_ref>
<file_name>libfftw3f-3-1-1a_upx.dll</file_name>
</file_ref>
</app_version>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>608</version_num>
<platform>windows_x86_64</platform>
<plan_class>cuda23</plan_class>
<avg_ncpus>0.040000</avg_ncpus>
<max_ncpus>0.040000</max_ncpus>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>MB_6.08_CUDA_V12_VLARKill_FPLim2048.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft.dll</file_name>
</file_ref>
<file_ref>
<file_name>libfftw3f-3-1-1a_upx.dll</file_name>
</file_ref>
</app_version>
</app_info>


Alliance Francophone
ID: 1025614 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4654
Credit: 47,537,079
RAC: 4
United Kingdom
Message 1025669 - Posted: 16 Aug 2010, 20:14:45 UTC - in response to Message 1025614.  

[AF>EDLS] Polynesia, the following app_info.xml should work for you:

<app_info> 
<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>AK_v8b_win_x64_SSE41.exe</name>
<executable/>
</file_info>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>603</version_num>
<platform>windows_intelx86</platform>
<file_ref>
<file_name>AK_v8b_win_x64_SSE41.exe</file_name>
<main_program/>
</file_ref>
</app_version>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>603</version_num>
<platform>windows_x86_64</platform>
<file_ref>
<file_name>AK_v8b_win_x64_SSE41.exe</file_name>
<main_program/>
</file_ref>
</app_version>
<app>
<name>astropulse_v505</name>
</app>
<file_info>
<name>ap_5.05r409_SSE.exe</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v505</app_name>
<version_num>505</version_num>
<platform>windows_intelx86</platform>
<file_ref>
<file_name>ap_5.05r409_SSE.exe</file_name>
<main_program/>
</file_ref>
</app_version> 
<app_version>
<app_name>astropulse_v505</app_name>
<version_num>505</version_num>
<platform>windows_x86_64</platform>
<file_ref>
<file_name>ap_5.05r409_SSE.exe</file_name>
<main_program/>
</file_ref>
</app_version>
<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>setiathome_6.10_windows_intelx86__cuda_fermi.exe</name>
<executable/>
</file_info>
<file_info>
<name>cudart32_30_14.dll</name>
<executable/>
</file_info>
<file_info>
<name>cufft32_30_14.dll</name>
<executable/>
</file_info>
<file_info>
<name>libfftw3f-3-1-1a_upx.dll</name>
<executable/>
</file_info>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>610</version_num>
<platform>windows_intelx86</platform>
<avg_ncpus>0.200000</avg_ncpus>
<max_ncpus>0.200000</max_ncpus>
<plan_class>cuda_fermi</plan_class>
<file_ref>
<file_name>setiathome_6.10_windows_intelx86__cuda_fermi.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart32_30_14.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft32_30_14.dll</file_name>
</file_ref>
<file_ref>
<file_name>libfftw3f-3-1-1a_upx.dll</file_name>
</file_ref>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
</app_version>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>610</version_num>
<platform>windows_x86_64</platform>
<avg_ncpus>0.200000</avg_ncpus>
<max_ncpus>0.200000</max_ncpus>
<plan_class>cuda_fermi</plan_class>
<file_ref>
<file_name>setiathome_6.10_windows_intelx86__cuda_fermi.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart32_30_14.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft32_30_14.dll</file_name>
</file_ref>
<file_ref>
<file_name>libfftw3f-3-1-1a_upx.dll</file_name>
</file_ref>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
</app_version>
</app_info>


Claggy
ID: 1025669 · Report as offensive
Previous · 1 . . . 10 · 11 · 12 · 13 · 14 · 15 · Next

Message boards : Number crunching : Running SETI@home on an nVidia Fermi GPU


 
©2024 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.