Intel GPU app

Message boards : SETI@home Science : Intel GPU app
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile KWSN THE Holy Hand Grenade!
Volunteer tester
Avatar

Send message
Joined: 25 Apr 07
Posts: 44
Credit: 30,057,505
RAC: 84
United States
Message 52038 - Posted: 26 Aug 2014, 8:40:33 UTC
Last modified: 26 Aug 2014, 8:41:54 UTC

On my laptop, which only has the Intel GPU (Intel I3 3110M) available for SETI/beta, I haven't gotten a WU for two weeks - are WU's for the Intel being produced? Before, when I was getting WU's, I was only getting AP WU's - are MB WU's produced for the Intel?
ID: 52038 · Report as offensive
Richard Haselgrove
Volunteer tester

Send message
Joined: 3 Jan 07
Posts: 1451
Credit: 3,266,428
RAC: 0
United Kingdom
Message 52039 - Posted: 26 Aug 2014, 11:13:47 UTC - in response to Message 52038.  

Only three types of WU are made by the server:

Astropulse (AP) WUs
Setiathome (MB) WUs
Setiathome.vlar (MB) WUs

VLAR WUs ate not sent to NVidia GPUs, but all other WUs are capable of being sent to any processing device that has an application capable of handling them.

So, there is no such thing as an 'Intel WU' - or a 'Linux WU' (or any other sub-category), come to that.

There are applications installed on the server for MB, AP v6, and AP v7. The current testing focus is on AP v7: with Eric having been out of town for the last week, it's possible that the MB queue has run dry without anyone else noticing. To participate in the AP v7 testing, check your preference page and make sure that the appropriate options are checked.
ID: 52039 · Report as offensive
Profile KWSN THE Holy Hand Grenade!
Volunteer tester
Avatar

Send message
Joined: 25 Apr 07
Posts: 44
Credit: 30,057,505
RAC: 84
United States
Message 52061 - Posted: 27 Aug 2014, 10:29:21 UTC - in response to Message 52039.  

As a long-time SETIzen, I'm aware of those facts, but I'm getting WU's for AP on computers with NVidia GPU's but not on the laptop mentioned... I've never gotten a MB WU for the Intel GPU... Maybe something went haywire in the scheduler when version 7.02 was installed, which carried over to 7.03?
ID: 52061 · Report as offensive
Richard Haselgrove
Volunteer tester

Send message
Joined: 3 Jan 07
Posts: 1451
Credit: 3,266,428
RAC: 0
United Kingdom
Message 52062 - Posted: 27 Aug 2014, 10:44:57 UTC - in response to Message 52061.  

If you enable the <work_fetch_debug> client logging option, can you confirm that your client is *requesting* work for the intel iGPU?
ID: 52062 · Report as offensive
Profile KWSN THE Holy Hand Grenade!
Volunteer tester
Avatar

Send message
Joined: 25 Apr 07
Posts: 44
Credit: 30,057,505
RAC: 84
United States
Message 52190 - Posted: 31 Aug 2014, 22:25:29 UTC - in response to Message 52062.  
Last modified: 31 Aug 2014, 22:27:00 UTC

It says its requesting GPU work in the log: as it only has an Intel GPU, it must be requesting Intel work... and it got Intel GPU work (AP's only, though...) before the switch to AP 7.02... (and I haven't changed anything...) This is a stock SETI build...
ID: 52190 · Report as offensive

Message boards : SETI@home Science : Intel GPU app


 
©2019 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.