Errors on old Nvidia GT9800 with opencl app

Message boards : AstroPulse : Errors on old Nvidia GT9800 with opencl app
Message board moderation

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
Ivailo Bonev
Volunteer tester

Send message
Joined: 11 May 07
Posts: 29
Credit: 273,332
RAC: 0
Bulgaria
Message 51943 - Posted: 17 Aug 2014, 6:33:34 UTC

I found after I've installed new Lunatics apps on main S@H, that my old GT9800 produce errors on Astropulse v6, and after small discussion with Richard, I agreed to move in Beta and help to find what is the cause of these errors. So I found that the errors are the same with new Astropulse v7 app. Here are the output:
http://setiweb.ssl.berkeley.edu/beta/result.php?resultid=17513943
http://setiweb.ssl.berkeley.edu/beta/result.php?resultid=17513887
Any suggestions?
ID: 51943 · Report as offensive
Ivailo Bonev
Volunteer tester

Send message
Joined: 11 May 07
Posts: 29
Credit: 273,332
RAC: 0
Bulgaria
Message 51944 - Posted: 17 Aug 2014, 6:37:59 UTC

And from the different account and PC with GeForce 8200M, same errors are produced:
http://setiweb.ssl.berkeley.edu/beta/result.php?resultid=17513944
ID: 51944 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 51949 - Posted: 17 Aug 2014, 10:08:16 UTC

thnaks for reporting.
Await replacement build.
News about SETI opt app releases: https://twitter.com/Raistmer
ID: 51949 · Report as offensive
Ivailo Bonev
Volunteer tester

Send message
Joined: 11 May 07
Posts: 29
Credit: 273,332
RAC: 0
Bulgaria
Message 51950 - Posted: 17 Aug 2014, 10:20:01 UTC
Last modified: 17 Aug 2014, 10:20:48 UTC

I changed driver version to 340.52, don't know if will help.
ID: 51950 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 51951 - Posted: 17 Aug 2014, 17:32:35 UTC

Please try this build as replacement:
https://www.dropbox.com/s/wkpg7ndei2cifsz/AP7_win_x86_SSE2_OpenCL_NV_r2605.7z
News about SETI opt app releases: https://twitter.com/Raistmer
ID: 51951 · Report as offensive
Ivailo Bonev
Volunteer tester

Send message
Joined: 11 May 07
Posts: 29
Credit: 273,332
RAC: 0
Bulgaria
Message 51952 - Posted: 17 Aug 2014, 20:14:56 UTC

It works now, but we have to wait 18 hours for the first result. Thanks
ID: 51952 · Report as offensive
Ivailo Bonev
Volunteer tester

Send message
Joined: 11 May 07
Posts: 29
Credit: 273,332
RAC: 0
Bulgaria
Message 51960 - Posted: 18 Aug 2014, 14:09:44 UTC

ID: 51960 · Report as offensive
Ivailo Bonev
Volunteer tester

Send message
Joined: 11 May 07
Posts: 29
Credit: 273,332
RAC: 0
Bulgaria
Message 51986 - Posted: 21 Aug 2014, 10:55:00 UTC
Last modified: 21 Aug 2014, 10:55:44 UTC

ID: 51986 · Report as offensive
Richard Haselgrove
Volunteer tester

Send message
Joined: 3 Jan 07
Posts: 1451
Credit: 3,266,428
RAC: 0
United Kingdom
Message 51988 - Posted: 21 Aug 2014, 13:34:36 UTC - in response to Message 51986.  

That's a bit of a b****r. Your task, running app r2605, didn't report any single pulses, whereas both your wingmates reported four.

Meanwhile, Raistmer has moved on, and he's now up to r2662. I dug out an old 9800GT, and loaded it up under 64-bit Windows 7 SP1, same as you: task 17517609 validated OK (though with only one single pulse).

I ran mine under driver 304.79, rather than your 340.52, but my experience with NV cards suggests that the driver version number makes very little difference on these legacy-support cards. We'd best wait until Joe and Raistmer come and analyse those signals in detail before deciding how to proceed.
ID: 51988 · Report as offensive
Ivailo Bonev
Volunteer tester

Send message
Joined: 11 May 07
Posts: 29
Credit: 273,332
RAC: 0
Bulgaria
Message 51989 - Posted: 21 Aug 2014, 14:44:17 UTC
Last modified: 21 Aug 2014, 15:20:35 UTC

Strange...
http://setiweb.ssl.berkeley.edu/beta/result.php?resultid=17514047
http://setiweb.ssl.berkeley.edu/beta/result.php?resultid=17514045
http://setiweb.ssl.berkeley.edu/beta/result.php?resultid=17514050
Recent new 3 units are valid. Nothing is changed by my side except new drivers. But all valid units have
single pulses: 0
Somehow do not detect or count single pulses.
ID: 51989 · Report as offensive
Josef W. Segur
Volunteer tester

Send message
Joined: 14 Oct 05
Posts: 1137
Credit: 1,848,733
RAC: 0
United States
Message 51990 - Posted: 21 Aug 2014, 16:58:47 UTC - in response to Message 51989.  

Strange...
http://setiweb.ssl.berkeley.edu/beta/result.php?resultid=17514047
http://setiweb.ssl.berkeley.edu/beta/result.php?resultid=17514045
http://setiweb.ssl.berkeley.edu/beta/result.php?resultid=17514050
Recent new 3 units are valid. Nothing is changed by my side except new drivers. But all valid units have
single pulses: 0
Somehow do not detect or count single pulses.

That does seem like a good summary. None of the completed tasks with that app have any single pulses shown in stderr.

Because the repetitive pulses are looking good, much of the logic is performing as designed. Running with -v 2 would perhaps clarify the problem, but maybe Raistmer will prefer to have you switch to the r2662 build Richard checked.
                                                                   Joe
ID: 51990 · Report as offensive
Ivailo Bonev
Volunteer tester

Send message
Joined: 11 May 07
Posts: 29
Credit: 273,332
RAC: 0
Bulgaria
Message 52156 - Posted: 30 Aug 2014, 12:48:28 UTC
Last modified: 30 Aug 2014, 12:48:48 UTC

Same thing with the newest Astropulse 7.03
Unit without single pulses validated:
http://setiweb.ssl.berkeley.edu/beta/result.php?resultid=17555947
Unit with single pulses are inconclusive (and will be invalid for sure), single pulses not detected (or counted):
http://setiweb.ssl.berkeley.edu/beta/result.php?resultid=17556921
ID: 52156 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 52163 - Posted: 30 Aug 2014, 18:41:18 UTC - in response to Message 52156.  

Same thing with the newest Astropulse 7.03
Unit without single pulses validated:
http://setiweb.ssl.berkeley.edu/beta/result.php?resultid=17555947
Unit with single pulses are inconclusive (and will be invalid for sure), single pulses not detected (or counted):
http://setiweb.ssl.berkeley.edu/beta/result.php?resultid=17556921


Do you able to repeat run of that task offline via KWSN bench suite from Lunatics site?
News about SETI opt app releases: https://twitter.com/Raistmer
ID: 52163 · Report as offensive
Ivailo Bonev
Volunteer tester

Send message
Joined: 11 May 07
Posts: 29
Credit: 273,332
RAC: 0
Bulgaria
Message 52166 - Posted: 30 Aug 2014, 19:00:47 UTC

I see Astropulse test tools on Lunatics site:
http://lunatics.kwsn.net/index.php?module=Downloads;catd=44
What I need to download and run?
ID: 52166 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 52167 - Posted: 30 Aug 2014, 19:06:10 UTC - in response to Message 52166.  

I see Astropulse test tools on Lunatics site:
http://lunatics.kwsn.net/index.php?module=Downloads;catd=44
What I need to download and run?


This: http://lunatics.kwsn.net/index.php?module=Downloads;sa=dlview;id=345

And supply task under investigation to it.
News about SETI opt app releases: https://twitter.com/Raistmer
ID: 52167 · Report as offensive
Ivailo Bonev
Volunteer tester

Send message
Joined: 11 May 07
Posts: 29
Credit: 273,332
RAC: 0
Bulgaria
Message 52168 - Posted: 30 Aug 2014, 19:19:34 UTC

How to download same unit again?
ID: 52168 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 52169 - Posted: 30 Aug 2014, 19:30:13 UTC - in response to Message 52168.  
Last modified: 30 Aug 2014, 19:31:05 UTC

ID: 52169 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 52171 - Posted: 30 Aug 2014, 20:01:25 UTC
Last modified: 30 Aug 2014, 20:01:52 UTC

And here is the tool by Richard Haselgrove that he wrote to simplify re-download of particular tasks from SETI servers for the testing purposes:
https://www.dropbox.com/s/vdk7a0u4o9g74ym/SETI%20general%20fanouts.zip?dl=0

Hope it will be available in Lunatics Download section too for convenience.
News about SETI opt app releases: https://twitter.com/Raistmer
ID: 52171 · Report as offensive
Richard Haselgrove
Volunteer tester

Send message
Joined: 3 Jan 07
Posts: 1451
Credit: 3,266,428
RAC: 0
United Kingdom
Message 52172 - Posted: 30 Aug 2014, 20:16:31 UTC - in response to Message 52171.  

Hope it will be available in Lunatics Download section too for convenience.

And so it came to pass.

http://lunatics.kwsn.net/index.php?module=Downloads;sa=dlview;id=415
ID: 52172 · Report as offensive
Ivailo Bonev
Volunteer tester

Send message
Joined: 11 May 07
Posts: 29
Credit: 273,332
RAC: 0
Bulgaria
Message 52186 - Posted: 31 Aug 2014, 18:31:39 UTC
Last modified: 31 Aug 2014, 18:34:55 UTC

Do I need reference app, and if it's mandatory, what app to use as a reference?
In ../Science_apps I've copied these files:
AP_clFFTplan_GeForce9800GT_32768_gr64_lr8_wg256_tw0_r2662.bin_34052
astropulse_7.03_windows_intelx86__opencl_nvidia_100.exe
AstroPulse_Kernels_r2662.cl
AstroPulse_Kernels_r2662.cl_GeForce9800GT.bin_V7_TWIN_FFA_34052
libfftw3f-3-3-4_x64.dll
libfftw3f-3-3-4_x86.dll
ID: 52186 · Report as offensive
1 · 2 · Next

Message boards : AstroPulse : Errors on old Nvidia GT9800 with opencl app


 
©2019 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.