Astropulse 6.02 Windows for OpenCL on ATI released.

Message boards : News : Astropulse 6.02 Windows for OpenCL on ATI released.
Message board moderation

To post messages, you must log in.

Previous · 1 . . . 3 · 4 · 5 · 6 · 7 · 8 · 9 . . . 45 · Next

AuthorMessage
No Linux. 50% Main, 50% Beta.
Volunteer tester
Avatar

Send message
Joined: 10 Mar 12
Posts: 1658
Credit: 12,434,813
RAC: 6,678
Sweden
Message 42284 - Posted: 18 Apr 2012, 22:49:28 UTC - in response to Message 42282.  

Looks like 11.1 - the first Catalyst with integrated OpenCL support (thanks goes to arkayn for discovering this).

Catalyst Software Suite 91.6 MB 11.1 1/26/2011 Download
Description:
Package Includes:
Display Driver
OpenCL Driver
ATI Integrated Driver
Catalyst Control Center
(English Language Only)
For the 64 bit version of Windows Vista and Windows 7

http://support.amd.com/us/gpudownload/windows/previous/11/Pages/radeon.aspx?os=Windows%20Vista%20-%2064-Bit%20Edition&rev=11.1


Yes, and I have 11.2 with Integrated OpenCL driver, but I do believe if I remember correctly that you have to choose that component actively during the install (tick a box), or it will not be installed. I can be wrong about that though, it's been a long time since I installed it. 11.2 works perfectly, so I haven't seen any reason to upgrade the driver.
WARNING!! "THIS IS A SIGNATURE", of the "IT MAY CHANGE AT ANY MOMENT" type. It may, or may not be considered insulting, all depending upon HOW SENSITIVE THE VIEWER IS, to certain inputs to/from the nervous system.
ID: 42284 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 42285 - Posted: 18 Apr 2012, 22:51:18 UTC

Then we should go higher... to version where it installed by default...
News about SETI opt app releases: https://twitter.com/Raistmer
ID: 42285 · Report as offensive
Richard Haselgrove
Volunteer tester

Send message
Joined: 3 Jan 07
Posts: 1451
Credit: 3,266,428
RAC: 1
United Kingdom
Message 42286 - Posted: 18 Apr 2012, 22:57:02 UTC - in response to Message 42285.  

Then we should go higher... to version where it installed by default...

Download links are available in the cheat sheet I've just edited into my previous post.
ID: 42286 · Report as offensive
arkayn
Volunteer tester
Avatar

Send message
Joined: 16 Jan 07
Posts: 155
Credit: 194,400
RAC: 0
United States
Message 42287 - Posted: 18 Apr 2012, 23:00:16 UTC

The test of the Nvidia OpenCL app came in at 5004 seconds at default settings on my GTX460.

This is fairly close to the times that I have r560 running at on Main with my GTX560.
http://setiathome.berkeley.edu/results.php?hostid=5338281
ID: 42287 · Report as offensive
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,919,053
RAC: 1,061
United States
Message 42288 - Posted: 18 Apr 2012, 23:01:36 UTC - in response to Message 42281.  

Yes, bandwidth is the issue.

I created a test plan_class called cuda_opencl_101 (as distinguished from opencl_nvidia_101) which should get everyone with an opencl compatible card. I may add a "max_core_client_version" to it to prevent confusion. And we'll see what happens with that. NVIDIA has well advertised driver versions for OpenCL 1.0 and 1.1 installation by default (and they claim to work on every card released since 2006.)

You would think that this sort of stuff would be saved in our host database, but it's not. Just the name and the driver revision, not whether OpenCL was found.
ID: 42288 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 42289 - Posted: 18 Apr 2012, 23:01:54 UTC - in response to Message 42287.  

The test of the Nvidia OpenCL app came in at 5004 seconds at default settings on my GTX460.

This is fairly close to the times that I have r560 running at on Main with my GTX560.
http://setiathome.berkeley.edu/results.php?hostid=5338281


It's almost the same app, so it shows that GTX560 not really faster than GTX460 perhaps...
News about SETI opt app releases: https://twitter.com/Raistmer
ID: 42289 · Report as offensive
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,919,053
RAC: 1,061
United States
Message 42290 - Posted: 18 Apr 2012, 23:05:08 UTC - in response to Message 42289.  

Unfortunately Catalyst versions aren't directly related to driver revisions. Your Catalyst 11.2 driver is version 1.4.1016
ID: 42290 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42291 - Posted: 18 Apr 2012, 23:06:02 UTC - in response to Message 42285.  

Then we should go higher... to version where it installed by default...


Today I installed 11.3 and I didn't click anything.
The OpenCl was already "clicked"(marked).

//TQ
TRuEQ & TuVaLu
ID: 42291 · Report as offensive
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,919,053
RAC: 1,061
United States
Message 42292 - Posted: 18 Apr 2012, 23:08:46 UTC - in response to Message 42291.  

Which of your machines was that?
ID: 42292 · Report as offensive
No Linux. 50% Main, 50% Beta.
Volunteer tester
Avatar

Send message
Joined: 10 Mar 12
Posts: 1658
Credit: 12,434,813
RAC: 6,678
Sweden
Message 42293 - Posted: 18 Apr 2012, 23:22:48 UTC - in response to Message 42291.  

Then we should go higher... to version where it installed by default...


Today I installed 11.3 and I didn't click anything.
The OpenCl was already "clicked"(marked).

//TQ


It might have been "ticked" for 11.2 also. As I said, I don't remember.
WARNING!! "THIS IS A SIGNATURE", of the "IT MAY CHANGE AT ANY MOMENT" type. It may, or may not be considered insulting, all depending upon HOW SENSITIVE THE VIEWER IS, to certain inputs to/from the nervous system.
ID: 42293 · Report as offensive
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,919,053
RAC: 1,061
United States
Message 42295 - Posted: 19 Apr 2012, 0:03:14 UTC - in response to Message 42293.  

Well, I made a guess at the proper version number. And now we'll see if it breaks anything.

Try getting some work on your older BOINC versions.
ID: 42295 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 42296 - Posted: 19 Apr 2012, 0:04:19 UTC
Last modified: 19 Apr 2012, 0:05:53 UTC

WoW, tried on my netbook w/o BOINc reinstall.
BOINC 6.10.60 there.
Now ATi build downloading !!! And wu too. So, we can go with BOINC 6.10.60 it seems!


EDIT: time to completion 550h.
This host can do ATI AP in 22h actually.
News about SETI opt app releases: https://twitter.com/Raistmer
ID: 42296 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 42297 - Posted: 19 Apr 2012, 0:07:05 UTC
Last modified: 19 Apr 2012, 0:07:45 UTC

Aha, running as ati14 plan class :) It works :)

0.21CPU and 1 GPU here. All cores busy with CPU apps too as should be.
News about SETI opt app releases: https://twitter.com/Raistmer
ID: 42297 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 42298 - Posted: 19 Apr 2012, 0:14:44 UTC
Last modified: 19 Apr 2012, 0:15:34 UTC

Looks like every newly started task suffers from GPU low usage bug on my host. Running few instances at once helped to keep GPU busy most of the time, now this bug go uncompensated.

Is it possible to configure stock app to run in few instances on capable GPUs ?


task was restarted - GPU load improved.
News about SETI opt app releases: https://twitter.com/Raistmer
ID: 42298 · Report as offensive
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,919,053
RAC: 1,061
United States
Message 42299 - Posted: 19 Apr 2012, 0:18:59 UTC - in response to Message 42298.  

The easiest way is to set use the memory requirement to set the number of GPUs to a number less than 1. For example if the app takes 256M and you've got 1024M, you could run four at once. In theory. I've never tried it.

Shall I change the scheduler?

Eric
ID: 42299 · Report as offensive
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,919,053
RAC: 1,061
United States
Message 42300 - Posted: 19 Apr 2012, 0:20:12 UTC

I've found one host that doesn't like the ATI jobs at the current min driver revision, so I'm going to go up a little.
ID: 42300 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 42301 - Posted: 19 Apr 2012, 0:26:32 UTC - in response to Message 42299.  

The easiest way is to set use the memory requirement to set the number of GPUs to a number less than 1. For example if the app takes 256M and you've got 1024M, you could run four at once. In theory. I've never tried it.

Shall I change the scheduler?

Eric


It would be interesting to try.
But then ap_cmdline.txt should be preconfigured with -instances_per_device N, where N is the number of instances to run.
In other case additional instances will just wait on mutex (and can timeout with -177 errors).

News about SETI opt app releases: https://twitter.com/Raistmer
ID: 42301 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 42302 - Posted: 19 Apr 2012, 0:27:13 UTC - in response to Message 42300.  

I've found one host that doesn't like the ATI jobs at the current min driver revision, so I'm going to go up a little.


COuld you post link to it or to its stderr at least ?

News about SETI opt app releases: https://twitter.com/Raistmer
ID: 42302 · Report as offensive
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,919,053
RAC: 1,061
United States
Message 42303 - Posted: 19 Apr 2012, 0:37:40 UTC - in response to Message 42302.  

It's host 45425. Right now I've got the version minimum set at 1.4.700. I expect to see failures there, too.
ID: 42303 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 42304 - Posted: 19 Apr 2012, 0:41:46 UTC - in response to Message 42303.  

It's host 45425. Right now I've got the version minimum set at 1.4.700. I expect to see failures there, too.


The most common cause for a 0xc0000135 error indicates that you need
to install the .NET Framework,

http://forums.techarena.in/windows-xp-support/1067313.htm
News about SETI opt app releases: https://twitter.com/Raistmer
ID: 42304 · Report as offensive
Previous · 1 . . . 3 · 4 · 5 · 6 · 7 · 8 · 9 . . . 45 · Next

Message boards : News : Astropulse 6.02 Windows for OpenCL on ATI released.


 
©2019 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.