Astropulse 6.02 Windows for OpenCL on ATI released.

Message boards : News : Astropulse 6.02 Windows for OpenCL on ATI released.
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3 · 4 · 5 · 6 . . . 45 · Next

AuthorMessage
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42224 - Posted: 18 Apr 2012, 17:58:31 UTC - in response to Message 42220.  
Last modified: 18 Apr 2012, 18:00:18 UTC

Eric,

Rather than you checking all the server logs manually, are you currently running Beta on a server powerful enough to allow user access to the logs?

If so, you might be able to find a user prepared to attach both here and to Einstein's 'Albert' test project, which is also testing OpenCL plan classes and has open access to the logs. I picked this user at random to show what's possible:

http://albert.phys.uwm.edu/hosts_user.php?userid=42297
http://albert.phys.uwm.edu/host_sched_logs/1/1362

If a user could see their own logs, and were to be attached to both projects (with, by definition, the same BOINC version and ATI driver), the difference in the log entries might reveal where the plan class problems lie.



2012-04-18 19:54:57 | Albert@Home | work fetch resumed by user
2012-04-18 19:54:59 | Albert@Home | project resumed by user
2012-04-18 19:55:01 | Albert@Home | Sending scheduler request: To fetch work.
2012-04-18 19:55:01 | Albert@Home | Requesting new tasks for ATI
2012-04-18 19:55:06 | Albert@Home | Scheduler request completed: got 24 new tasks


But I can't keep it requesting new work then it will fill all of the BM cue/cache and won't ask for SETI Beta work...

I've mailed DA about this cue/cache thing and he said he would fix it...
When I don't know...

But now I am attached to both SETI Beta and Albert@home
Using the ATI 5850 Catalyst 11.12 and BM 7.0.26

Link to computor at albert: http://albert.phys.uwm.edu/hosts_user.php?userid=214138

//TRuEQ
TRuEQ & TuVaLu
ID: 42224 · Report as offensive
zombie67 [MM]
Volunteer tester
Avatar

Send message
Joined: 18 May 06
Posts: 280
Credit: 26,329,548
RAC: 367
United States
Message 42225 - Posted: 18 Apr 2012, 18:07:12 UTC

For the folks that can't get work, did you try detaching/re-attaching? That worked for me. I also quit BOINC in between, just to make sure the project info was complete removed before re-attaching.
Dublin, California
Team: SETI.USA

ID: 42225 · Report as offensive
arkayn
Volunteer tester
Avatar

Send message
Joined: 16 Jan 07
Posts: 155
Credit: 194,400
RAC: 0
United States
Message 42226 - Posted: 18 Apr 2012, 18:07:43 UTC - in response to Message 42224.  
Last modified: 18 Apr 2012, 18:15:24 UTC

Eric,

Rather than you checking all the server logs manually, are you currently running Beta on a server powerful enough to allow user access to the logs?

If so, you might be able to find a user prepared to attach both here and to Einstein's 'Albert' test project, which is also testing OpenCL plan classes and has open access to the logs. I picked this user at random to show what's possible:

http://albert.phys.uwm.edu/hosts_user.php?userid=42297
http://albert.phys.uwm.edu/host_sched_logs/1/1362

If a user could see their own logs, and were to be attached to both projects (with, by definition, the same BOINC version and ATI driver), the difference in the log entries might reveal where the plan class problems lie.



2012-04-18 19:54:57 | Albert@Home | work fetch resumed by user
2012-04-18 19:54:59 | Albert@Home | project resumed by user
2012-04-18 19:55:01 | Albert@Home | Sending scheduler request: To fetch work.
2012-04-18 19:55:01 | Albert@Home | Requesting new tasks for ATI
2012-04-18 19:55:06 | Albert@Home | Scheduler request completed: got 24 new tasks


But I can't keep it requesting new work then it will fill all of the BM cue/cache and won't ask for SETI Beta work...

I've mailed DA about this cue/cache thing and he said he would fix it...
When I don't know...

But now I am attached to both SETI Beta and Albert@home
Using the ATI 5850 Catalyst 11.12 and BM 7.0.26

Link to computor at albert: http://albert.phys.uwm.edu/hosts_user.php?userid=214138

//TRuEQ


I created the account first and then attached my computer so I could only get 1 WU to test.
http://albert.phys.uwm.edu/host_sched_logs/2/2728
ID: 42226 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42227 - Posted: 18 Apr 2012, 18:10:17 UTC

Both Albert and POEM has said no to the use of ATI OpenCl 1.0 cards.
I think that they have different reasons for it.

I have no clue if this information is relevant though....

//TRuEQ
TRuEQ & TuVaLu
ID: 42227 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42228 - Posted: 18 Apr 2012, 18:12:44 UTC - in response to Message 42226.  

Eric,

Rather than you checking all the server logs manually, are you currently running Beta on a server powerful enough to allow user access to the logs?

If so, you might be able to find a user prepared to attach both here and to Einstein's 'Albert' test project, which is also testing OpenCL plan classes and has open access to the logs. I picked this user at random to show what's possible:

http://albert.phys.uwm.edu/hosts_user.php?userid=42297
http://albert.phys.uwm.edu/host_sched_logs/1/1362

If a user could see their own logs, and were to be attached to both projects (with, by definition, the same BOINC version and ATI driver), the difference in the log entries might reveal where the plan class problems lie.



2012-04-18 19:54:57 | Albert@Home | work fetch resumed by user
2012-04-18 19:54:59 | Albert@Home | project resumed by user
2012-04-18 19:55:01 | Albert@Home | Sending scheduler request: To fetch work.
2012-04-18 19:55:01 | Albert@Home | Requesting new tasks for ATI
2012-04-18 19:55:06 | Albert@Home | Scheduler request completed: got 24 new tasks


But I can't keep it requesting new work then it will fill all of the BM cue/cache and won't ask for SETI Beta work...

I've mailed DA about this cue/cache thing and he said he would fix it...
When I don't know...

But now I am attached to both SETI Beta and Albert@home
Using the ATI 5850 Catalyst 11.12 and BM 7.0.26

Link to computor at albert: http://albert.phys.uwm.edu/hosts_user.php?userid=214138

//TRuEQ


I created the account first and then attached my computer so I could only get 1 WU to test.



I was already attached to Albert when it was suggested. I got 24tasks and then I(as usual) NNT Albert to keep an non filled cache to have SETI Beta keep requesting more work.

//TRuEQ
TRuEQ & TuVaLu
ID: 42228 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42229 - Posted: 18 Apr 2012, 18:13:41 UTC - in response to Message 42225.  

For the folks that can't get work, did you try detaching/re-attaching? That worked for me. I also quit BOINC in between, just to make sure the project info was complete removed before re-attaching.



I'll giv it a try.... brb


TRuEQ & TuVaLu
ID: 42229 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42230 - Posted: 18 Apr 2012, 18:16:28 UTC - in response to Message 42229.  

For the folks that can't get work, did you try detaching/re-attaching? That worked for me. I also quit BOINC in between, just to make sure the project info was complete removed before re-attaching.



I'll giv it a try.... brb

No luck. It didn't work.




TRuEQ & TuVaLu
ID: 42230 · Report as offensive
Jamie
Volunteer tester

Send message
Joined: 17 Mar 10
Posts: 34
Credit: 5,632,256
RAC: 0
United Kingdom
Message 42231 - Posted: 18 Apr 2012, 18:21:14 UTC - in response to Message 42230.  
Last modified: 18 Apr 2012, 18:29:39 UTC

not so much luck on my dual GPU (Nv & ATI host) Boinc 7.0.26 x64 http://setiweb.ssl.berkeley.edu/beta/show_host_detail.php?hostid=57941
Boinc tries to start 3 tasks at the same time and none of them progress.

Each of them have the same message in the stderr in their slot dir:

DATA_CHUNK_UNROLL at default:4
Priority of worker thread raised successfully
Priority of process adjusted successfully, below normal priority class used
GPU type not found in init_data.xml
OpenCL platform detected: NVIDIA Corporation
OpenCL platform detected: Advanced Micro Devices, Inc.
WARNING: BOINC supplied wrong platform!
BOINC assigns 0 device, slots 0 to 0 (including) will be checked
WARNING: Can't follow BOINC's proposal, will try to find free device..


Is finding both my GPU's as OpenCl compatible as well
18/04/2012 19:22:52 | | NVIDIA GPU 0: GeForce GTX 465 (driver version 301.24, CUDA version 4.20, compute capability 2.0, 1024MB, 871MB available, 1021 GFLOPS peak)
18/04/2012 19:22:52 | | ATI GPU 0: Redwood (CAL version 1.4.1720, 1024MB, 991MB available, 1240 GFLOPS peak)
18/04/2012 19:22:52 | | OpenCL: NVIDIA GPU 0: GeForce GTX 465 (driver version 301.24, device version OpenCL 1.1 CUDA, 1024MB, 871MB available)
18/04/2012 19:22:52 | | OpenCL: ATI GPU 0: Redwood (driver version CAL 1.4.1720 (VM), device version OpenCL 1.2 AMD-APP (923.1), 1024MB, 991MB available)
18/04/2012 19:22:52 | | NVIDIA library reports 1 GPU
ID: 42231 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42232 - Posted: 18 Apr 2012, 18:23:15 UTC
Last modified: 18 Apr 2012, 18:23:30 UTC

I said something that was wrong earlier.
POEM supports ATI OpenCl 1.0 cards.

My mistake.

//TQ
TRuEQ & TuVaLu
ID: 42232 · Report as offensive
Richard Haselgrove
Volunteer tester

Send message
Joined: 3 Jan 07
Posts: 1451
Credit: 3,266,428
RAC: 0
United Kingdom
Message 42233 - Posted: 18 Apr 2012, 18:23:47 UTC - in response to Message 42225.  

For the folks that can't get work, did you try detaching/re-attaching? That worked for me. I also quit BOINC in between, just to make sure the project info was complete removed before re-attaching.

Did you do any analysis, say of your work fetch debug logs before/after, to indicate why this course of action should make a difference?
ID: 42233 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42234 - Posted: 18 Apr 2012, 18:29:22 UTC - in response to Message 42233.  

For the folks that can't get work, did you try detaching/re-attaching? That worked for me. I also quit BOINC in between, just to make sure the project info was complete removed before re-attaching.

Did you do any analysis, say of your work fetch debug logs before/after, to indicate why this course of action should make a difference?


If I use a logic analysis from my computor and the actions taken I'd say it shouldn't make a difference.

But since Zombie67 said it could work I gave it a try since BM doesn't always act logical.

//TQ
TRuEQ & TuVaLu
ID: 42234 · Report as offensive
Richard Haselgrove
Volunteer tester

Send message
Joined: 3 Jan 07
Posts: 1451
Credit: 3,266,428
RAC: 0
United Kingdom
Message 42235 - Posted: 18 Apr 2012, 18:30:40 UTC - in response to Message 42228.  

I was already attached to Albert when it was suggested. I got 24tasks and then I(as usual) NNT Albert to keep an non filled cache to have SETI Beta keep requesting more work.

//TRuEQ

That would be good. BOINC will contact the Albert server once every 24 hours anyway to report completed work: if you could briefly allow new work around this time, the Albert server logs will continue to display 'work request' style logs for comparison. We can only see logs for the single most recent server contact, so if that contact is 'report only', the information visible in the logs will be incomplete.
ID: 42235 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42236 - Posted: 18 Apr 2012, 18:32:56 UTC - in response to Message 42235.  

I was already attached to Albert when it was suggested. I got 24tasks and then I(as usual) NNT Albert to keep an non filled cache to have SETI Beta keep requesting more work.

//TRuEQ

That would be good. BOINC will contact the Albert server once every 24 hours anyway to report completed work: if you could briefly allow new work around this time, the Albert server logs will continue to display 'work request' style logs for comparison. We can only see logs for the single most recent server contact, so if that contact is 'report only', the information visible in the logs will be incomplete.


I just removed NNT and got me 12more tasks.

2012-04-18 20:31:17 | Albert@Home | work fetch resumed by user
2012-04-18 20:31:23 | Albert@Home | Sending scheduler request: To fetch work.
2012-04-18 20:31:23 | Albert@Home | Requesting new tasks for ATI
2012-04-18 20:31:27 | Albert@Home | Scheduler request completed: got 12 new tasks
2012-04-18 20:31:29 | Albert@Home | Started download of p2030.20111210.G37.15+00.21.S.b6s0g0.00000_1704.bin4

//TQ

TRuEQ & TuVaLu
ID: 42236 · Report as offensive
Richard Haselgrove
Volunteer tester

Send message
Joined: 3 Jan 07
Posts: 1451
Credit: 3,266,428
RAC: 0
United Kingdom
Message 42237 - Posted: 18 Apr 2012, 18:35:37 UTC - in response to Message 42234.  

... since BM doesn't always act logical.

It's the core client, not the Manager, which makes work requests.

Always work on the assumption that computer programs are utterly, absolutely, logical. They will do exactly what their programmer told them to do: even if those instructions are utterly nonsensical and bear no relation to what the programmer intended to tell them to do.

That's what debugging is all about.
ID: 42237 · Report as offensive
Jamie
Volunteer tester

Send message
Joined: 17 Mar 10
Posts: 34
Credit: 5,632,256
RAC: 0
United Kingdom
Message 42238 - Posted: 18 Apr 2012, 18:48:18 UTC - in response to Message 42237.  
Last modified: 18 Apr 2012, 18:57:41 UTC

Ok, I've worked out the problem on my host, for some reason Boinc isn't flagging the task as running on the ATI card (no running (x CPU + 1 ATI GPU's)) in the status column.
So Boinc runs 1 ATI task on the card (currently anon platform @ Main), and then launches the Beta AP task whilst thinking it is running on the CPU, although it's also using the GPU resource
ID: 42238 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42239 - Posted: 18 Apr 2012, 19:06:18 UTC
Last modified: 18 Apr 2012, 19:07:53 UTC

2012-04-18 21:04:48 | SETI@home Beta Test | update requested by user
2012-04-18 21:04:50 | SETI@home Beta Test | Sending scheduler request: Requested by user.
2012-04-18 21:04:50 | SETI@home Beta Test | Requesting new tasks for ATI
2012-04-18 21:04:53 | SETI@home Beta Test | Scheduler request completed: got 1 new tasks
2012-04-18 21:04:55 | SETI@home Beta Test | Started download of astropulse_6.02_windows_intelx86__opencl_ati.exe
2012-04-18 21:04:55 | SETI@home Beta Test | Started download of libfftw3f-3.dll
2012-04-18 21:05:00 | SETI@home Beta Test | Finished download of astropulse_6.02_windows_intelx86__opencl_ati.exe
2012-04-18 21:05:00 | SETI@home Beta Test | Started download of astropulse_6.02_windows_intelx86__opencl_ati.pdb
2012-04-18 21:05:08 | SETI@home Beta Test | Finished download of libfftw3f-3.dll
2012-04-18 21:05:08 | SETI@home Beta Test | Started download of ap_cmdline_6.02_windows_intelx86__opencl_ati.txt
2012-04-18 21:05:10 | SETI@home Beta Test | Finished download of ap_cmdline_6.02_windows_intelx86__opencl_ati.txt
2012-04-18 21:05:10 | SETI@home Beta Test | Started download of AstroPulse_Kernels_r1298.cl
2012-04-18 21:05:12 | SETI@home Beta Test | Finished download of AstroPulse_Kernels_r1298.cl
2012-04-18 21:05:12 | SETI@home Beta Test | Started download of astropulse_6.02_opencl_ati_AUTHORS
2012-04-18 21:05:13 | SETI@home Beta Test | Finished download of astropulse_6.02_opencl_ati_AUTHORS
2012-04-18 21:05:13 | SETI@home Beta Test | Started download of astropulse_6.02_opencl_ati_COPYRIGHT
2012-04-18 21:05:15 | SETI@home Beta Test | Finished download of astropulse_6.02_opencl_ati_COPYRIGHT
2012-04-18 21:05:15 | SETI@home Beta Test | Started download of astropulse_6.02_opencl_ati_COPYING
2012-04-18 21:05:16 | SETI@home Beta Test | Finished download of astropulse_6.02_opencl_ati_COPYING
2012-04-18 21:05:16 | SETI@home Beta Test | Started download of ap_21my11ac_B6_P0_00163_20120417_03054.wu
2012-04-18 21:05:30 | SETI@home Beta Test | Finished download of astropulse_6.02_windows_intelx86__opencl_ati.pdb


Now I got me a task!!!!

Estemated 109hours ; running cpu(0.977 + 1ATI GPU)



//TQ
TRuEQ & TuVaLu
ID: 42239 · Report as offensive
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,923,595
RAC: 1,148
United States
Message 42240 - Posted: 18 Apr 2012, 19:08:51 UTC - in response to Message 42238.  

The plan_class_spec.xml stuff is totally fubar. There was no way for the OpenCL support to execute, and if you added the code to force it to execute it never detected an ATI GPU on any host.

I've gone back to the default OpenCL plan, which means were temporarily back to OpenCL 1.1+ only. I'll put in some work on getting back down to OpenCL 1.0 this afternoon.
ID: 42240 · Report as offensive
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,923,595
RAC: 1,148
United States
Message 42241 - Posted: 18 Apr 2012, 19:11:08 UTC - in response to Message 42239.  


Now I got me a task!!!!

Estemated 109hours ; running cpu(0.977 + 1ATI GPU)


I have no freaking idea how that happened.
ID: 42241 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 42242 - Posted: 18 Apr 2012, 19:12:31 UTC - in response to Message 42231.  

not so much luck on my dual GPU (Nv & ATI host) Boinc 7.0.26 x64 http://setiweb.ssl.berkeley.edu/beta/show_host_detail.php?hostid=57941
Boinc tries to start 3 tasks at the same time and none of them progress.

It should not start 3 at once.
Delete ap_cmdline.txt left from anonymous platfor install.

News about SETI opt app releases: https://twitter.com/Raistmer
ID: 42242 · Report as offensive
arkayn
Volunteer tester
Avatar

Send message
Joined: 16 Jan 07
Posts: 155
Credit: 194,400
RAC: 0
United States
Message 42243 - Posted: 18 Apr 2012, 19:13:05 UTC
Last modified: 18 Apr 2012, 19:16:13 UTC

Albert is running 1CPU and 1ATI, but only using about %10 of the CPU.

Mine is 0.951CPU and 1ATI.
ID: 42243 · Report as offensive
Previous · 1 · 2 · 3 · 4 · 5 · 6 . . . 45 · Next

Message boards : News : Astropulse 6.02 Windows for OpenCL on ATI released.


 
©2019 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.