Astropulse 6.02 Windows for OpenCL on ATI released.

Message boards : News : Astropulse 6.02 Windows for OpenCL on ATI released.
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3 · 4 · 5 . . . 45 · Next

AuthorMessage
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,917,982
RAC: 1,315
United States
Message 42204 - Posted: 18 Apr 2012, 15:46:04 UTC - in response to Message 42201.  

FYI, I didn't add any specifications of BOINC or OpenCL versions beyond what's in the default OpenCL plan class. They are...

min_opencl_device_version = 101 (which is 1.1 I assume)
min_global_mem_size = 256M
ndevs = 1
cpu_frac = .1,
flops_scale = .2

I don't think there are any version requirements for BOINC beyond it being able to report that it has an ATI GPU that's capable of OpenCL.

Raistmer, do you think that this app will run with OpenCL 1.0? If so, should I reduce the version requirement?

Regarding the time estimates, we should be getting to the point where we have enough non-overflow results that the scheduler should start dropping time estimates. Initial estimates were based on about 5GFLOP and actual performance seems to be about 600GFLOP.
ID: 42204 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 42205 - Posted: 18 Apr 2012, 15:51:51 UTC - in response to Message 42204.  
Last modified: 18 Apr 2012, 16:01:50 UTC


Raistmer, do you think that this app will run with OpenCL 1.0? If so, should I reduce the version requirement?


Yes, definitely!
If not we should know about it at least. So, please, reduce requirements to OpenCL 1.0.

And about BOINC version: I suppose if BOINC can't report OpenCL device no app will be given.
And, for example, 6.10.58 hardly can report OpenCL devices...

EDIT: LoL, it an be advertisment for BOINC7. Maybe realising that David could help more? ;)
News about SETI opt app releases: https://twitter.com/Raistmer
ID: 42205 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 42206 - Posted: 18 Apr 2012, 15:53:21 UTC - in response to Message 42204.  


cpu_frac = .1,


So, no full core reservation should be done...
News about SETI opt app releases: https://twitter.com/Raistmer
ID: 42206 · Report as offensive
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,917,982
RAC: 1,315
United States
Message 42207 - Posted: 18 Apr 2012, 15:56:39 UTC - in response to Message 42203.  

And what is: Couldn't open plan class spec file '../plan_class_spec.xml' ?


That's file where I can make adjustments to some of the default values without recompiling the feeder. I hope. I haven't tested it yet.
ID: 42207 · Report as offensive
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,917,982
RAC: 1,315
United States
Message 42208 - Posted: 18 Apr 2012, 15:57:47 UTC - in response to Message 42206.  


cpu_frac = .1,


So, no full core reservation should be done...


Yes, but it looks like it's using at least 0.4 cores. Not sure I should do anything about it until it looks like it's causing problems.
ID: 42208 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 42209 - Posted: 18 Apr 2012, 16:03:56 UTC - in response to Message 42208.  


cpu_frac = .1,


So, no full core reservation should be done...


Yes, but it looks like it's using at least 0.4 cores. Not sure I should do anything about it until it looks like it's causing problems.


The best is you could add ap_cmdline.txt to it.
Most of users can go with higher unroll.

Also, CPU usage strongly depends on blanking.

News about SETI opt app releases: https://twitter.com/Raistmer
ID: 42209 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42210 - Posted: 18 Apr 2012, 16:17:26 UTC - in response to Message 42208.  


cpu_frac = .1,


So, no full core reservation should be done...


Yes, but it looks like it's using at least 0.4 cores. Not sure I should do anything about it until it looks like it's causing problems.



Sometimes I run CPU tasks with max cpu usage set to 10-20% along with the GPU tasks...I don't think that can be done if the app uses cpu(0.975).

Maybe I am about the few that runs like that.
I use app_info.xml files to control that anyhow...
But I can use the lunatics when it is released.

I've seen alot of people that gets a bit upset(frustrated) when projects like Albert and Poem locks 1cpu core totally. They probelbly update their apps in the future.

//TRuEQ
TRuEQ & TuVaLu
ID: 42210 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42211 - Posted: 18 Apr 2012, 16:20:12 UTC - in response to Message 42205.  
Last modified: 18 Apr 2012, 16:20:28 UTC


Raistmer, do you think that this app will run with OpenCL 1.0? If so, should I reduce the version requirement?


Yes, definitely!
If not we should know about it at least. So, please, reduce requirements to OpenCL 1.0.

And about BOINC version: I suppose if BOINC can't report OpenCL device no app will be given.
And, for example, 6.10.58 hardly can report OpenCL devices...

EDIT: LoL, it an be advertisment for BOINC7. Maybe realising that David could help more? ;)


I have the 4850(512MB) standing by to test OpenCl 1.0 and another 4650(256MB) as well. The 4650(128MB)AGP card I won't try :)


//TRuEQ
TRuEQ & TuVaLu
ID: 42211 · Report as offensive
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,917,982
RAC: 1,315
United States
Message 42212 - Posted: 18 Apr 2012, 17:03:39 UTC - in response to Message 42211.  

In theory, you should be getting work now if you try. But some people that were getting work last night with the default plan class are now getting: "Don't need CPU jobs, skipping".

But the only way that's supposed to happen is if they don't have a GPU (or have it set to no GPU work).



ID: 42212 · Report as offensive
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,917,982
RAC: 1,315
United States
Message 42213 - Posted: 18 Apr 2012, 17:06:40 UTC - in response to Message 42211.  
Last modified: 18 Apr 2012, 17:06:59 UTC

The 4650(128MB)AGP card I won't try :)


Actually, if you don't mind putting it on the project... It's important for me to see that it doesn't get any GPU work.
ID: 42213 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42214 - Posted: 18 Apr 2012, 17:12:23 UTC - in response to Message 42212.  

In theory, you should be getting work now if you try. But some people that were getting work last night with the default plan class are now getting: "Don't need CPU jobs, skipping".

But the only way that's supposed to happen is if they don't have a GPU (or have it set to no GPU work).




2012-04-18 19:11:11 | SETI@home Beta Test | Scheduler request completed: got 0 new tasks
2012-04-18 19:11:11 | SETI@home Beta Test | No tasks sent
2012-04-18 19:11:11 | SETI@home Beta Test | No tasks are available for SETI@home v7
2012-04-18 19:11:11 | SETI@home Beta Test | No tasks are available for AstroPulse v6
2012-04-18 19:11:11 | SETI@home Beta Test | Uppgifter för CPU finns tillgängliga, men du har valt att inte acceptera dessa

The 5850 that has done some tasks does not get any new ones....

//TRuEQ

TRuEQ & TuVaLu
ID: 42214 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42215 - Posted: 18 Apr 2012, 17:17:23 UTC - in response to Message 42213.  

The 4650(128MB)AGP card I won't try :)


Actually, if you don't mind putting it on the project... It's important for me to see that it doesn't get any GPU work.


I can try tomorrow. But no promises I can get it to work with new drivers.

I had some problems with the sdk2.3 and newer.
I think I ran on it with SDK 2.1... Not sure if it was brook version though.

I'll try get it to work... But the Nvidia drivers nowadays...


Will Brook version be included here as well?
I ran a couple of ap5 with an 128MB ATI 2600XT, brook version.

//TRuEQ
TRuEQ & TuVaLu
ID: 42215 · Report as offensive
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,917,982
RAC: 1,315
United States
Message 42216 - Posted: 18 Apr 2012, 17:17:45 UTC - in response to Message 42211.  

Here's the work request from the 512MB one. Again if the messages are to be believed all the OpenCL checks succeeded, but another part of the scheduler thinks there are no GPUs.


2012-04-18 09:49:56.0289 [PID=28073]   Request: [USER#14842] [HOST#58314] [IP 83.253.75.42] client 6.12.34
2012-04-18 09:49:56.0296 [PID=28073]    [send] Not using matchmaker scheduling; Not using EDF sim
2012-04-18 09:49:56.0296 [PID=28073]    [send] CPU: req 0.00 sec, 0.00 instances; est delay 0.00
2012-04-18 09:49:56.0296 [PID=28073]    [send] ATI: req 1.00 sec, 0.86 instances; est delay 0.00
2012-04-18 09:49:56.0296 [PID=28073]    [send] work_req_seconds: 0.00 secs
2012-04-18 09:49:56.0296 [PID=28073]    [send] available disk 98.87 GB, work_buf_min 0
2012-04-18 09:49:56.0296 [PID=28073]    [send] active_frac 0.994371 on_frac 0.991676
2012-04-18 09:49:56.0297 [PID=28073]    [send] p_vm_extensions_disabled: no
2012-04-18 09:49:56.0297 [PID=28073]    [send] CPU features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 s
s htt tm pni ssse3 cx16 sse4_1 sse4_2 syscall nx lm vmx tm2 popcnt pbe
2012-04-18 09:49:56.0304 [PID=28073]    [version] looking for version of astropulse_v6
2012-04-18 09:49:56.0304 [PID=28073]    [version] [AV#321] Skipping CPU version - user prefs say no CPUs
2012-04-18 09:49:56.0304 [PID=28073]    [version] Checking plan class 'opencl_ati_101'
2012-04-18 09:49:56.0310 [PID=28073]    [version] reading plan classes from file '../plan_class_spec.xml'
2012-04-18 09:49:56.0310 [PID=28073]    [version] host_flops: 2.572205e+09,     speedup: 100.00,        projected_flops: 2.572205e+11,  peak_flops: 2.572205e+09,       p
eak_flops_factor: 1.00
2012-04-18 09:49:56.0310 [PID=28073]    [version] [AV#327] Skipping CPU version - user prefs say no CPUs
2012-04-18 09:49:56.0310 [PID=28073]    [version] returning NULL; platforms:
2012-04-18 09:49:56.0310 [PID=28073]    [version] windows_x86_64
2012-04-18 09:49:56.0310 [PID=28073]    [version] windows_intelx86
2012-04-18 09:49:56.0333 [PID=28073]    [version] looking for version of setiathome_v7
2012-04-18 09:49:56.0333 [PID=28073]    [version] [AV#315] Skipping CPU version - user prefs say no CPUs
2012-04-18 09:49:56.0333 [PID=28073]    [version] returning NULL; platforms:
2012-04-18 09:49:56.0333 [PID=28073]    [version] windows_x86_64
2012-04-18 09:49:56.0333 [PID=28073]    [version] windows_intelx86
2012-04-18 09:49:56.0339 [PID=28073]    [send] [HOST#58314] is looking for work from a non-preferred application
2012-04-18 09:49:56.0349 [PID=28073]    Sending reply to [HOST#58314]: 0 results, delay req 7.00
2012-04-18 09:49:56.0350 [PID=28073]    Scheduler ran 0.011 seconds

ID: 42216 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42217 - Posted: 18 Apr 2012, 17:25:02 UTC - in response to Message 42216.  

Here's the work request from the 512MB one. Again if the messages are to be believed all the OpenCL checks succeeded, but another part of the scheduler thinks there are no GPUs.


2012-04-18 09:49:56.0289 [PID=28073]   Request: [USER#14842] [HOST#58314] [IP 83.253.75.42] client 6.12.34
2012-04-18 09:49:56.0296 [PID=28073]    [send] Not using matchmaker scheduling; Not using EDF sim
2012-04-18 09:49:56.0296 [PID=28073]    [send] CPU: req 0.00 sec, 0.00 instances; est delay 0.00
2012-04-18 09:49:56.0296 [PID=28073]    [send] ATI: req 1.00 sec, 0.86 instances; est delay 0.00
2012-04-18 09:49:56.0296 [PID=28073]    [send] work_req_seconds: 0.00 secs
2012-04-18 09:49:56.0296 [PID=28073]    [send] available disk 98.87 GB, work_buf_min 0
2012-04-18 09:49:56.0296 [PID=28073]    [send] active_frac 0.994371 on_frac 0.991676
2012-04-18 09:49:56.0297 [PID=28073]    [send] p_vm_extensions_disabled: no
2012-04-18 09:49:56.0297 [PID=28073]    [send] CPU features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 s
s htt tm pni ssse3 cx16 sse4_1 sse4_2 syscall nx lm vmx tm2 popcnt pbe
2012-04-18 09:49:56.0304 [PID=28073]    [version] looking for version of astropulse_v6
2012-04-18 09:49:56.0304 [PID=28073]    [version] [AV#321] Skipping CPU version - user prefs say no CPUs
2012-04-18 09:49:56.0304 [PID=28073]    [version] Checking plan class 'opencl_ati_101'
2012-04-18 09:49:56.0310 [PID=28073]    [version] reading plan classes from file '../plan_class_spec.xml'
2012-04-18 09:49:56.0310 [PID=28073]    [version] host_flops: 2.572205e+09,     speedup: 100.00,        projected_flops: 2.572205e+11,  peak_flops: 2.572205e+09,       p
eak_flops_factor: 1.00
2012-04-18 09:49:56.0310 [PID=28073]    [version] [AV#327] Skipping CPU version - user prefs say no CPUs
2012-04-18 09:49:56.0310 [PID=28073]    [version] returning NULL; platforms:
2012-04-18 09:49:56.0310 [PID=28073]    [version] windows_x86_64
2012-04-18 09:49:56.0310 [PID=28073]    [version] windows_intelx86
2012-04-18 09:49:56.0333 [PID=28073]    [version] looking for version of setiathome_v7
2012-04-18 09:49:56.0333 [PID=28073]    [version] [AV#315] Skipping CPU version - user prefs say no CPUs
2012-04-18 09:49:56.0333 [PID=28073]    [version] returning NULL; platforms:
2012-04-18 09:49:56.0333 [PID=28073]    [version] windows_x86_64
2012-04-18 09:49:56.0333 [PID=28073]    [version] windows_intelx86
2012-04-18 09:49:56.0339 [PID=28073]    [send] [HOST#58314] is looking for work from a non-preferred application
2012-04-18 09:49:56.0349 [PID=28073]    Sending reply to [HOST#58314]: 0 results, delay req 7.00
2012-04-18 09:49:56.0350 [PID=28073]    Scheduler ran 0.011 seconds



My fault.

I was running 1 ap .r560 just to see that is could run and it could.
I aborted that task and now I am requesting new tasks.
But gets none.

2012-04-18 19:23:01 | SETI@home Beta Test | Master file download succeeded
2012-04-18 19:23:07 | SETI@home Beta Test | Sending scheduler request: Project initialization.
2012-04-18 19:23:07 | SETI@home Beta Test | Requesting new tasks for CPU and ATI
2012-04-18 19:23:11 | SETI@home Beta Test | Scheduler request completed: got 0 new tasks
2012-04-18 19:23:11 | SETI@home Beta Test | No tasks sent
2012-04-18 19:23:11 | SETI@home Beta Test | No tasks are available for SETI@home v7
2012-04-18 19:23:11 | SETI@home Beta Test | No tasks are available for AstroPulse v6
2012-04-18 19:23:11 | SETI@home Beta Test | Uppgifter för CPU finns tillgängliga, men du har valt att inte acceptera dessa


//TRuEQ

TRuEQ & TuVaLu
ID: 42217 · Report as offensive
arkayn
Volunteer tester
Avatar

Send message
Joined: 16 Jan 07
Posts: 155
Credit: 194,400
RAC: 0
United States
Message 42218 - Posted: 18 Apr 2012, 17:32:43 UTC

I have been attempting to get work for my HD7750, but all I get is no AP work available.
4/18/2012 10:27:37 | SETI@home Beta Test | Sending scheduler request: To fetch work.
4/18/2012 10:27:37 | SETI@home Beta Test | Requesting new tasks for ATI
4/18/2012 10:27:39 | SETI@home Beta Test | Scheduler request completed: got 0 new tasks
4/18/2012 10:27:39 | SETI@home Beta Test | No tasks sent
4/18/2012 10:27:39 | SETI@home Beta Test | No tasks are available for AstroPulse v6
4/18/2012 10:27:39 | SETI@home Beta Test | Tasks for CPU are available, but your preferences are set to not accept them

This computer.
http://setiweb.ssl.berkeley.edu/beta/show_host_detail.php?hostid=55184
ID: 42218 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42219 - Posted: 18 Apr 2012, 17:36:21 UTC
Last modified: 18 Apr 2012, 17:36:59 UTC

I just upgraded drivers to catalyst 12.3 on my 5850
Can it be a driver issue??
I'll downgrade back to 11.12
//TRuEQ
TRuEQ & TuVaLu
ID: 42219 · Report as offensive
Richard Haselgrove
Volunteer tester

Send message
Joined: 3 Jan 07
Posts: 1451
Credit: 3,266,428
RAC: 1
United Kingdom
Message 42220 - Posted: 18 Apr 2012, 17:40:42 UTC

Eric,

Rather than you checking all the server logs manually, are you currently running Beta on a server powerful enough to allow user access to the logs?

If so, you might be able to find a user prepared to attach both here and to Einstein's 'Albert' test project, which is also testing OpenCL plan classes and has open access to the logs. I picked this user at random to show what's possible:

http://albert.phys.uwm.edu/hosts_user.php?userid=42297
http://albert.phys.uwm.edu/host_sched_logs/1/1362

If a user could see their own logs, and were to be attached to both projects (with, by definition, the same BOINC version and ATI driver), the difference in the log entries might reveal where the plan class problems lie.
ID: 42220 · Report as offensive
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 15 Mar 05
Posts: 1547
Credit: 26,917,982
RAC: 1,315
United States
Message 42221 - Posted: 18 Apr 2012, 17:48:52 UTC - in response to Message 42217.  

I put on a scheduler that will give me a bit more debugging info.

ID: 42221 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 42222 - Posted: 18 Apr 2012, 17:54:39 UTC

Now am back to catalist driver 11.12 which I used earlier when I downloaded tasks.
The server says:

2012-04-18 19:51:18 | SETI@home Beta Test | Sending scheduler request: To fetch work.
2012-04-18 19:51:18 | SETI@home Beta Test | Requesting new tasks for ATI
2012-04-18 19:51:21 | SETI@home Beta Test | Scheduler request completed: got 0 new tasks


Are the servers out of work??

//TRuEQ

TRuEQ & TuVaLu
ID: 42222 · Report as offensive
arkayn
Volunteer tester
Avatar

Send message
Joined: 16 Jan 07
Posts: 155
Credit: 194,400
RAC: 0
United States
Message 42223 - Posted: 18 Apr 2012, 17:56:19 UTC - in response to Message 42221.  

I put on a scheduler that will give me a bit more debugging info.


Still no AP listed as available.
ID: 42223 · Report as offensive
Previous · 1 · 2 · 3 · 4 · 5 . . . 45 · Next

Message boards : News : Astropulse 6.02 Windows for OpenCL on ATI released.


 
©2019 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.