Posts by Francesco Forti


log in
41) Message boards : Number crunching : V8 CUDA for Linux? (Message 1774913)
Posted 29 Mar 2016 by Profile Francesco Forti
Thanks!
I will try this evening
42) Message boards : Number crunching : V8 CUDA for Linux? (Message 1774823)
Posted 28 Mar 2016 by Profile Francesco Forti
More complex

Here all programs I see in my setiathome.berkeley.edu folder
/var/lib/boinc-client/projects/setiathome.berkeley.edu/astropulse_7.00_i686-pc-linux-gnu /var/lib/boinc-client/projects/setiathome.berkeley.edu/astropulse_7.00_x86_64-pc-linux-gnu /var/lib/boinc-client/projects/setiathome.berkeley.edu/astropulse_7.04_i686-pc-linux-gnu__sse /var/lib/boinc-client/projects/setiathome.berkeley.edu/astropulse_7.04_x86_64-pc-linux-gnu__sse2 /var/lib/boinc-client/projects/setiathome.berkeley.edu/astropulse_7.08_x86_64-pc-linux-gnu__opencl_nvidia_100 /var/lib/boinc-client/projects/setiathome.berkeley.edu/setiathome_7.01_i686-pc-linux-gnu /var/lib/boinc-client/projects/setiathome.berkeley.edu/setiathome_7.01_x86_64-pc-linux-gnu /var/lib/boinc-client/projects/setiathome.berkeley.edu/setiathome_7.08_x86_64-pc-linux-gnu__opencl_nvidia_sah /var/lib/boinc-client/projects/setiathome.berkeley.edu/setiathome_8.00_i686-pc-linux-gnu /var/lib/boinc-client/projects/setiathome.berkeley.edu/setiathome_8.00_x86_64-pc-linux-gnu /var/lib/boinc-client/projects/setiathome.berkeley.edu/setigraphics_7.01_i686-pc-linux-gnu /var/lib/boinc-client/projects/setiathome.berkeley.edu/setigraphics_7.01_x86_64-pc-linux-gnu /var/lib/boinc-client/projects/setiathome.berkeley.edu/setigraphics_8.00_i686-pc-linux-gnu /var/lib/boinc-client/projects/setiathome.berkeley.edu/setigraphics_8.00_x86_64-pc-linux-gnu

I Immagine I need an app_info entra for each one.

Correct?
43) Message boards : Number crunching : V8 CUDA for Linux? (Message 1774167)
Posted 26 Mar 2016 by Profile Francesco Forti
Ok: Thanks!

Seen ad downloaded SETIv8_Linux_CUDA42.7z

In read_me file I cannot see anything about installation on linux mint.

Where do I have to move files?

Years ago I used Lunatics' optimized apps on win xp hosts but now all my win xp host are linux mint 17.3 and I do not have idea about how to install optimized apps on linux.

Maybe this SETIv8_Linux_CUDA42.7z is a part of a greater optimized package or is a stand alone program?

In this moment I don't have any app_info.xlm file in my linux systems.
The one I found in SETIv8_Linux_CUDA42.7z is standalone or have I to merge it with someone else?

Sorry for so many questions.
Reply after Easter, if you are running.
And of course good holidays to everybody
44) Message boards : Number crunching : V8 CUDA for Linux? (Message 1773998)
Posted 25 Mar 2016 by Profile Francesco Forti
Sorry, TBar, I cannot follow you in "pre-fermi" or cuda42.
Simply tell me what I have to install.
On linux systems I have
    NVIDIA GeForce GTX 260
    NVIDIA GeForce GT 640
    NVIDIA GeForce GTX 560
    NVIDIA GeForce GTS 250


I don't know which is pre-fermi or not and if cuda 42 or else is good.
Thanks

45) Message boards : Number crunching : V8 CUDA for Linux? (Message 1773915)
Posted 25 Mar 2016 by Profile Francesco Forti
Driver nvidia-352 installed. I get GPU.
It's important to install "nvidia-modprobe" with synaptic.

ven 25 mar 2016 15:07:50 CET | | CUDA: NVIDIA GPU 0: GeForce GTX 560 (driver version unknown, CUDA version 7.5, compute capability 2.1, 1023MB, 811MB available, 1243 GFLOPS peak)
ven 25 mar 2016 15:07:50 CET | | OpenCL: NVIDIA GPU 0: GeForce GTX 560 (driver version 352.79, device version OpenCL 1.1 CUDA, 1023MB, 811MB available, 1243 GFLOPS peak)
46) Message boards : Number crunching : V8 CUDA for Linux? (Message 1773895)
Posted 25 Mar 2016 by Profile Francesco Forti

Well, any port in a storm. I don't see why the compute capability couldn't be used. I was wondering if the Linux CUDA Apps have the built-in Version 7 compatibility, I don't remember seeing it in action. Looking at Francesco's host it appears he is using the old Version 7 OpenCL App, and from my memory that App requires driver 350 or higher to work correctly. Could be why his host has such a dismal record with the Version 7 task, http://setiathome.berkeley.edu/results.php?hostid=7866790&appid=11. If the newer Linux CUDA Apps have the version 7 compatibility built-in, it might work better if he were to upgrade to one.

Well. I was using 304 driver (normal or updated) because it was the only way to have GPU recognition at startup (No usable GPUs found).

Now that Laurent Domisse told me to install nvidia-modprobe, I can use nvidia340 and maybe 352 too.
mar 22 mar 2016 12:59:26 CET | | CUDA: NVIDIA GPU 0: GeForce GTX 560 (driver version unknown, CUDA version 6.5, compute capability 2.1, 1023MB, 761MB available, 1243 GFLOPS peak)
mar 22 mar 2016 12:59:26 CET | | OpenCL: NVIDIA GPU 0: GeForce GTX 560 (driver version 340.96, device version OpenCL 1.1 CUDA, 1023MB, 761MB available, 1243 GFLOPS peak)

In this moment ap splitter are not running so I don't get job and I can't see if I have less errors.
47) Message boards : Number crunching : V8 CUDA for Linux? (Message 1773307)
Posted 22 Mar 2016 by Profile Francesco Forti
Infact No job:

mar 22 mar 2016 22:57:25 CET | SETI@home | Sending scheduler request: To fetch work.
mar 22 mar 2016 22:57:25 CET | SETI@home | Requesting new tasks for CPU and NVIDIA
mar 22 mar 2016 22:57:27 CET | SETI@home | Scheduler request completed: got 0 new tasks
mar 22 mar 2016 22:57:27 CET | SETI@home | No tasks sent
mar 22 mar 2016 22:57:27 CET | SETI@home | No tasks are available for SETI@home v7
mar 22 mar 2016 22:57:27 CET | SETI@home | No tasks are available for AstroPulse v7
mar 22 mar 2016 22:57:27 CET | SETI@home | No tasks are available for SETI@home v8
mar 22 mar 2016 22:57:27 CET | SETI@home | This computer has reached a limit on tasks in progress
48) Message boards : Number crunching : V8 CUDA for Linux? (Message 1773237)
Posted 22 Mar 2016 by Profile Francesco Forti
I had to install nvidia-modprobe in order GPU to be seen by boinc.

Great suggestion!

Now with 340 drivers I get:

mar 22 mar 2016 12:59:26 CET | | CUDA: NVIDIA GPU 0: GeForce GTX 560 (driver version unknown, CUDA version 6.5, compute capability 2.1, 1023MB, 761MB available, 1243 GFLOPS peak)
mar 22 mar 2016 12:59:26 CET | | OpenCL: NVIDIA GPU 0: GeForce GTX 560 (driver version 340.96, device version OpenCL 1.1 CUDA, 1023MB, 761MB available, 1243 GFLOPS peak)

Prevoiusly no GPU available.

Now I wait for job and if I get it, I'll inform you.
49) Message boards : Number crunching : V8 CUDA for Linux? (Message 1773235)
Posted 22 Mar 2016 by Profile Francesco Forti
same for 340.

I see that the driver update via driver manager modify nvidia and opencl packages too.
No usable GPUs found.
If I use 304 drivers (updated or not) I find usable GPU but no V8-Invidia job.
50) Message boards : Number crunching : V8 CUDA for Linux? (Message 1773229)
Posted 22 Mar 2016 by Profile Francesco Forti
I have changed driver form 304 to 352 using Driver Manager in Linux Mint.

Now I get

mar 22 mar 2016 12:17:26 CET | | Starting BOINC client version 7.2.42 for x86_64-pc-linux-gnu mar 22 mar 2016 12:17:26 CET | | log flags: file_xfer, sched_ops, task mar 22 mar 2016 12:17:26 CET | | Libraries: libcurl/7.35.0 OpenSSL/1.0.1f zlib/1.2.8 libidn/1.28 librtmp/2.3 mar 22 mar 2016 12:17:26 CET | | Data directory: /var/lib/boinc-client mar 22 mar 2016 12:17:26 CET | | No usable GPUs found mar 22 mar 2016 12:17:26 CET | | app version refers to missing GPU type NVIDIA mar 22 mar 2016 12:17:26 CET | SETI@home | Application uses missing NVIDIA GPU mar 22 mar 2016 12:17:26 CET | | app version refers to missing GPU type NVIDIA mar 22 mar 2016 12:17:26 CET | SETI@home | Application uses missing NVIDIA GPU mar 22 mar 2016 12:17:26 CET | | Host name: cil-System-Product-Name mar 22 mar 2016 12:17:26 CET | | Processor: 8 GenuineIntel Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz [Family 6 Model 42 Stepping 7] mar 22 mar 2016 12:17:26 CET | | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb pln pts dtherm tpr_shadow vnmi flexpriority ept vpid xsaveopt mar 22 mar 2016 12:17:26 CET | | OS: Linux: 3.19.0-32-generic mar 22 mar 2016 12:17:26 CET | | Memory: 7.77 GB physical, 7.97 GB virtual mar 22 mar 2016 12:17:26 CET | | Disk: 212.09 GB total, 126.47 GB free mar 22 mar 2016 12:17:26 CET | | Local time is UTC +1 hours
51) Message boards : Number crunching : V8 CUDA for Linux? (Message 1772684)
Posted 19 Mar 2016 by Profile Francesco Forti
There are currently Two Linux CUDA Apps available. The CUDA 42 version is best for your pre-fermi cards with less than driver version 331. I think the CUDA 6.0 version needs driver 331 or maybe 334, but even then doesn't seem to work well on my pre-fermi cards. The CUDA 42 version needs driver 295 to 337. I would suggest using the Berkeley version of BOINC where the BOINC folder is in your Home folder and contains ALL the BOINC components, I prefer version 7.2.33. This makes changing Apps and others things very simple as opposed to the repository version which scatters the components among different folders. It also makes moving the host from one Linux version to another very simple. You won't get the same times you do in XP, but they will be comparable to times in other OSes.

CUDA 42: http://www.arkayn.us/forum/index.php?topic=197.msg4489
CUDA 60: http://jgopt.org/download.html

Ok, I (perhaps) understand. Now I'm running standard 7.2.42 (x64) and Nvidia-304.
304 is the only way to run Astropulse V7 7.08 opencl_nvidia_100 on this GTX 560.
In the driver management for my Linux Mint 17.3 I can get also 340 and 352 (and connected updates) but not 331 or 334 (and not 295 to 337).

What can I do?
52) Message boards : Number crunching : V8 CUDA for Linux? (Message 1772446)
Posted 18 Mar 2016 by Profile Francesco Forti
Any update?
I have 3500 Gflops sleeping ....
53) Message boards : Number crunching : V8 CUDA for Linux? (Message 1758156)
Posted 22 Jan 2016 by Profile Francesco Forti
Hi!
I have a mix of windows and linux hosts (7.2.41 x64).
Now I see that my 4 win hosts are cruncing V8(cuda42, ...23, ..50)
No V8 cuda job for my 4 Linux host with cuda.
Have I something to do?

Thanks
FF
54) Questions and Answers : GPU applications : BOINC not using CUDA after upgrade to Ubuntu 14.04 (Message 1555689)
Posted 12 Aug 2014 by Profile Francesco Forti
I have the same problem after upgrading from linux mint 16 to 17

Note that with mint 17 CUDA was working fine (very fine!)

mar 12 ago 2014 16:00:05 CEST | | No usable GPUs found
mar 12 ago 2014 16:00:05 CEST | | app version refers to missing GPU type NVIDIA
mar 12 ago 2014 16:00:05 CEST | SETI@home | Application uses missing NVIDIA GPU

Maybe there is some new version for Boinc?

I have 7.2.42 and nvidia drivers 331 for Gforce GT640

===
Just to be more clear, on an other host I'm using mint 17 and BOINC witht CUDA without any problems, even if the installation was very long ...
55) Message boards : Number crunching : Now that v7 has rolled out.......... (Message 1376402)
Posted 4 Jun 2013 by Profile Francesco Forti
Hi, as suggested I have prepared an app_config.hml file for hosts in which GPU I want to run 2 intances.

Here is my file
<app_config> <app> <name>setiathome_v7</name> <gpu_versions> <gpu_usage>0.5</gpu_usage> <cpu_usage>.4</cpu_usage> </gpu_versions> </app> <app> <name>astropulse_v6</name> <gpu_versions> <gpu_usage>0.5</gpu_usage> <cpu_usage>0.4</cpu_usage> </gpu_versions> </app> </app_config>

As I can see, it' working.
In one hosts now I see two
SETI@home 6.04 AstroPulse v6 (opencl_nvidia_100) running
and in the other I see two
SETI@home 7.00 SETI@home v7 (cuda50) Running

Same file in both host.
But in both host I'v got the message : app setiathome_v7 not found in app_config.xml
56) Questions and Answers : Web site : Date and Time of every post? (Message 1375928)
Posted 3 Jun 2013 by Profile Francesco Forti
It's not only this.
Reply quoting when translated becames "leave team" (!!)
"Send" is "No reply" !!
There are a lot of errors.
57) Message boards : Number crunching : Now that v7 has rolled out.......... (Message 1375789)
Posted 3 Jun 2013 by Profile Francesco Forti

2) Host 6334665 has had plenty of v7 work. Host 5381180 has already got a whole shitload of work allocated to it, including 75 Astropulse v6 tasks, you'll have to get those resent, and crunched before you'll start getting Seti v7 tasks.

3) It is not CPU max, it is max_concurrent, that is GPU & CPU, if you put that as 4, and put gpu_usage as 0.5 you'll run two on the GPU and two on the CPU (a total of four), As with all Boinc configuration, it is in the Wiki: Client configuration

Claggy

2) Ok, Now (this morning, at my time) I see them too.
3) Ok, everything is clear, now. I will read that page.
Thanks
58) Questions and Answers : Web site : Date and Time of every post? (Message 1375760)
Posted 3 Jun 2013 by Profile Francesco Forti
Thanks,
I was thinking to revert to English, yust for test, but you came firts.
59) Questions and Answers : Web site : Date and Time of every post? (Message 1375582)
Posted 2 Jun 2013 by Profile Francesco Forti
Very strange. My firefox 21 doesn't show me this.
Maybe is an other error in Italian layout and translation.

I see: "non letto Messaggio - Messaggi Scaduto - nessuna rispostaMessaggio.Modifica "

I think that in the italian table there is a misalignment of strings.
(see the other error hat I have reported)
60) Questions and Answers : Web site : Date and Time of every post? (Message 1375527)
Posted 2 Jun 2013 by Profile Francesco Forti
I don't see any of this data.
Where is the date and time of your message?


Previous 20 · Next 20

Copyright © 2016 University of California