Posts by arkayn


log in
41) Questions and Answers : GPU applications : nVidia detected in Linux Mint 17 but no GPU tasks (Message 1566000)
Posted 2 Sep 2014 by Profile arkaynProject donor
A newly-built system is dual-boot with Windows 8.1 64-bit and Linux Mint 17 (Ubuntu 14.04) 64-bit.

It is an i7 (4790K) with 32GB of RAM on an Asus ROG Maximus VI Formula mobo and an Asus ROG Striker Platinum nVidia GTX-760 (1152 cores, 4GB).

Windows BOINC 7.2.42 x64 with nVidia driver 340.52 detects and uses the GPU properly - and is getting new tasks.

However in Linux no GPU tasks are ever received.

Does anyone see where the error lies here? Suggestions?

In Linux Mint 17:
- BOINC 7.2.42 x64 installed as service via package manager
- nVidia driver 343.13 from xedgers for 14.04.1 with UVM
- nVidia Cuda Toolkit 6.0.37 from nVidia
- OpenCL 1.1 symbolically linked to the Cuda Toolkit version, not the driver version

When booting to Linux Mint it is necessary to open a terminal and restart the boinc-client service as root.

inxi -Fx says:

System: Host: clavius Kernel: 3.13.0-24-generic x86_64 (64 bit, gcc: 4.8.2) Desktop: N/A Distro: Linux Mint 17 Qiana Machine: System: ASUS product: All Series Mobo: ASUSTeK model: MAXIMUS VI FORMULA version: Rev 1.xx serial: 140424303800285 Bios: American Megatrends version: 1505 date: 06/05/2014 CPU: Quad core Intel Core i7-4790K CPU (-HT-MCP-) cache: 8192 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 31928.4 Clock Speeds: 1: 3991.055 MHz 2: 3991.055 MHz 3: 3991.055 MHz 4: 3991.055 MHz 5: 3991.055 MHz 6: 3991.055 MHz 7: 3991.055 MHz 8: 3991.055 MHz Graphics: Card: NVIDIA GK104 [GeForce GTX 760] bus-ID: 01:00.0 X.org: 1.15.1 drivers: nvidia (unloaded: fbdev,vesa,nouveau) tty size: 204x55 Advanced Data: N/A for root Audio: Card-1: Intel 8 Series/C220 Series Chipset High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 Card-2: NVIDIA GK104 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1 Sound: Advanced Linux Sound Architecture ver: k3.13.0-24-generic Network: Card: Intel Ethernet Connection I217-V driver: e1000e ver: 2.3.2-k port: f020 bus-ID: 00:19.0 IF: eth0 state: up speed: 1000 Mbps duplex: full mac: e0:3f:49:b6:21:a2 Drives: HDD Total Size: 12002.4GB (23.8% used) 1: id: /dev/sda model: Addonics size: 0.1GB temp: 0C 2: id: /dev/sdb model: ST4000DM000 size: 4000.8GB temp: 28C 3: id: /dev/sdc model: ST4000DM000 size: 4000.8GB temp: 34C 4: id: /dev/sdd model: Backup+_Desk size: 4000.8GB temp: 0C Partition: ID: / size: 1.8T used: 566G (34%) fs: ext4 ID: swap-1 size: 65.54GB used: 0.00GB (0%) fs: swap RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:33C Fan Speeds (in rpm): cpu: N/A Info: Processes: 240 Uptime: 33 min Memory: 713.3/32115.4MB Runlevel: 2 Gcc sys: 4.8.2 Client: Shell inxi: 1.8.4


lspci -vnn|fgrep VGA -A 17 says:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK104 [GeForce GTX 760] [10de:1187] (rev a1) (prog-if 00 [VGA controller]) Subsystem: ASUSTeK Computer Inc. Device [1043:84a8] Flags: bus master, fast devsel, latency 0, IRQ 47 Memory at de000000 (32-bit, non-prefetchable) [size=16M] Memory at d0000000 (64-bit, prefetchable) [size=128M] Memory at d8000000 (64-bit, prefetchable) [size=32M] I/O ports at e000 [size=128] [virtual] Expansion ROM at df000000 [disabled] [size=512K] Capabilities: [60] Power Management version 3 Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+ Capabilities: [78] Express Endpoint, MSI 00 Capabilities: [b4] Vendor Specific Information: Len=14 <?> Capabilities: [100] Virtual Channel Capabilities: [128] Power Budgeting <?> Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?> Capabilities: [900] #19 Kernel driver in use: [b]nvidia[/b]


BOINC log says (timestamp removed):

Starting BOINC client version 7.2.42 for x86_64-pc-linux-gnu log flags: file_xfer, sched_ops, task Libraries: libcurl/7.35.0 OpenSSL/1.0.1f zlib/1.2.8 libidn/1.28 librtmp/2.3 Data directory: /var/lib/boinc-client CUDA: NVIDIA GPU 0: [b]GeForce GTX 760[/b] (driver version unknown, CUDA version 6.5, compute capability 3.0, 4096MB, 3987MB available, 2650 GFLOPS peak) OpenCL: NVIDIA GPU 0: GeForce GTX 760 (driver version 343.13, device version OpenCL 1.1 CUDA, 4096MB, 3987MB available, 2650 GFLOPS peak) Host name: clavius Processor: 8 GenuineIntel Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz [Family 6 Model 60 Stepping 3] Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm OS: Linux: 3.13.0-24-generic Memory: 31.36 GB physical, 61.04 GB virtual Disk: 1.73 TB total, 1.09 TB free Local time is UTC -6 hours Config: GUI RPC allowed from any host Config: GUI RPCs allowed from: SETI@home | URL http://setiathome.berkeley.edu/; Computer ID 7353509; resource share 100 SETI@home | General prefs: from SETI@home (last modified 13-Aug-2014 11:18:16) SETI@home | Computer location: home SETI@home | General prefs: no separate prefs for home; using your defaults Reading preferences override file Preferences: max memory usage when active: 16057.72MB max memory usage when idle: 28903.90MB max disk usage: 100.00GB don't compute while active don't use GPU while active suspend work if non-BOINC CPU load exceeds 25% (to change preferences, visit a project web site or select Preferences in the Manager) gui_rpc_auth.cfg is empty - no GUI RPC password protection Not using a proxy Suspending computation - computer is in use SETI@home | Sending scheduler request: To report completed tasks. SETI@home | Reporting 1 completed tasks SETI@home | [b]Requesting new tasks for CPU and NVIDIA[/b]


/usr/local/cuda/samples/1_Utilities/deviceQuery/deviceQuery says:

CUDA Device Query (Runtime API) version (CUDART static linking) Detected 1 CUDA Capable device(s) Device 0: "GeForce GTX 760" CUDA Driver Version / Runtime Version 6.5 / 6.0 CUDA Capability Major/Minor version number: 3.0 Total amount of global memory: 4096 MBytes (4294639616 bytes) ( 6) Multiprocessors, (192) CUDA Cores/MP: 1152 CUDA Cores GPU Clock rate: 1150 MHz (1.15 GHz) Memory Clock rate: 3004 Mhz Memory Bus Width: 256-bit L2 Cache Size: 524288 bytes Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096) Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers Total amount of constant memory: 65536 bytes Total amount of shared memory per block: 49152 bytes Total number of registers available per block: 65536 Warp size: 32 Maximum number of threads per multiprocessor: 2048 Maximum number of threads per block: 1024 Max dimension size of a thread block (x,y,z): (1024, 1024, 64) Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535) Maximum memory pitch: 2147483647 bytes Texture alignment: 512 bytes Concurrent copy and kernel execution: Yes with 1 copy engine(s) Run time limit on kernels: Yes Integrated GPU sharing Host Memory: No Support host page-locked memory mapping: Yes Alignment requirement for Surfaces: Yes Device has ECC support: Disabled Device supports Unified Addressing (UVA): Yes Device PCI Bus ID / PCI location ID: 1 / 0 Compute Mode: < Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) > deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 6.5, CUDA Runtime Version = 6.0, NumDevs = 1, Device0 = GeForce GTX 760


The problem you are running into is that SETI does not have a stock Multibeam app for Linux CUDA yet.

You should be able to get AP work when it is available though as there is a stock Linux AP OpenCL app for Nvidia.
42) Message boards : Cafe SETI : Mysterious Miscellaneous Tool Time V4 (Message 1564817)
Posted 30 Aug 2014 by Profile arkaynProject donor
Whomever wins this round should start a new thread as this one is getting long in the tooth.
43) Message boards : Cafe SETI : Weather Forecasts V (Message 1564816)
Posted 30 Aug 2014 by Profile arkaynProject donor
As was predicted for today, the temp outside is 105f/41C...

This place could be names HADES, it wouldn't be far off...


No that would be either Bullhead City or Lake Havasu City.
44) Questions and Answers : Windows : SETI@Home don't want to stop computing (Message 1564812)
Posted 30 Aug 2014 by Profile arkaynProject donor
Also make certain that the Activity Menu has "Run based on Preferences" selected.
45) Message boards : Number crunching : AMD and PSU's (Message 1562823)
Posted 27 Aug 2014 by Profile arkaynProject donor
Thank's arkayn
Are you using the 970 chipset with that 1 ,it has been suggested that it' could also be the 4+1 power on the board and maybe i should be using the 990 chipset as it has 8+2 ?


Nope, mine is a 870 chipset.

http://www.newegg.com/Product/Product.aspx?Item=N82E16813130632R

Though I plan on eventually upgrading to a newer board and processor.
46) Message boards : Number crunching : AMD and PSU's (Message 1562499)
Posted 26 Aug 2014 by Profile arkaynProject donor
FalconFly i agree the PSU's i have been using should be enough but there simply not and i can't understand why this is happening even if they only produce 60% of there power it should be enough but it's not .

I have always used Intel and i tell you what if the next PSU fails within a month i'm going to trash this piece of crap and go back to intel and never never use AMD again

The fact that the same PSU used in a Intel q8400 shows the 12 volt at 12.55 at idle and the AMD says 12.3 tells me there is no PSU that will work with this chip at full load and nobody has explained why the voltage is different i suspect it's using a higher voltage to start off with and there is the main problem unless you can explain the difference i can see me trashing this chip and board .

I have ask AMD the same question in a email i just sent to them if they say what your saying i'm gona get real peed off with them

Was the old PSU a single rail?
Wattage is really a secondary consideration, as I have seen 1250 watt PSU, that had multiple 12 Volt rails. The problem with that, is that a CPU or GPU combination can use up all the current for a given rail, while being no where near the wattage limit for the supply.

I use a Corsair AX1200 supply with a single 100.4 amp rail, and ran a heavy load of 975 watts on it for years. It may be getting tired now, but the key was single rail. they have a new Corsair AX1500i that has a single 125 Amp rail.

Wattage is important, but make sure you have all the needed current on your rail, and it won't matter if the CPU is Intel or AMD. If GPU's are loading down the PSU, the CPU will sense it quickly, and possibly crash. A single rail system makes that very unlikely.

Steve


My current PSU that was gifted to me last year is a PC Power & Cooling Silencer Mk II 950 watt. Rated 83.4A on a single rail.

Currently running a GTX-670 and GTX-760.
47) Message boards : Number crunching : Panic Mode On (89) Server Problems? (Message 1558476)
Posted 18 Aug 2014 by Profile arkaynProject donor
Now we need to follow the tape (18fe09ag) to see if he stuck again.

Has anybody received any actual WUs from 18fe09ag? I've got none cached at the moment (and I'm not going to look at my database of completed tasks until the morning).

I've got 1 on my main rig which would've come from the last kick it got which took that file from 3 to 4 channels done.

Cheers.


I have 1 as well.
48) Message boards : Number crunching : Panic Mode On (89) Server Problems? (Message 1556228)
Posted 13 Aug 2014 by Profile arkaynProject donor
Them stuck tapes are getting old!!
49) Message boards : Number crunching : Lunatics Windows Installer v0.42 Release Notes (Message 1555087)
Posted 11 Aug 2014 by Profile arkaynProject donor
Crunchers Anonymous is now online for downloads as well.

CA Downloads
50) Message boards : Number crunching : contoling cuda tasks (Message 1554864)
Posted 11 Aug 2014 by Profile arkaynProject donor
I want to limit how many cuda tasks I have at any given time. I don't see anyway to do that and still get tasks for my CPU. If I set cuda to no in seti preferences will the tasks I have continue to run?


yes, the settings on the site only control what you get not what you already have.
51) Message boards : Number crunching : 15th Anni T-shirt discussions (Message 1553528)
Posted 8 Aug 2014 by Profile arkaynProject donor

This what the white shirt looks like. I like it better then a a black background.


I like darker T-shirts myself, probably because I wear white shirts for work.
52) Message boards : Cafe SETI : Weather Forecasts V (Message 1553413)
Posted 7 Aug 2014 by Profile arkaynProject donor
Also why I use a 11500 pump for mine.
53) Message boards : Cafe SETI : Weather Forecasts V (Message 1552452)
Posted 5 Aug 2014 by Profile arkaynProject donor
I got 0.54 inches, and all the washes were running last night.
54) Message boards : Cafe SETI : Weather Forecasts V (Message 1551460)
Posted 2 Aug 2014 by Profile arkaynProject donor
Thunderstorms and a power outage this morning. Continued thunderstorms for the weekend.
55) Message boards : Cafe SETI : Car transmissions - Standard or automatic? (Message 1551235)
Posted 2 Aug 2014 by Profile arkaynProject donor
I learned to drive in a 1979 Ford Fairmont Station wagon and a Ford F150 pickup truck.

The station wagon was automatic and the pickup was stick.

Most of my cars have been automatic though.
56) Message boards : Number crunching : FEED ME MORE - FEED ME MORE! (Message 1550784)
Posted 1 Aug 2014 by Profile arkaynProject donor
The kitties have no complaints....
They feast on AP when it is available and then dutifully crunch away at the MB cache to help the servers towards the next batch of AP.

It would be nice if the credits were normalized between the two types of work though.

AstroPulse v7 will probably do that. It is current being tested on Beta.


Most likely the wrong direction though.
57) Questions and Answers : Windows : BOINC Manager Can't Connect to localhost (Message 1550783)
Posted 1 Aug 2014 by Profile arkaynProject donor
I have two PCs that, until Apr, have successfully run the BOINC Manager (running two projects SETI and Einstein). Both are running Win7 (SP1) and ZoneAlarm Free. Windows Firewall is disabled. The computers are connected on a LAN with a DIR-645 DLink router. Regular Internet access is not impeded (games, e-mail, browsing, access to NAS).

One computer's OS was completely re-installed in Apr and, consequently, so was every application on that machine. BONIC Manager now refuses to connect to the localhost. On log in, I get a dialog which states that "BOINC has exited unexpectedly 3 times within the last 3 minutes. Would you like to restart it again?" Clicking "No" shows a BM status of "Disconnected".

I click on "Yes" and the status in the lower right hand corner says "Connecting to localhost". It eventually times out. When the screensaver starts, the screen reports that BOINC is not running.

I have tried reinstalling BOINC, and suspending the firewall and antivirus. I cannot specifically open any TCP ports with this version of ZoneAlarm but all of the BOINC executables and screensaver are at the "Super" trust level.

I've googled the problem and searched the BOINC forums and have not found an answer. I would really like to get this working again.

Please, any sage advice?

Cheers,

Skywalker


Check ZoneAlarm and make certain that BOINC can communicate on port 31416.
58) Message boards : Number crunching : CUDA Versions (Message 1549944)
Posted 30 Jul 2014 by Profile arkaynProject donor
ok here is Arkan's site

http://lunatics.kwsn.net/index.php


That is not my site, mine is http://www.arkayn.us/forum/index.php
59) Message boards : Cafe SETI : Raccoon Update XX - All are welcome in the Critter Cafe (Message 1549288)
Posted 29 Jul 2014 by Profile arkaynProject donor

Something like this is what I have in mind. The heat has burned the garden out for the summer so I am not going to show you a current picture.


Southern or Northern Arizona?

Kind of half way - Phoenix area.


To me that would be Southern, mostly.

I am definitely northern though.
60) Message boards : Cafe SETI : Raccoon Update XX - All are welcome in the Critter Cafe (Message 1548994)
Posted 28 Jul 2014 by Profile arkaynProject donor

Something like this is what I have in mind. The heat has burned the garden out for the summer so I am not going to show you a current picture.


Southern or Northern Arizona?


Previous 20 · Next 20

Copyright © 2014 University of California