Linux: Upgrade to the latest driver

Message boards : Number crunching : Linux: Upgrade to the latest driver
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile Igor_b

Send message
Joined: 25 Jun 00
Posts: 3
Credit: 764,932,348
RAC: 436,808
Poland
Message 1887903 - Posted: 4 Sep 2017, 20:09:28 UTC

Hello,

On one computer I'm running Seti@Home using BOINC 7.6.22.
The OS is Fedora 26 Server 64-bit GNU/Linux, fully updated.
This machine has nVidia GeForce GTX 260 GPU and the latest (340.102) official nVidia drivers are installed using a patch which fixed the famous kernel build problem.
BOINC properly detects the GPU, but it doesn't use it (no GPU tasks), reporting that the nVidia drivers should be updated.
Do you have any suggestions on how to fix this?
This is the BOINC log:
Mon 04 Sep 2017 09:47:43 PM CEST | | cc_config.xml not found - using defaults
Mon 04 Sep 2017 09:47:43 PM CEST | | Starting BOINC client version 7.6.22 for x86_64-pc-linux-gnu
Mon 04 Sep 2017 09:47:43 PM CEST | | log flags: file_xfer, sched_ops, task
Mon 04 Sep 2017 09:47:43 PM CEST | | Libraries: libcurl/7.53.1 NSS/3.31 zlib/1.2.11 libidn2/2.0.4 libpsl/0.18.0 (+libidn2/2.0.3) libssh2/1.8.0 nghttp2/1.21.1
Mon 04 Sep 2017 09:47:43 PM CEST | | Running as a daemon
Mon 04 Sep 2017 09:47:43 PM CEST | | Data directory: /var/lib/boinc
Mon 04 Sep 2017 09:47:43 PM CEST | | CUDA: NVIDIA GPU 0: GeForce GTX 260 (driver version 340.10, CUDA version 6.5, compute capability 1.3, 895MB, 812MB available, 907 GFLOPS peak)
Mon 04 Sep 2017 09:47:43 PM CEST | | OpenCL: NVIDIA GPU 0: GeForce GTX 260 (driver version 340.102, device version OpenCL 1.0 CUDA, 895MB, 812MB available, 907 GFLOPS peak)
Mon 04 Sep 2017 09:47:43 PM CEST | | Host name: granger
Mon 04 Sep 2017 09:47:43 PM CEST | | Processor: 4 GenuineIntel Intel(R) Core(TM) i5-4670K CPU @ 3.40GHz [Family 6 Model 60 Stepping 3]
Mon 04 Sep 2017 09:47:43 PM CEST | | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm cpuid_fault tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid xsaveopt dtherm arat pln pts
Mon 04 Sep 2017 09:47:43 PM CEST | | OS: Linux: 4.12.9-300.fc26.x86_64
Mon 04 Sep 2017 09:47:43 PM CEST | | Memory: 7.74 GB physical, 7.87 GB virtual
Mon 04 Sep 2017 09:47:43 PM CEST | | Disk: 14.99 GB total, 4.60 GB free
Mon 04 Sep 2017 09:47:43 PM CEST | | Local time is UTC +2 hours
Mon 04 Sep 2017 09:47:43 PM CEST | LHC@home | URL https://lhcathome.cern.ch/lhcathome/; Computer ID 10496895; resource share 60
Mon 04 Sep 2017 09:47:43 PM CEST | SETI@home | URL http://setiathome.berkeley.edu/; Computer ID 8333951; resource share 40
Mon 04 Sep 2017 09:47:43 PM CEST | SETI@home | General prefs: from SETI@home (last modified 24-Sep-2009 12:32:11)
Mon 04 Sep 2017 09:47:43 PM CEST | SETI@home | Computer location: work
Mon 04 Sep 2017 09:47:43 PM CEST | SETI@home | General prefs: no separate prefs for work; using your defaults
Mon 04 Sep 2017 09:47:43 PM CEST | | Reading preferences override file
Mon 04 Sep 2017 09:47:43 PM CEST | | Preferences:
Mon 04 Sep 2017 09:47:43 PM CEST | | max memory usage when active: 3963.07MB
Mon 04 Sep 2017 09:47:43 PM CEST | | max memory usage when idle: 7133.53MB
Mon 04 Sep 2017 09:47:43 PM CEST | | max disk usage: 0.67GB
Mon 04 Sep 2017 09:47:43 PM CEST | | max CPUs used: 3
Mon 04 Sep 2017 09:47:43 PM CEST | | don't use GPU while active
Mon 04 Sep 2017 09:47:43 PM CEST | | suspend work if non-BOINC CPU load exceeds 25%
Mon 04 Sep 2017 09:47:43 PM CEST | | (to change preferences, visit a project web site or select Preferences in the Manager)
Mon 04 Sep 2017 09:47:43 PM CEST | | Suspending computation - initial delay
Mon 04 Sep 2017 09:47:44 PM CEST | | Suspending GPU computation - computer is in use
Mon 04 Sep 2017 09:48:07 PM CEST | SETI@home | project resumed by user
Mon 04 Sep 2017 09:48:18 PM CEST | SETI@home | update requested by user
Mon 04 Sep 2017 09:48:18 PM CEST | SETI@home | Sending scheduler request: Requested by user.
Mon 04 Sep 2017 09:48:18 PM CEST | SETI@home | Reporting 1 completed tasks
Mon 04 Sep 2017 09:48:18 PM CEST | SETI@home | Requesting new tasks for CPU
Mon 04 Sep 2017 09:48:20 PM CEST | SETI@home | Scheduler request completed: got 2 new tasks
Mon 04 Sep 2017 09:48:20 PM CEST | SETI@home | Message from server: NVIDIA GPU: Upgrade to the latest driver to process tasks using your computer's GPU
ID: 1887903 · Report as offensive     Reply Quote
Profile ML1
Volunteer tester

Send message
Joined: 25 Nov 01
Posts: 9370
Credit: 7,024,043
RAC: 5,176
United Kingdom
Message 1887933 - Posted: 5 Sep 2017, 1:02:18 UTC

Might this be a misleading error message for an old GPU with too limited a compute capability version number?

Is the GTX250 ok for other Boinc projects? Such as Einstein or GIMPS as a test?


Keep searchin'
Martin
See new freedom: Mageia Linux
Take a look for yourself: Linux Format
The Future is what We all make IT (GPLv3)
ID: 1887933 · Report as offensive     Reply Quote
Profile Wiggo "Socialist"
Avatar

Send message
Joined: 24 Jan 00
Posts: 12599
Credit: 169,190,798
RAC: 86,104
Australia
Message 1887946 - Posted: 5 Sep 2017, 2:50:27 UTC

Nvidia drivers from 340.xx do not work well with pre-Fermi GPU's so try a slightly earlier driver to see if you get the same problem.]

Cheers.
ID: 1887946 · Report as offensive     Reply Quote
TBar
Volunteer tester

Send message
Joined: 22 May 99
Posts: 3789
Credit: 186,175,612
RAC: 237,325
United States
Message 1887949 - Posted: 5 Sep 2017, 4:32:03 UTC - in response to Message 1887903.  

...using a patch which fixed the famous kernel build problem.
I think Ubuntu provides driver 304 for this series card, you might try that driver. If you still can't get tasks I'd recommend using Anonymous platform with this App, CUDA 4.2 App with CPU App tuned to run on Intel CPUs with at least SSSE3.
I don't know if the CUDA 42 App will work with that 'patched' 340, but it works well with my GTS 250 with driver 337.25 from nVidia in Ubuntu.
ID: 1887949 · Report as offensive     Reply Quote
Profile Igor_b

Send message
Joined: 25 Jun 00
Posts: 3
Credit: 764,932,348
RAC: 436,808
Poland
Message 1887973 - Posted: 5 Sep 2017, 9:06:05 UTC
Last modified: 5 Sep 2017, 9:09:26 UTC

Thank you guys!
I didn't realized this GPU is so old.
I'll just try to change it to the one and I'll let you know about the results.
ID: 1887973 · Report as offensive     Reply Quote

Message boards : Number crunching : Linux: Upgrade to the latest driver


 
©2017 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.