Lunatics Windows Installer v0.42 Release Notes

Message boards : Number crunching : Lunatics Windows Installer v0.42 Release Notes
Message board moderation

To post messages, you must log in.

Previous · 1 . . . 4 · 5 · 6 · 7 · 8 · 9 · 10 . . . 12 · Next

AuthorMessage
Profile Mike Special Project $75 donor
Volunteer tester
Avatar

Send message
Joined: 17 Feb 01
Posts: 31321
Credit: 66,194,540
RAC: 24,963
Germany
Message 1557950 - Posted: 16 Aug 2014, 20:53:43 UTC

Instead of hair splitting we should be happy to have those options.
With each crime and every kindness we birth our future.
ID: 1557950 · Report as offensive
JohnDK Crowdfunding Project Donor*Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 28 May 00
Posts: 1041
Credit: 181,627,960
RAC: 294,627
Denmark
Message 1558900 - Posted: 18 Aug 2014, 20:51:34 UTC

Maybe a bit optimistic but would it be possible to make a program that could test a card and come up with a command line specific for that card?

(Not that I could make that program ;))
ID: 1558900 · Report as offensive
kittyman Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 9 Jul 00
Posts: 50084
Credit: 937,058,263
RAC: 236,191
United States
Message 1558902 - Posted: 18 Aug 2014, 20:53:06 UTC - in response to Message 1558900.  

Maybe a bit optimistic but would it be possible to make a program that could test a card and come up with a command line specific for that card?

(Not that I could make that program ;))

I think that Jason has been hard at work at such a thing.........
As you may imagine, it is NOT an easy task.
Happy is the person who shares their life with a cat. (Or two or three or........) =^.^=

Have made friends here.
Most were cats.
ID: 1558902 · Report as offensive
Profile HAL9000
Volunteer tester
Avatar

Send message
Joined: 11 Sep 99
Posts: 6530
Credit: 189,774,516
RAC: 15,332
United States
Message 1558913 - Posted: 18 Aug 2014, 21:18:33 UTC - in response to Message 1558900.  
Last modified: 18 Aug 2014, 21:32:04 UTC

Maybe a bit optimistic but would it be possible to make a program that could test a card and come up with a command line specific for that card?

(Not that I could make that program ;))

The benchmark tools could be used to do that. It just would be done manually. Automating various command line settings wouldn't be that hard. Just stuff the values in an array and go through all of them. It might takes a few hours(days) to check them all, but you would have the best values for your hardware.
SETI@home classic workunits: 93,865 CPU time: 863,447 hours
Join the BP6/VP6 User Group today!
ID: 1558913 · Report as offensive
Profile FalconFly
Avatar

Send message
Joined: 5 Oct 99
Posts: 394
Credit: 18,053,892
RAC: 0
Germany
Message 1559709 - Posted: 20 Aug 2014, 21:44:47 UTC - in response to Message 1558913.  
Last modified: 20 Aug 2014, 22:18:45 UTC

I need a quick advice for a team member :

He's running a Mobility Radeon HD5470 on a Win7 Notebook (intel i3 M330 CPU) and encountered errored out/abandoned AP Workunits after installing the v0.42.

It being a mobile GPU, is there any known limitation of the Mobility HD5470 "Cedar" GPU concerning AP or OpenCL in general ?

I assume it should be able to run :
- AP CPU SSE3 r2163
- MB CPU SSE4.2 r2549
- AP GPU SSE2 OpenCL_ATI r2399
- MB GPU SSE OpenCL_ATI r2489 (HD4xxx I presume, since it's a mobile GPU that was apparently still based on the same older Mobility HD4xxx generation GPUs)
ID: 1559709 · Report as offensive
Profile HAL9000
Volunteer tester
Avatar

Send message
Joined: 11 Sep 99
Posts: 6530
Credit: 189,774,516
RAC: 15,332
United States
Message 1559740 - Posted: 20 Aug 2014, 22:20:21 UTC - in response to Message 1559709.  
Last modified: 20 Aug 2014, 22:38:40 UTC

I need a quick advice for a team member :

He's running a Mobility Radeon HD5470 on a Win7 Notebook (intel i3 M330 CPU) and encountered errored out/abandoned AP Workunits after installing the v0.42.

It being a mobile GPU, is there any known limitation of the Mobility HD5470 "Cedar" GPU concerning AP or OpenCL in general ?

I assume it should be able to run :
- AP CPU SSE3
- MB CPU SSE4.2
- AP GPU SSE2 OpenCL_ATI r2399
- MB GPU SSE OpenCL_ATI (HD4xxx I presume, since it's a mobile GPU that was apparently still based on the same older Mobility HD4xxx generation GPUs)

My system with basically the same specs, the HD6370 is just a renamed HD5470, had an issue as well. The r2399 is not compatible with some cards with small WG size like these. Even -tune command line does not seem to help. You can have them try the values I was given to see if it does work on their system. However, I expect not.

Either use older GPU app work wait for v7 app if -tune also does not work for them.
SETI@home classic workunits: 93,865 CPU time: 863,447 hours
Join the BP6/VP6 User Group today!
ID: 1559740 · Report as offensive
Profile Cliff Harding
Volunteer tester
Avatar

Send message
Joined: 18 Aug 99
Posts: 1352
Credit: 89,988,782
RAC: 20,869
United States
Message 1559746 - Posted: 20 Aug 2014, 22:32:05 UTC

-use_sleep -unroll 10 -ffa_block 12288 -ffa_block_fetch 6144 -tune 1 64 4 1

Without the tune option, AP GPU (2 x GTX750Ti FTW - 2GB @ 2 tasks each) tasks total run times were averaging 1.5 - 1.75 hrs. With the option, with the few that I've seen validated already times of 1 hour. Again Mike, many thanks.


I don't buy computers, I build them!!
ID: 1559746 · Report as offensive
Profile FalconFly
Avatar

Send message
Joined: 5 Oct 99
Posts: 394
Credit: 18,053,892
RAC: 0
Germany
Message 1559777 - Posted: 20 Aug 2014, 23:35:16 UTC - in response to Message 1559740.  
Last modified: 20 Aug 2014, 23:50:42 UTC

My system with basically the same specs, the HD6370 is just a renamed HD5470, had an issue as well. The r2399 is not compatible with some cards with small WG size like these. Even -tune command line does not seem to help. You can have them try the values I was given to see if it does work on their system. However, I expect not.

Either use older GPU app work wait for v7 app if -tune also does not work for them.


Darn, I was fearing something like that... Thanks for the info.

I wonder if using the previous Lunatics v0.41 would help that, which is using older versions...
ID: 1559777 · Report as offensive
Cruncher-American Special Project $75 donor

Send message
Joined: 25 Mar 02
Posts: 1468
Credit: 282,305,042
RAC: 122,414
United States
Message 1560318 - Posted: 21 Aug 2014, 22:03:55 UTC

Dumb question: if I have both app_info.xml and app_config.xml, do the settings in app_config override those in app_info? In other words, can I set up my app_config with the parms for running AP and MB on my graphics cards, and not worry about what app_info says? (Or to put it differently, since it says somewhere above that the Installer doesn't do anything with app_config, that I don't need to mod app_info at all to control where threads run?)
ID: 1560318 · Report as offensive
Richard Haselgrove Project Donor
Volunteer tester

Send message
Joined: 4 Jul 99
Posts: 12180
Credit: 124,784,056
RAC: 39,253
United Kingdom
Message 1560329 - Posted: 21 Aug 2014, 22:37:56 UTC - in response to Message 1560318.  

Dumb question: if I have both app_info.xml and app_config.xml, do the settings in app_config override those in app_info? In other words, can I set up my app_config with the parms for running AP and MB on my graphics cards, and not worry about what app_info says? (Or to put it differently, since it says somewhere above that the Installer doesn't do anything with app_config, that I don't need to mod app_info at all to control where threads run?)

Correct - it says that in the opening post of this thread.

You are strongly recommended to use a version of BOINC which supports app_config.xml files. These can be used to manage the number of tasks running on each GPU more simply than by editing app_info.xml, and will NOT be removed by re-running this or subsequent installers.

And yes - if you create an app_config.xml file to control how many tasks run on each GPU, those figures override the app_info.xml figures. And for even finer control, most of the apps now have command-line parameters which can be set via a .txt or .cfg file - see the individual ReadMe files for each application for details.
ID: 1560329 · Report as offensive
Richard Haselgrove Project Donor
Volunteer tester

Send message
Joined: 4 Jul 99
Posts: 12180
Credit: 124,784,056
RAC: 39,253
United Kingdom
Message 1560695 - Posted: 22 Aug 2014, 17:31:08 UTC

As we were discussing yesterday in Glenn Savill's thread 'Lunatics not working', there are known problems which prevent two of the applications in the v0.42 installer working on older, smaller cards.

1) The Astropulse/OpenCL application for NVIDIA cards can fail to run on older cards like the 9800GT or GT 220.

2) The Astropulse/OpenCL application for ATI cards can fail to run on older cards like the HD5470/HD6370m with 'Max work group size: 128'

As a very quick and dirty temporary measure before this week's AP tasks run out, I have built a v0.42a installer with older replacements for the two troublesome apps. v0.42a contains the exact same builds that were in the v0.41 installer, so I'm pretty sure that, whilst not state of the art, they should run without error.

There have been rapid code changes in the preparation for Astropulse v7, and it's proving difficult to find a more recent v6 build that has passed all stages of testing. But I hope to have a v0.42b installer in place before next week's AP splitting run commences on Tuesday evening.

v0.42a is available now for download from http://1drv.ms/1vrU6pP, and v0.42b will be uploaded to there as well when ready.

Please note that these are interim releases only intended for users experiencing the specific problems listed above. Most users should continue downloading the original v0.42 installers direct from Luntics or our mirror site partners.
ID: 1560695 · Report as offensive
Profile BilBg
Volunteer tester
Avatar

Send message
Joined: 27 May 07
Posts: 3719
Credit: 9,318,314
RAC: 857
Bulgaria
Message 1560953 - Posted: 23 Aug 2014, 4:05:19 UTC - in response to Message 1560695.  
Last modified: 23 Aug 2014, 4:09:12 UTC

 
Add also this issue:
AP6_win_x86_SSE2_OpenCL_ATI_r2058 ... r2567
Fail on Catalyst 11.12 on Windows XP


AP6_win_x86_SSE2_OpenCL_ATI_r1843 works OK

Windows XP
AMD ATI Radeon HD 6570 (NI TURKS) [ASUS EAH6570/DI/1GD3(LP)]
Catalyst 11.12

==============

I reported this in PM to Raistmer on 16 Jul 2014
Next day I posted the copy of PM here (in the middle of the post):
http://setiathome.berkeley.edu/forum_thread.php?id=74864&postid=1543057#1543057

Then it was also reported by TBar (18 Jul 2014):
http://setiweb.ssl.berkeley.edu/beta/forum_thread.php?id=2182&postid=51630#51630

Then the 'debug session' was here (I continued in PMs because no RAC on SETI@home Beta):
"oclFFT's -34 failure in last AP builds debugging":
http://setiweb.ssl.berkeley.edu/beta/forum_thread.php?id=2185
 
 


- ALF - "Find out what you don't do well ..... then don't do it!" :)
 
ID: 1560953 · Report as offensive
Profile HAL9000
Volunteer tester
Avatar

Send message
Joined: 11 Sep 99
Posts: 6530
Credit: 189,774,516
RAC: 15,332
United States
Message 1560972 - Posted: 23 Aug 2014, 5:50:04 UTC - in response to Message 1560953.  

 
Add also this issue:
AP6_win_x86_SSE2_OpenCL_ATI_r2058 ... r2567
Fail on Catalyst 11.12 on Windows XP


AP6_win_x86_SSE2_OpenCL_ATI_r1843 works OK

Windows XP
AMD ATI Radeon HD 6570 (NI TURKS) [ASUS EAH6570/DI/1GD3(LP)]
Catalyst 11.12

==============

I reported this in PM to Raistmer on 16 Jul 2014
Next day I posted the copy of PM here (in the middle of the post):
http://setiathome.berkeley.edu/forum_thread.php?id=74864&postid=1543057#1543057

Then it was also reported by TBar (18 Jul 2014):
http://setiweb.ssl.berkeley.edu/beta/forum_thread.php?id=2182&postid=51630#51630

Then the 'debug session' was here (I continued in PMs because no RAC on SETI@home Beta):
"oclFFT's -34 failure in last AP builds debugging":
http://setiweb.ssl.berkeley.edu/beta/forum_thread.php?id=2185
 

Did you try the v7.02 app on Beta? It is based on build r2601.
SETI@home classic workunits: 93,865 CPU time: 863,447 hours
Join the BP6/VP6 User Group today!
ID: 1560972 · Report as offensive
Profile BilBg
Volunteer tester
Avatar

Send message
Joined: 27 May 07
Posts: 3719
Credit: 9,318,314
RAC: 857
Bulgaria
Message 1560979 - Posted: 23 Aug 2014, 6:33:11 UTC - in response to Message 1560972.  

Did you try the v7.02 app on Beta? It is based on build r2601.

The last I try was this build (AP7_win_x86_SSE2_OpenCL_ATI_r2567_oclFFT_11.12drv_issue_fix.7z):
http://setiweb.ssl.berkeley.edu/beta/forum_thread.php?id=2185&postid=51771#51771

It works in offline test


My computer is attached to Beta but the problem is (copy from my PM to Raistmer):

I try to run some stock ATI AstroPulse tasks on SETI@home Beta but I don't receive any
It seems there is no plan class for ATI AMD + old BOINC
http://setiweb.ssl.berkeley.edu/beta/apps.php

For NVIDIA there are cuda_opencl_100 and opencl_nvidia_100
For ATI only opencl_ati_100

Do you know why there is no ati_opencl_100 (which I think is the plan class name used for old BOINC)?
If ATI + old BOINC is not banned for purpose can you ask Eric to add ati_opencl_100 plan class for AstroPulse?

Is there a way to fake the BOINC version reported to the server?


I understand Russian so Raistmer answers in a 'common' language ;)

Привет.
Я Эрику про это уже писал. Собственно, для NV план по моей просьбе он и добавил.
С АТи пока думает как лучше сделать. У АТи есть битые драйвера - как их под BOINC 6 исключать - непонятно...

 


- ALF - "Find out what you don't do well ..... then don't do it!" :)
 
ID: 1560979 · Report as offensive
Profile HAL9000
Volunteer tester
Avatar

Send message
Joined: 11 Sep 99
Posts: 6530
Credit: 189,774,516
RAC: 15,332
United States
Message 1561099 - Posted: 23 Aug 2014, 14:34:48 UTC - in response to Message 1560979.  

Did you try the v7.02 app on Beta? It is based on build r2601.

The last I try was this build (AP7_win_x86_SSE2_OpenCL_ATI_r2567_oclFFT_11.12drv_issue_fix.7z):
http://setiweb.ssl.berkeley.edu/beta/forum_thread.php?id=2185&postid=51771#51771

It works in offline test

My computer is attached to Beta but the problem is (copy from my PM to Raistmer):

I try to run some stock ATI AstroPulse tasks on SETI@home Beta but I don't receive any
It seems there is no plan class for ATI AMD + old BOINC
http://setiweb.ssl.berkeley.edu/beta/apps.php

For NVIDIA there are cuda_opencl_100 and opencl_nvidia_100
For ATI only opencl_ati_100

Do you know why there is no ati_opencl_100 (which I think is the plan class name used for old BOINC)?
If ATI + old BOINC is not banned for purpose can you ask Eric to add ati_opencl_100 plan class for AstroPulse?

Is there a way to fake the BOINC version reported to the server?


I understand Russian so Raistmer answers in a 'common' language ;)

Привет.
Я Эрику про это уже писал. Собственно, для NV план по моей просьбе он и добавил.
С АТи пока думает как лучше сделать. У АТи есть битые драйвера - как их под BOINC 6 исключать - непонятно...

It is good the app version to fix that issue works on your system.
Your message:

Add also this issue:
AP6_win_x86_SSE2_OpenCL_ATI_r2058 ... r2567
Fail on Catalyst 11.12 on Windows XP

Seemed to say that all revisions from r2058 on did not work. Including AP7 r2567.
You can use app_info.xml on beta to specify whichever plan class you like.
SETI@home classic workunits: 93,865 CPU time: 863,447 hours
Join the BP6/VP6 User Group today!
ID: 1561099 · Report as offensive
kittyman Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 9 Jul 00
Posts: 50084
Credit: 937,058,263
RAC: 236,191
United States
Message 1561105 - Posted: 23 Aug 2014, 14:55:55 UTC

GPU usage on the new AP app..........sux.

Meow.
Happy is the person who shares their life with a cat. (Or two or three or........) =^.^=

Have made friends here.
Most were cats.
ID: 1561105 · Report as offensive
Richard Haselgrove Project Donor
Volunteer tester

Send message
Joined: 4 Jul 99
Posts: 12180
Credit: 124,784,056
RAC: 39,253
United Kingdom
Message 1561112 - Posted: 23 Aug 2014, 15:21:55 UTC - in response to Message 1561105.  

GPU usage on the new AP app..........sux.

Meow.

Specific details, please.

App revision number
GPU used
Driver used
Any non-standard configuration settings, like <count> or cmdline parameters
Link to sample TaskID, so we can read blanking %age and other details.
ID: 1561112 · Report as offensive
kittyman Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 9 Jul 00
Posts: 50084
Credit: 937,058,263
RAC: 236,191
United States
Message 1561118 - Posted: 23 Aug 2014, 15:30:30 UTC - in response to Message 1561112.  

GPU usage on the new AP app..........sux.

Meow.

Specific details, please.

App revision number
GPU used
Driver used
Any non-standard configuration settings, like <count> or cmdline parameters
Link to sample TaskID, so we can read blanking %age and other details.


Want to review?
My AP results.
Driver 334.89, the same I have used for a long time.
Yes, not the most current, but nobody had indicated a problem with it.
I have 9 rigs to maintain, and I don't make too many changes unless warranted.
I since install, changed count from 1 to .5 to get 2/per on the GPUs.
The command line is the one in the readme for top end GPUs. Cut and pasted, except I added the -use_sleep option, which works very well.

Have a look, the app sux.
Happy is the person who shares their life with a cat. (Or two or three or........) =^.^=

Have made friends here.
Most were cats.
ID: 1561118 · Report as offensive
Richard Haselgrove Project Donor
Volunteer tester

Send message
Joined: 4 Jul 99
Posts: 12180
Credit: 124,784,056
RAC: 39,253
United Kingdom
Message 1561119 - Posted: 23 Aug 2014, 15:37:55 UTC - in response to Message 1561118.  

Want to review?
My AP results.

You should know by now that UserID links are for the owner only - the rest of us have to follow HostID links.

And I'd prefer specific examples, please, rather than generalities: I have to pass this on to the developers, and I know that they will ignore vague grumblings. I would in their place.
ID: 1561119 · Report as offensive
Profile HAL9000
Volunteer tester
Avatar

Send message
Joined: 11 Sep 99
Posts: 6530
Credit: 189,774,516
RAC: 15,332
United States
Message 1561125 - Posted: 23 Aug 2014, 15:43:36 UTC - in response to Message 1561118.  

GPU usage on the new AP app..........sux.

Meow.

Specific details, please.

App revision number
GPU used
Driver used
Any non-standard configuration settings, like <count> or cmdline parameters
Link to sample TaskID, so we can read blanking %age and other details.


Want to review?
My AP results.
Driver 334.89, the same I have used for a long time.
Yes, not the most current, but nobody had indicated a problem with it.
I have 9 rigs to maintain, and I don't make too many changes unless warranted.
I since install, changed count from 1 to .5 to get 2/per on the GPUs.
The command line is the one in the readme for top end GPUs. Cut and pasted, except I added the -use_sleep option, which works very well.

Have a look, the app sux.

Did you really link to your user task list that you know no one else can see? :P

Looking on this machine. The run times for r1843 look to be nearly the same as r2399 for non-blanked tasks. If you switched form running 1 per GPU to 2 per GPU with the same run times that would indicate a good increase in performance. In this last batch a great deal of the work is blanked. So you might want to check that out for any specific examples.
SETI@home classic workunits: 93,865 CPU time: 863,447 hours
Join the BP6/VP6 User Group today!
ID: 1561125 · Report as offensive
Previous · 1 . . . 4 · 5 · 6 · 7 · 8 · 9 · 10 . . . 12 · Next

Message boards : Number crunching : Lunatics Windows Installer v0.42 Release Notes


 
©2018 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.