Problem with Screensaver


log in

Advanced search

Questions and Answers : Windows : Problem with Screensaver

Author Message
Manowar
Send message
Joined: 23 Feb 14
Posts: 1
Credit: 409
RAC: 0
Russia
Message 1481006 - Posted: 23 Feb 2014, 19:20:54 UTC
Last modified: 23 Feb 2014, 19:26:20 UTC

(sorry, i am from Russia, my English is maybe bad)
I have a problem with BOINC ScreenSaver. When he start, I see a BOINC logo and the text "BOINC screensaver loading". Then i see the very cool animated 3d-diagram, that displays current task. It's very good. But.... after 1 second i see windows's taskbar and the black screen. Then at once ScreenSaver download again, i see logo, diagram, windows's taskbar. So it's cyclically.
My videocard is ATI Radeon HD4850, i have manufacturer's driver installed.

P.S. I know about SETI@home preferences, i tried to change a field "Maximum CPU % for graphics" (values 20, 50, 80, 100). It didn't help me.

Profile Ageless
Avatar
Send message
Joined: 9 Jun 99
Posts: 12461
Credit: 2,690,003
RAC: 1,209
Netherlands
Message 1481072 - Posted: 23 Feb 2014, 22:28:28 UTC - in response to Message 1481006.

It's not your fault, it's a problem with the BOINC screen saver. The BOINC developers know of it and are trying to find a fix for it. Until that fix, you can either switch the screen saver off (Start\Control Panel\Appearance and Personalization\Personalization\Screen Saver\set it to None), or switch back to BOINC 7.2.33
____________
Jord

Fighting for the correct use of the apostrophe, together with Weird Al Yankovic

Otetiana
Send message
Joined: 18 Sep 01
Posts: 1
Credit: 1,046,862
RAC: 1,319
United States
Message 1481109 - Posted: 24 Feb 2014, 2:26:48 UTC

The screensaver display does not fill the 3D box with Time/Frequency/Power data. The rest of the Screensaver seems to work OK. I am running Windows 8.1. with Bionic 7.2.39. I could not find any settings in Preferences to correct the condition.
____________

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2894
Credit: 6,610,549
RAC: 7,936
Bulgaria
Message 1481247 - Posted: 24 Feb 2014, 15:58:04 UTC - in response to Message 1481109.

This is different problem.
You are using Intel HD Graphics - there are many threads here about this, e.g.:
http://setiathome.berkeley.edu/forum_thread.php?id=69101
http://setiathome.berkeley.edu/forum_thread.php?id=71007
http://setiathome.berkeley.edu/forum_thread.php?id=73010
http://setiathome.berkeley.edu/forum_thread.php?id=72841

http://boinc.berkeley.edu/dev/forum_thread.php?id=8856
____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Ryan Price
Avatar
Send message
Joined: 10 Feb 01
Posts: 2
Credit: 35,941
RAC: 0
Canada
Message 1481788 - Posted: 26 Feb 2014, 5:58:29 UTC
Last modified: 26 Feb 2014, 6:34:51 UTC

Problem solved! :)
____________
Ryan Price
I want to believe

rob smithProject donor
Volunteer tester
Send message
Joined: 7 Mar 03
Posts: 8809
Credit: 62,885,675
RAC: 75,181
United Kingdom
Message 1481790 - Posted: 26 Feb 2014, 6:10:18 UTC

Since you have a Nvidia GPU screensaver mode is not available
____________
Bob Smith
Member of Seti PIPPS (Pluto is a Planet Protest Society)
Somewhere in the (un)known Universe?

Ryan Price
Avatar
Send message
Joined: 10 Feb 01
Posts: 2
Credit: 35,941
RAC: 0
Canada
Message 1481796 - Posted: 26 Feb 2014, 6:36:11 UTC - in response to Message 1481790.

Thanks for the reply Bob, it's working fine now, I guess I just had to wait for it to do it's thing.
:)
____________
Ryan Price
I want to believe

TheDJ
Send message
Joined: 10 Feb 10
Posts: 2
Credit: 411,438
RAC: 30
Germany
Message 1514261 - Posted: 9 May 2014, 23:51:30 UTC
Last modified: 10 May 2014, 0:11:41 UTC

Hi together,
I'm experiencing the same problem as Manowar. I also participate in other projects with Screensaver support (rosetta, climateprediction etc.).

However, whenever I try to start the screensaver, I experience the same "flickering" as Manowar. I was just wondering if this is the same problem, that Ageless mentioned or if I have a wrong configuration.

What I was suprised about, was the fact, that the Computer list on the Seti@home webpage states, that my graphics card only uses OpenCL 1.1 - I have a Geforce GTX570M with latest drivers (335.23) installed directly from the "Geforce Experience" software.

[edit] I just checked the product page of my GTX570M on the Nvidia page and it says that it supports OpenCL 1.1. Does that mean I cannot use the Screensaver at all?

Profile JLDun
Volunteer tester
Avatar
Send message
Joined: 21 Apr 06
Posts: 307
Credit: 51,623
RAC: 0
United States
Message 1514293 - Posted: 10 May 2014, 3:24:03 UTC - in response to Message 1514261.

For any OpenCL workunit, the task will crunch, but the screensaver would work only if it's a CPU task. [OpenCL/CUDA are usually GPU, which is what the screensaver would use.]
____________

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2894
Credit: 6,610,549
RAC: 7,936
Bulgaria
Message 1514307 - Posted: 10 May 2014, 5:44:48 UTC - in response to Message 1514261.

Why do you think the Screensaver depends on OpenCL ?
It uses OpenGL

And if you "experience the same "flickering" as Manowar" then yes "this is the same problem, that Ageless mentioned"
(but you have 'Computers - hidden' so we can't know what BOINC version do you use)

Read:
http://boinc.berkeley.edu/dev/forum_thread.php?id=9009
http://boinc.berkeley.edu/dev/forum_thread.php?id=9145
____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

TheDJ
Send message
Joined: 10 Feb 10
Posts: 2
Credit: 411,438
RAC: 30
Germany
Message 1514338 - Posted: 10 May 2014, 9:19:18 UTC

Thanks for replying so fast! Sorry, I was mistaken about OpenCL/OpenGL. Somehow my mind played a trick on me, when I read this FAQ post - http://boincfaq.mundayweb.com/index.php?language=1&view=64&sessionID=9eb3b85be7ca3724fb88e0d07e90f339

Thank you also for helping me out with some other forum threads. I'm currently using the 7.2.42. version, therefore I now know, where the problem comes from.
I might be switching back to the .39 version then. Is there any possibility to do that without losing the progress on projects (I'm running a climateprediction-task and it would be a shame if I lost the credits for that one)?

Sorry for all the questions- I used BOINC several years ago on another computer and I noticed a lot of changes since then, so I just have to get used to new settings etc.

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2894
Credit: 6,610,549
RAC: 7,936
Bulgaria
Message 1514656 - Posted: 11 May 2014, 6:00:52 UTC - in response to Message 1514338.

I might be switching back to the .39 version then.

No, it's BOINC 7.2.33 and before (".39 version" have the problem)
(links to get it? - read again the second link)


Is there any possibility to do that without losing the progress on projects

I think you can just install BOINC 7.2.33 over your current BOINC (without losing the progress)
But it's your decision, you may wait until climateprediction task is finished and reported.
____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Questions and Answers : Windows : Problem with Screensaver

Copyright © 2014 University of California