Boinc client for Solaris 8?


log in

Advanced search

Questions and Answers : Unix/Linux : Boinc client for Solaris 8?

Author Message
Profile Mark Becker
Send message
Joined: 19 Feb 02
Posts: 5
Credit: 66,544
RAC: 0
United States
Message 1408224 - Posted: 27 Aug 2013, 5:08:52 UTC

Was looking at the system activity log and wondered why activity was around .01. Now I know; the seti client hasn't been receiving any work since around June 7!

Looks like I missed an update. Or several. Or a LOT.

The target computer is an UltraSparc-10 with gcc 3.4.6 . Ouch. Last fiddled with September 2006.

There's a client available for Solaris 8. According to that site, it was compiled with GCC 4.0 . Do I need to install 4.0 into the target computer so that the client will run?

This sounds like a massive effort; like near every tool in /usr/local/bin will need recompiling.

Thanks.

____________

rob smithProject donor
Volunteer tester
Send message
Joined: 7 Mar 03
Posts: 8398
Credit: 56,805,560
RAC: 78,003
United Kingdom
Message 1408227 - Posted: 27 Aug 2013, 5:18:29 UTC

You've certainly missed a few updates!
BOINC is now at version 7.something
and the SETI@Home application is at 7.0
I suspect you are going to have to recompile the source for both on your Solaris machine, but first it would be worth looking at: http://boinc.berkeley.edu/trac/wiki/DownloadOther as one may be in existence already.

Good luck.
____________
Bob Smith
Member of Seti PIPPS (Pluto is a Planet Protest Society)
Somewhere in the (un)known Universe?

Profile Mark Becker
Send message
Joined: 19 Feb 02
Posts: 5
Credit: 66,544
RAC: 0
United States
Message 1408640 - Posted: 28 Aug 2013, 3:21:53 UTC - in response to Message 1408227.

Hello Bob -

Yep.. looks like I missed a bunch.

I'll have to thread through that web page to find the sources. Thanks.

Mark

Questions and Answers : Unix/Linux : Boinc client for Solaris 8?

Copyright © 2014 University of California