Installing 64 bit BOINC on Ubuntu 12.04.2 64 bit Linux

Questions and Answers : Unix/Linux : Installing 64 bit BOINC on Ubuntu 12.04.2 64 bit Linux

To post messages, you must log in.

AuthorMessage
M0CZY
Avatar

Send message
Joined: 23 Sep 06
Posts: 7
Credit: 7,310
RAC: 3
United Kingdom
Message 1400589 - Posted: 8 Aug 2013, 12:24:04 UTC
Last modified: 8 Aug 2013, 12:25:35 UTC

What is the best way to install 64 bit BOINC on a Ubuntu 64 bit system?

I tried to install from the BOINC PPA, which would give me 7.0.27, but it wanted to install the 32 bit version.

The official Ubuntu repository only has 7.0.24, which if I remember, was very buggy.

I really want it installed properly, not just running from a folder in my Home folder.


The biggest threat to public safety and security is not terrorism, it is Government abuse of authority.

Bitcoin Donations: 1Le52kWoLz42fjfappoBmyg73oyvejKBR3

ID: 1400589 · Report as offensive
M0CZY
Avatar

Send message
Joined: 23 Sep 06
Posts: 7
Credit: 7,310
RAC: 3
United Kingdom
Message 1400612 - Posted: 8 Aug 2013, 13:44:15 UTC - in response to Message 1400589.
Last modified: 8 Aug 2013, 14:15:59 UTC

Further to my above post.

I downloaded the official 7.0.65 64 bit version from the BOINC website and tried to run it, but got the error:
./boinc: error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory

I tried doing: sudo apt-get install libXss

and got: E: Unable to locate package libXss

I don't know how to proceed from here. All I want is an installation of 64 bit BOINC that works.


The biggest threat to public safety and security is not terrorism, it is Government abuse of authority.

Bitcoin Donations: 1Le52kWoLz42fjfappoBmyg73oyvejKBR3

ID: 1400612 · Report as offensive
Profile arkaynProject Donor
Volunteer tester
Avatar

Send message
Joined: 14 May 99
Posts: 4097
Credit: 51,576,090
RAC: 1,593
United States
Message 1400637 - Posted: 8 Aug 2013, 14:42:20 UTC

There is a third party PPA that has the newest versions available.

https://launchpad.net/~costamagnagianfranco/+archive/locutusofborg-ppa



ID: 1400637 · Report as offensive
M0CZY
Avatar

Send message
Joined: 23 Sep 06
Posts: 7
Credit: 7,310
RAC: 3
United Kingdom
Message 1400647 - Posted: 8 Aug 2013, 15:27:11 UTC

There is a third party PPA that has the newest versions available.

https://launchpad.net/~costamagnagianfranco/+archive/locutusofborg-ppa


I tried using that PPA, and it wanted to download about 90 MB of 32 bit stuff.
Are you sure it will install 64 bit BOINC on my machine?
The biggest threat to public safety and security is not terrorism, it is Government abuse of authority.

Bitcoin Donations: 1Le52kWoLz42fjfappoBmyg73oyvejKBR3

ID: 1400647 · Report as offensive
Profile arkaynProject Donor
Volunteer tester
Avatar

Send message
Joined: 14 May 99
Posts: 4097
Credit: 51,576,090
RAC: 1,593
United States
Message 1400699 - Posted: 8 Aug 2013, 17:25:04 UTC - in response to Message 1400647.
Last modified: 8 Aug 2013, 17:43:00 UTC

There is a third party PPA that has the newest versions available.

https://launchpad.net/~costamagnagianfranco/+archive/locutusofborg-ppa


I tried using that PPA, and it wanted to download about 90 MB of 32 bit stuff.
Are you sure it will install 64 bit BOINC on my machine?


I'm testing the download now on my Linux Mint 15 installation, the last time I installed BOINC from there it was a 64-bit install.

[later]
Yes, it does install the 64-bit version.

Some of the 32-bit stuff might be dependencies for the BOINC install.

ID: 1400699 · Report as offensive
M0CZY
Avatar

Send message
Joined: 23 Sep 06
Posts: 7
Credit: 7,310
RAC: 3
United Kingdom
Message 1400796 - Posted: 8 Aug 2013, 21:00:01 UTC

OK, I've installed version 7.2.7 x64 to my satisfaction, and got it running on a few projects.

Thanks for your help and patience. I'll mark this thread as 'solved'.


The biggest threat to public safety and security is not terrorism, it is Government abuse of authority.

Bitcoin Donations: 1Le52kWoLz42fjfappoBmyg73oyvejKBR3

ID: 1400796 · Report as offensive
Martin Lategan

Send message
Joined: 15 Aug 13
Posts: 2
Credit: 38,561
RAC: 1
South Africa
Message 1404246 - Posted: 17 Aug 2013, 9:25:03 UTC

Hi everyone,

Is anyone else having an issue where Boinc just gives a Communication Deferred message and download failed?

Any Ideas or solutions for these issues?

Martin Lategan

ID: 1404246 · Report as offensive
Profile Gundolf Jahn

Send message
Joined: 19 Sep 00
Posts: 3184
Credit: 386,666
RAC: 39
Germany
Message 1404293 - Posted: 17 Aug 2013, 13:41:45 UTC - in response to Message 1404246.

Did you try setting some log flags (see Client configuration) to get more information in your BOINC event log?

Gruß
Gundolf


Computer sind nicht alles im Leben. (Kleiner Scherz)

SETI@home classic workunits 3,758
SETI@home classic CPU time 66,520 hours

ID: 1404293 · Report as offensive
Martin Lategan

Send message
Joined: 15 Aug 13
Posts: 2
Credit: 38,561
RAC: 1
South Africa
Message 1404629 - Posted: 18 Aug 2013, 9:40:31 UTC - in response to Message 1404293.

Thanks Gundolf, I'll give that a try and see what the logs say

ID: 1404629 · Report as offensive

Questions and Answers : Unix/Linux : Installing 64 bit BOINC on Ubuntu 12.04.2 64 bit Linux


 
©2016 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.