sorry to wingmen\women


log in

Advanced search

Message boards : Number crunching : sorry to wingmen\women

Author Message
Profile john3760
Avatar
Send message
Joined: 9 Feb 11
Posts: 334
Credit: 3,400,979
RAC: 0
United Kingdom
Message 1362717 - Posted: 29 Apr 2013, 22:55:38 UTC

Just back to SETI,with a new card.
Everything was going so well,( a few invalids which I had sorted out by downclocking slightly).Everything was going so well in fact,I decided to make " a few adjustments ".
OOPS

I have since returned all my settings to where they were before I fiddled with them,and I promise I probably won't do it again . 8/

John3760
____________

Profile WilliamProject donor
Volunteer tester
Avatar
Send message
Joined: 14 Feb 13
Posts: 1602
Credit: 9,469,424
RAC: 265
Message 1362829 - Posted: 30 Apr 2013, 7:55:37 UTC

Well you managed to kill your cache very spectacularly :)
Actually you managed to get into a DL kill loop?

What on earth were you trying to do, to get those particular errors - never seen them before?

If you need help with an upgrade to x41zc, just give us a shout.
____________
A person who won't read has no advantage over one who can't read. (Mark Twain)

Profile Wiggo
Avatar
Send message
Joined: 24 Jan 00
Posts: 7141
Credit: 95,330,379
RAC: 73,268
Australia
Message 1362832 - Posted: 30 Apr 2013, 8:01:32 UTC - in response to Message 1362717.
Last modified: 30 Apr 2013, 8:02:13 UTC

Just back to SETI,with a new card.
Everything was going so well,( a few invalids which I had sorted out by downclocking slightly).Everything was going so well in fact,I decided to make " a few adjustments ".
OOPS

I have since returned all my settings to where they were before I fiddled with them,and I promise I probably won't do it again . 8/

John3760

Don't worry I screwed 100 on my 2500K last week but at least they were sent out again quickly and only 4 of them are left now and you don't mind.

William, you may get a PM from me if I can't solve something by myself in the next week or so if I can find some free time.

Cheers.

Profile john3760
Avatar
Send message
Joined: 9 Feb 11
Posts: 334
Credit: 3,400,979
RAC: 0
United Kingdom
Message 1362835 - Posted: 30 Apr 2013, 8:13:13 UTC - in response to Message 1362829.

Thanks William,

Yes I tried to upgrade,to 41zc.
I am going to leave it for a little while before I try again,and I will PM you before I do it,as I need a day off work to do it.

Thanks again !! :)

John3760
____________

Profile john3760
Avatar
Send message
Joined: 9 Feb 11
Posts: 334
Credit: 3,400,979
RAC: 0
United Kingdom
Message 1365294 - Posted: 6 May 2013, 23:38:36 UTC - in response to Message 1362829.
Last modified: 6 May 2013, 23:47:52 UTC

Thanks again William

Well you managed to kill your cache very spectacularly :)
Actually you managed to get into a DL kill loop?

What on earth were you trying to do, to get those particular errors - never seen them before?

If you need help with an upgrade to x41zc, just give us a shout.


Looking back,I think I downloaded the wrong app for my card (NV660 ti).
I tried the 50 app(Kepler) instead of the 42(Fermi),and compounded the problem using my "unadvanced user" abilities,and inability to read instructions properly.

I am currently running my cache down,so that i dont trash another couple of hundred WUs,before I try again.

All of the relevant dlls etc are in my programme data file,but as I said before,I have pressed the "no new tasks" button and I am waiting until all my current WUs are complete before I unleash my APP INFO file.

I copied and pasted together the .aistub files that came with each opt app,as I couldnt write one from scratch,and ended up with this :-

<app_info>
<app>
<name>astropulse_v6</name>
</app>
<file_info>
<name>AP6_win_x86_SSE2_OpenCL_NV_r1761.exe</name>
<executable/>
</file_info>
<file_info>
<name>libfftw3f-3.dll</name>
<executable/>
</file_info>
<file_info>
<name>ap_cmdline_win_x86_SSE2_OpenCL_NV.txt</name>
</file_info>
<app_version>
<app_name>astropulse_v6</app_name>
<version_num>604</version_num>
<platform>windows_intelx86</platform>
<avg_ncpus>0.04</avg_ncpus>
<max_ncpus>0.2</max_ncpus>
<plan_class>cuda_opencl_100</plan_class>
<cmdline></cmdline>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>AP6_win_x86_SSE2_OpenCL_NV_r1761.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>libfftw3f-3.dll</file_name>
</file_ref>
<file_ref>
<file_name>ap_cmdline_win_x86_SSE2_OpenCL_NV.txt</file_name>
<open_name>ap_cmdline.txt</open_name>
</file_ref>
</app_version>
<app_version>
<app_name>astropulse_v6</app_name>
<version_num>604</version_num>
<platform>windows_intelx86</platform>
<avg_ncpus>0.04</avg_ncpus>
<max_ncpus>0.2</max_ncpus>
<plan_class>opencl_nvidia_100</plan_class>
<cmdline></cmdline>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>AP6_win_x86_SSE2_OpenCL_NV_r1761.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>libfftw3f-3.dll</file_name>
</file_ref>
<file_ref>
<file_name>ap_cmdline_win_x86_SSE2_OpenCL_NV.txt</file_name>
<open_name>ap_cmdline.txt</open_name>
</file_ref>
</app_version>
<app>
<name>astropulse_v6</name>
</app>
<file_info>
<name>AP6_win_x86_SSE2_OpenCL_NV_r1761.exe</name>
<executable/>
</file_info>
<file_info>
<name>libfftw3f-3.dll</name>
<executable/>
</file_info>
<file_info>
<name>ap_cmdline_win_x86_SSE2_OpenCL_NV.txt</name>
</file_info>
<app_version>
<app_name>astropulse_v6</app_name>
<version_num>604</version_num>
<platform>windows_intelx86</platform>
<avg_ncpus>0.04</avg_ncpus>
<max_ncpus>0.2</max_ncpus>
<plan_class>cuda_opencl_100</plan_class>
<cmdline></cmdline>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>AP6_win_x86_SSE2_OpenCL_NV_r1761.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>libfftw3f-3.dll</file_name>
</file_ref>
<file_ref>
<file_name>ap_cmdline_win_x86_SSE2_OpenCL_NV.txt</file_name>
<open_name>ap_cmdline.txt</open_name>
</file_ref>
</app_version>
<app_version>
<app_name>astropulse_v6</app_name>
<version_num>604</version_num>
<platform>windows_intelx86</platform>
<avg_ncpus>0.04</avg_ncpus>
<max_ncpus>0.2</max_ncpus>
<plan_class>opencl_nvidia_100</plan_class>
<cmdline></cmdline>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>AP6_win_x86_SSE2_OpenCL_NV_r1761.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>libfftw3f-3.dll</file_name>
</file_ref>
<file_ref>
<file_name>ap_cmdline_win_x86_SSE2_OpenCL_NV.txt</file_name>
<open_name>ap_cmdline.txt</open_name>
</file_ref>
</app_version>
<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>Lunatics_x41zc_win32_cuda42.exe</name>
<executable/>
</file_info>
<file_info>
<name>cudart32_42_9.dll</name>
<executable/>
</file_info>
<file_info>
<name>cufft32_42_9.dll</name>
<executable/>
</file_info>
<file_info>
<name>mbcuda.cfg</name>
</file_info>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>610</version_num>
<platform>windows_intelx86</platform>
<plan_class>cuda_fermi</plan_class>
<avg_ncpus>0.040000</avg_ncpus>
<max_ncpus>0.040000</max_ncpus>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>Lunatics_x41zc_win32_cuda42.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart32_42_9.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft32_42_9.dll</file_name>
</file_ref>
<file_ref>
<file_name>mbcuda.cfg</file_name>
</file_ref>
</app_version>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>609</version_num>
<platform>windows_intelx86</platform>
<plan_class>cuda23</plan_class>
<avg_ncpus>0.040000</avg_ncpus>
<max_ncpus>0.040000</max_ncpus>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>Lunatics_x41zc_win32_cuda42.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart32_42_9.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft32_42_9.dll</file_name>
</file_ref>
<file_ref>
<file_name>mbcuda.cfg</file_name>
</file_ref>
</app_version>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>608</version_num>
<platform>windows_intelx86</platform>
<plan_class>cuda</plan_class>
<avg_ncpus>0.040000</avg_ncpus>
<max_ncpus>0.040000</max_ncpus>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>Lunatics_x41zc_win32_cuda42.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart32_42_9.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft32_42_9.dll</file_name>
</file_ref>
<file_ref>
<file_name>mbcuda.cfg</file_name>
</file_ref>
</app_version>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>610</version_num>
<platform>windows_x86_64</platform>
<plan_class>cuda_fermi</plan_class>
<avg_ncpus>0.040000</avg_ncpus>
<max_ncpus>0.040000</max_ncpus>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>Lunatics_x41zc_win32_cuda42.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart32_42_9.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft32_42_9.dll</file_name>
</file_ref>
<file_ref>
<file_name>mbcuda.cfg</file_name>
</file_ref>
</app_version>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>609</version_num>
<platform>windows_x86_64</platform>
<plan_class>cuda23</plan_class>
<avg_ncpus>0.040000</avg_ncpus>
<max_ncpus>0.040000</max_ncpus>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>Lunatics_x41zc_win32_cuda42.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart32_42_9.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft32_42_9.dll</file_name>
</file_ref>
<file_ref>
<file_name>mbcuda.cfg</file_name>
</file_ref>
</app_version>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>608</version_num>
<platform>windows_x86_64</platform>
<plan_class>cuda</plan_class>
<avg_ncpus>0.040000</avg_ncpus>
<max_ncpus>0.040000</max_ncpus>
<coproc>
<type>CUDA</type>
<count>1</count>
</coproc>
<file_ref>
<file_name>Lunatics_x41zc_win32_cuda42.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>cudart32_42_9.dll</file_name>
</file_ref>
<file_ref>
<file_name>cufft32_42_9.dll</file_name>
</file_ref>
<file_ref>
<file_name>mbcuda.cfg</file_name>
</file_ref>
</app_version>
</app_info>

Is there any chance of this working when I use it?
I have also added -unroll 10 -ffa_block 6144 -ffa_block_fetch 1536 -hp to the ap_cmdline_win_x86_SSE2_OpenCL_NV.txt file,which I got from another thread.

It will probably be Wednesday when I try again.

I can always revert back to 41b and my current APP INFO if it feels like my brain is about to explode :)

Any advice would be appreciated, thanks

john3760

EDIT I think I may have repeated some of the 41zc bit in the app info!
____________

Profile Cliff HardingProject donor
Volunteer tester
Avatar
Send message
Joined: 18 Aug 99
Posts: 992
Credit: 52,095,136
RAC: 41,254
United States
Message 1365326 - Posted: 7 May 2013, 2:21:19 UTC - in response to Message 1365294.
Last modified: 7 May 2013, 2:21:56 UTC

Looking back,I think I downloaded the wrong app for my card (NV660 ti).
I tried the 50 app(Kepler) instead of the 42(Fermi),and compounded the problem using my "unadvanced user" abilities,and inability to read instructions properly.



I believe your GTX660Ti is a Kepler card and the _x41zc_cuda50 app would have been the right one for that card. I will let someone else figure out the problem(s).
____________


I don't buy computers, I build them!!

Profile john3760
Avatar
Send message
Joined: 9 Feb 11
Posts: 334
Credit: 3,400,979
RAC: 0
United Kingdom
Message 1365362 - Posted: 7 May 2013, 6:58:48 UTC - in response to Message 1365326.

Thanks,

I think its the 104 chip so you are right.The 660 used a different chip(106).
The 660ti seems to be a cut down version of the 670/680.

I will redo the app info again when I get back from work, and put the cuda50 app back in my programme data folder.

I still have a day or two left in my cache,so Ive get plenty of time to do it.

thanks again

john3760



____________

Profile WilliamProject donor
Volunteer tester
Avatar
Send message
Joined: 14 Feb 13
Posts: 1602
Credit: 9,469,424
RAC: 265
Message 1365381 - Posted: 7 May 2013, 10:13:18 UTC

Anything from 3.2 onwards works on Fermi/Kepler - just with different speeds. On Kepler Cuda 5.0 is fastest.

You seem to be on a working Lunatics 0.40 install - you can keep that setup, you just need to edit app_info.xml to reflect the newer apps you want to use.

AFAIK Raistmer is handing out an .aistub with his apps as well - makes life far easier - um somebody might want to crosscheck that holds true for AP NV r1761 as well...
First, make a backup of your working app_info.xml - just in case.

Unpack the new packages (x41zc_cuda50 (64bit), AP6_win_x86_SSE2_OpenCL_NV_r1761) into the project direcory - make sure the suppiled .aistub files overwrite the existing ones. Run aimerge (in your project dir from the Lunatics installer). If necessary and wished, change <count> variables. Adjust OpenCL commandlines (see readme) adjust mbcuda.cfg (see x41zc readme or cfg file). You should be good to go.
If in doubt, post app_info.xml.

HTH - NB I'm offline for the rest of the week but there are plenty of other helping eyes around.
____________
A person who won't read has no advantage over one who can't read. (Mark Twain)

Profile Fred E.Project donor
Volunteer tester
Send message
Joined: 22 Jul 99
Posts: 768
Credit: 24,139,004
RAC: 7
United States
Message 1365402 - Posted: 7 May 2013, 11:43:31 UTC

AFAIK Raistmer is handing out an .aistub with his apps as well - makes life far easier - um somebody might want to crosscheck that holds true for AP NV r1761 as well...

Yes the download zip file includes the aistub file, and that made it easier to install than the prior version.Here's link for the package:

http://lunatics.kwsn.net/index.php?module=Downloads;sa=dlview;id=354

The OpenCL command line parameters are important for this app, and the readme has some good info on how to choose them.
____________
Another Fred
Support SETI@home when you search the Web with GoodSearch or shop online with GoodShop.

Profile john3760
Avatar
Send message
Joined: 9 Feb 11
Posts: 334
Credit: 3,400,979
RAC: 0
United Kingdom
Message 1365417 - Posted: 7 May 2013, 12:40:10 UTC - in response to Message 1365381.
Last modified: 7 May 2013, 12:42:28 UTC

Thanks again! ,
I've done a bit more reading since my last attempt :)

I will deffinately get there in the end,it might just take a couple of goes.

I'm going with CUDA50 , I will redo the APP INFO tonight when I get in,and reinstall the DLLs.
Hopefully I'll run out of work tomorrow then I'll give it a go.

And thanks Fred!!

John3760
____________

Profile john3760
Avatar
Send message
Joined: 9 Feb 11
Posts: 334
Credit: 3,400,979
RAC: 0
United Kingdom
Message 1365553 - Posted: 7 May 2013, 22:53:01 UTC

Thanks !!!!

It seems to be working,I'll find out fully when I wake up for work in 5 hours time.
My head is battered, but I have a better understanding of how everything goes together now :)

John3760
____________

Profile john3760
Avatar
Send message
Joined: 9 Feb 11
Posts: 334
Credit: 3,400,979
RAC: 0
United Kingdom
Message 1365649 - Posted: 8 May 2013, 7:11:29 UTC

Well everything seems to be running ok,I will adjust the openCL Config files in due course.

One Astropulse though, finished in 3 seconds ( the wingman a bit less !!! ) and validated with a SETI TOASTER score of 600+ .
Can that be right,or have two invalids become the right result ???

John3760
____________

ClaggyProject donor
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 4101
Credit: 33,141,197
RAC: 7,353
United Kingdom
Message 1365671 - Posted: 8 May 2013, 8:03:25 UTC - in response to Message 1365649.
Last modified: 8 May 2013, 8:04:57 UTC

One Astropulse though, finished in 3 seconds ( the wingman a bit less !!! ) and validated with a SETI TOASTER score of 600+ .
Can that be right,or have two invalids become the right result ???

That app version hasn't completed it's 10 validations yet, probably was on Zero then so server didn't know how much time a full Wu takes, i think it'll use the average for anonymous platform (for that app_version), so 603.65 Credits,
both your tasks reported at that time had the same wingman, both those tasks were reported by your wingman at the same time too,
the 2nd task reported probably used your wingman's app_version to determine the amount of Credit awarded, hence 790.88 Credits, (he's running Stock with lots of completions)

Claggy

Profile john3760
Avatar
Send message
Joined: 9 Feb 11
Posts: 334
Credit: 3,400,979
RAC: 0
United Kingdom
Message 1365708 - Posted: 8 May 2013, 10:56:43 UTC

Thanks Claggy,
It still seems odd that I took 3 secs, my wingman 2 and a bit secs and it gave 603 points :/

While I'm on ,
In an earlier post in this thread, I posted an ( I will use the term loosely ) App Info printout.
If anybody is considering copying and pasting it , don't , it won't work sorry.
It was my feeble attempt at cobbling together an app info.Luckily SETI was down for maintenance an no WUs were harmed .
____________

Profile john3760
Avatar
Send message
Joined: 9 Feb 11
Posts: 334
Credit: 3,400,979
RAC: 0
United Kingdom
Message 1366245 - Posted: 10 May 2013, 7:45:36 UTC

A small update on th Astropulse GPU WUs.


This may or may not be a problem,(I for one am quite happy with the times !)
but it seems as though my completion times are pretty close to my CPU usage times on every WU.

All of my wingmen seem to have CPU usage times that are about half of the completion time.

Although the GPU WUs are a lot quicker than my Astropulse CPU WUs, it seems to me that the GPU ones are using a lot of the CPU compared to other people using the same opt app.

thanks

john3760


____________

Profile MikeProject donor
Volunteer tester
Avatar
Send message
Joined: 17 Feb 01
Posts: 24197
Credit: 33,335,404
RAC: 23,972
Germany
Message 1366260 - Posted: 10 May 2013, 8:18:11 UTC - in response to Message 1366245.

A small update on th Astropulse GPU WUs.


This may or may not be a problem,(I for one am quite happy with the times !)
but it seems as though my completion times are pretty close to my CPU usage times on every WU.

All of my wingmen seem to have CPU usage times that are about half of the completion time.

Although the GPU WUs are a lot quicker than my Astropulse CPU WUs, it seems to me that the GPU ones are using a lot of the CPU compared to other people using the same opt app.

thanks

john3760



Thats a known issue on nvidia GPU`s.
Nothing to worry about.



____________

Profile john3760
Avatar
Send message
Joined: 9 Feb 11
Posts: 334
Credit: 3,400,979
RAC: 0
United Kingdom
Message 1366269 - Posted: 10 May 2013, 8:37:21 UTC - in response to Message 1366260.

Thanks,

I was just wondering :)

John3760
____________

Profile arkaynProject donor
Volunteer tester
Avatar
Send message
Joined: 14 May 99
Posts: 3654
Credit: 48,600,912
RAC: 2,299
United States
Message 1366382 - Posted: 10 May 2013, 16:40:38 UTC - in response to Message 1366260.

A small update on th Astropulse GPU WUs.


This may or may not be a problem,(I for one am quite happy with the times !)
but it seems as though my completion times are pretty close to my CPU usage times on every WU.

All of my wingmen seem to have CPU usage times that are about half of the completion time.

Although the GPU WUs are a lot quicker than my Astropulse CPU WUs, it seems to me that the GPU ones are using a lot of the CPU compared to other people using the same opt app.

thanks

john3760



Thats a known issue on nvidia GPU`s.
Nothing to worry about.




I can even point you to my split personality machine and it's OpenCL AP work on Linux.

http://setiathome.berkeley.edu/results.php?hostid=6961644&offset=0&show_names=0&state=0&appid=12
____________

Profile john3760
Avatar
Send message
Joined: 9 Feb 11
Posts: 334
Credit: 3,400,979
RAC: 0
United Kingdom
Message 1366639 - Posted: 11 May 2013, 4:14:41 UTC - in response to Message 1366382.

Now I'm confused Arkayn,

I don't understand how CPU usage time can be greater than the completion time!!

John3760
____________

Profile arkaynProject donor
Volunteer tester
Avatar
Send message
Joined: 14 May 99
Posts: 3654
Credit: 48,600,912
RAC: 2,299
United States
Message 1366644 - Posted: 11 May 2013, 4:36:45 UTC - in response to Message 1366639.

Now I'm confused Arkayn,

I don't understand how CPU usage time can be greater than the completion time!!

John3760


That happens if I am doing something CPU intensive on the machine during the run, especially when it wants to use the CPU right at that moment.
____________

Message boards : Number crunching : sorry to wingmen\women

Copyright © 2014 University of California