Seti, BOINC 7.0.28 going to 7.0.6x and 197 (0xc5) EXIT_TIME_LIMIT_EXCEEDED error on GPU work

Questions and Answers : GPU applications : Seti, BOINC 7.0.28 going to 7.0.6x and 197 (0xc5) EXIT_TIME_LIMIT_EXCEEDED error on GPU work

To post messages, you must log in.

AuthorMessage
Profile Ageless
Avatar

Send message
Joined: 9 Jun 99
Posts: 13822
Credit: 3,269,733
RAC: 0
Netherlands
Message 1348055 - Posted: 18 Mar 2013, 13:09:18 UTC

When you've updated to the latest and greatest (release candidate) (alpha) BOINC, coming from BOINC 7.0.28 or before, AND when crunching work on an anonymous platform GPU application (such as the ones from Lunatics), you have a good chance that all your work errs with a 197 (0xc5) EXIT_TIME_LIMIT_EXCEEDED error.

This is because of an addition to the code in BOINC 7.0.33, where when you run the anonymous platform and you have not supplied a flops value in your app_info.xml file, that the flops value used for GPU tasks is increased by a factor of 10.

It will only affect old work still in cache from before the upgrade. Any newer work your BOINC downloads, will not be affected.

Two ways to work around this:
1. Before you upgrade, set No New Tasks and run your cache empty. Report all. Then upgrade to the new version and set Allow New Tasks.

2. Done the upgrade with a full cache? Reset the project. This will throw away all present work in cache, but since the project has resend lost work available, your tasks will be resent to you and seen as new work.
Jord

Ancient Astronaut Theorists suggest that in many ways, you can be considered an alien conspiracy!
ID: 1348055 · Report as offensive
Richard HaselgroveProject Donor
Volunteer tester

Send message
Joined: 4 Jul 99
Posts: 11143
Credit: 83,845,636
RAC: 46,284
United Kingdom
Message 1360395 - Posted: 23 Apr 2013, 22:03:36 UTC

Update 23 April 2013

BOINC versions 7.0.64 (for Windows) and 7.0.65 (for Linux and Mac OS X) have been declared the 'recommended' version, as of this evening.

Ageless' warning about EXIT_TIME_LIMIT_EXCEEDED still applies to these new recommended versions

Users running GPU applications under anonymous platform should think carefully before following the notifications advising you to upgrade, which will shortly start appearing in your message/event logs.

If you are currently running v7.0.28 (the old recommended version) or earlier, set 'No New Tasks' to run down your cache before upgrading, otherwise you risk wasting time on work which will fail.

If you:
1) Don't use a GPU for crunching.
2) Run stock applications
3) Are already running v7.0.30 or later

don't worry - any one of those is enough to protect you from the effects of this change: upgrade whenever you want.
ID: 1360395 · Report as offensive

Questions and Answers : GPU applications : Seti, BOINC 7.0.28 going to 7.0.6x and 197 (0xc5) EXIT_TIME_LIMIT_EXCEEDED error on GPU work


 
©2016 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.