Error while computing cuda_fermi


log in

Advanced search

Message boards : Number crunching : Error while computing cuda_fermi

1 · 2 · Next
Author Message
Starman
Avatar
Send message
Joined: 15 May 99
Posts: 133
Credit: 35,310,213
RAC: 49,267
Canada
Message 1346953 - Posted: 15 Mar 2013, 18:36:36 UTC

OK, have my firm Nvidia card crunching and all cuda_fermi wu are erroring out.

Stderr output
<core_client_version>7.0.28</core_client_version>
<![CDATA[
<message>
Incorrect function. (0x1) - exit code 1 (0x1)
</message>
<stderr_txt>
setiathome_CUDA: Found 1 CUDA device(s):
Device 1 : GeForce GT 640
totalGlobalMem = 1073741824
sharedMemPerBlock = 49152
regsPerBlock = 65536
warpSize = 32
memPitch = 2147483647
maxThreadsPerBlock = 1024
clockRate = 954000
totalConstMem = 65536
major = 3
minor = 0
textureAlignment = 512
deviceOverlap = 1
multiProcessorCount = 2
setiathome_CUDA: CUDA Device 1 specified, checking...
Device 1: GeForce GT 640 is okay
SETI@home using CUDA accelerated device GeForce GT 640
setiathome_enhanced 6.09 Visual Studio/Microsoft C++
libboinc: 6.3.22

Work Unit Info:
...............
WU true angle range is : 1.162030
Optimal function choices:
-----------------------------------------------------
name
-----------------------------------------------------
v_BaseLineSmooth (no other)
v_GetPowerSpectrum 0.00018 0.00000
v_ChirpData 0.00831 0.00000
v_Transpose4 0.00263 0.00000
FPU opt folding 0.00146 0.00000
CUFFT error in file 'd:/Projects/SETI/seti_boinc/client/cuda/cudaAcc_fft.cu' in line 62.

</stderr_txt>
]]>

Machine is EWABRETT

Any and suggestions welcome.

Thanks,

Brett
____________

Richard HaselgroveProject donor
Volunteer tester
Send message
Joined: 4 Jul 99
Posts: 8436
Credit: 47,934,033
RAC: 58,701
United Kingdom
Message 1346968 - Posted: 15 Mar 2013, 18:49:42 UTC - in response to Message 1346953.
Last modified: 15 Mar 2013, 19:14:11 UTC

Although your GT640 is indeed a Fermi card (compute capability 2.1), have you tried setting the CUDA_GRID_SIZE_COMPAT environment variable described for Kepler cards in the driver problems thread?

I doubt that it will cure it, but it won't do any harm.

Edit - what's that

major = 3
minor = 0

doing in there? Looks like CC 3.0 - in which case the environment variable will help, and NVidia's documentation is wrong. What make/model is that GT640?

2nd. edit - according to wikipedia, there are four different versions of the GT 640 - three of them are Keplers, and only one is a Fermi. So http://www.nvidia.co.uk/object/cuda_gpus_uk.html only has a 25% chance of being right. Gnash.

spitfire_mk_2
Avatar
Send message
Joined: 14 Apr 00
Posts: 442
Credit: 12,255,681
RAC: 5,560
United States
Message 1346986 - Posted: 15 Mar 2013, 19:50:06 UTC

This might be a shot in the dark, but people have been having problems with BOINC 7.0.28. I would suggest trying BOINC 7.0.25
____________

Profile arkaynProject donor
Volunteer tester
Avatar
Send message
Joined: 14 May 99
Posts: 3615
Credit: 48,202,303
RAC: 35,893
United States
Message 1347002 - Posted: 15 Mar 2013, 20:04:39 UTC - in response to Message 1346986.

This might be a shot in the dark, but people have been having problems with BOINC 7.0.28. I would suggest trying BOINC 7.0.25


Better would be 7.0.56.
http://boinc.berkeley.edu/dl/?C=M;O=D
____________

Starman
Avatar
Send message
Joined: 15 May 99
Posts: 133
Credit: 35,310,213
RAC: 49,267
Canada
Message 1347012 - Posted: 15 Mar 2013, 20:17:44 UTC - in response to Message 1346968.

It's a Dell XPS 8500 with a NVIDIA GT640 1gb GDDR5. As to what specific model number, I do not know.
____________

Starman
Avatar
Send message
Joined: 15 May 99
Posts: 133
Credit: 35,310,213
RAC: 49,267
Canada
Message 1347014 - Posted: 15 Mar 2013, 20:25:19 UTC - in response to Message 1347002.

No Joy on 7.0.56
____________

ClaggyProject donor
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 4058
Credit: 32,802,646
RAC: 5,161
United Kingdom
Message 1347023 - Posted: 15 Mar 2013, 20:33:58 UTC - in response to Message 1347014.

No Joy on 7.0.56


I'm not surprised, as it's an application problem, not a Boinc problem, see Richard's advice.

Claggy

Starman
Avatar
Send message
Joined: 15 May 99
Posts: 133
Credit: 35,310,213
RAC: 49,267
Canada
Message 1347027 - Posted: 15 Mar 2013, 20:45:27 UTC - in response to Message 1347023.

I've made Richards changes. Just downloading some new tasks and will see what happens.
____________

Richard HaselgroveProject donor
Volunteer tester
Send message
Joined: 4 Jul 99
Posts: 8436
Credit: 47,934,033
RAC: 58,701
United Kingdom
Message 1347099 - Posted: 15 Mar 2013, 22:58:21 UTC - in response to Message 1347027.

I've made Richards changes. Just downloading some new tasks and will see what happens.

ChangeS? You only need one. What exactly did you change?

spitfire_mk_2
Avatar
Send message
Joined: 14 Apr 00
Posts: 442
Credit: 12,255,681
RAC: 5,560
United States
Message 1347165 - Posted: 16 Mar 2013, 3:18:18 UTC - in response to Message 1347027.
Last modified: 16 Mar 2013, 3:20:09 UTC

I've made Richards changes. Just downloading some new tasks and will see what happens.

This is waste of time. Post the screen shot of the GPU-z for your card. This way we will know what the F we are dealing with.

Example:



____________

Starman
Avatar
Send message
Joined: 15 May 99
Posts: 133
Credit: 35,310,213
RAC: 49,267
Canada
Message 1347446 - Posted: 16 Mar 2013, 21:35:57 UTC - in response to Message 1347165.

OK, will do on Monday.
____________

rob smithProject donor
Volunteer tester
Send message
Joined: 7 Mar 03
Posts: 8254
Credit: 54,414,536
RAC: 73,936
United Kingdom
Message 1347447 - Posted: 16 Mar 2013, 21:38:53 UTC

Due tot he error rate on your computer can I request that you either stop it crunching S@H, or turn it off:
http://setiathome.berkeley.edu/results.php?hostid=6942032
____________
Bob Smith
Member of Seti PIPPS (Pluto is a Planet Protest Society)
Somewhere in the (un)known Universe?

ClaggyProject donor
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 4058
Credit: 32,802,646
RAC: 5,161
United Kingdom
Message 1347503 - Posted: 17 Mar 2013, 1:41:41 UTC - in response to Message 1347027.

I've made Richards changes. Just downloading some new tasks and will see what happens.

Can you post a picture of what environment variable you put in, so we can check for typos.

Claggy

Grant (SSSF)
Send message
Joined: 19 Aug 99
Posts: 5774
Credit: 57,495,850
RAC: 48,485
Australia
Message 1347507 - Posted: 17 Mar 2013, 2:18:14 UTC - in response to Message 1347503.

I've made Richards changes. Just downloading some new tasks and will see what happens.

Can you post a picture of what environment variable you put in, so we can check for typos.

And did you re-boot efter entering the variable?
____________
Grant
Darwin NT.

Luther
Send message
Joined: 11 Mar 13
Posts: 12
Credit: 420,913
RAC: 0
United States
Message 1347522 - Posted: 17 Mar 2013, 4:05:10 UTC

I'm still getting errors from time to time with my 560ti's also but no where nearly as bad as before, for me since I have a sli setup if I see fermi's finishing within 1 minute I will do a temp fix by turning on sli in Nvidia Control panel, when I do that it gives me a window of time where all the fermi's that run finish good, once the error comes back i turn off sli and again that fix's the issue tell it comes back again.

I noticed the latest version of boinc helped also.

I think the latest drivers of nvidia has a update for cuda also.

Starman
Avatar
Send message
Joined: 15 May 99
Posts: 133
Credit: 35,310,213
RAC: 49,267
Canada
Message 1348187 - Posted: 18 Mar 2013, 19:05:04 UTC



Here is the GPU-Z info
____________

Starman
Avatar
Send message
Joined: 15 May 99
Posts: 133
Credit: 35,310,213
RAC: 49,267
Canada
Message 1348191 - Posted: 18 Mar 2013, 19:14:55 UTC - in response to Message 1347503.
Last modified: 18 Mar 2013, 19:15:31 UTC

CUDA_GRID_SIZE_COMPAT Value = 1
____________

spitfire_mk_2
Avatar
Send message
Joined: 14 Apr 00
Posts: 442
Credit: 12,255,681
RAC: 5,560
United States
Message 1348203 - Posted: 18 Mar 2013, 19:33:08 UTC - in response to Message 1348187.



Here is the GPU-Z info

You have GK chip. K stands for Kepler. So you have GT640 with Kepler chip, you need the software for cuda_kepler.

Richard, I looked at the thread you linked earlier, it is dated October 2012. Is there a solution for Kepler cards now?
____________

ClaggyProject donor
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 4058
Credit: 32,802,646
RAC: 5,161
United Kingdom
Message 1348209 - Posted: 18 Mar 2013, 19:36:26 UTC - in response to Message 1348191.
Last modified: 18 Mar 2013, 19:37:56 UTC

CUDA_GRID_SIZE_COMPAT Value = 1


Because you wrote it like that, Did you put in

CUDA_GRID_SIZE_COMPAT Value = 1 Or CUDA_GRID_SIZE_COMPAT 1
(with the 1 being in the value column)

Claggy

ClaggyProject donor
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 4058
Credit: 32,802,646
RAC: 5,161
United Kingdom
Message 1348216 - Posted: 18 Mar 2013, 19:41:58 UTC - in response to Message 1348203.

You have GK chip. K stands for Kepler. So you have GT640 with Kepler chip, you need the software for cuda_kepler.

Richard, I looked at the thread you linked earlier, it is dated October 2012. Is there a solution for Kepler cards now?

The solutions are:

a) Use an optimised Cuda application, where available.
b) Downgrade to the 301.42 driver - only possible on GTX 670/680/690 cards, not on newer releases like the 650/660 or their Ti variants.
c) Set an environment variable, as shown below.
d) wait for Setiahome v7 to arrive, it'll use the app from a)

Claggy

1 · 2 · Next

Message boards : Number crunching : Error while computing cuda_fermi

Copyright © 2014 University of California