OpenCL apps are available for download on Lunatics


log in

Advanced search

Message boards : Number crunching : OpenCL apps are available for download on Lunatics

1 · 2 · 3 · 4 . . . 9 · Next
Author Message
Profile Mike
Volunteer tester
Avatar
Send message
Joined: 17 Feb 01
Posts: 22380
Credit: 29,296,795
RAC: 23,754
Germany
Message 1333128 - Posted: 31 Jan 2013, 10:33:58 UTC
Last modified: 31 Jan 2013, 10:36:42 UTC

Current OpenCL apps are available for download on Lunatics again.

Multibeam for ATI GPU`s
Astropulse for ATI and Nvidia.

http://lunatics.kwsn.net/index.php?module=Downloads

Each package containing Readme (please read carefully) as well as appinfo section (aistub)
In the Readme you will find some examples of command line switches as well as some hints for better performance.

As usual, the creation of new release packages was team work of our Lunatics crew
(in alphabetical order):
Arkayn, Claggy, Josef W. Segur, Mike, Raistmer, Richard Haselgrove, Urs Echternacht.
Special thank you goes to Claggy and Mike for truly endless testing, help in text files creation and proofreading that was almost as endless as testing this time.

MB_ATI_r1761

AP6_ATI_r1761

AP6_NV_r1761
____________

Wedge009
Volunteer tester
Avatar
Send message
Joined: 3 Apr 99
Posts: 237
Credit: 107,132,528
RAC: 164,651
Australia
Message 1333180 - Posted: 31 Jan 2013, 15:30:36 UTC

As always, thanks to everyone involved for your dedication and hard work.

Just a quick feedback from me on the new applications, with no other changes to parameters in app_info.xml, at least for GPUs on which I have work-units (downloads remain stuck for a lot of them).

HD 6970

WinXP, Catalyst 11.2.

AP: Seems to be working okay.
MB: No work given.

HD 6950

WinXP, Catalyst 11.2.

AP: Seems to be working okay.
MB: All WUs ending with -9 result overflow error (example). Reverted to r426 - WUs processing properly again.

GT 430

WinXP, Catalyst 11.12.

AP: Seems to be working okay.

AMD C-50

Win7 32-bit, Catalyst 13.1.

AP: Seems to be working okay.
MB: Reverted to Catalyst 12.8, purged bin/wisdom files, yet driver crashes within minutes of starting a WU. Reverted to r426 - WUs processing properly again.

AMD E-450

Win7 64-bit, Catalyst 13.1.

AP: Seems to be working okay.
MB: Reverted to Catalyst 12.8, purged bin/wisdom files. Seems to be working okay.
____________
Soli Deo Gloria

Profile Raistmer
Volunteer developer
Volunteer tester
Avatar
Send message
Joined: 16 Jun 01
Posts: 3276
Credit: 40,760,043
RAC: 60,054
Russia
Message 1333207 - Posted: 31 Jan 2013, 17:01:14 UTC - in response to Message 1333180.
Last modified: 31 Jan 2013, 17:06:30 UTC

Link to announcement: http://setiathome.berkeley.edu/forum_thread.php?id=53611&postid=1333128


WinXP, Catalyst 11.2.

AP: Seems to be working okay.
MB: All WUs ending with -9 result overflow error (example). Reverted to r426 - WUs processing properly again.


Driver Conformance
AMD APP SDK v2.7 AMD Catalystâ„¢ 12.4 (8.961)
AMD APP SDK v2.6 AMD Catalystâ„¢ 11.12 (8.92)
AMD APP SDK v2.5 AMD Catalystâ„¢ 11.7 (8.872)
Both apps (and stock ATi AP,btw) are built against SDK 2.5, so minimal driver version is: 11.7



AMD C-50

Win7 32-bit, Catalyst 13.1.

AP: Seems to be working okay.
MB: Reverted to Catalyst 12.8, purged bin/wisdom files, yet driver crashes within minutes of starting a WU. Reverted to r426 - WUs processing properly again.

Not complete reverting. it's not so easy, look Claggy's post and readme for this. Special tool or manual treatment of leftovers is required, thanks to AMD.
EDIT: another possibility - need to increase iterations number. New app can load GPU harder.


AMD E-450

Win7 64-bit, Catalyst 13.1.

AP: Seems to be working okay.
MB: Reverted to Catalyst 12.8, purged bin/wisdom files. Seems to be working okay.

You just lucky. Still driver cleanup may be needed.
____________
News about SETI opt app releases: https://twitter.com/Raistmer

Wedge009
Volunteer tester
Avatar
Send message
Joined: 3 Apr 99
Posts: 237
Credit: 107,132,528
RAC: 164,651
Australia
Message 1333239 - Posted: 31 Jan 2013, 18:42:06 UTC - in response to Message 1333207.

Thanks for the feedback.

Regarding HD 6950/6970 - I've had a strange bit of bad luck with these across different (WinXP) machines over all these years: drivers either won't install or they crash the system once installed or AP WUs exhibit high CPU usage... eventually I settled on a guaranteed-to-work formula: Catalyst 11.7, but with the CAL and OpenCL DLLs replaced with the ones from Catalyst 11.2. It's a major kludge, but it's the only one that's been guaranteed to work. That is, before I got the -9 result overflows, I have always been getting valid results from it.

About the driver crash on the C-50, I realise I may have to do a complete driver sweep or something like that, but I ran out of time, staying up far too late to finish this as it is. Anyway, r426 works for the time being, r1761 does not. :/

I'll continue monitoring what happens as WUs (eventually) get downloaded and run.
____________
Soli Deo Gloria

Profile Raistmer
Volunteer developer
Volunteer tester
Avatar
Send message
Joined: 16 Jun 01
Posts: 3276
Credit: 40,760,043
RAC: 60,054
Russia
Message 1333244 - Posted: 31 Jan 2013, 18:55:51 UTC

r426 old enough to be built with SDK 2.4
____________
News about SETI opt app releases: https://twitter.com/Raistmer

Keith White
Avatar
Send message
Joined: 29 May 99
Posts: 369
Credit: 2,471,783
RAC: 2,350
United States
Message 1333280 - Posted: 31 Jan 2013, 20:26:18 UTC
Last modified: 31 Jan 2013, 20:41:40 UTC

Could someone please explain, using small words, the difference between MB7_win_x86_SSE_OpenCL_ATi_r1761 and MB6_win_x86_SSE3_OpenCL_ATi_HD5_r390? Better performance, better stability, less inconclusive results, what (besides large wu support, I can read a readme file)?

Since I'm going to have to manual edit the app_info.xml, which some people seem to keep it's syntax a closely guarded secret, to use this new task over the one the 0.40 installer created, you should under my hesitation.

Also the existing app_info has a section for the .cl file but the example in the readme doesn't but there is a new .cl file in the package. What should I do?
____________
"Life is just nature's way of keeping meat fresh." - The Doctor

Wedge009
Volunteer tester
Avatar
Send message
Joined: 3 Apr 99
Posts: 237
Credit: 107,132,528
RAC: 164,651
Australia
Message 1333282 - Posted: 31 Jan 2013, 20:37:44 UTC

The new application knows where to look for the .cl kernel, I believe, so it seems it's not necessary to specify it in the app_info.xml any more.
____________
Soli Deo Gloria

Claggy
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 3963
Credit: 31,840,347
RAC: 10,843
United Kingdom
Message 1333283 - Posted: 31 Jan 2013, 20:44:23 UTC - in response to Message 1333280.

Could someone please explain, using small words, the difference between MB7_win_x86_SSE_OpenCL_ATi_r1761 and MB6_win_x86_SSE3_OpenCL_ATi_HD5_r390? Better performance, better stability, less inconclusive results, what (besides large wu support, I can read a readme file)?

Since I'm going to have to manual edit the app_info.xml, which some people seem to keep it's syntax a closely guarded secret, to use this new task over the one the 0.40 installer created, you should under my hesitation.

Also the existing app_info has a section for the .cl but the example in the readme doesn't but there is a new .cl file in the package. What should I do?

The latest MB apps are MBv7 capable, and have increased precision compared to the old r390 apps, the HD5 variant is faster on HD5*** and later GPUs, while the Normal ATI version is aimed at HD4*** GPUs,

The syntax isn't a closely guarded secret, a suitable app_info section is supplied in the .aistub and in the Readme.

The old app needed the .cl copying to the slot directory, the new app looks for the .cl file in the project directory, so no need to have it in the app_info.

Claggy

Wedge009
Volunteer tester
Avatar
Send message
Joined: 3 Apr 99
Posts: 237
Credit: 107,132,528
RAC: 164,651
Australia
Message 1333285 - Posted: 31 Jan 2013, 20:52:15 UTC - in response to Message 1333283.

Are there still standard vs HD5+ versions? I only see one executable for the new r1761 MB.
____________
Soli Deo Gloria

Keith White
Avatar
Send message
Joined: 29 May 99
Posts: 369
Credit: 2,471,783
RAC: 2,350
United States
Message 1333287 - Posted: 31 Jan 2013, 21:00:02 UTC - in response to Message 1333283.
Last modified: 31 Jan 2013, 21:15:11 UTC


The syntax isn't a closely guarded secret, a suitable app_info section is supplied in the .aistub and in the Readme.

The old app needed the .cl copying to the slot directory, the new app looks for the .cl file in the project directory, so no need to have it in the app_info.

Claggy


You should remember that outside of the GPU/optimized app group of players, most of us never edit much less look at the app_info file. And most of us who are using Lunatics used the windows install program to do the heavy lifting.

As for secrets, it was like pulling teeth to find out about the <flops> tag so the servers would fetch me a reasonably correct number of units for a six day queue (ah those were the days). For some reason, still to this day, my returned units aren't incrementing the "Number of Tasks Completed" or updating the average processing rate and turnaround time. So without the <flops> tag it assumed it would take over a day to do (instead of 1/4 to 1 hour) a GPU assigned unit and therefore supply me with an eyedropper portion of them.

See, never would have looked in the .aistub (ah, as in app_info stub, I get it now) and I just thought we copied the files in question to the projects directory and since I don't understand how BOINC supervises the execution of the various apps, I wouldn't understand about how the slots directory factors in.

Yet another dumb question. Why are there two identical "<platform>windows_intelx86</platform>" instead of one "<platform>windows_intelx86</platform>" and one "<platform>windows_x86_64</platform>" in the aistub file? Cut and paste error?
____________
"Life is just nature's way of keeping meat fresh." - The Doctor

Claggy
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 3963
Credit: 31,840,347
RAC: 10,843
United Kingdom
Message 1333293 - Posted: 31 Jan 2013, 21:25:01 UTC - in response to Message 1333287.
Last modified: 31 Jan 2013, 22:02:37 UTC

Yet another dumb question. Why are there two identical "<platform>windows_intelx86</platform>" instead of one "<platform>windows_intelx86</platform>" and one "<platform>windows_x86_64</platform>" in the aistub file? Cut and paste error?

They have different plan classes. ati_opencl_100 and opencl_ati_100 for Astropulse, and ati_opencl_sah and opencl_ati_sah for Multibeam.

Claggy

TBar
Volunteer tester
Send message
Joined: 22 May 99
Posts: 1077
Credit: 30,496,463
RAC: 83,532
United States
Message 1333299 - Posted: 31 Jan 2013, 21:39:36 UTC

What's the lowest generation ATI card that can use MB7_win_x86_SSE_OpenCL_ATi_r1761.exe? Can my HD 4670 r430 use it, or is it still restricted to APs only? I'm using the AMD 13.1 Legacy driver containing AMD-APP 937.2, is that a 'bad' number for any of these Apps?

Thanks for all your work.

Profile Fred E.
Volunteer tester
Send message
Joined: 22 Jul 99
Posts: 731
Credit: 22,060,771
RAC: 24,080
United States
Message 1333302 - Posted: 31 Jan 2013, 21:49:27 UTC
Last modified: 31 Jan 2013, 22:04:37 UTC

I replaced 1316 with 1761 (NV) and it runs okay, but the first 3 tasks ran more than twice as long than was typical with 1316. Do I need some run time parameters? I've just added this line that I used with the prior version to app_info.xml:

<cmdline>-unroll 10 -ffa_block 8192 -ffa_block_fetch 4096 -hp</cmdline>

That's for a gtx 670 with a count of .25, 32 bit XP. It seems to be helping. Any suggestions?
____________
Another Fred
Support SETI@home when you search the Web with GoodSearch or shop online with GoodShop.

Claggy
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 3963
Credit: 31,840,347
RAC: 10,843
United Kingdom
Message 1333304 - Posted: 31 Jan 2013, 21:52:30 UTC - in response to Message 1333299.
Last modified: 31 Jan 2013, 21:59:41 UTC

What's the lowest generation ATI card that can use MB7_win_x86_SSE_OpenCL_ATi_r1761.exe? Can my HD 4670 r430 use it, or is it still restricted to APs only? I'm using the AMD 13.1 Legacy driver containing AMD-APP 937.2, is that a 'bad' number for any of these Apps?

Don't know, i don't think anyone has tested it on a HD4670, Grab the MB Bench, the AMD/ATI MB apps, the v6 PG series of Wu's and Bench it and see.

Claggy

Claggy
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 3963
Credit: 31,840,347
RAC: 10,843
United Kingdom
Message 1333305 - Posted: 31 Jan 2013, 21:58:22 UTC - in response to Message 1333302.

I replaced 1316 with 1761 (NV) and it runs okay, but the first 3 tasks ran more than twice as long than was typical with 1316. Do I need some run time parameters? I've just added this line that I used with the prior version to app)info.xml:

<cmdline>-unroll 10 -ffa_block 8192 -ffa_block_fetch 4096 -hp</cmdline>

That's for a gtx 670 with a count of .25, 32 bit XP. It seems to be helping. Any suggestions?


Rather than putting the cmdline parameters in the app_info, put them in the ap_cmdline_win_x86_SSE2_OpenCL_NV.txt file instead, then you can adjust them more easily, and you don't need to restart Boinc to use them.

Make sure you reserve a core to feed the GPU, I do it by setting both <avg_ncpus> and <max_ncpus> to 1.0

Claggy

Profile Mike
Volunteer tester
Avatar
Send message
Joined: 17 Feb 01
Posts: 22380
Credit: 29,296,795
RAC: 23,754
Germany
Message 1333307 - Posted: 31 Jan 2013, 22:02:40 UTC - in response to Message 1333299.

What's the lowest generation ATI card that can use MB7_win_x86_SSE_OpenCL_ATi_r1761.exe? Can my HD 4670 r430 use it, or is it still restricted to APs only? I'm using the AMD 13.1 Legacy driver containing AMD-APP 937.2, is that a 'bad' number for any of these Apps?

Thanks for all your work.


Lowest generation is HD 5xxx.
Only card that is proved to work from HD 4 is HD 4850.

____________

Claggy
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 3963
Credit: 31,840,347
RAC: 10,843
United Kingdom
Message 1333314 - Posted: 31 Jan 2013, 22:15:42 UTC - in response to Message 1333287.

See, never would have looked in the .aistub (ah, as in app_info stub, I get it now) and I just thought we copied the files in question to the projects directory and since I don't understand how BOINC supervises the execution of the various apps, I wouldn't understand about how the slots directory factors in.

If you have used the Installer in the past, you'll have a number of .aistub's there, if you copy the new .aistub's and all the other files, while deleting the old APATI.aistub, MBATI.aistub and MBATI_HD5.aistub's,
(just leave the .aistub's that you want in your app_info) then run the aimerge.cmd, it'll merge all your .aistub's into one app_info.xml

Claggy

TBar
Volunteer tester
Send message
Joined: 22 May 99
Posts: 1077
Credit: 30,496,463
RAC: 83,532
United States
Message 1333320 - Posted: 31 Jan 2013, 22:40:08 UTC - in response to Message 1333307.

What's the lowest generation ATI card that can use MB7_win_x86_SSE_OpenCL_ATi_r1761.exe? Can my HD 4670 r430 use it, or is it still restricted to APs only? I'm using the AMD 13.1 Legacy driver containing AMD-APP 937.2, is that a 'bad' number for any of these Apps?

Thanks for all your work.


Lowest generation is HD 5xxx.
Only card that is proved to work from HD 4 is HD 4850.

Oh well. I might give it a try in a few days anyway. I'm fresh out of my weeks' allotment of testing for now.

Keith White
Avatar
Send message
Joined: 29 May 99
Posts: 369
Credit: 2,471,783
RAC: 2,350
United States
Message 1333321 - Posted: 31 Jan 2013, 22:42:27 UTC
Last modified: 31 Jan 2013, 22:54:49 UTC

And thank you all for mentioning I was just suppose to just add the aistub to the existing app_info instead of swapping out the existing GPU section. Surprise! Dumped all of my previously fetched GPU units. Sorry wingmen.

Very much not happy now.

See, never would have looked in the .aistub (ah, as in app_info stub, I get it now) and I just thought we copied the files in question to the projects directory and since I don't understand how BOINC supervises the execution of the various apps, I wouldn't understand about how the slots directory factors in.

If you have used the Installer in the past, you'll have a number of .aistub's there, if you copy the new .aistub's and all the other files, while deleting the old APATI.aistub, MBATI.aistub and MBATI_HD5.aistub's,
(just leave the .aistub's that you want in your app_info) then run the aimerge.cmd, it'll merge all your .aistub's into one app_info.xml

Claggy


Well better late than never... oops.

Edit: Actually it looks like it's now refetching my GPU tasks so my wingmen should be alright. Whew!
____________
"Life is just nature's way of keeping meat fresh." - The Doctor

janneseti
Send message
Joined: 14 Oct 09
Posts: 79
Credit: 470,107
RAC: 154
Sweden
Message 1333324 - Posted: 31 Jan 2013, 22:48:54 UTC - in response to Message 1333320.

There are also a highest generation driver for this.
From the Readme:
- Catalyst 12.10,12.11 beta and 13.1 have broken OpenCL compiler that will result in driver restarts or invalid results.

1 · 2 · 3 · 4 . . . 9 · Next

Message boards : Number crunching : OpenCL apps are available for download on Lunatics

Copyright © 2014 University of California