Added NVidia GT630 GPU, not getting expected boost

Message boards : Number crunching : Added NVidia GT630 GPU, not getting expected boost

To post messages, you must log in.

AuthorMessage
SSimek

Send message
Joined: 29 Mar 12
Posts: 17
Credit: 880,607
RAC: 0
United States
Message 1328247 - Posted: 17 Jan 2013, 12:39:06 UTC

Hi. I just added a Zotac GT630 with 1GB memory to my configuration (Dell OptiPlex 745, dual core). It's running 1 task, which I suspect is incorrect. When I initially downloaded extra tasks I got a "scheduler wait" due to CPU/GPU memory, byt haven't seen that message since. Sorry for the newbie question, but I anticipated a lot more gain than this... What am I missing? Two other questions also please...

-Where is the "last contact" log?
-Why is another project (Einstein) loading now but SETI refusing to send more work even though I have a 50/50 split?

All help appreciated, and thanks!

ID: 1328247 · Report as offensive
ClaggyProject Donor
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4622
Credit: 46,334,608
RAC: 2,751
United Kingdom
Message 1328250 - Posted: 17 Jan 2013, 12:54:05 UTC - in response to Message 1328247.
Last modified: 17 Jan 2013, 12:55:30 UTC

By default you will only run one task at a time on your GPU, but it'll run it a lot faster than if it was CPU task,

Seiathome doesn't have a last contact log, unlike Einstein.

Claggy

ID: 1328250 · Report as offensive
SSimek

Send message
Joined: 29 Mar 12
Posts: 17
Credit: 880,607
RAC: 0
United States
Message 1328254 - Posted: 17 Jan 2013, 13:08:46 UTC - in response to Message 1328250.

Ok, thanks for that. Also, SETI has now magically downloaded a few tasks and DLL's, although nothing has started. We'll see what happens. I've read somewhere, and not sure where now, that I could change the "count" value and run multiple tasks per GPU... Possible? Optimal? I keep looking for an app_info file, but no joy. Does it need to be manually created? Other optimizations I may be missing?
Many thanks
Steve

ID: 1328254 · Report as offensive
Profile BilBg
Volunteer tester
Avatar

Send message
Joined: 27 May 07
Posts: 3654
Credit: 8,591,924
RAC: 1,300
Bulgaria
Message 1328263 - Posted: 17 Jan 2013, 14:50:49 UTC - in response to Message 1328254.

I keep looking for an app_info file, but no joy. Does it need to be manually created?

app_info.xml do not exists in standard installation, it is created manually or by the Lunatics installers

You may find some info here (the links are for very new CUDA apps), read also next posts:
http://setiathome.berkeley.edu/forum_thread.php?id=70264&postid=1327312#1327312





- ALF - "Find out what you don't do well ..... then don't do it!" :)

ID: 1328263 · Report as offensive
Profile Raistmer
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 16 Jun 01
Posts: 5412
Credit: 66,340,484
RAC: 12,692
Russia
Message 1328319 - Posted: 17 Jan 2013, 17:51:33 UTC

Now app_info not needed if the single reason to switch to anonymous platform is to get few tasks running at once (with same binary as for stock).
Look here how to implement few tasks at once with stock apps:
http://setiweb.ssl.berkeley.edu/beta/forum_thread.php?id=1981


SETI apps news
We're not gonna fight them. We're gonna transcend them.

ID: 1328319 · Report as offensive
SSimek

Send message
Joined: 29 Mar 12
Posts: 17
Credit: 880,607
RAC: 0
United States
Message 1328381 - Posted: 17 Jan 2013, 20:04:10 UTC - in response to Message 1328319.

Good info, thanks! I've read the links and seems to make sense. I'll try it out tonight and report back.
Thanks again!
Steve

ID: 1328381 · Report as offensive

Message boards : Number crunching : Added NVidia GT630 GPU, not getting expected boost


 
©2016 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.