2nd GPU not used


log in

Advanced search

Questions and Answers : GPU applications : 2nd GPU not used

Author Message
Profile John S. (Low IFR) Jenkins
Send message
Joined: 22 Feb 01
Posts: 53
Credit: 24,515,908
RAC: 0
United States
Message 1289980 - Posted: 1 Oct 2012, 8:45:33 UTC

Sudently only 1 GPU is being used. Startup log shows "GPU 1 not used". Only GPU 0 is being used.
Help Wanted !!!!!!
** John **

Profile Ageless
Avatar
Send message
Joined: 9 Jun 99
Posts: 12128
Credit: 2,522,193
RAC: 465
Netherlands
Message 1289998 - Posted: 1 Oct 2012, 10:27:19 UTC - in response to Message 1289980.

All BOINC versions but for 6.4.5 used the best GPU only by default.
When it's two GPUs of the same make and model, they can still differ.
BOINC decides which GPU is best based on these factors, in decreasing priority):
- compute capability
- software version
- available memory
- speed

To be able to use all GPUs, use Notepad to add or edit the cc_config.xml file in your BOINC Data directory, add or edit these lines into it:

<cc_config>
<log_flags>
</log_flags>
<options>
<use_all_gpus>1</use_all_gpus>
</options>
</cc_config>


This file does not exist on a cleanly installed BOINC. It will only be there if you added it manually, or you added exclusive applications through BOINC Manager's local preferences.

See client configuration for ore information on this file.

When saving, do Save As..., save as All Files, ANSI format. Do check that the extension is just .xml, not an added .txt
When all that's done and checked, exit BOINC fully & restart it (Start->ALl Programs->BOINC->BOINC Manager).
____________
Jord

Loving awareness is free.

Profile John S. (Low IFR) Jenkins
Send message
Joined: 22 Feb 01
Posts: 53
Credit: 24,515,908
RAC: 0
United States
Message 1290672 - Posted: 3 Oct 2012, 10:39:50 UTC

6.12.34 runs both GPU's as it should

Profile BilBg
Avatar
Send message
Joined: 27 May 07
Posts: 2457
Credit: 5,430,083
RAC: 8,095
Bulgaria
Message 1291032 - Posted: 4 Oct 2012, 2:52:56 UTC - in response to Message 1290672.

6.12.34 runs both GPU's as it should

Then you are/were affected by the bug in some of 7.0.xx versions that make BOINC sometimes report ridiculously high GPU RAM as in:

NVIDIA GPU 0: GeForce GTX 460 (driver version unknown, CUDA version 4.20, compute capability 2.1, 134214656MB, 134214259MB available, 941 GFLOPS peak)
http://setiathome.berkeley.edu/forum_thread.php?id=69263

You can see/check the old logs in stdoutdae.txt and stdoutdae.old


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Profile John S. (Low IFR) Jenkins
Send message
Joined: 22 Feb 01
Posts: 53
Credit: 24,515,908
RAC: 0
United States
Message 1296100 - Posted: 17 Oct 2012, 8:55:29 UTC

Any word on a fix ? Does .31 have the same bug ?

Profile arkayn
Volunteer tester
Avatar
Send message
Joined: 14 May 99
Posts: 3544
Credit: 46,202,586
RAC: 31,146
United States
Message 1296180 - Posted: 17 Oct 2012, 15:25:25 UTC - in response to Message 1296100.
Last modified: 17 Oct 2012, 15:31:13 UTC

Any word on a fix ? Does .31 have the same bug ?


Yes, but .36 has it mostly fixed.

http://boinc.berkeley.edu/dl/?C=M;O=D

See also this post from Claggy
http://setiathome.berkeley.edu/forum_thread.php?id=69729&postid=1296095
There is a Wacky GPU memory reporting Bug with the recent Boinc 7 clients, because the available GPU memory is reported wrong, Boinc then doesn't use both GPUs because they aren't similar enough,
Boinc 7.0.36 has a partial fix, But there are changes to the (internal) flops reported for the GPU, and because of the changes, existing GPU Wu's will be on the verge of going Maximum time exceeded,
so any GPU Wu's should be completed prior to upgrading to Boinc 7.0.36 (new GPU Wu's will get a revised <rsc_fpops_est> figure so will complete O.K)

____________

Questions and Answers : GPU applications : 2nd GPU not used

Copyright © 2014 University of California