Windows BOINC reporting incorrect available memory for NVIDIA GPU


log in

Advanced search

Questions and Answers : GPU applications : Windows BOINC reporting incorrect available memory for NVIDIA GPU

Author Message
Profile fmustang76
Send message
Joined: 6 Jan 01
Posts: 3
Credit: 690,624
RAC: 552
United States
Message 1287028 - Posted: 23 Sep 2012, 13:01:24 UTC

I recently did a clean install of Windows 7 x64 on my laptop. At that time I installed the latest NVIDIA drivers for my GPU, (driver version 306.23) as well as the latest stable version of BOINC (7.0.28_x64). I noticed the system wasn't responding like a fresh install should or has in the past. And today I had a BSOD which as far as I can remember has not happened before on this system.

Shutting BOINC down resulted in a long wait and required restart as the system became very slow to respond. With laptop restarted and BOINC shut down laptop responded normally. I later noticed BOINC has been running GPU apps for SETI. Seeing as my GPU only has 128MB of memory I knew it shouldn't be and as far as I can recall it never has before.

Prompted by the info and logs mentioned in the post:

http://setiathome.berkeley.edu/forum_thread.php?id=69263

I noticed mine were similar but I am using Windows 7 x64. Here are the relevant lines from my log:

9/23/2012 6:51:32 AM | | NVIDIA GPU 0: GeForce 8400M GS
(driver version 306.23, CUDA version 5.0, compute capability
1.1, 128MB, 8380482MB available, 38 GFLOPS peak)


The "available" memory is way off. I know I can specify no GPU tasks in each project but I wanted to bring this to light so it can be determined if it is a BOINC bug or GPU driver bug. I'm not noticing any computation errors and I plan to let the GPU units finish out. I did notice before I posted that my GPU is mentioned on the NVIDIA CUDA website but I'm assumming it is because it may come in some configurations with 256MB of memory but mine did not.

Has this been fixed in the newest BETA if it is a BOINC problem or is it a NVIDIA driver problem? I can test different drivers/BOINC versions if needed which I plan to anyway.


Windows 7 x64 SP1 4GB
NVIDIA GPU 0: GeForce 8400M GS 128MB(Driver ver. 306.23)
BOINC 7.0.28_x64
____________

Profile BilBg
Avatar
Send message
Joined: 27 May 07
Posts: 2445
Credit: 5,391,194
RAC: 7,570
Bulgaria
Message 1287354 - Posted: 24 Sep 2012, 9:22:42 UTC - in response to Message 1287028.

Has this been fixed in the newest BETA

I think some fixes were attempted but am not sure how successfully, try to find yourself in change logs:

http://setiathome.berkeley.edu/forum_thread.php?id=67785


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Profile fmustang76
Send message
Joined: 6 Jan 01
Posts: 3
Credit: 690,624
RAC: 552
United States
Message 1287874 - Posted: 26 Sep 2012, 4:10:26 UTC

Thanks. I looked through the link you posted but I did not see anything resembling my issue.

Using the BOINC bug reporting site I noticed other posts in regard to NVIDIA memory reporting problems and they may have fixed the problem in 7.0.36. Before I saw that info, I did conduct my own testing using the current listed beta and it resulted in the same problem.

But for reference.. without changing my NVIDIA installed driver I tried several x86 and x64 versions of BOINC and I found that BOINC x64 versions higher than 7.0.25 are reporting available video memory incorrectly. BOINC x86 versions tested appear to be reporting available memory correctly.

Install File:
boinc_7.0.25_windows_x86_64.exe
boinc_7.0.28_windows_intelx86.exe
boinc_7.0.31_windows_intelx86.exe (Current BETA)

Log Results:
NVIDIA GPU 0: GeForce 8400M GS (driver version 306.23, CUDA version 5.0, compute capability 1.1, 128MB, 19MB available, 38 GFLOPS peak)
OpenCL: NVIDIA GPU 0: GeForce 8400M GS (driver version 306.23, device version OpenCL 1.0 CUDA, 128MB, 19MB available)


Install File:
boinc_7.0.26_windows_x86_64.exe
boinc_7.0.27_windows_x86_64.exe
boinc_7.0.28_windows_x86_64.exe
boinc_7.0.31_windows_x86_64.exe (Current BETA)

Log Results:
NVIDIA GPU 0: GeForce 8400M GS (driver version 306.23, CUDA version 5.0, compute capability 1.1, 128MB, 8380435MB available, 38 GFLOPS peak)
OpenCL: NVIDIA GPU 0: GeForce 8400M GS (driver version 306.23, device version OpenCL 1.0 CUDA, 128MB, 8380435MB available)

Hope this helps.


Windows 7 x64 SP1 4GB
NVIDIA GPU 0: GeForce 8400M GS 128MB(Driver ver. 306.23)
____________

Profile BilBg
Avatar
Send message
Joined: 27 May 07
Posts: 2445
Credit: 5,391,194
RAC: 7,570
Bulgaria
Message 1287884 - Posted: 26 Sep 2012, 4:50:36 UTC - in response to Message 1287874.
Last modified: 26 Sep 2012, 4:55:57 UTC

I noticed other posts in regard to NVIDIA memory reporting problems and they may have fixed the problem in 7.0.36

To get 7.0.36 look at bottom of this list of All BOINC Versions:
http://boinc.berkeley.edu/dl/?C=M;O=A

Mind the warning by Richard Haselgrove (for those people that have existing CUDA tasks):
http://setiathome.berkeley.edu/forum_thread.php?id=67785&postid=1266731#1266731


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Profile fmustang76
Send message
Joined: 6 Jan 01
Posts: 3
Credit: 690,624
RAC: 552
United States
Message 1288030 - Posted: 26 Sep 2012, 13:22:08 UTC

Thanks, I had forgotten to add that download link myself and to mention that I did try BOINC 7.0.36. It is now reporting the correct GPU memory available.
____________

Questions and Answers : GPU applications : Windows BOINC reporting incorrect available memory for NVIDIA GPU

Copyright © 2014 University of California