Optimize your GPU. Find the value the easy way.


log in

Advanced search

Message boards : Number crunching : Optimize your GPU. Find the value the easy way.

Previous · 1 . . . 4 · 5 · 6 · 7 · 8 · 9 · 10 . . . 13 · Next
Author Message
Profile Fred E.Project donor
Volunteer tester
Send message
Joined: 22 Jul 99
Posts: 768
Credit: 24,139,004
RAC: 1
United States
Message 1279205 - Posted: 2 Sep 2012, 10:31:06 UTC

What an absolutely brilliant bit of software - hats off to you my man, and thx for the effort :-)

+1

Fred, you have a remarkable ability to see a need and find a solution. I love BoincTasks and Tthrottle because they fill holes that BOINC can't seem to fill. Maybe someday that team will figure out how to count tasks!
____________
Another Fred
Support SETI@home when you search the Web with GoodSearch or shop online with GoodShop.

John
Send message
Joined: 21 May 99
Posts: 49
Credit: 5,131,529
RAC: 4,701
United States
Message 1279268 - Posted: 2 Sep 2012, 14:19:28 UTC

Starting automatic test: (lunatics_x41g_win32_cuda32_perf.exe)
02 September 2012 - 09:53:30 Start, devices: 2, device count: 1
02 September 2012 - 09:55:56 Runtime: Device: 1, count: 0, 145 seconds
02 September 2012 - 09:55:56 Device: 1, finished
02 September 2012 - 09:56:04 Runtime: Device: 0, count: 0, 153 seconds
02 September 2012 - 09:56:04 Device: 0, finished
Ready ---------------------------------------------------------------------
Results:
Device: 0, device count: 1, average time / count: 153, average time on device: 153 Seconds (2 Minutes, 33 Seconds)
Device: 1, device count: 1, average time / count: 145, average time on device: 145 Seconds (2 Minutes, 25 Seconds)
Next ---------------------------------------------------------------------
02 September 2012 - 09:56:05 Start, devices: 2, device count: 2
02 September 2012 - 09:59:53 Runtime: Device: 1, count: 1, 228 seconds
02 September 2012 - 09:59:53 Runtime: Device: 1, count: 0, 228 seconds
02 September 2012 - 09:59:53 Device: 1, finished
02 September 2012 - 09:59:53 Device: 1, finished
02 September 2012 - 10:00:39 Runtime: Device: 0, count: 0, 274 seconds
02 September 2012 - 10:00:39 Device: 0, finished
02 September 2012 - 10:00:39 Runtime: Device: 0, count: 1, 274 seconds
02 September 2012 - 10:00:39 Device: 0, finished
Ready ---------------------------------------------------------------------
Results:
Device: 0, device count: 2, average time / count: 274, average time on device: 137 Seconds (2 Minutes, 17 Seconds)
Device: 1, device count: 2, average time / count: 228, average time on device: 114 Seconds (1 Minutes, 54 Seconds)
Next ---------------------------------------------------------------------
02 September 2012 - 10:00:40 Start, devices: 2, device count: 3
02 September 2012 - 10:06:17 Runtime: Device: 1, count: 1, 336 seconds
02 September 2012 - 10:06:17 Device: 1, finished
02 September 2012 - 10:06:17 Runtime: Device: 1, count: 2, 336 seconds
02 September 2012 - 10:06:17 Device: 1, finished
02 September 2012 - 10:06:18 Runtime: Device: 1, count: 0, 337 seconds
02 September 2012 - 10:06:18 Device: 1, finished
02 September 2012 - 10:07:25 Runtime: Device: 0, count: 0, 404 seconds
02 September 2012 - 10:07:25 Device: 0, finished
02 September 2012 - 10:07:26 Runtime: Device: 0, count: 1, 405 seconds
02 September 2012 - 10:07:26 Device: 0, finished
Windows 7 64 bit Gtx 670 gtx 470 Nvidia driver 306.02 beta

02 September 2012 - 10:07:27 Runtime: Device: 0, count: 2, 406 seconds
02 September 2012 - 10:07:27 Device: 0, finished
Ready ---------------------------------------------------------------------
Results:
Device: 0, device count: 3, average time / count: 405, average time on device: 135 Seconds (2 Minutes, 15 Seconds)
Device: 1, device count: 3, average time / count: 336, average time on device: 112 Seconds (1 Minutes, 52 Seconds)
Next ---------------------------------------------------------------------
02 September 2012 - 10:07:29 Start, devices: 2, device count: 4
02 September 2012 - 10:14:55 Runtime: Device: 1, count: 0, 445 seconds
02 September 2012 - 10:14:55 Device: 1, finished
02 September 2012 - 10:14:56 Runtime: Device: 1, count: 2, 446 seconds
02 September 2012 - 10:14:56 Device: 1, finished
02 September 2012 - 10:14:56 Runtime: Device: 1, count: 3, 446 seconds
02 September 2012 - 10:14:56 Device: 1, finished
02 September 2012 - 10:14:57 Runtime: Device: 1, count: 1, 447 seconds
02 September 2012 - 10:14:57 Device: 1, finished
____________

John
Send message
Joined: 21 May 99
Posts: 49
Credit: 5,131,529
RAC: 4,701
United States
Message 1279269 - Posted: 2 Sep 2012, 14:23:45 UTC - in response to Message 1279268.

Windows 7 64 bit Gtx 670 and gtx 470 nvidia 306.02 beta driver

1st run set at 2 each ok
Having problems getting workunits to test at 3 temps at 2 ok so far


Starting automatic test: (lunatics_x41g_win32_cuda32_perf.exe)
02 September 2012 - 09:53:30 Start, devices: 2, device count: 1
02 September 2012 - 09:55:56 Runtime: Device: 1, count: 0, 145 seconds
02 September 2012 - 09:55:56 Device: 1, finished
02 September 2012 - 09:56:04 Runtime: Device: 0, count: 0, 153 seconds
02 September 2012 - 09:56:04 Device: 0, finished
Ready ---------------------------------------------------------------------
Results:
Device: 0, device count: 1, average time / count: 153, average time on device: 153 Seconds (2 Minutes, 33 Seconds)
Device: 1, device count: 1, average time / count: 145, average time on device: 145 Seconds (2 Minutes, 25 Seconds)
Next ---------------------------------------------------------------------
02 September 2012 - 09:56:05 Start, devices: 2, device count: 2
02 September 2012 - 09:59:53 Runtime: Device: 1, count: 1, 228 seconds
02 September 2012 - 09:59:53 Runtime: Device: 1, count: 0, 228 seconds
02 September 2012 - 09:59:53 Device: 1, finished
02 September 2012 - 09:59:53 Device: 1, finished
02 September 2012 - 10:00:39 Runtime: Device: 0, count: 0, 274 seconds
02 September 2012 - 10:00:39 Device: 0, finished
02 September 2012 - 10:00:39 Runtime: Device: 0, count: 1, 274 seconds
02 September 2012 - 10:00:39 Device: 0, finished
Ready ---------------------------------------------------------------------
Results:
Device: 0, device count: 2, average time / count: 274, average time on device: 137 Seconds (2 Minutes, 17 Seconds)
Device: 1, device count: 2, average time / count: 228, average time on device: 114 Seconds (1 Minutes, 54 Seconds)
Next ---------------------------------------------------------------------
02 September 2012 - 10:00:40 Start, devices: 2, device count: 3
02 September 2012 - 10:06:17 Runtime: Device: 1, count: 1, 336 seconds
02 September 2012 - 10:06:17 Device: 1, finished
02 September 2012 - 10:06:17 Runtime: Device: 1, count: 2, 336 seconds
02 September 2012 - 10:06:17 Device: 1, finished
02 September 2012 - 10:06:18 Runtime: Device: 1, count: 0, 337 seconds
02 September 2012 - 10:06:18 Device: 1, finished
02 September 2012 - 10:07:25 Runtime: Device: 0, count: 0, 404 seconds
02 September 2012 - 10:07:25 Device: 0, finished
02 September 2012 - 10:07:26 Runtime: Device: 0, count: 1, 405 seconds
02 September 2012 - 10:07:26 Device: 0, finished
Windows 7 64 bit Gtx 670 gtx 470 Nvidia driver 306.02 beta

02 September 2012 - 10:07:27 Runtime: Device: 0, count: 2, 406 seconds
02 September 2012 - 10:07:27 Device: 0, finished
Ready ---------------------------------------------------------------------
Results:
Device: 0, device count: 3, average time / count: 405, average time on device: 135 Seconds (2 Minutes, 15 Seconds)
Device: 1, device count: 3, average time / count: 336, average time on device: 112 Seconds (1 Minutes, 52 Seconds)
Next ---------------------------------------------------------------------
02 September 2012 - 10:07:29 Start, devices: 2, device count: 4
02 September 2012 - 10:14:55 Runtime: Device: 1, count: 0, 445 seconds
02 September 2012 - 10:14:55 Device: 1, finished
02 September 2012 - 10:14:56 Runtime: Device: 1, count: 2, 446 seconds
02 September 2012 - 10:14:56 Device: 1, finished
02 September 2012 - 10:14:56 Runtime: Device: 1, count: 3, 446 seconds
02 September 2012 - 10:14:56 Device: 1, finished
02 September 2012 - 10:14:57 Runtime: Device: 1, count: 1, 447 seconds
02 September 2012 - 10:14:57 Device: 1, finished


____________

jthon
Volunteer tester
Avatar
Send message
Joined: 12 May 08
Posts: 18
Credit: 11,160,563
RAC: 753
United States
Message 1279305 - Posted: 2 Sep 2012, 17:00:13 UTC
Last modified: 2 Sep 2012, 17:13:19 UTC

In the following picture you will find "running (0.05 CPUs + 1 ATI GPU)". Then it will change to "waiting to run(0.05 CPUs + 1 ATI GPU)(scheduler wait). This is for the ATI Video Card AMD Radeon 6700. Will I need to take this card out on the system?

can not get the image to load here so here is the link

https://sites.google.com/site/ka3wjz/home/Image4.jpg

jthon
Volunteer tester
Avatar
Send message
Joined: 12 May 08
Posts: 18
Credit: 11,160,563
RAC: 753
United States
Message 1279336 - Posted: 2 Sep 2012, 18:35:23 UTC
Last modified: 2 Sep 2012, 18:53:45 UTC

what is the diff between 41_g and 41_z?

thanks
john

rolo1
Volunteer tester
Avatar
Send message
Joined: 6 Dec 10
Posts: 14
Credit: 5,799,772
RAC: 9
United States
Message 1279339 - Posted: 2 Sep 2012, 18:52:45 UTC

Excellent!!!! Thank you for this, it has help a ton!!!

Profile arkaynProject donor
Volunteer tester
Avatar
Send message
Joined: 14 May 99
Posts: 3692
Credit: 48,733,295
RAC: 6,001
United States
Message 1279342 - Posted: 2 Sep 2012, 18:56:41 UTC - in response to Message 1279336.

what is the diff between 41_g and 41_z?

thanks
john


41_g has been released and 41_z is still in alpha test status.
____________

jthon
Volunteer tester
Avatar
Send message
Joined: 12 May 08
Posts: 18
Credit: 11,160,563
RAC: 753
United States
Message 1279346 - Posted: 2 Sep 2012, 19:10:45 UTC
Last modified: 2 Sep 2012, 19:26:29 UTC

hi, i have 2 nVIDIA cards gtx450 and gtx460 in my system. how do i utilize both?
worked fine before lunatics, had 2 cuda fermi running and now i have 4 running but off one video card. is there a fix to get the second card running.

thanks
john

jthon
Volunteer tester
Avatar
Send message
Joined: 12 May 08
Posts: 18
Credit: 11,160,563
RAC: 753
United States
Message 1279349 - Posted: 2 Sep 2012, 19:22:08 UTC - in response to Message 1279342.

thanks that helps, was getting confused during all the reading in these post.

jthon
Volunteer tester
Avatar
Send message
Joined: 12 May 08
Posts: 18
Credit: 11,160,563
RAC: 753
United States
Message 1279359 - Posted: 2 Sep 2012, 20:02:41 UTC - in response to Message 1279305.

In the following picture you will find "running (0.05 CPUs + 1 ATI GPU)". Then it will change to "waiting to run(0.05 CPUs + 1 ATI GPU)(scheduler wait). This is for the ATI Video Card AMD Radeon 6700. Will I need to take this card out on the system?

can not get the image to load here so here is the link

https://sites.google.com/site/ka3wjz/home/Image4.jpg




i took out the amd radion and put in another nvidia card. problem solved

juan BFBProject donor
Volunteer tester
Avatar
Send message
Joined: 16 Mar 07
Posts: 5414
Credit: 306,667,776
RAC: 330,801
Brazil
Message 1279365 - Posted: 2 Sep 2012, 20:17:15 UTC - in response to Message 1279346.

hi, i have 2 nVIDIA cards gtx450 and gtx460 in my system. how do i utilize both?
worked fine before lunatics, had 2 cuda fermi running and now i have 4 running but off one video card. is there a fix to get the second card running.

thanks
john


Look the answer in your other thread.

____________

Profile S@NL - eFMer - efmer.com/boincProject donor
Volunteer tester
Avatar
Send message
Joined: 7 Jun 99
Posts: 512
Credit: 130,106,819
RAC: 33,877
United States
Message 1279544 - Posted: 3 Sep 2012, 6:20:26 UTC

A GT 230M

Starting automatic test: (x41g)
02 September 2012 - 17:49:38 Start, devices: 1, device count: 1 (1.00)
02 September 2012 - 18:04:39 Runtime: Device: 0, count: 0, 888 seconds
02 September 2012 - 18:04:39 Device: 0, Count: 0, finished.
Ready ---------------------------------------------------------------------
Results:
Device: 0, device count: 1, average time / count: 888, average time on device: 888 Seconds (14 Minutes, 48 Seconds)
Next ---------------------------------------------------------------------
02 September 2012 - 18:04:39 Start, devices: 1, device count: 2 (0.50)
02 September 2012 - 18:32:12 Runtime: Device: 0, count: 1, 1642 seconds
02 September 2012 - 18:32:12 Device: 0, Count: 1, finished.
02 September 2012 - 18:32:15 Runtime: Device: 0, count: 0, 1645 seconds
02 September 2012 - 18:32:15 Device: 0, Count: 0, finished.
Ready ---------------------------------------------------------------------
Results:
Device: 0, device count: 2, average time / count: 1643, average time on device: 821 Seconds (13 Minutes, 41 Seconds)
Next ---------------------------------------------------------------------
02 September 2012 - 18:32:15 Start, devices: 1, device count: 3 (0.33)
02 September 2012 - 19:13:21 Runtime: Device: 0, count: 1, 2452 seconds
02 September 2012 - 19:13:21 Device: 0, Count: 1, finished.
02 September 2012 - 19:13:22 Runtime: Device: 0, count: 2, 2453 seconds
02 September 2012 - 19:13:22 Device: 0, Count: 2, finished.
02 September 2012 - 19:13:31 Runtime: Device: 0, count: 0, 2462 seconds
02 September 2012 - 19:13:31 Device: 0, Count: 0, finished.
Ready ---------------------------------------------------------------------
Results:
Device: 0, device count: 3, average time / count: 2455, average time on device: 818 Seconds (13 Minutes, 38 Seconds)
Next ---------------------------------------------------------------------
02 September 2012 - 19:13:33 Start, devices: 1, device count: 4 (0.25)
02 September 2012 - 20:18:58 Runtime: Device: 0, count: 3, 3912 seconds
02 September 2012 - 20:18:58 Device: 0, Count: 3, finished.
02 September 2012 - 20:19:01 Runtime: Device: 0, count: 2, 3916 seconds
02 September 2012 - 20:19:01 Device: 0, Count: 2, finished.
02 September 2012 - 20:19:02 Runtime: Device: 0, count: 1, 3917 seconds
02 September 2012 - 20:19:02 Device: 0, Count: 1, finished.
02 September 2012 - 20:19:06 Runtime: Device: 0, count: 0, 3921 seconds
02 September 2012 - 20:19:06 Device: 0, Count: 0, finished.
Ready ---------------------------------------------------------------------
Results:
Device: 0, device count: 4, average time / count: 3916, average time on device: 979 Seconds (16 Minutes, 19 Seconds)
The best average time found: 818 Seconds (13 Minutes, 38 Seconds), with count: 0.33 (3)
____________
TThrottle Control your temperatures. BoincTasks The best way to view BOINC. Anza Borrego Desert hiking.

John
Send message
Joined: 21 May 99
Posts: 49
Credit: 5,131,529
RAC: 4,701
United States
Message 1279644 - Posted: 3 Sep 2012, 13:24:07 UTC

Windows 7 Msi gtx 670 gtx 470 driver 306.02 Msi afterburner ver 2.2.3

first full run at 3 wu per card

room temp at 71 board 0 at 61 degrees c board 1 at 63 degrees C.
will see how it goes as day heats up and if I can continue to get work units.

will have to wait and see what rac does.
thanks for all the help.

____________

Profile Alex Storey
Volunteer tester
Avatar
Send message
Joined: 14 Jun 04
Posts: 553
Credit: 1,667,736
RAC: 575
Greece
Message 1279649 - Posted: 3 Sep 2012, 14:55:00 UTC - in response to Message 1279544.
Last modified: 3 Sep 2012, 15:06:20 UTC

A GT 230M...
[snip,snip]
The best average time found: 818 Seconds (13 Minutes, 38 Seconds), with count: 0.33 (3)


In Kyle's mom's voice:
"WHAT, WHAT, WHAT?"

On a pre-Fermi mobile chip? Three tasks? And no comments?

Awesome idea this tool, BTW:) Mahalo!

rolo1
Volunteer tester
Avatar
Send message
Joined: 6 Dec 10
Posts: 14
Credit: 5,799,772
RAC: 9
United States
Message 1279664 - Posted: 3 Sep 2012, 15:46:11 UTC

Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz

NVIDIA GeForce GT 525M (1023MB) driver: 301.42



Starting automatic test: (x41g)
03 September 2012 - 10:26:06 Start, devices: 1, device count: 1 (1.00)
03 September 2012 - 10:39:05 Runtime: Device: 0, count: 0, 778 seconds
03 September 2012 - 10:39:05 Device: 0, Count: 0, finished.
Ready ---------------------------------------------------------------------
Results:
Device: 0, device count: 1, average time / count: 778, average time on device: 778 Seconds (12 Minutes, 58 Seconds)
Next ---------------------------------------------------------------------
03 September 2012 - 10:39:06 Start, devices: 1, device count: 2 (0.50)
03 September 2012 - 11:00:58 Runtime: Device: 0, count: 0, 1311 seconds
03 September 2012 - 11:00:58 Device: 0, Count: 0, finished.
03 September 2012 - 11:01:06 Runtime: Device: 0, count: 1, 1319 seconds
03 September 2012 - 11:01:06 Device: 0, Count: 1, finished.
Ready ---------------------------------------------------------------------
Results:
Device: 0, device count: 2, average time / count: 1315, average time on device: 657 Seconds (10 Minutes, 57 Seconds)
Next ---------------------------------------------------------------------
03 September 2012 - 11:01:06 Start, devices: 1, device count: 3 (0.33)
03 September 2012 - 11:34:09 Runtime: Device: 0, count: 0, 1981 seconds
03 September 2012 - 11:34:09 Device: 0, Count: 0, finished.
03 September 2012 - 11:34:09 Runtime: Device: 0, count: 1, 1981 seconds
03 September 2012 - 11:34:09 Device: 0, Count: 1, finished.
03 September 2012 - 11:34:15 Runtime: Device: 0, count: 2, 1987 seconds
03 September 2012 - 11:34:15 Device: 0, Count: 2, finished.
Ready ---------------------------------------------------------------------
Results:
Device: 0, device count: 3, average time / count: 1983, average time on device: 661 Seconds (11 Minutes, 1 Seconds)
The best average time found: 657 Seconds (10 Minutes, 57 Seconds), with count: 0.50 (2)

SFCC
Send message
Joined: 3 Sep 12
Posts: 1
Credit: 15,558
RAC: 0
United States
Message 1279832 - Posted: 3 Sep 2012, 23:41:05 UTC
Last modified: 3 Sep 2012, 23:57:40 UTC

OK, I GIVE UP!!

As I have said in previous posts, V 1.0 and V 1.1 error out. I thought maybe it was because I am not running the Lunatics GPU app, so I downloaded and installed it (V 0.40). Restarted BOINC and SETI Enhanced appears to run OK using the Lunatics executable. "Snoozed" the GPU and ran V 1.1, error! Downloaded V 1.2 -- same thing!

I changed the setting in app_info.xml to run two instances in the GPU, and it is chugging along just fine!

So why the #@! won't Fred's test program run on my machine??

Dual core AMD, 3GB memory, NVIDIA GT 520 GPU with 2GB memory and driver 285.58, Windows XP SP3, BOINC 7.0.28.

EDIT -- Just noticed that I posted this under the wrong user name (I have two -- don't ask). The machine in question is running SETI under the user name 'w1hue', machine ID 'lepc'. Sorry about that...

EDIT #2 -- the GT 520 has 1GB of memory, not 2GB. According to GPU-Z, it is running at 99% capacity with two SETI instances under Lunatics -- it was at 92% using the standard app (didn't check it with one instance under Lunatics).

Grant (SSSF)
Send message
Joined: 19 Aug 99
Posts: 5868
Credit: 60,622,963
RAC: 47,477
Australia
Message 1279893 - Posted: 4 Sep 2012, 5:55:55 UTC - in response to Message 1279832.


So why the #@! won't Fred's test program run on my machine??

Try exiting BOINC, not snoozing.
____________
Grant
Darwin NT.

John
Send message
Joined: 21 May 99
Posts: 49
Credit: 5,131,529
RAC: 4,701
United States
Message 1279961 - Posted: 4 Sep 2012, 12:19:18 UTC

First Run at 3 wu each on Gtx 670 and Gtx 470
Have completed over 400 wu with a full 1 day cache.

I have only seen one error so far on the work unit listed below.
not a -9 error still trying to figure out what card it came from. System temps
worst seen so far, Room Temp 84 f board 0 at 71 degrees c and board 1 at 70 degrees C. (seems ok so far)
Started with RAC close to zero and at 3026 after almost a full day of running CUDA only. Waiting for CPU DistRTgen tasks on CPU to finish. Should complete some time today.



Workunit 1058725176
____________

Profile arkaynProject donor
Volunteer tester
Avatar
Send message
Joined: 14 May 99
Posts: 3692
Credit: 48,733,295
RAC: 6,001
United States
Message 1279991 - Posted: 4 Sep 2012, 14:36:55 UTC - in response to Message 1279961.

First Run at 3 wu each on Gtx 670 and Gtx 470
Have completed over 400 wu with a full 1 day cache.

I have only seen one error so far on the work unit listed below.
not a -9 error still trying to figure out what card it came from. System temps
worst seen so far, Room Temp 84 f board 0 at 71 degrees c and board 1 at 70 degrees C. (seems ok so far)
Started with RAC close to zero and at 3026 after almost a full day of running CUDA only. Waiting for CPU DistRTgen tasks on CPU to finish. Should complete some time today.



Workunit 1058725176


You currently have 2 errors, 1 from each card. But they are a software error and not hardware. The most recent one came from the GTX-470.

The -12 error is something that is being mostly fixed in the forthcoming x41z.

setiathome_CUDA: Found 2 CUDA device(s):
Device 1: GeForce GTX 470, 1279 MiB, regsPerBlock 32768
computeCap 2.0, multiProcs 14
clockRate = 1215000
Device 2: GeForce GTX 670, 2048 MiB, regsPerBlock 65536
computeCap 3.0, multiProcs 7
clockRate = 1045500
In cudaAcc_initializeDevice(): Boinc passed DevPref 1
setiathome_CUDA: CUDA Device 1 specified, checking...
Device 1: GeForce GTX 470 is okay
SETI@home using CUDA accelerated device GeForce GTX 470
____________

w1hueProject donor
Volunteer tester
Send message
Joined: 4 Aug 00
Posts: 48
Credit: 1,806,452
RAC: 1,043
United States
Message 1280053 - Posted: 4 Sep 2012, 22:42:13 UTC - in response to Message 1279893.


So why the #@! won't Fred's test program run on my machine??

Try exiting BOINC, not snoozing.

Did that already -- still won't run. Here's what I get:

Starting automatic test: (x41g)
04 September 2012 - 15:40:25 Start, devices: 1, device count: 1 (1.00)
04 September 2012 - 15:40:34 ERROR: Device: 0, Count: 0, program failed to start.
Ready ---------------------------------------------------------------------
Results:
Device: 0, device count: 1, average time / count: 0, average time on device: 0 Seconds (0 Minutes, 0 Seconds)
Aborted, detected an error, results may be invalid.

____________

Previous · 1 . . . 4 · 5 · 6 · 7 · 8 · 9 · 10 . . . 13 · Next

Message boards : Number crunching : Optimize your GPU. Find the value the easy way.

Copyright © 2014 University of California