Optimize your GPU. Find the value the easy way.


log in

Advanced search

Message boards : Number crunching : Optimize your GPU. Find the value the easy way.

Previous · 1 . . . 10 · 11 · 12 · 13
Author Message
Profile S@NL - eFMer - efmer.com/boincProject donor
Volunteer tester
Avatar
Send message
Joined: 7 Jun 99
Posts: 512
Credit: 128,932,809
RAC: 35,663
United States
Message 1307062 - Posted: 17 Nov 2012, 9:49:39 UTC - in response to Message 1306949.

Hello Fred, thank you very much for the program i use it from the first version you release.
I want to ask you which driver you use to complete 130sec for WU for GTX 295 and which WU from the list because my top time with 3 drivers tested same clock everything the same the best time for Core755/Shaders1655/Mem1255 is 188-190 sec with x41g for wu.
and my max settings are 805/1733/1255 the time for PG0444_v7 unit need 179 sec.

Driver 280.26
The Wu is the one in zip\x41g
Using default settings 576 / 1008 / 1242 "Factory shipped frequencies"

____________
TThrottle Control your temperatures. BoincTasks The best way to view BOINC. Anza Borrego Desert hiking.

Profile S@NL - eFMer - efmer.com/boincProject donor
Volunteer tester
Avatar
Send message
Joined: 7 Jun 99
Posts: 512
Credit: 128,932,809
RAC: 35,663
United States
Message 1307064 - Posted: 17 Nov 2012, 9:54:37 UTC - in response to Message 1307062.

V 1.7 with a small bug fix, now stops as soon as the best result has been reached.

http://www.efmer.eu/forum_tt/index.php?topic=974.0
____________
TThrottle Control your temperatures. BoincTasks The best way to view BOINC. Anza Borrego Desert hiking.

SupeRNovA
Volunteer tester
Avatar
Send message
Joined: 25 Oct 04
Posts: 131
Credit: 9,238,042
RAC: 0
Bulgaria
Message 1307081 - Posted: 17 Nov 2012, 12:52:30 UTC - in response to Message 1307062.
Last modified: 17 Nov 2012, 13:09:57 UTC

Hello Fred, thank you very much for the program i use it from the first version you release.
I want to ask you which driver you use to complete 130sec for WU for GTX 295 and which WU from the list because my top time with 3 drivers tested same clock everything the same the best time for Core755/Shaders1655/Mem1255 is 188-190 sec with x41g for wu.
and my max settings are 805/1733/1255 the time for PG0444_v7 unit need 179 sec.

Driver 280.26
The Wu is the one in zip\x41g
Using default settings 576 / 1008 / 1242 "Factory shipped frequencies"

It is my mistake it is not the PG0444_v7 unit it was the unit which was in the zip\x41g ok. thank you i will install the 280.26 and give it a try.

BTW these 130sec are for 1 wu for the GTX 295 total or 130 sec per gpu on the GTX 295 ?
Thank You
____________

JarrettH
Send message
Joined: 14 Nov 02
Posts: 71
Credit: 12,844,499
RAC: 8,773
Canada
Message 1328158 - Posted: 17 Jan 2013, 3:58:29 UTC

I get this error all the time...

Starting automatic test: (x41g)
16 January 2013 - 22:54:39 Start, devices: 1, device count: 1 (1.00)
16 January 2013 - 22:54:40 ERROR: Device: 0, Count: 0, program failed to start.
--------------------------------------------------------------------------- Results:
Device: 0, device count: 1, average time / count: 0, average time on device: 0 Seconds (0 Minutes, 0 Seconds)
Aborted, detected an error, results may be invalid.

Intel Core 2 Duo E6600
GeForce 550 Ti 310.90 WHQL
Windows 7 64-bit

No matter if I run 32-bit app or 64-bit app and test automatically or with values above.

____________

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2686
Credit: 6,078,810
RAC: 4,384
Bulgaria
Message 1328209 - Posted: 17 Jan 2013, 7:26:27 UTC - in response to Message 1328158.


Paste/start this from Run ... (Win+R or the field in Start Menu):
Explorer "%APPDATA%\eFMer\SetiPerformance\"

Go to slot0 folder

Start the test in SetiPerformance64.exe
Wait for error, do not exit SetiPerformance
Check the stderr.txt (in slot0)


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Profile S@NL - eFMer - efmer.com/boincProject donor
Volunteer tester
Avatar
Send message
Joined: 7 Jun 99
Posts: 512
Credit: 128,932,809
RAC: 35,663
United States
Message 1328412 - Posted: 17 Jan 2013, 21:00:53 UTC - in response to Message 1275613.


So ... what am I not doing correctly? (Yes, I stopped BOINC Manager before executing the performance utility).

Look here:
C:\Users\username\AppData\Roaming\eFMer\SetiPerformance\slot0

stderr.txt should give you a clue.

The GT 520 may not be able to run the g version.
____________
TThrottle Control your temperatures. BoincTasks The best way to view BOINC. Anza Borrego Desert hiking.

JarrettH
Send message
Joined: 14 Nov 02
Posts: 71
Credit: 12,844,499
RAC: 8,773
Canada
Message 1328504 - Posted: 18 Jan 2013, 2:46:04 UTC

I don't see a stderr.txt in the slot0 folder

files in slot0 folder are...

cudart32_32_16.dll
cufft32_32_16.dll
init_data
Lunatics_x41g_win32_cuda32_perf
work_unit.sah
____________

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2686
Credit: 6,078,810
RAC: 4,384
Bulgaria
Message 1328638 - Posted: 18 Jan 2013, 14:06:02 UTC - in response to Message 1328504.
Last modified: 18 Jan 2013, 14:23:00 UTC


Do you exit BOINC before SetiPerformance test?
Try also to stop your antivirus before the test.
(something is preventing Lunatics_x41g_win32_cuda32_perf.exe to start)


Another test you may try:
Get the 'combined package' (collected by me) from this post:
http://setiathome.berkeley.edu/forum_thread.php?id=69136&postid=1300787#1300787

Select 'SetiPerformance Test4Test' (there are 2 versions)
Try to run it
(it starts very simple executable - no CPU or GPU usage, just wait timer)
Report is it starting.

Try also the NVIDIA AP test (AP6_win_x86_SSE2_OpenCL_NV_r1316) (from the same 'combined package')


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Profile Michael W.F. Miles
Avatar
Send message
Joined: 24 Mar 07
Posts: 238
Credit: 28,373,532
RAC: 19,713
Canada
Message 1328833 - Posted: 18 Jan 2013, 21:49:24 UTC

Just for your info
Jason Gee is the developer and he has done a tremendous job.
Much much faster

http://jgopt.org/download.html


S@NL - JBGProject donor
Send message
Joined: 26 Jan 00
Posts: 11
Credit: 12,048,710
RAC: 6,297
Netherlands
Message 1331249 - Posted: 25 Jan 2013, 19:39:46 UTC

Here the results of the GPU test with AP6_win_x86_SSE2_OpenCL_NV_r1316.


Grafic card info:
TThrottle running with setup GPU max temp = 78grC (@100% GPU use) // Max temp GPU @100% during test GPU0 = 75grC // GPU1 = 72grC

OpenCL: NVIDIA GPU 1: GeForce GTX 690 (driver version 306.97, device version OpenCL 1.1 CUDA, 2048MB, 1880MB available)
OpenCL: NVIDIA GPU 0: GeForce GTX 690 (driver version 306.97, device version OpenCL 1.1 CUDA, 2048MB, 8382243MB available)
NVIDIA GPU 1: GeForce GTX 690 (driver version 306.97, CUDA version 5.0, compute capability 3.0, 2048MB, 1880MB available, 3132 GFLOPS peak)
NVIDIA GPU 0: GeForce GTX 690 (driver version 306.97, CUDA version 5.0, compute capability 3.0, 2048MB, 8382243MB available, 3132 GFLOPS peak)



Starting automatic test: (AP6_win_x86_SSE2_OpenCL_NV_r1316)
25 January 2013 - 19:56:30 Start, devices: 2, device count: 1 (1.00)
--------------------------------------------------------------------------- Results:
Device: 0, device count: 1, average time / count: 210, average time on device: 210 Seconds (3 Minutes, 30 Seconds)
Device: 1, device count: 1, average time / count: 216, average time on device: 216 Seconds (3 Minutes, 36 Seconds)
Next :---------------------------------------------------------------------------
25 January 2013 - 20:00:09 Start, devices: 2, device count: 2 (0.50)
--------------------------------------------------------------------------- Results:
Device: 0, device count: 2, average time / count: 392, average time on device: 196 Seconds (3 Minutes, 16 Seconds)
Device: 1, device count: 2, average time / count: 406, average time on device: 203 Seconds (3 Minutes, 23 Seconds)
Next :---------------------------------------------------------------------------
25 January 2013 - 20:07:04 Start, devices: 2, device count: 3 (0.33)
--------------------------------------------------------------------------- Results:
Device: 0, device count: 3, average time / count: 595, average time on device: 198 Seconds (3 Minutes, 18 Seconds)
Device: 1, device count: 3, average time / count: 618, average time on device: 206 Seconds (3 Minutes, 26 Seconds)
Next :---------------------------------------------------------------------------
25 January 2013 - 20:17:30 Start, devices: 2, device count: 4 (0.25)
-------------------------------------------------------------------------- Results:
Device: 0, device count: 4, average time / count: 798, average time on device: 199 Seconds (3 Minutes, 19 Seconds)
Device: 1, device count: 4, average time / count: 830, average time on device: 207 Seconds (3 Minutes, 27 Seconds)

Program: >> The best average time found: 202 Seconds (3 Minutes, 22 Seconds), with count: 0.33 (3)

But with just a fuw seconds between all the tests seems that on my card the count set to 0.25 will also work.

____________

ClaggyProject donor
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 4094
Credit: 33,032,408
RAC: 7,374
United Kingdom
Message 1331289 - Posted: 25 Jan 2013, 21:21:24 UTC - in response to Message 1331249.

Program: >> The best average time found: 202 Seconds (3 Minutes, 22 Seconds), with count: 0.33 (3)

But with just a fuw seconds between all the tests seems that on my card the count set to 0.25 will also work.

And what is the Best number of tasks to run if you Optimise the AP app's parameters first? The default parameters are set very low so it'll run on almost any GPU.

Claggy

S@NL - JBGProject donor
Send message
Joined: 26 Jan 00
Posts: 11
Credit: 12,048,710
RAC: 6,297
Netherlands
Message 1331350 - Posted: 25 Jan 2013, 23:37:07 UTC - in response to Message 1331289.

Here you have the request information using the Optimised parameters:


Starting automatic test: (AP6_win_x86_SSE2_OpenCL_NV_r1316)
26 January 2013 - 00:12:06 Start, devices: 2, device count: 1 (1.00)
26 January 2013 - 00:12:06 Set: AP6_win_x86_SSE2_OpenCL_NV_r1316 , Exe: AP6_win_x86_SSE2_OpenCL_NV_r1316.exe , Parameters: --device %device -unroll 10 -ffa_block 6144 -ffa_block_fetch 1536
--------------------------------------------------------------------------- Results:
Device: 0, device count: 1, average time / count: 156, average time on device: 156 Seconds (2 Minutes, 36 Seconds)
Device: 1, device count: 1, average time / count: 158, average time on device: 158 Seconds (2 Minutes, 38 Seconds)
Next :---------------------------------------------------------------------------
26 January 2013 - 00:14:47 Start, devices: 2, device count: 2 (0.50)
26 January 2013 - 00:14:47 Set: AP6_win_x86_SSE2_OpenCL_NV_r1316 , Exe: AP6_win_x86_SSE2_OpenCL_NV_r1316.exe , Parameters: --device %device -unroll 10 -ffa_block 6144 -ffa_block_fetch 1536
--------------------------------------------------------------------------- Results:
Device: 0, device count: 2, average time / count: 308, average time on device: 154 Seconds (2 Minutes, 34 Seconds)
Device: 1, device count: 2, average time / count: 310, average time on device: 155 Seconds (2 Minutes, 35 Seconds)
Next :---------------------------------------------------------------------------
26 January 2013 - 00:20:03 Start, devices: 2, device count: 3 (0.33)
26 January 2013 - 00:20:03 Set: AP6_win_x86_SSE2_OpenCL_NV_r1316 , Exe: AP6_win_x86_SSE2_OpenCL_NV_r1316.exe , Parameters: --device %device -unroll 10 -ffa_block 6144 -ffa_block_fetch 1536
-------------------------------------------------------------------------- Results:
Device: 0, device count: 3, average time / count: 410, average time on device: 136 Seconds (2 Minutes, 16 Seconds)
Device: 1, device count: 3, average time / count: 416, average time on device: 138 Seconds (2 Minutes, 18 Seconds)
Next :---------------------------------------------------------------------------
26 January 2013 - 00:27:13 Start, devices: 2, device count: 4 (0.25)
26 January 2013 - 00:27:13 Set: AP6_win_x86_SSE2_OpenCL_NV_r1316 , Exe: AP6_win_x86_SSE2_OpenCL_NV_r1316.exe , Parameters: --device %device -unroll 10 -ffa_block 6144 -ffa_block_fetch 1536
--------------------------------------------------------------------------- Results:
Device: 0, device count: 4, average time / count: 535, average time on device: 133 Seconds (2 Minutes, 13 Seconds)
Device: 1, device count: 4, average time / count: 537, average time on device: 134 Seconds (2 Minutes, 14 Seconds)

>> The best average time found: 137 Seconds (2 Minutes, 17 Seconds), with count: 0.33 (3)


As you can see the speed is almost 1 minute faster using the optimised parameters
____________

Previous · 1 . . . 10 · 11 · 12 · 13

Message boards : Number crunching : Optimize your GPU. Find the value the easy way.

Copyright © 2014 University of California