GPU use questions


log in

Advanced search

Questions and Answers : GPU applications : GPU use questions

Author Message
Profile Samaritan Jim
Send message
Joined: 27 Mar 05
Posts: 6
Credit: 2,190,608
RAC: 2,978
United States
Message 1273077 - Posted: 19 Aug 2012, 19:49:25 UTC

Hello all,

I am looking to build a new computer ( my first home built )and would like to know .. If I build a new machine and want to take advantage of the new GPU's ability to crunch more data for various projects then a standard Windows computer using just a Cpu, will a computer use both the GPU and the CPU(S) on a machine or only use the GPU with the new software made to run on Boinc projects?

I ask as I am not clear about that and wondered if it only uses GPU then I would not go out of my way to build a high end quad as it would not use the Cpu but if it does use both Gpu and Cpu, going high end quad would make sense with a good Gpu.

Any help - thoughts on this to help me out?

Also, anyone build a good machine that would be willing to send me a detail list of the parts they have used to make their machine?

THANK YOU all for your time and help.

Jim

Profile Gatekeeper
Avatar
Send message
Joined: 14 Jul 04
Posts: 887
Credit: 176,479,616
RAC: 0
United States
Message 1273081 - Posted: 19 Aug 2012, 20:05:53 UTC

BOINC/seti will use both CPU and GPU(s) for analyzing data. As you said, the GPU will do much more work, faster.

If you want an idea of what others are using, a good place to start is the "top computers" listing under Statistics. Obviously, these tend to be higher end machines, but smaller, less expensive builds will perform as well, they just won't produce the same high numbers.
____________

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2794
Credit: 6,307,169
RAC: 7,460
Bulgaria
Message 1273222 - Posted: 20 Aug 2012, 8:35:33 UTC - in response to Message 1273077.


If you want to read some (long) discussions about build/upgrade (to decide your own "detail list of the parts"):
http://setiathome.berkeley.edu/forum_thread.php?id=68799
http://setiathome.berkeley.edu/forum_thread.php?id=68906
http://setiathome.berkeley.edu/forum_thread.php?id=68511
http://setiathome.berkeley.edu/forum_thread.php?id=67605


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Belgarath the Sorcerer
Send message
Joined: 25 Aug 99
Posts: 2
Credit: 283,177
RAC: 0
Sweden
Message 1275723 - Posted: 26 Aug 2012, 12:07:45 UTC

Hi!

I think this is third time i got an opencl_nvidia_100 workunit (8 MB size).
It has failed processing every time.

After a few seconds it stops processing with a computation error and the workunit disappears from the Tasks window. :-(

See log:


2012-08-26 13:04:19 | SETI@home | Started download of ap_22fe12ad_B6_P1_00216_20120825_03472.wu
2012-08-26 13:04:19 | SETI@home | Started download of ap_23no10ae_B5_P0_00392_20120825_25934.wu
2012-08-26 13:04:21 | | Windows is resuming operations
2012-08-26 13:05:31 | | Resuming computation
2012-08-26 13:05:39 | SETI@home | Finished download of ap_22fe12ad_B6_P1_00216_20120825_03472.wu
2012-08-26 13:05:39 | SETI@home | Started download of 06my10ab.21167.16427.5.10.246
2012-08-26 13:05:39 | SETI@home | Starting task ap_22fe12ad_B6_P1_00216_20120825_03472.wu_0 using astropulse_v6 version 604 (opencl_nvidia_100) in slot 5
2012-08-26 13:05:41 | SETI@home | Computation for task ap_22fe12ad_B6_P1_00216_20120825_03472.wu_0 finished
2012-08-26 13:05:41 | SETI@home | Output file ap_22fe12ad_B6_P1_00216_20120825_03472.wu_0_0 for task ap_22fe12ad_B6_P1_00216_20120825_03472.wu_0 absent

---

I am using Boinc v7.0.28 (x64).

My computer is:
GenuineIntel
Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz [Family 6 Model 42 Stepping 7]
(8 processors)

NVIDIA GeForce GT 525M (2014MB) driver: 265.94

Microsoft Windows 7
Home Premium x64 Edition, Service Pack 1, (06.01.7601.00)

/Regards,
Peter Nilsson
User ID: 186154


____________

Profile Raistmer
Volunteer developer
Volunteer tester
Avatar
Send message
Joined: 16 Jun 01
Posts: 3486
Credit: 47,522,898
RAC: 36,755
Russia
Message 1276376 - Posted: 27 Aug 2012, 19:02:37 UTC - in response to Message 1275723.
Last modified: 27 Aug 2012, 19:03:38 UTC

OpenCL runtime reported error code -11, that is, CL_BUILD_PROGRAM_FAILURE.
Not very descriptive one. Maybe CL file is damaged, try to redownload it...
[EDIT: you need to do project reset for this AFAIK]

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2794
Credit: 6,307,169
RAC: 7,460
Bulgaria
Message 1276561 - Posted: 28 Aug 2012, 6:50:20 UTC - in response to Message 1275723.
Last modified: 28 Aug 2012, 7:07:22 UTC


You can get this 'CL file' (47 KB - 47,964 bytes) from this direct link and compare with the one you have to see are they the same length/content:
http://boinc2.ssl.berkeley.edu/sah/download_fanout/AstroPulse_Kernels_r1316.cl


P.S.
Be careful - if you [Reset] the project - all (even finished) tasks will be deleted.

If you decide to do 'Reset':
- set [No new tasks] (from Projects tab)
- Finish all tasks and Report them ([Update] button from Projects tab) (after this the Tasks tab will be empty)
- Now you can do [Reset]
- [Allow new tasks]


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Questions and Answers : GPU applications : GPU use questions

Copyright © 2014 University of California