Bug in server affecting older BOINC clients with NVIDIA GPUs.


log in

Advanced search

Message boards : News : Bug in server affecting older BOINC clients with NVIDIA GPUs.

Previous · 1 · 2 · 3 · 4 · 5 . . . 7 · Next
Author Message
Grant (SSSF)
Send message
Joined: 19 Aug 99
Posts: 5566
Credit: 51,417,689
RAC: 42,001
Australia
Message 1272400 - Posted: 18 Aug 2012, 2:25:18 UTC - in response to Message 1272335.

Damn, now the vlars are broke again?

Not that i've noticed.
There aren't a lot about at the moment, but since the outage all that i have received have gone to my CPUs, not my Nvidia GPUs.
____________
Grant
Darwin NT.

Eric Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar
Send message
Joined: 3 Apr 99
Posts: 1076
Credit: 7,785,993
RAC: 6,865
United States
Message 1272419 - Posted: 18 Aug 2012, 3:32:27 UTC - in response to Message 1272400.

Good! A check of the server logs also shows that the VLAR prevention mechanism should be in place.

____________

默声人
Send message
Joined: 10 Aug 12
Posts: 2
Credit: 22,561
RAC: 0
China
Message 1272421 - Posted: 18 Aug 2012, 3:54:53 UTC

我明白了

Profile BilBg
Avatar
Send message
Joined: 27 May 07
Posts: 2457
Credit: 5,428,413
RAC: 8,051
Bulgaria
Message 1272427 - Posted: 18 Aug 2012, 5:20:56 UTC


translate.google:
我明白了 == I understand


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Charles LaDue
Send message
Joined: 13 Aug 10
Posts: 1
Credit: 25,355
RAC: 0
United States
Message 1272441 - Posted: 18 Aug 2012, 6:03:34 UTC
Last modified: 18 Aug 2012, 6:04:39 UTC

I don't know how to write code and was hoping someone might post a cc.config.xml that forces BOINC to use my single GTX 550 Ti gpu..can't seem to get any task to utilize this gpu...please help.

Thank you in advance. I am using version 7.0.28

samspade
Send message
Joined: 10 Jul 12
Posts: 9
Credit: 62,635
RAC: 0
Germany
Message 1272444 - Posted: 18 Aug 2012, 6:18:16 UTC


Hello ?!

what bug in nvidia is it exactly ?

nvidia in Window$
or
nvidia under Linux ?

It seems that driver-package of nvidia has those bugs,
who are creating trouble under Linux - wherefor it is better
to run vesa under Linux than nvidia-drivers ...
sometimes it is better not to use the most modern or most actual software
like those drivers of nvidia, which are not completely un-bugged.

Regards.
samspade.

Profile BilBg
Avatar
Send message
Joined: 27 May 07
Posts: 2457
Credit: 5,428,413
RAC: 8,051
Bulgaria
Message 1272457 - Posted: 18 Aug 2012, 6:43:10 UTC - in response to Message 1272441.
Last modified: 18 Aug 2012, 7:09:36 UTC

... cc.config.xml that forces BOINC to use my single GTX 550 Ti ...

You don't need cc_config.xml to use GTX 550 Ti for BOINC purposes, you need CUDA driver.

So, never let Windows to install/update video card drivers! (they lack many features)
Get the driver from the video card manufacturer or the GPU manufacturer (in your case NVIDIA)

Check with GPU-Z to see if CUDA and OpenCL are installed.


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Profile BilBg
Avatar
Send message
Joined: 27 May 07
Posts: 2457
Credit: 5,428,413
RAC: 8,051
Bulgaria
Message 1272460 - Posted: 18 Aug 2012, 6:57:17 UTC - in response to Message 1272444.
Last modified: 18 Aug 2012, 7:36:29 UTC

what bug in nvidia is it exactly ?

There are bugs in nVidia drivers (as in any other software) but this thread is not about any of them.

The bug was in the server part of BOINC (at setiathome.berkeley.edu)
(Not connected/induced by anything that you as user do or not do on your machine (except your chosen BOINC version).
The problem: the new BOINC server code (that runs in the SETI lab at Berkeley) 'forgot' that it have to connect also to older (before v7) BOINC versions on the user machines.

The new BOINC server code reported <type>NVIDIA</type> but the older BOINC versions on the user machines understand only <type>CUDA</type>
Now BOINC server code is fixed to report <type>NVIDIA</type> if you use BOINC 7.0 (or later) and <type>CUDA</type> if you use BOINC < v7 (e.g. 6.10.x)
)


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Profile Ageless
Avatar
Send message
Joined: 9 Jun 99
Posts: 12128
Credit: 2,522,094
RAC: 460
Netherlands
Message 1272488 - Posted: 18 Aug 2012, 8:17:32 UTC - in response to Message 1272441.

Addendum to what BilBg wrote to you, the Nvidia drivers can be found on http://www.nvidia.com/Download/index.aspx?lang=en-us
____________
Jord

Loving awareness is free.

msattler
Volunteer tester
Avatar
Send message
Joined: 9 Jul 00
Posts: 37382
Credit: 500,097,420
RAC: 524,079
United States
Message 1272766 - Posted: 19 Aug 2012, 0:08:48 UTC
Last modified: 19 Aug 2012, 0:09:15 UTC

So, if I understand this correctly, these WUs are sitting in my caches on 7 rigs like little time bombs waiting to go off when they get to the top of the cache?
____________
******************
Crunching Seti, loving all of God's kitties.

I have met a few friends in my life.
Most were cats.

Profile Wiggo
Avatar
Send message
Joined: 24 Jan 00
Posts: 5210
Credit: 83,109,175
RAC: 72,062
Australia
Message 1272770 - Posted: 19 Aug 2012, 0:43:09 UTC - in response to Message 1272766.
Last modified: 19 Aug 2012, 0:43:36 UTC

My GTX560 TI and 2x GTX550Ti rigs don't seem to have a problem with them other than they take 3-5 times longer to complete than an average work unit (both rigs no signs of bogging down even with each card doing 2 at a time).

It will interesting to see how my 3x 9800GT rig handles them when it comes to getting into its lot, but then drivers have come quite a long way since the VLAR code was first introduced.

Cheers.
____________

Profile BilBg
Avatar
Send message
Joined: 27 May 07
Posts: 2457
Credit: 5,428,413
RAC: 8,051
Bulgaria
Message 1272795 - Posted: 19 Aug 2012, 3:14:39 UTC - in response to Message 1272770.


This thread is not about 'VLARs on NVIDIA GPUs'
It's about different problem: running many (e.g. 10-40) tasks (of any AR, not only VLAR) on single NVIDIA GPU

(I'm not sure if this problem affects 'Anonymous platform' hosts)


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Profile BilBg
Avatar
Send message
Joined: 27 May 07
Posts: 2457
Credit: 5,428,413
RAC: 8,051
Bulgaria
Message 1272797 - Posted: 19 Aug 2012, 3:19:58 UTC - in response to Message 1272766.

So, if I understand this correctly, these WUs are sitting in my caches ...

Do you have <type>NVIDIA</type> in client_state.xml


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Josef W. Segur
Volunteer developer
Volunteer tester
Send message
Joined: 30 Oct 99
Posts: 4137
Credit: 1,004,312
RAC: 247
United States
Message 1272811 - Posted: 19 Aug 2012, 5:29:00 UTC - in response to Message 1272766.

So, if I understand this correctly, these WUs are sitting in my caches on 7 rigs like little time bombs waiting to go off when they get to the top of the cache?

No, the problem only happened to hosts running stock where the server sends a complete app_version. Hosts running anonymous platform are merely told which of the app_versions listed in the app_info.xml to use.
Joe

msattler
Volunteer tester
Avatar
Send message
Joined: 9 Jul 00
Posts: 37382
Credit: 500,097,420
RAC: 524,079
United States
Message 1272826 - Posted: 19 Aug 2012, 6:04:38 UTC - in response to Message 1272811.

So, if I understand this correctly, these WUs are sitting in my caches on 7 rigs like little time bombs waiting to go off when they get to the top of the cache?

No, the problem only happened to hosts running stock where the server sends a complete app_version. Hosts running anonymous platform are merely told which of the app_versions listed in the app_info.xml to use.
Joe

Thanks, Joe.
That gives the kitties a little more peace of mind.
____________
******************
Crunching Seti, loving all of God's kitties.

I have met a few friends in my life.
Most were cats.

Profile KWSN THE Holy Hand Grenade!
Volunteer tester
Avatar
Send message
Joined: 20 Dec 05
Posts: 1831
Credit: 7,554,851
RAC: 21,038
United States
Message 1273349 - Posted: 20 Aug 2012, 16:02:31 UTC
Last modified: 20 Aug 2012, 16:03:26 UTC

in the "news" department, there are two problems: 1) I can't upload completed tasks; 2) the "Server Status" page shows as a blank! (as of time & date posted)
____________
.

msattler
Volunteer tester
Avatar
Send message
Joined: 9 Jul 00
Posts: 37382
Credit: 500,097,420
RAC: 524,079
United States
Message 1273352 - Posted: 20 Aug 2012, 16:06:15 UTC - in response to Message 1273349.

in the "news" department, there are two problems: 1) I can't upload completed tasks; 2) the "Server Status" page shows as a blank! (as of time & date posted)

Servers are probably being rebooted as we speak....
____________
******************
Crunching Seti, loving all of God's kitties.

I have met a few friends in my life.
Most were cats.

Profile Ageless
Avatar
Send message
Joined: 9 Jun 99
Posts: 12128
Credit: 2,522,094
RAC: 460
Netherlands
Message 1273353 - Posted: 20 Aug 2012, 16:07:01 UTC - in response to Message 1273349.
Last modified: 20 Aug 2012, 16:07:24 UTC

2) the "Server Status" page shows as a blank! (as of time & date posted)

It's partially available on http://setiathome.berkeley.edu/server_status.php although very slow to load to it. Thus looks like a new server setup has been loaded, as the 'server_status.php' page is the default page in the BOINC back-end source code. 'sah_status.html' is the Setified page for it, but not the standard one.
____________
Jord

Loving awareness is free.

Profile Tom Miller
Send message
Joined: 31 Mar 12
Posts: 2
Credit: 39,167,089
RAC: 107,658
United States
Message 1273440 - Posted: 20 Aug 2012, 18:16:51 UTC - in response to Message 1271871.

I just put up a new machine, Enigma III. I can't get work. All my machines will be changing over the next two weeks. I never have been successful in bringing work assignments to a new machine. ( a little help? ).

When might I see work for Enigma III?


____________

Profile Fred E.
Volunteer tester
Send message
Joined: 22 Jul 99
Posts: 731
Credit: 22,137,559
RAC: 25,096
United States
Message 1273461 - Posted: 20 Aug 2012, 18:35:31 UTC

When might I see work for Enigma III?


Shouild be soon. The project has had problems and work's underway. Downloads just came back.

If you don't get some soon, open a thread in Q&A or Number Crunching - we don't usually do troubleshooting in this forum.
____________
Another Fred
Support SETI@home when you search the Web with GoodSearch or shop online with GoodShop.

Previous · 1 · 2 · 3 · 4 · 5 . . . 7 · Next

Message boards : News : Bug in server affecting older BOINC clients with NVIDIA GPUs.

Copyright © 2014 University of California