New AstroPulse applications for GPUs.


log in

Advanced search

Message boards : News : New AstroPulse applications for GPUs.

Previous · 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 . . . 10 · Next
Author Message
ClaggyProject donor
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 4251
Credit: 34,990,554
RAC: 20,889
United Kingdom
Message 1273948 - Posted: 22 Aug 2012, 12:49:53 UTC - in response to Message 1273899.
Last modified: 22 Aug 2012, 12:51:25 UTC

Should this also work on a ATI 4650 AGP GPU? And/or is there a specific catalyst driver version that is needed? Mine isn't automatically downloading GPU work units at the moment...
Depends what CPU you have, If the CPU supports SSE2 and above then yes, but i reckon your CPU is an XP Athlon with only SSE, so No. (Similar to my XP3200+/AGP HD4650/8400GS host)

It should work on an AGP HD4650 (subject to correct CPU support), Cat 10.12 might be too old, But since you're running XP the latest driver that you can use is Cat 12.1, drivers after that have OpenCL support deprecated.

Claggy

Lelton Woodham
Send message
Joined: 7 Jul 02
Posts: 4
Credit: 1,292,397
RAC: 0
United States
Message 1274298 - Posted: 23 Aug 2012, 8:59:59 UTC - in response to Message 1269053.
Last modified: 23 Aug 2012, 9:35:03 UTC

If the stock applications, then exit BOINC completely, next navigate to your BOINC data directory (default at C:\Programdata\BOINC\), \projects\setiathome.berkeley.edu\ and delete the app_info.xml file.
Next restart BOINC (Start->All programs->BOINC->BOINC Manager), advanced view, Projects tab, select Seti@Home and click Reset. Acknowledge the reset.



I have an ATI HD 5870 and am running win 7 64bit. My processor is Intel i975 Extreme and have 12 gig ram. I am running BOINC version 7.0.28(x64)and Catalyst 12.8 video driver.

I have yet to download an Astropulse workunit. I checked for an app_info.xml where you suggested and found none. I also verified that there was no such file anywhere on my system. Any ideas? Thanks in advance.

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2894
Credit: 6,640,316
RAC: 7,914
Bulgaria
Message 1274317 - Posted: 23 Aug 2012, 9:53:58 UTC - in response to Message 1274298.
Last modified: 23 Aug 2012, 10:01:01 UTC


First check that you have "AstroPulse v6: yes" here:
http://setiathome.berkeley.edu/prefs.php?subset=project

Then - don't expect AstroPulse tasks will be available every day (they are 30x less 'in stock' than "SETI@home Enhanced" tasks)

P.S.
What you quoted is not aimed at you:
* Do NOT 'Reset' the project - all (even finished) tasks will be deleted.
* No need to search for app_info.xml - this is non-standard file (do not exist in 'standard' circumstances)


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Jupiter8
Avatar
Send message
Joined: 19 Aug 12
Posts: 6
Credit: 208,200
RAC: 0
United States
Message 1274415 - Posted: 23 Aug 2012, 14:45:14 UTC

As info -

Since I have been trying to get my ATI GPU's busy with SETI work I have noticed periodic messages such as the following in my BOINC Manager-->Advanced-->"Event log..." window:

8/23/2012 9:18:00 AM | SETI@home | Tasks for NVIDIA GPU are available, but your preferences are set to not accept them
8/23/2012 10:15:06 AM | SETI@home | Sending scheduler request: To fetch work.
8/23/2012 10:15:06 AM | SETI@home | Requesting new tasks for ATI
8/23/2012 10:15:09 AM | SETI@home | Scheduler request completed: got 0 new tasks
8/23/2012 10:15:09 AM | SETI@home | Project has no tasks available

So I think I have things setup properly on my end, I'm just waiting for ATI work.

Profile Ray_GTI-R
Avatar
Send message
Joined: 17 May 99
Posts: 56
Credit: 276,074
RAC: 0
United Kingdom
Message 1274675 - Posted: 24 Aug 2012, 1:22:04 UTC - in response to Message 1268997.
Last modified: 24 Aug 2012, 1:23:09 UTC

Well new WUs would be nice for starters but "don't expect AstroPulse tasks will be available every day (they are 30x less 'in stock' than "SETI@home Enhanced" tasks)" Oh, BTW ...WHY?
Anyway, I just want a few WUs to test that this release works better than the Lunat... app (read virtually nil GPU processing & virtually 100% flat-out CPU processing irrespective of standard BOINC non-geek CPU usage settings, abandoned some time past).

Now waiting for flak from Raist...
____________
The difference between 0 and 1 is greater than the difference between 1 and 1,000,000

Josef W. SegurProject donor
Volunteer developer
Volunteer tester
Send message
Joined: 30 Oct 99
Posts: 4348
Credit: 1,129,178
RAC: 953
United States
Message 1274703 - Posted: 24 Aug 2012, 3:25:03 UTC - in response to Message 1274675.

Well new WUs would be nice for starters but "don't expect AstroPulse tasks will be available every day (they are 30x less 'in stock' than "SETI@home Enhanced" tasks)" Oh, BTW ...WHY?
...

It's actually closer to 40x. Each AP WU contains 8 MB of the raw data as recorded at Arecibo (possibly some replaced by shaped noise when needed). Each channel of a 50.2 GB tape file has enough data to produce around 400 AP WUs. But for MB, splitting produces 256 WUs from 64 MB of raw data and there's an overlap with the next group. The channel produces about 62 groups of 256 = 15872 WUs.
Joe

Lelton Woodham
Send message
Joined: 7 Jul 02
Posts: 4
Credit: 1,292,397
RAC: 0
United States
Message 1274706 - Posted: 24 Aug 2012, 3:37:14 UTC - in response to Message 1274298.

I have an ATI HD 5870 and am running win 7 64bit. My processor is Intel i975 Extreme and have 12 gig ram. I am running BOINC version 7.0.28(x64)and Catalyst 12.8 video driver.

I have yet to download an Astropulse workunit. I checked for an app_info.xml where you suggested and found none. I also verified that there was no such file anywhere on my system. Any ideas? Thanks in advance.



Update: I have now received and GPU processed my first AP v6.04 work unit. It seems that all is well. Thanks for all the great info.

Lelton Woodham
Send message
Joined: 7 Jul 02
Posts: 4
Credit: 1,292,397
RAC: 0
United States
Message 1274708 - Posted: 24 Aug 2012, 3:48:20 UTC - in response to Message 1274703.

It's actually closer to 40x. Each AP WU contains 8 MB of the raw data as recorded at Arecibo (possibly some replaced by shaped noise when needed). Each channel of a 50.2 GB tape file has enough data to produce around 400 AP WUs. But for MB, splitting produces 256 WUs from 64 MB of raw data and there's an overlap with the next group. The channel produces about 62 groups of 256 = 15872 WUs.



It sounds like we need 400 more radio telescopes. :P

RSCBeard
Send message
Joined: 9 Oct 03
Posts: 3
Credit: 617,100
RAC: 1,051
United States
Message 1274874 - Posted: 24 Aug 2012, 14:02:18 UTC

I hoping to get the AMD GPU processing to work. I keep get messages to upgrade my driver to the latest version, but when I check AMD's website it says I have the latest (8.801.2.3000) the card is AMD Radeon 6450M. Any suggestions?

RAB
____________

Profile David Mueller
Volunteer tester
Send message
Joined: 8 Feb 01
Posts: 5
Credit: 13,072,460
RAC: 7,833
Canada
Message 1274987 - Posted: 24 Aug 2012, 19:31:22 UTC

I only have one astropulse WU for GPU.
I understand there are no AP units being created now.
But when AP units are being created.
Will I get AP WUs just for Nvidia GPU only or will I get AP WUs for my CPUs like before along with my GPU AP WUs?

Thanks
David Mueller
____________

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2894
Credit: 6,640,316
RAC: 7,914
Bulgaria
Message 1275386 - Posted: 25 Aug 2012, 14:30:33 UTC - in response to Message 1274874.
Last modified: 25 Aug 2012, 15:12:51 UTC

I hoping to get the AMD GPU processing to work.
I keep get messages to upgrade my driver to the latest version, but when I check AMD's website it says I have the latest (8.801.2.3000)
The card is AMD Radeon 6450M.
Any suggestions?

RAB

Where do you "get messages to upgrade my driver to the latest version"?

Read this my post for suggestions/links:
http://setiathome.berkeley.edu/forum_thread.php?id=69019&postid=1274352#1274352

(probably you don't have OpenCL driver installed (or it is too old?))

You use Cat 10.12 (= 2010.December), I can't believe "it says I (you) have the latest"

Is this the page you are using?:
http://support.amd.com/us/gpudownload/windows/Pages/radeonmob_win7-64.aspx


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2894
Credit: 6,640,316
RAC: 7,914
Bulgaria
Message 1275387 - Posted: 25 Aug 2012, 14:39:51 UTC - in response to Message 1274987.

But when AP units are being created.
Will I get AP WUs just for Nvidia GPU only or will I get AP WUs for my CPUs like before along with my GPU AP WUs?

Yes, you will get AP WUs for CPU & for GPU

Provided you have:
Use CPU yes
Use NVIDIA GPU yes

AstroPulse v6: yes

... here:
http://setiathome.berkeley.edu/prefs.php?subset=project


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

EldRick
Send message
Joined: 21 Jan 11
Posts: 4
Credit: 23,989
RAC: 0
United States
Message 1275439 - Posted: 25 Aug 2012, 17:14:27 UTC

That's odd. No mention of Mac OpenCL GPU support, and, actually, no mention that this only supports the ATI GPUs on Windows. Dull.

I'll surely get back in if you guys ever get around to supporting my ATI 6970M/iMac. I'm not interested in cooking the system by using the CPU.

Profile arkaynProject donor
Volunteer tester
Avatar
Send message
Joined: 14 May 99
Posts: 3748
Credit: 48,777,915
RAC: 1,076
United States
Message 1275451 - Posted: 25 Aug 2012, 17:55:49 UTC - in response to Message 1275439.

That's odd. No mention of Mac OpenCL GPU support, and, actually, no mention that this only supports the ATI GPUs on Windows. Dull.

I'll surely get back in if you guys ever get around to supporting my ATI 6970M/iMac. I'm not interested in cooking the system by using the CPU.



Eric is working on getting a Mac GPU app running, check the beta thread for more info.
http://setiweb.ssl.berkeley.edu/beta/forum_thread.php?id=1908&sort_style=6&start=60
____________

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2894
Credit: 6,640,316
RAC: 7,914
Bulgaria
Message 1275618 - Posted: 26 Aug 2012, 4:56:43 UTC - in response to Message 1275439.

That's odd. No mention of Mac OpenCL GPU support, and, actually, no mention that this only supports the ATI GPUs on Windows.

Ha!?

! First sentence in the first post:
"We've released the first of four new AstroPulse Windows applications for ATI/AMD Graphics Processing Units that support the OpenCL language"


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

RSCBeard
Send message
Joined: 9 Oct 03
Posts: 3
Credit: 617,100
RAC: 1,051
United States
Message 1276400 - Posted: 27 Aug 2012, 19:43:32 UTC - in response to Message 1275386.

The message shows up as a notice in BIONC. I've discovered that my issue is that I'm using a toshiba which evidently has issues with drivers. The verification tool will not even load. Looks like no GPU for me.

Thanks for the help.

Rich

____________

Profile Fred J. Verster
Volunteer tester
Avatar
Send message
Joined: 21 Apr 04
Posts: 3252
Credit: 31,903,520
RAC: 119
Netherlands
Message 1276422 - Posted: 27 Aug 2012, 20:26:50 UTC - in response to Message 1276400.
Last modified: 27 Aug 2012, 20:33:42 UTC

Another thing, I've had several AstroPulse WUs on my ATI 5870 GPUs, but now
I get them on the slowest (Q6600)CPU* I've running, why?

If it's really about processing them right and fast, why send it to a
CPU, if 2 fast GPUs are available? (Ten hours on CPU* and 45 minutes on ATI 5870).

Or do they simply want to 'test' the new stock AstroPulse for (ATI)? GPU(s)?
But also for NVidia GPUs? Sometimes, I don't get the picture........:-\

B.t.w. still using cat.12.4 driver and AMD-APP(SDK) 2.4, OpenCL 1.2, BOINC
7.0.31 (64bit) on WIN 7 x64, CPU=i7-2600; GPUs HD5870, 2x.8GByte DDR3 DRAM 1600
MHz.
(Also a GTX470 & 480.)
____________

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2894
Credit: 6,640,316
RAC: 7,914
Bulgaria
Message 1276629 - Posted: 28 Aug 2012, 10:59:10 UTC - in response to Message 1276400.

I'm using a Toshiba which evidently has issues with drivers. The verification tool will not even load.

Is this your laptop? (Toshiba Tecra® R850-S8530):
http://us.toshiba.com/computers/laptops/tecra/r850/r850-s8530/

If it is - look here (there is 'AMD Display Driver(06-29-2011; 131.17M)' - but probably it is with 'high CPU usage bug' for OpenCL):
http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/modelContent.jsp?ct=DL&os=&category=&moid=2998365&rpn=PT520U&modelFilter=R850-S8530&selCategory=2756709&selFamily=1073768664

Or try to find your laptop here (and select 'Display' for listing the Display Drivers):
http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/home.jsp?nav=Download


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

CommanderKeen
Send message
Joined: 25 Aug 12
Posts: 2
Credit: 31,508
RAC: 0
Germany
Message 1276949 - Posted: 29 Aug 2012, 10:15:26 UTC

Heyy Peeps,

i am new, so please excuse me, if i make this post at the wrong place.

Generally I really like the ideas behind SETI@HOME and I am willing to help!

BUT:
I had to disable the GPU usage on both my computers. My Laptop (a mobile GF 520) and my Desktop (GF GTX470) are getting under serious heat while running astropulse. Both Cards switch their fans almost instantly to max. Thats not cool - by both meanings of the word.

The GPU usage seems to be MUCH faster than CPU and i dont need my GFX card as often as the CPU - so this is really a pitty.

Is there any way to throttle the load put on the GPU? Dont get me wrong, but as long as this isnt possible i wont be using it, as i am really afraid to grill my hardware.

I'd really love to see this in the future or to receive a lil' help on how i can do this.

Cheers,
Daniel

Profile Bernie Vine
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 26 May 99
Posts: 7198
Credit: 29,221,683
RAC: 36,102
United Kingdom
Message 1277011 - Posted: 29 Aug 2012, 11:44:41 UTC
Last modified: 29 Aug 2012, 11:45:42 UTC

Hi

Firstly it is best to post questions like this in the Number Crunching Forum.

I can only see your desktop machine attached to your account, however you should not worry as Astropulse work units should not normally be sent to Nvidia cards, this was a problem at the server end and has now been rectifed.

A GFX470 should not have problems with regular work units, laptops on the other hand do heat up quite easily. I have mine on a cooling pad, works a treat.

Bernie
____________


Today is life, the only life we're sure of. Make the most of today.

Previous · 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 . . . 10 · Next

Message boards : News : New AstroPulse applications for GPUs.

Copyright © 2014 University of California