New AstroPulse applications for GPUs.


log in

Advanced search

Message boards : News : New AstroPulse applications for GPUs.

Previous · 1 · 2 · 3 · 4 · 5 · 6 · 7 . . . 10 · Next
Author Message
Digital1
Send message
Joined: 5 Aug 11
Posts: 11
Credit: 11,210,595
RAC: 356
United States
Message 1272334 - Posted: 17 Aug 2012, 22:59:32 UTC

Conspiracy theorists migh suggest that this OpenGL improvement for ATI video cards and the most recent "bug" that has all work suspended for nVidia cards just might be related somehow... <grin>
____________
Digital1

Profile Raistmer
Volunteer developer
Volunteer tester
Avatar
Send message
Joined: 16 Jun 01
Posts: 3368
Credit: 46,099,115
RAC: 25,072
Russia
Message 1272461 - Posted: 18 Aug 2012, 6:57:42 UTC - in response to Message 1272334.

Conspiracy theorists migh suggest that this OpenGL improvement for ATI video cards and the most recent "bug" that has all work suspended for nVidia cards just might be related somehow... <grin>


OMG, OpenCL, not GL :D

Profile TRuEQ & TuVaLu
Volunteer tester
Avatar
Send message
Joined: 4 Oct 99
Posts: 450
Credit: 17,727,604
RAC: 401
Sweden
Message 1272472 - Posted: 18 Aug 2012, 7:40:07 UTC

It is the same as with cars....Big difference.
Volkswagen GOLF CL is Diesel
And The Golf GL is petrol unleaded.

GOLF GTI is fuel injected.

That is why the option TI is added to some cards when it comes to computors.
TI for something extra kicked in the card.

Anyone fall for this????

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2568
Credit: 5,871,440
RAC: 2,620
Bulgaria
Message 1272477 - Posted: 18 Aug 2012, 7:49:17 UTC - in response to Message 1272472.


That C and G look similar is a fault of the Roman Empire (they invented Latin alphabet)

But Open Computing Language (OpenCL) and OpenGL (Open Graphics Library) are different things:
http://en.wikipedia.org/wiki/OpenCL
http://en.wikipedia.org/wiki/OpenGL


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Profile Pascal
Send message
Joined: 22 Jan 00
Posts: 23
Credit: 3,558,281
RAC: 3
Netherlands
Message 1272745 - Posted: 18 Aug 2012, 22:28:06 UTC
Last modified: 18 Aug 2012, 23:15:24 UTC

Hi,

It looks like ATI stock openCL apps don't work for me.. sorry!

using ATI radion HD 5870 with catalyst 12.8(x64) driver BOINC 7.0.28(x64).
GPU&Grpfx-memory clock is high (temperature goes up) but there is no activity.(default settings GPU&Grpfx-memory not overclocked)

activity on the card goes up after stopping tasks running on the CPU.
Have similar issues with opt-apps.

Had best results using catalyst 11.3(x64) driver in the past.
(using opt-apps)

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2568
Credit: 5,871,440
RAC: 2,620
Bulgaria
Message 1272801 - Posted: 19 Aug 2012, 3:35:46 UTC - in response to Message 1272745.
Last modified: 19 Aug 2012, 3:40:33 UTC

It looks like ATI stock openCL apps don't work for me.. sorry!

What are exactly your complains (1. 2. 3. ...)?

You have 'Completed and validated' AstroPulse v6 v6.04 (opencl_ati_100)
http://setiathome.berkeley.edu/result.php?resultid=2567262936

And you have some 'Completed, waiting for validation'
http://setiathome.berkeley.edu/results.php?hostid=5867419&offset=0&show_names=0&state=2&appid=12


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Profile Pascal
Send message
Joined: 22 Jan 00
Posts: 23
Credit: 3,558,281
RAC: 3
Netherlands
Message 1272856 - Posted: 19 Aug 2012, 8:14:23 UTC - in response to Message 1272801.
Last modified: 19 Aug 2012, 8:34:42 UTC

True. But read what happens is in the post..
Will try to explain in other words.

The first task running after starting BOING is going "okay".
Then the "second" task is running and it's like it's running on just the CPU.
To complete the second "in a short". I have to stop boinc and start it aging.
Then the task is running, till it's done. Then the next task again is running very slowly. Again It's like it's only running on the CPU at that moment.

I have no complaints!! Only questions. ;) I only expect activity on the GPU?
According to the catalyst driver there is none or very little.
With the old old catalyst 11.3(x64) and (yes i know) opt apps from lunatics the activity on the GPU was "continuously high".

Maybe I'm wrong.... That's why I wrote it looks like...
And yes I did gorget to mention that I only had astropuls task for the GPU..Sorry! Cant's say anythin about the others at the moment. didn't had those tasks yet.


It looks like ATI stock openCL apps don't work for me.. sorry!

What are exactly your complains (1. 2. 3. ...)?

You have 'Completed and validated' AstroPulse v6 v6.04 (opencl_ati_100)
http://setiathome.berkeley.edu/result.php?resultid=2567262936

And you have some 'Completed, waiting for validation'
http://setiathome.berkeley.edu/results.php?hostid=5867419&offset=0&show_names=0&state=2&appid=12

Claggy
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 4048
Credit: 32,693,129
RAC: 604
United Kingdom
Message 1272859 - Posted: 19 Aug 2012, 8:34:31 UTC - in response to Message 1272745.
Last modified: 19 Aug 2012, 8:35:39 UTC

There is an ATI Low GPU usage Bug out there when all the CPU cores are fully utilised,

Freeing a core by changing your preferences to 87.5% of CPUs, then suspending GPU usage, waiting for the app to exit, then resuming GPU usage often gets a Higher GPU usage again,

Claggy

Profile Pascal
Send message
Joined: 22 Jan 00
Posts: 23
Credit: 3,558,281
RAC: 3
Netherlands
Message 1272862 - Posted: 19 Aug 2012, 8:42:25 UTC - in response to Message 1272859.
Last modified: 19 Aug 2012, 8:44:25 UTC

Hi Claggy!

That are answeres that are usable!..

okay..
I thing you mean the "use max xx% from the processor." (don't know what it sais in eng.. I have a dutch interface).

But wil it help to lower the "use max xx% CPU time"
Or do I realy have to say to use just 7 "cores" from the CPU.

Thanks!

Claggy
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 4048
Credit: 32,693,129
RAC: 604
United Kingdom
Message 1272864 - Posted: 19 Aug 2012, 8:47:03 UTC - in response to Message 1272862.
Last modified: 19 Aug 2012, 8:51:48 UTC

But wil it help to lower the "use max xx% CPU time"
Or do I realy have to say to use just 7 "cores" from the CPU.

I'd leave the CPU time setting alone, Boinc will stop and start computation a free seconds at a time, and i don't know how reliable the apps are to that use,

Edit: the wording in english (on the Website) is: On multiprocessors, use at most (Enforced by version 6.1+) 87.5% of the processors

Claggy

Profile Pascal
Send message
Joined: 22 Jan 00
Posts: 23
Credit: 3,558,281
RAC: 3
Netherlands
Message 1272865 - Posted: 19 Aug 2012, 8:50:22 UTC - in response to Message 1272864.

okay !

changed the interface language.
The setting I mentions is:
"On multiprocessor systems, use at most xx% of the processor"

thanks!


Profile Mike
Volunteer tester
Avatar
Send message
Joined: 17 Feb 01
Posts: 23365
Credit: 31,790,439
RAC: 24,552
Germany
Message 1272869 - Posted: 19 Aug 2012, 8:55:54 UTC

In addition, dont forget high blanked units are using lot of CPU as well.
I had 50 out of 80 units with 88% blanking in just 2 days.


____________

Profile Pascal
Send message
Joined: 22 Jan 00
Posts: 23
Credit: 3,558,281
RAC: 3
Netherlands
Message 1272872 - Posted: 19 Aug 2012, 9:02:19 UTC
Last modified: 19 Aug 2012, 9:21:34 UTC

Hi Mike,

Thanks! Will keep it in mind.
I did the changes Claggy mentioned and GPU usage is noticeable again.

Thanks again to you both!

Profile Ageless
Avatar
Send message
Joined: 9 Jun 99
Posts: 12258
Credit: 2,552,418
RAC: 812
Netherlands
Message 1272916 - Posted: 19 Aug 2012, 13:15:19 UTC

A word of warning, though. At Einstein, it's been reported that the 12.8 Catalysts add significantly to the overall run time.
____________
Jord

Fighting for the correct use of the apostrophe, together with Weird Al Yankovic

Profile Pascal
Send message
Joined: 22 Jan 00
Posts: 23
Credit: 3,558,281
RAC: 3
Netherlands
Message 1272918 - Posted: 19 Aug 2012, 13:34:52 UTC - in response to Message 1272916.

hmmmm... No I have too choose..
go back to 12.6.. or leave 12.8...

love to play SWTOR every now and than.
The 12.8 solves some SWTOR issues though.

<grin>

Thanks for the info.

Jupiter8
Avatar
Send message
Joined: 19 Aug 12
Posts: 6
Credit: 208,200
RAC: 0
United States
Message 1273532 - Posted: 20 Aug 2012, 22:11:39 UTC

I have an i7 950 system overclocked (so I have 8 threads working), with 3 ATI HD 4800 series graphics cards. I'm new to all of this but was looking forward to getting my first astropulse work-set when I heard it might use the ATI GPU's. I finally got my first astropulse today and my GPU's are showing idle.

I saw where some special .exe's proceeded the running of the astropulse, but it's like they are not running. Where do I go to read about turning them on or looking for an error log to diagnose things?

So far I have looked in Bionic's Advanced / Event Log and didn't see anything note worthy.

Thank you.

Profile Raistmer
Volunteer developer
Volunteer tester
Avatar
Send message
Joined: 16 Jun 01
Posts: 3368
Credit: 46,099,115
RAC: 25,072
Russia
Message 1273616 - Posted: 21 Aug 2012, 6:14:08 UTC - in response to Message 1273532.
Last modified: 21 Aug 2012, 6:16:36 UTC

I have an i7 950 system overclocked (so I have 8 threads working), with 3 ATI HD 4800 series graphics cards. I'm new to all of this but was looking forward to getting my first astropulse work-set when I heard it might use the ATI GPU's. I finally got my first astropulse today and my GPU's are showing idle.

I saw where some special .exe's proceeded the running of the astropulse, but it's like they are not running. Where do I go to read about turning them on or looking for an error log to diagnose things?

So far I have looked in Bionic's Advanced / Event Log and didn't see anything note worthy.


Thank you.


Look here: http://setiathome.berkeley.edu/results.php?hostid=6749865&offset=0&show_names=0&state=0&appid=12 So far your host has only CPU AP tasks, no work for GPU from SETI servers hence GPU idle.

EDIT: AP tasks are CPU cache hungry ones so I would recommend to disable CPU AP work for your host if possible and to process AP on GPU only. You could busy CPU with MB tasks then.

Claggy
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 4048
Credit: 32,693,129
RAC: 604
United Kingdom
Message 1273717 - Posted: 21 Aug 2012, 12:43:43 UTC - in response to Message 1273616.

EDIT: AP tasks are CPU cache hungry ones so I would recommend to disable CPU AP work for your host if possible and to process AP on GPU only. You could busy CPU with MB tasks then.

Raistmer, that can't be done at present (without using an app_info), you can't disable Astropulse for one resource only,

He'd have to it in stages, first fill up the CPU with only MB work, then disable CPU work fetch, enable Astropulse_v6 and then fill up with ATI Work, then rinse and repeat,

Claggy

Jupiter8
Avatar
Send message
Joined: 19 Aug 12
Posts: 6
Credit: 208,200
RAC: 0
United States
Message 1273768 - Posted: 21 Aug 2012, 22:36:43 UTC - in response to Message 1273717.

Thank you for the replies! I will see if I can fiddle with it to force the use of the GPU(s).

-Regards

Pete(r) van der Spoel
Send message
Joined: 7 Sep 00
Posts: 5
Credit: 3,070,008
RAC: 41
Netherlands
Message 1273899 - Posted: 22 Aug 2012, 8:14:02 UTC

Should this also work on a ATI 4650 AGP GPU? And/or is there a specific catalyst driver version that is needed? Mine isn't automatically downloading GPU work units at the moment...
____________

Previous · 1 · 2 · 3 · 4 · 5 · 6 · 7 . . . 10 · Next

Message boards : News : New AstroPulse applications for GPUs.

Copyright © 2014 University of California